Larian Studios

Summoning Quetzacellona

Posted By: 9114

Summoning Quetzacellona - 14/08/06 08:40 PM

I have been to the library and found the book on summoning, and my informer is an imp, I have the rune of w....m,the k...r root , the f....r potion and the s....r leg and the Ranaar Summoning Elder keeps telling me some of the articles are still
missing and to quit wasting his time and mine. What do I need to complete this test?
Posted By: Raze

Re: Summoning Quetzacellona - 15/08/06 02:54 AM

Go back out into the hallway, drop all of the ingredients on the ground, have your hero pick them up again and return to the summoning room. Infrequently the game can not recognize you have a particular item, but dropping it and picking it back up again should be enough to fix that. A few people have run into this issue with the first summoning test, and it can also occur sometimes if you find a quest item before getting the relevant quest.

The game checks for the ingredients as you go through the doorway from the hallway, and you should see an experience point message scroll up the screen when if it finds them, after which the instructor will respond properly.
Posted By: maxi

Re: Summoning Quetzacellona - 24/09/06 06:23 PM

What if dropping and re-picking up items doesn't work?

maxi
Posted By: Raze

Re: Summoning Quetzacellona - 24/09/06 09:43 PM

If all the ingredients are present but unrecognized even after dropping and picking them up again, try dropping, storing or selling extra stuff in your hero's inventory. One person mentioned having to drop regular roots to get the game to recognize a special root (don't recall if it was the Kohar root, though).
Posted By: maxi

Re: Summoning Quetzacellona - 27/09/06 01:45 AM

I dropped EVERYTHING! Shoes, armor, weapons, down to bare skin, the book, and the four items, still won't register that I have the "right stuff". Now what?

maxi
Posted By: Raze

Re: Summoning Quetzacellona - 27/09/06 06:09 AM

Well, the problem is not with your inventory, anyway. In most cases where people have had an issue with this quest simply dropping the items and picking them back up has worked, though one or two had to get rid of normal roots.

Does your quest log appear normal (ie previous parts of the quest are listed as complete)?

Since you restarted from the previous act and ran into the same problem, it is probably not something in the save itself (at least not directly). You could try re-installing the game and patch, and see if that helps.
Alternately, there is a file verification procedure (see below) you can use to check the game itself.


Check your PM (click 'My Home' in the top menu bar, then 'Received Private Messages').


~~~

To do a clean re-install of the game (and patch);
Zip or otherwise backup your saved games folder to another location first, just in case. Each save is a separate subfolder in the '..\Beyond Divinity\savegames' folder; the 5 'bd_act#_start' folders are created/updated by the game/patch, and do not need to be backed up.
Un-install the game, re-boot, in Windows Explorer browse to the 'Beyond Divinity' folder and make sure there are no files or folders remaining, except within the 'savegames' folder (though the 5 'bd_act#_start' folders should be gone). After that, shut down all non essential programs (especially anti-virus), re-install the game, re-boot and shut down all non essential programs again. At this point you may be able to start the game and see if any problems persist. However, if you saved games in the patched version, they will not be playable in the unpatched game version. After that you can (optionally) reboot and shut down all non-essential programs before re-installing the patch.

~~~

The install program should report any problems, such as CRC errors, during install. However, if it fails to do so, or a file becomes corrupt after installation, the integrity of the files can still be verified using a program such as FileCheck; download (194KB). This is a small freeware program (no install required) to calculate the CRC-32 values (the cyclic redundancy check used in zip files) of a number of files. It can also compare a previously calculated CRC file with a set of files/folders.

After doing a clean install of BD and rebooting, I deleted the files in the '..\Beyond Divinity\DirectX9' folder (since they are not needed if/once DirectX 9 is installed). Then I used FileCheck to create a crc file of the game folders, installed the 1.45 patch and did so again, both before starting the game (I repeated this procedure with the 1.47 patch). If you compare the appropriate CRC file to your install, it should tell you if there are any corrupt files. You do not need to worry about moving any saved games out of the savegames folder or deleting the files in the dynamic folders, since new files will not be tested by FileCheck, just those listed in the crc file. If you have started the game and changed any options, there will be differences reported in the config.div and keylist.txt files. In my install the '..\Beyond Divinity\Editor\dgen_themes.000' file was also reported to be different.

There are several files in the Beyond Divinity folder created when the game is started or options are changed, including init.cfg, mapids.000, persist.dat, sinfo.000, slashed-d3d6.cfg, slashed.cfg, sound.cfg and starlog.txt. A couple other files are also added, but another crc file including these wouldn't help much, since most or all are system or option dependent, so these files would usually be reported as different regardless of being valid or corrupt.
At least the config.div, slashed.cfg and slashed-d3d6.cfg files in the Beyond Divinity folder can be deleted, and the configuration program / game will recreate them the next time it is started.

Beyond Divinity CRC files (285 KB)
  • These crc files are based on the UK English version; the North American version should be the same, I think, but the Australian version will have differences (it uses a different copy protection).
  • FileCheck expects the files to be in the original locations to verify, so if you installed BD to a location other than the default (C:\Program Files\Larian Studios\Beyond Divinity), open the CRC file in Wordpad (for example), and do a search-and-replace so the file/folder paths match your install.

    If your CRC values match, it is not the game itself, but likely a conflict with something else in your system or a problem in the saved game folder. When examining the list of 'errors' FileCheck produces, potential problem files would be those with an error trying to read, or with a large size difference (especially zero byte files) from the known good install.
  • Posted By: Kyp

    Re: Summoning Quetzacellona - 04/09/11 03:22 PM

    I have exactly the same problem. I have the three ingredients and the correct rune and the teacher says I'm still lacking some ingredients. Leaving the room, dropping everything an taking only the requiered items doesn't help.
    So does reinstalling the game.

    I guess it means that's the end of Beyond Divinity for me...

    EDIT : I just discovered why it happened. It's because of a well known bug in Act 3. I already had a "Wisdom rune" in my inventory. It's not the one I need and it should have disappeared at the end of Act 3. But because of that, I couldn't take the new "Wisdom rune" and I can't go back to where I take it anymore. Anyway, I kept a savegame at the beginning of Act 4. This is all so very tedious but at least I will be able to finish the game eventually.
    Posted By: Raze

    Re: Summoning Quetzacellona - 04/09/11 04:10 PM


    You can replace the rune; see the topic Inventory files.

    It should also be possible to hex teleporting back to the rune room, but someone would need a save in that room to get the coordinates (I still have all my saves).
    Posted By: Godlike

    Re: Summoning Quetzacellona - 25/12/16 04:25 PM

    I just encountered this bug. It's unfixable, not even by inventory edit.

    The only one way to fix this is to load game BEFORE getting wisdom rune AND/OR root. I went to the summoning room and there was no one... I've changed location and entered again, first test guide was there (jesus this quest is so bugged) and he detected my items correctly this time.

    Don't take all the runes from rooms, just take the wisdom one and try -> doesn't work -> reload, try again.

    As I saw dialog and quest files not packaged nor encrypted I hoped that I could fix this quest for other poeple here but I can't do anything as game logic and scripts behind it are not in plain form or they're inside exe. .dlg/.gsm files doesn't contain game logic (did you used LUA here? I would be happy to patch it if you know where scripts are).

    EDIT:: Completed the game, thanks for the ending. It was great.

    Regards
    Posted By: Darkhencman

    Re: Summoning Quetzacellona - 26/05/18 02:31 PM

    Maybe I've found the solution!
    I have the same problem, and like Godlike said, I had a Wisdom Rune in my inventory.
    I had all the component, and nothing happened. Then I droped the old Wisdom from my inventory, and that's it! This worked for me!
    © 2019 Larian Studios forums