Larian Studios

FIX for broken Imp Council Member quest

Posted By: Raze

FIX for broken Imp Council Member quest - 19/03/03 06:29 AM

After this problem came up a few times, I decided to check something, and figured out how to fix the quest if it gets broken. Actually, it was so easy I am surprised someone did not try this sooner. smile

Thanks go to Kordoba, as well. If not for his Post "OK I GOT IT!! This is how to get your Explosive Keg back or any other lost item" (see below), I probably would not have had the idea to try what I did.

Harglowe used essentially the same technique to temporarily restore a missing person; Rimmer is missing (see below). I likely read that first, and had it bouncing around in my subconscious when I tried fixing the imp quest. Maybe that's why I found it easy to do. biggrin

Note: The next patch (after 1.32) should fix this bug.


After asking the Imp in the Ducal inn to join the council and having him explain that Antx is hiding in the sphere, there are two responses you can give;

1) "I understand! How can I speak to Antx...."

2) "Are you feeling all right? ... I don't understand a thing your saying..." (sic)

The response to both if you refuse to touch the sphere is:
"Enter magic sheer! Meet Antx! You come back whenever you're ready" (sic)

If you choose 2 and back out, you do get the option to touch the sphere again each time you speak to him. However, if you pick 1 and change your mind, you do not get another chance. This breaks a quest that you have to complete to finish the game. disagree mad

Please read this post through before attempting, and make sure you follow the steps below carefully.


1) Save your game under a new name (better safe than sorry), such as 'imp fix'.

2) Rename the dialogs.000 file in the newly saved game folder, move it to a new subfolder, or otherwise make a backup. Important: You must restore this file at the end of the procedure.

2b) Confirm that you have completed step 2.

3) Find a saved game from before you talked to the imp at the Ducal inn and refused to touch the sphere. If you do not have such a saved game, start a new game, save it right away and use the file from there. I tested this with the same character class, gender and name as my broken imp quest game, though I do not believe that is required. Or just download this dialogs.000 file (18KB) from a new game.

4) Copy the dialogs.000 file from that saved game folder to the 'imp fix' folder, overwriting the file there if necessary.

5) Re-load the 'imp fix' save.

6) Talk to the imp and agree to touch the sphere. Once you get teleported, save immediately to a new game, such as 'imp world'.

7) Delete the dialogs.000 file from the 'imp world' folder, and replace it with the backup copy of that file from the 'imp fix' folder, re-naming it back to dialogs.000

7b) Confirm that you have completed step 7.

8) Re-load the 'imp world' save.

You can now finish the imp council member quest.
biggrin biggrin

I ran through the quest again to make sure it would work, but did not do much after that. I sided with the wasps this time, just to see what would happen. There were a lot more toads than I remember compared to siding with the bees, and the queen bee drops better stuff than the wasp/wizard when you kill her (medium charm and amulet, in addition to the key). Of course, you miss the Aura of Command spell the bee would have taught you if you side with the wasps (who are, after all, the bad guys).

This technique can also be used for the George's murder quest.

Some people have run into a problem where they can not report the details of George's murder to Mardaneus after he has joined the council. Swapping dialogs.000 files should allow you complete the quest and get the experience and level of Restoration. I have not tested this, but Barnabus has a similar post and zipped dialog file in the german forum, so I imagine it will work in the english game as well. wink

Here is a dialogs.000 file (20KB) from after talking to the vampire in Verdistis and killing him. Save your game beside Mardaneus, backup your dialog file and replace with mine, re-load, talk to Mardaneus, save, restore your file, re-load.


originally posted by Kordoba in the old forum. See also the procedure described in Lost Items -guide and directory of inventory files.

OK I GOT IT!! This is how to get your Explosive Keg back or any other lost item

First go to your latest savegame and drop on the ground everthing you do not want to lose(from inventory and Equipment) Quest items for sure. Do not drop your Pyramids on the ground and also make sure both pyramids are in your inventory. Drop your money too . Now save this as a test savegame. (just in case)

Now go back to a savegame where you do have the item you lost. eg. explosive keg. Now go to your savegame folders and copy all 6 INV items from your old savegame and copy and paste them into your testing savegame.

Now when you reload, your old savegame inventory will be in your new game. and all your good stuff will still be on the ground.

Other things to note before making this transfer.
-Make sure you have 2 pyramids in inventory in both savegames.
-Make sure you don't have duplicate quest items on the ground so that when you make the transfer you don't have 2 of something, it may not hurt but I don't know what will happen.
-Make sure you use different saves from this point for a while because also I don't know whats gonna happen

Warning this could get ugly!
Now if you already havn't figured this out, you can obviously make lots of duplicates of everything you own in this fassion. eg. you have 100000 gold. Drop your gold or whatever on the ground and make a second save, go to your folders and copy inventories, now when you reload you will have 100000 gold on the ground and 100000 gold in your inventory. Sounds sweet huh? well let me know if it works because i never tried it and I'm not going to because I don't cheat. I only fix things I was shafted out of!

Ok Ive done a little Testing and the Keg was a 100% Sucess and I'd recomend anyone to try this out thats lost theirs, its worth it because it not only sets your mind at ease that you completed the quests but the two sabatage missions are worth over 70000 xp
If anyone wants their explosive keg back but do not have a prior save with the keg I can send them my INV files with nothing but the Keg in the Inventory. Alls you would have to do is drop all your items before overwriting the INV files and pick them up again after.

originally posted by Harglowe in the old forum.

Rimmer is missing

Alas, I turned the dwarven village inside out, but no Rimmer.
I did solve the problem in the end, by cheating however.

I took an old saved game (a game where I hadn't been to the dwarven village at all) and temporarily copied the data.000 file from that saved game to my newest saved game (after making a backup of the original data.000).
It appears that the data.000 file contains the location of all NPC's and even your own location.
I started up the saved game, went to Rimmers house, talked to him (he was standing in his house, a few feet from the entrance), saved the game and restored the data.000 file.

I hate 'cheating', but in this case, it seems to work.
Posted By: Raze

Re: FIX for broken Imp Council Member quest - 06/04/03 05:59 AM

This technique may also be useful for the Dragon Armour quest, if Sir Patrick will not let you bring up the subject. Sometimes he is just stubborn, and repeatedly going back to talk to the dwarven king and Grisha then back to Sir Patrick (multiple times) will get him to talk about it.

If that fails, you may be able to use a dialogs.000 file (21KB) from a save where I get the option to ask him about the armour. Make sure you backup your original file and restore it afterwards, as described above. I have not run into this bug and can not do anything to cause it, so have not tested this. In theory, it should work though.

Save your game under a new name, backup your dialogs.000 file and replace with mine, re-load, talk to Sir Patrick and do his quest (without talking to anyone else besides Lucius, or doing parts of any other quests), get the armour, save under a new name, delete the dialogs.000 file in that folder and replace with the backup of your original file, re-load.

If this fails, you can still download the inventory files for the Dragon Armour, but you will miss the experience and completed quest that way.
Lost Items - guide and directory of inventory files
Posted By: Raze

Re: FIX for broken Imp Council Member quest - 23/09/03 03:02 AM

The imp fix procedure can also be used if Grisha does not bring up a dialog option about the dragon armour (though this problem appears to be much less common then that with Sir Patrick; it has occurred just once, that I know of).

Here is the dialogs.000 file (16KB). I went straight from the dwarven king to Sir Patrick, so you may have to talk to Grisha a couple times, once to get the description of the dragon armour, and again to tell him you have the pieces. Make sure you backup your original file and restore it afterwards, as described above.

Save your game under a new name, backup your dialogs.000 file and replace with mine, re-load, talk to Grisha, wait awhile (1 game day, IIRC) then talk to him again to get the completed armour (without talking to anyone else about quests, or doing parts of any other quests), save under a new name, delete the dialogs.000 file in that folder and replace with the backup of your original file, re-load.

You may need to re-load a few times to get good stats on the armour. If you have a potentially good set, move it in your inventory and save the game first if you want to keep trying. If you get something crappy, you can also just buy back the original from Grisha (though you need the fixed armour to show the king, and wear the complete set once).
© 2020 Larian Studios forums