Larian Studios

Controller mode

Posted By: Jiri

Controller mode - 09/11/19 01:40 PM

Hi, I really want to play game witch Steam Controller, but it is not possible, because when I switch to Controller mode, the game menu get bigger, but Steam Controller or my USB Controller stop working, mouse stop working too, so I can only press Alt+F4, then I can again work with mouse. I tried it with many overlay setting, from big picture mode, without bit picture, steam runtime, steam native, over steam link, from gnome, from plasma, from icewm, but the Controller mode is everywhere the same - without response. But the Steam Controller or USB Controller, which is PS4 compatible is normally working in other game. I looked over internet and that is not just my problem, this problem have so many people. Please Larian Studios, can you pleas check this and fix it pleas? Or is here some workaround? I am using Arch Linux, but on internet there is so many same problems with other distributions ....
PS: because I am really disappointed about that situation, I tried another udev rules, run the game outside of Steam, Proton Emulated version, I am sure, that problem is not just mine ....
PPS: this post is about EE version
Posted By: Raze

Re: Controller mode - 10/11/19 05:42 AM


In Steam have you tried changing the controller configuration for the game? Is PS4 controller compatibility enabled in Steam?
Posted By: Jiri

Re: Controller mode - 10/11/19 08:39 AM

Thanks Raze for answer, yes, I tried everything, which you mentioned, but when you said compatibility, I tried to something like emulation and found this: https://github.com/kozec/sc-controller
And this is working solution, so thanks for push smile.
Posted By: Raze

Re: Controller mode - 10/11/19 10:19 AM


Thank for the update, and details.
© 2020 Larian Studios forums