Larian Banner
Previous Thread
Next Thread
Print Thread
[Mac] keyboard stops responding #523769
19/07/14 09:39 PM
19/07/14 09:39 PM
Joined: Jul 2014
Posts: 5
V
viniosity Offline OP
stranger
viniosity  Offline OP
stranger
V

Joined: Jul 2014
Posts: 5
After about 10 minutes into the game my keyboard stops responding correctly. Hitting 'i' for inventory instead makes my character start moving towards wherever my mouse is hovering. Most keys are unresponsive.. I can't even save my game. Anyone know a solution?

Re: [Mac] keyboard stops responding [Re: viniosity] #523799
19/07/14 10:49 PM
19/07/14 10:49 PM
Joined: Jan 2014
Posts: 277
Stauff1138 Offline
enthusiast
Stauff1138  Offline
enthusiast

Joined: Jan 2014
Posts: 277
Is Alt-Tab combo working? What happens with other apps when you Alt-Tab, are they working fine? What happens when you Alt-Tab back into the game?

Re: [Mac] keyboard stops responding [Re: viniosity] #523826
19/07/14 11:31 PM
19/07/14 11:31 PM
Joined: Mar 2003
Posts: 27,834
Canada
Raze Offline

Larian Studios
Raze  Offline

Larian Studios

Joined: Mar 2003
Posts: 27,834
Canada

Have you tried switching the display mode to windowed or fake fullscreen?

Re: [Mac] keyboard stops responding [Re: viniosity] #523841
20/07/14 12:14 AM
20/07/14 12:14 AM
Joined: Jul 2014
Posts: 5
V
viniosity Offline OP
stranger
viniosity  Offline OP
stranger
V

Joined: Jul 2014
Posts: 5
Alt-tab still works but most other keys do not. I alt-tabbed and launched text-edit via the mouse and could not get a single key to show up. Quitting the app doesn't help either. Once this happens I have to completely restart the computer. Even logging out and back in is impossible as I can't type in my username and password.

I've tried disabling the universal access for steam but that didn't help either. Basically playing this game is making my entire system unusable. So strange that nobody else is having this same problem..

Re: [Mac] keyboard stops responding [Re: viniosity] #523934
20/07/14 05:46 AM
20/07/14 05:46 AM
Joined: Jan 2014
Posts: 277
Stauff1138 Offline
enthusiast
Stauff1138  Offline
enthusiast

Joined: Jan 2014
Posts: 277
Can you drop us your system specs, please.

Indeed, never heard about such an issue. As it affects Mac, system-wide this is even more strange.

The only very small chance of system-wide corruption are touch hooks, please enter this line in Terminal to disable touches..

defaults write com.larian.dos DisableTouchRotate -bool true

Last edited by Stauff1138; 20/07/14 06:02 AM.
Re: [Mac] keyboard stops responding [Re: viniosity] #524462
21/07/14 02:07 AM
21/07/14 02:07 AM
Joined: Jul 2014
Posts: 5
V
viniosity Offline OP
stranger
viniosity  Offline OP
stranger
V

Joined: Jul 2014
Posts: 5
It's a 2010 Macbook Air:

2.13 GHz intel Core 2 Duo
4GB 1067 MHz DD# RAM
OS X 10.9.4

I'm a developer so I have some external things loaded via homebrew (elasticsearch, redis, etc) but otherwise pretty stock setup. Let me know if you have any other questions - I'll be happy to help.

Will try playing a bit tonight (twist my arm!) after disabling touches using the command you provided


[Update:] didn't work. Interestingly, the arrow keys still function but I couldn't hit the return key to re-enter this into terminal after the keyboard stopped responding.

Last edited by viniosity; 21/07/14 02:32 AM.
Re: [Mac] keyboard stops responding [Re: viniosity] #524561
21/07/14 05:54 AM
21/07/14 05:54 AM
Joined: Jan 2014
Posts: 277
Stauff1138 Offline
enthusiast
Stauff1138  Offline
enthusiast

Joined: Jan 2014
Posts: 277
Any console suspicious output? I know for sure Airs get very hot with D:OS. Looks like recent ones are pretty much fine, however. What's your feeling - is the temperature of Air over the top at the moment of keyboard malfunction?

Re: [Mac] keyboard stops responding [Re: Stauff1138] #524844
21/07/14 04:15 PM
21/07/14 04:15 PM
Joined: Jul 2014
Posts: 5
V
viniosity Offline OP
stranger
viniosity  Offline OP
stranger
V

Joined: Jul 2014
Posts: 5
I really don't think so.. I've played Guild Wars 2 on this same machine for hours and it's been fine. This keyboard issue pops up usually within 10 minutes. Do you know if anyone else having this problem or is it just me?

Re: [Mac] keyboard stops responding [Re: viniosity] #524845
21/07/14 04:17 PM
21/07/14 04:17 PM
Joined: Jan 2014
Posts: 277
Stauff1138 Offline
enthusiast
Stauff1138  Offline
enthusiast

Joined: Jan 2014
Posts: 277
You seem to be the only one... Screwing keyboard system completely is not a light task on OS X.. Unless you have Assistive device applications that can screw it quite easily..

Go to System Prefs-> Security & Privacy -> Privacy -> Accessibility.

I even remove Steam from there because it's pretty buggy to tell the truth.

Last edited by Stauff1138; 21/07/14 04:19 PM.
Re: [Mac] keyboard stops responding [Re: viniosity] #525353
22/07/14 03:56 PM
22/07/14 03:56 PM
Joined: Jul 2014
Posts: 5
V
viniosity Offline OP
stranger
viniosity  Offline OP
stranger
V

Joined: Jul 2014
Posts: 5
I tried disabling all the Assistive apps but it still killed my keyboard after a while. I think I'll just wait for the linux release and hope that it works there. (Or worse, case until a Broadwell mac is released next year but hopefully the linux release comes sooner than that!)

Re: [Mac] keyboard stops responding [Re: viniosity] #525355
22/07/14 04:01 PM
22/07/14 04:01 PM
Joined: Jan 2014
Posts: 277
Stauff1138 Offline
enthusiast
Stauff1138  Offline
enthusiast

Joined: Jan 2014
Posts: 277
Are you sure 'Console' is dead silent about keyboard issues?

Re: [Mac] keyboard stops responding [Re: Stauff1138] #532720
30/07/14 05:31 PM
30/07/14 05:31 PM
Joined: Jul 2014
Posts: 1
S
SomeCoolName Offline
stranger
SomeCoolName  Offline
stranger
S

Joined: Jul 2014
Posts: 1
I have the same exact problem (down to I causing my characters to move to targeted location). Using default keyboard settings, 2013 macbook retina, running on osx 10.8.5. Loading a previous save fixed it once last night, then later when it happened again, loading didn't fix it.

Last edited by SomeCoolName; 31/07/14 01:36 AM.
Re: [Mac] keyboard stops responding [Re: viniosity] #536554
04/08/14 10:50 AM
04/08/14 10:50 AM
Joined: Apr 2013
Posts: 17
E
eleve Offline

stranger
eleve  Offline

stranger
E

Joined: Apr 2013
Posts: 17
There is a bug in OS X and keyboards... try and send your machine to sleep for a moment then wake it back up. If it is this particular bug it will be fixed after that (until next time it happens).

Re: [Mac] keyboard stops responding [Re: viniosity] #536558
04/08/14 11:11 AM
04/08/14 11:11 AM
Joined: Jan 2014
Posts: 277
Stauff1138 Offline
enthusiast
Stauff1138  Offline
enthusiast

Joined: Jan 2014
Posts: 277
Can you guys collectively think about reproducible scenario?

May be some assistive stuff crawls in?..

If this issue affects other apps other than Divinity - it's very serious OS issue and probably needs Apple input. If this thing affects only Divinity then sure thing it's some weird bug.

Last edited by Stauff1138; 04/08/14 11:13 AM.
Re: [Mac] keyboard stops responding [Re: viniosity] #536561
04/08/14 11:23 AM
04/08/14 11:23 AM
Joined: Jan 2014
Posts: 277
Stauff1138 Offline
enthusiast
Stauff1138  Offline
enthusiast

Joined: Jan 2014
Posts: 277
Ha!

It's Mouse Keys option.

With Mouse Keys, you can move the mouse pointer and press the mouse button using the keyboard or numeric keypad. To turn on Mouse Keys, choose Apple menu > System Preferences, click Accessibility, click Mouse & Trackpad, then select the checkbox.

Open the Mouse & Trackpad pane of Accessibility preferences

The following illustration shows the keys to use on a keyboard (the keys on the left) and on a numeric keypad (the keys on the right) when Mouse Keys is on.

Keys that move the mouse pointer when Mouse Keys is on.
To move the mouse pointer:
With a numeric keypad: Use the 7, 8, 9, 4, 6, 1, 2, 3 keys on the keypad.
With the keyboard: Use the 7, 8, 9, U, O, J, K, L keys.

To click a mouse button:
With a numeric keypad: Press 5 on the keypad.
With the keyboard: Press I.

Thus 'I' is indeed mouse click!

Apple menu > System Preferences, click Accessibility, click Mouse & Trackpad and turn this off! Especially five times option.

Case closed wink


Powered by UBB.threads™ PHP Forum Software 7.6.2