Divinity Banner
Previous Thread
Next Thread
Print Thread
HH's v2.0.164.992 Bug Topic #585518
15/09/16 01:05 AM
15/09/16 01:05 AM
Joined: Apr 2011
Posts: 1,771
Hassat Hunter Offline OP

Hassat Hunter  Offline OP


Joined: Apr 2011
Posts: 1,771
Going to sleep now, it's late... barely got into the game yet, will continue tomorrow then add to this topic. Here are my bugreports so far:

* Bartering and leadership skills next level description doesn't properly start on the next line (no next before level 2 either) - during character creation anyway.
* Get rid of the "profit", earn 10%/20% more is enough text.
* Lucky charm, Persuasion and Telekenisis are missing grey description text of effects at all.
* Facial Feature 1 turns to none when pressing left or right button on Lizard customisation
* Going back on customising skills, appearance is reset (provided you haven't saved with accept before going into customise, which makes little sense to do).
* Putting a skillpoint in loremaste, sneaking or thievery there's a lot of blank space before base: 1. Probably lacking next level text?
* Demon, Ice King and One Man Army talents has no proper line-breaks if prequisites are not met.
* Battle stomp mentions x-x physical damage, Crippling blow x-x physical WEAPON damage. Will that be a difference between always and depends on weapon. If the second, weapon definitely should be highlighted aswell rather than be the same text colour. Even white like the physical will do. Alternatively if it's the same, use the same terminology throughout the game.
* Warfare +1 damage does not seem to be counted, and also it's +x% damage seems displayed as strength instead (of course strength modifies it, but how, the GUI doesn't say)
* Old issue; Trying to remove the collar, the text is hidden under the GUI.
* Pants: This particular pair have seen many owners > has, or this > these
* If the broken sword is 1 equip, one attack, why does the damage stat says 2AP to attack?
* Interestingly fists do the exact same damage as the broken sword (but take more AP, eh?). Actually ingame it seems the fist do far less damage, only the stastics say it's the same.
* Backpack/skills screen tutorial has no "okay, I got it" prompt.
* Healing potion should say "heals 50%" not "heals +50%" Probably also add vitality.
* Skill Deck Manager (the actual text) doesn't fit 0_o (1920x1080)
* In the skills manager selecting the first option actually raises the other skills from level 1 to 2 for some reason. Perhaps those 11 shouldn't have a level?
* Dragon's Blaze still has | | marks.
* Many a placeholder text in the skillsbook.
* Civil Abilities hover has | | marks.
* Being knight; you can confuse the active skills in the skillbook by removing a skill, then trying to open the selective subsection of skills. It wont open, but the icon will turn grey/active despite.
* Clicking "share journal" defaults it to the first entered quest.
* Flanking says "defence rate reduced" while it's dodging rate. Also this allows negative dodge (got -10% now from being flanked having 0 dodge).
* Diseased says it's lowering vitality. True, but it does so affecting constitution. Vitality doesn't mention properly being lowered from disease (since base + constitution isn't split)
* Oil flask says it has 1m radius, effects say it has 2.0m explosive radius.
* Not quite sure why enemy containers appear if no loot is inside... it seems unwise to me to use such containers, can't move them either. Wont they de-spawn? Also inspecting them they say "vitality from constitution" or "base: +20%", probably should not affect them.
* Same as healing potion apples (and probably all others) say "heals: +10%", should just be "heals: 10%".
* Body Containers wont say if they're empty/emtied.
* Body Containers show no box display on top if howevered over, yet if hovering over the right-click menu they do. Think they either should always, or never, not this inconsitency with other things ingame.
* Most hotkeys are blocked during conversation, but inventory and crafting are not? Can't really do much during conversation though (I could unequip sword, but re-equipping? Impossible)
** Yet immediately when the conversation ended I dropped into overhead stealth mode.
* Strength (so I guess Warfare) boni count twice? Why?
* Attacking invernable stuff like sleeping bag, sack or campfire, weapons flying in the sky hitting nothing; durability is still drained.
* Restorating scroll is one-use item with memory requirement?
* Movement penalty reduction text is displayed hovering over movement if only wearing +movement itemry.
* The "simple helmet" in the hidden alcave with a iron helmet icon is actually a hood when wearing it 0_o
* -accuracy (I assume, it says nothing) from blinding is not displayed in accuracy statistics.
* You can attack Tam, then talk to him while he runs (and you'll have him vanish before you with the dialogue still open)
* Crippled effect on movement speed probably should not be "movement speed boost: -100%"

* Texture issues (check inside the bushes for a grey untextured area):

* Tree clipping with banner (looks weird):

* Player dies, hood surives!

Last edited by Hassat Hunter; 15/09/16 02:34 PM.
Re: HH's v2.0.164.992 Bug Topic [Re: Hassat Hunter] #585614
15/09/16 12:22 PM
15/09/16 12:22 PM
Joined: Apr 2011
Posts: 1,771
Hassat Hunter Offline OP

Hassat Hunter  Offline OP


Joined: Apr 2011
Posts: 1,771
* Unnis tells me to stow my weapons even if stowed. And she keeps her knife out at all times now.
* Color-codes seem to surprass after loading a save. A buried treasure I unburied, went in inventory, dropped used to have a purple-code, now on load save, it's name is white.
* Ralvo's dialogue should mention how much money will be reduced. Also he stands on his bench when you approach to join.
* Elodi is harmed by my Dragon's Blaze even if it's only supposed to hit non-allies.
* Burro and Kana had "leader in sight" bonusses but neither have Leadership. They got it from Lohse, which was totally unrelated to them.
* Leadership 1 (shown on Dominick) gives +2% critical chance, unlisted in it's description (and I don't think it should, it's listed as lvl 2's reward?)
* Now that I got Lohse and she gets +damage from intelligence (note NOTHING on Intelligence says so), does Warfare simply not work. It's only giving +damage from strenght, nothing about +warfare damages
* Trying to use the gate (or just going up the darn ladder trying to talk to people!) could give a warning, instead of them murdering me in cold blood smirk Actually, why ARE the ladders marked as theft?
* Encourage boosts Dexterity. There is no Dexterity in this game.
* If putting on the bucket, hovering over initiative does not say where the -1 is coming from.
* Responding to Mona she's standing on her chair.
* Are gloves on Ceville meant to turn into leaves hanging on her arms. Seems weird for leather gloves.
* Twig with a string has 1AP equip, 2AP attack. Result = 2AP attack. Then why, why, are 1AP equip, 1AP attack weapons also 2AP?
* Sebille (ingame recruit) starts with 0(!) civil abilities.
* Apparently fortify requires Geomancer 1. I use it, Geomancer 0 (probably since you can't swap skills at start)
* Narin's trap gets... a little bit... spoiled by having his textline above him after he hides and moves, and the camera moving along with him. I knew exactly where he was when it was my turn.
* Team conversation with 2 partymembers after ambush is... weird. But that's probably also due to the heavy amount of placeholder I hope.
* Margo is supposed to give me a recipe for being a prince and listening to her tale... but... nothing is added (even if the "item to character" animation played on the portrait)

More clipping flags:

I have a feeling tail and cat tail clippings will be common:

+Dodge on gear doesn't work?

Headless sitting people (zooming in):

The mysterious decorative element "2":

Narrator break/error:

Typo, sclaes > scales

New recipe fail:

Hovered over tooltips remain if closing inventory & leather gloves with physical defense have wrong "mage gloves" description:

If you piss of Hilde, she will no longer trade with you, however her dialogue still mentions trading:

Amyro: Name never was mentioned before this option, yet you suddenly can mention him.

You can re-cap tutorial messages in a menu that does NOT exist:

Re: HH's v2.0.164.992 Bug Topic [Re: Hassat Hunter] #585625
15/09/16 01:24 PM
15/09/16 01:24 PM
Joined: Aug 2015
Posts: 308
Quebec, Canada
norD Offline
norD  Offline

Joined: Aug 2015
Posts: 308
Quebec, Canada
Damn, all your images are "gone" frown
Thanks a lot for the feedback though!

Re: HH's v2.0.164.992 Bug Topic [Re: Hassat Hunter] #585631
15/09/16 02:32 PM
15/09/16 02:32 PM
Joined: Apr 2011
Posts: 1,771
Hassat Hunter Offline OP

Hassat Hunter  Offline OP


Joined: Apr 2011
Posts: 1,771
Just uploading these real fast before I forget all about the combat stuff, as I know I will... first some more basics:

* If you fold, you can tell Ralvo he cheats, however he didn't show his hand, how could you tell?
* Leveling up in combat sets AP to full.
* First Aid skill doesn't actually heal for 30% (probably due to 0 turns effect). Does seem to heal out of combat though.
* First Aid's rested doesn't mention +1 STR/INT/FIN effect.
* Combat is over, and my PC just runs out away from where he was (surrounded by cursed fire)... and died due to that. What?
* Yup, dodge from gear is definitely broken.
* Dragon's Blaze may not damage allies(?) it does set them and the surface around them on fire, harming them anyway smirk

Then what was very confusing my last fight;
* Hail strike seemed to cause way more damage than intended, and as result of being multi-hit it's chill becomes automatic freeze. Seems; broken. Atleast doesn't match what it's said it should do at all;

* Here we got warfare at work... I think. It says 3 physical armor reduction, no idea what that is. Then it's substracted by... 19 damage. What? I have no idea what's going on in the log here;

Re: HH's v2.0.164.992 Bug Topic [Re: norD] #585632
15/09/16 02:33 PM
15/09/16 02:33 PM
Joined: Apr 2011
Posts: 1,771
Hassat Hunter Offline OP

Hassat Hunter  Offline OP


Joined: Apr 2011
Posts: 1,771
Originally Posted By: norD
Damn, all your images are "gone" frown
Thanks a lot for the feedback though!

That's odd, it says they should display for developers; thus... you. Nevertheless if not, they should all appear once the game goes live "for real".

Re: HH's v2.0.164.992 Bug Topic [Re: Hassat Hunter] #585688
15/09/16 05:26 PM
15/09/16 05:26 PM
Joined: Apr 2011
Posts: 1,771
Hassat Hunter Offline OP

Hassat Hunter  Offline OP


Joined: Apr 2011
Posts: 1,771
Seeing as there's an update, final few bugs found using v2.0.164.992 still:

* Ifan Ben-Mezd starts with 7 attribute points rather than the proper 5 everyone else has? (recruited him lvl 2, but he still has +2 I can appoint myself too. And all others match level 1's as should)
* Throwing knife special is "CanBackstab"
* Hail Strike says it only harms enemies, but it also hits allies. Spell or description is off.
* If Mody flees for the red demon, just talking to her again makes her resume her regular playing.
* I'm going to assume Elodi's "thug" line is a placeholder, even if it has no [] (meeting her back in the cave, first line)?
* Before you go I give you price, here... have a severed head... and no questions where asked. Trust me, I have PLENTY of questions here. How can the player just casually accept that?

Re: HH's v2.0.164.992 Bug Topic [Re: Hassat Hunter] #585909
16/09/16 02:46 PM
16/09/16 02:46 PM
Joined: Apr 2011
Posts: 1,771
Hassat Hunter Offline OP

Hassat Hunter  Offline OP


Joined: Apr 2011
Posts: 1,771
Apparently 0kb was just for non-KS backers, so same version. However now that we really have a first update, final ones of .992.

Note those with TBD will hopefully be updated later. Sadly enough uploading those screenshots to the Steam cloud crashes my entire client for some reason, so I can't show them now. Will wait a while and if Steam keeps it up, probably have to look for an alternative upload-source.
EDIT: Added

* No actual interaction possible with the barricade? In original setting all I got is out of range, moving them with telekenisis I just walk around it, no text.
* Acid physical armor damage effect is not logged.
* Found a few more scrolls, all 1 memory requirement. Scrolls don't need those.
* Picking up the cup of tea or empty cup near Lord Withermoore suddenly makes the top of the box dissapear, causing all other items to fall under the box. Trying to move the box takes them along too, making it required for you to pick it up to take the other items.
* Lord Withermoore is petrified, he should not animate when talking to him before release
* If I face the direction of the stairs in For Joy (the arena) I get 25FPS... all others, 100FPS (my FPS lock). Ultra graphics, haven't noticed a dip below 50 anywhere else yet.
* Rex in the arena gives no XP? (even though it's not a spawn)
* Can't talk to faithful one after getting buff until fight is done.
* One of the animations of the faitful one warps her sword infront of her, then it's back at her back again once the animation is over.
* Repeating the same question of the Burnished one with different characters is... odd.
* The Shrine to Amadia has the same non-narrator ? as the Divine shrine has.
* I've killed Delorus, got XP, but combat log doesn't show the skill. Probably since NPC?
* Houndmaster summoned hound... but nothing happened.
* Enemies launching armor-piercing grenades, damage blocked by physical armor. Shouldn't they act like piercing and disregard physical armor?
* What does the "Lowered Armour" debuff do? As far as I can tell got nothing.
* Welp, super confusion... +2 vitality on gear apparently meant the ability, not just +HP. Got me!
* Equipping gloves with +2 vitality (or is due to level 3?) raised critical chance by 2% aswell... what?
* Using fortified with 0 armour at that moment gave me 49 armor. +46 from fortified itself. Does fortified restore ontop of that? Should probably be told in description!

* Says absorbed 9 when really it's absorbed 1

* Why does Richocet curses the ice and water?

* I don't quite get those status-effects... they immediately wear off?

* Ifan's resisted death shows only 1 damage done? Shouldn't he only die if damaged again, missing in log or?

* The remains of the charged frog is are invisible? Also the corrosive slug is very hard to select and the poison slug doesn't highlight hovered over:
http://steamcommunity.com/sharedfiles/filedetails/?id=764480045 (you can't see it in this image but the cursor is above the nameplate, FAR away from the actual body)

* Graphical Anomaly in the end of the cave:

* Is it supposed to look like that?

* Vast One intro error:

* Magic Shell buff says +30 magic armor, gives +39 instead. Had 28 from gear, no magical armor skills.

* Height targeting (and yes, I could attack the first):

Sadly, looting his corpse did NOT grant me AP:

So, yeah... he teleported there and since there was a locked door inbetween us combat just stalled... till I lockpicked said door.

Last edited by Hassat Hunter; 16/09/16 04:44 PM. Reason: 2 screenshots
Re: HH's v2.0.164.992 Bug Topic [Re: Hassat Hunter] #586695
18/09/16 01:01 PM
18/09/16 01:01 PM
Joined: Apr 2011
Posts: 1,771
Hassat Hunter Offline OP

Hassat Hunter  Offline OP


Joined: Apr 2011
Posts: 1,771
While we do have a new version now ( going to stick to this topic for the time being since it was a rather small patch, and doesn't really affect the things I report. Moving on it seems the time for conversation is over, combat after combat awaits. Dissapointing. It looks like the amount of quests and dialogues is heavily turned down from D:OS1 or is that just me? The price of branching origin missions?

Continued report of bugs (smaller since so much time taken by combat, and I think I already reported all things confusing me... combat generally devoids in "everything's on fire" anyway, with melee being useless since they burn to dead before reaching anything, but that's for another topic):

* Yup, definitely confirmed it now, my +2 vitality gloves gives +2 crit (Gear: +2) while the vit is it's only effect.
* Eddies lockpicks don't seem to stack with my existing ones.
* Not sure you're supposed to trade with the Magister Houndmaster.
* Verdas rose up from his bench upon becoming wet in combat (Rain).
** And then when combat was over... he died smirk
* (loading save) Verdas first response as lizard lacks the [LIZARD] tag. Same with Humans and [HUMAN], and probably all others.
* Like many others, Verdas stands tall on his bed when talked to the second time (didn't happen all throughout first convo)
* Bit odd to have a 2-way conversation at Delorus when 1) there's no other so far ingame, 2) we have 4 players now rather than the old 2. 3) Actual good old fashioned dialogue (just lacking the "") 4) Actually all agree to help and still can let him rot.
* Terror grenade. Probably should say "Terrifying" rather than "Terrific"
** Also it has a "100% chance to set for 2 turn(s)"
* For some reason Ifan pretty much always starts his turns with 6AP?
* Imperial Fire Slug can be frozen... how does that work?
* Much like dodge, it appears accuracy from gear is broken.
* Well, that was interesting... If I ask the AI to go from beach to prison block, they make a full circle in the cave area before going into Vasyna's cell.
* Brittle soul jar: Don't you mean whirl instead of whorl?
* Only the player-created character gets a tombstone?

* What's up with that flashy icon on that... corpse?

* Corpse floor clipping (Verdas):

* Wits line is cutoff:

* Apparently some issues with backstabbing on elevation:

* Just check this log (also Ifan died 3 times 0_o):

Re: HH's v2.0.164.992 Bug Topic [Re: Hassat Hunter] #586697
18/09/16 01:02 PM
18/09/16 01:02 PM
Joined: Jun 2014
Posts: 89
Plumpbiscuit Offline

Plumpbiscuit  Offline


Joined: Jun 2014
Posts: 89
This is some great feedback, going to bump this as I've had the same issues in my playthrough, too.

Re: HH's v2.0.164.992 Bug Topic [Re: Hassat Hunter] #586788
18/09/16 04:14 PM
18/09/16 04:14 PM
Joined: Apr 2011
Posts: 1,771
Hassat Hunter Offline OP

Hassat Hunter  Offline OP


Joined: Apr 2011
Posts: 1,771
* Clicking the lever again to Withersmoore jar's room shakes the screen, while nothing actually happens.
* Using Richochet I suddenly get 2 silent monks joining the fight that were never my enemy.
* Ground Smash skillbook gives Battle Stomp (same skill)
* Critical on gear should say +2%, and hovering over critical it says Gear + 2 rahter than Gear + 2%
* The healing potion and resurection scroll in the dogpen doesn't stack with other similar items (considered stolen even if yellow and no stolen tag?)?
* Talking to a Emmie with a character with no Pet-Talent still provides actual dialogue
* All the books (bar 1) in the dogpen's prison are emptry.
* Sleeping in the bed of the Houndmaster's Room gives 1400XP for no reason? Misplaced exploration XP?
* Releasing Birdie it starts convo with the very nearest person, rather than with a Pet Person user if one's in the party.
* The line about your hand repeats after release, even if it makes no sense there never offering your hand like in the convo when she's caged. Should probably be replaced with a new relevant line.
* The hell. A check of 17+persuasion fails a roll against authority, but 11+persuasion succeeds against the same authority roll. How the hell does persuasion's mechanics work. Do they work?
* Way to skift XP. Succeeding a check; 1400XP... killing Birdie (cause failed roll); 0XP.
* The pain bench in the fort does damage. However the one Verdas was on does not?
* While the pain bench works, the pain seat has animation issues, causing the character to stand up each time they take damage
* I'm really not sure you should be able to trade with all the magisters who are going to kill you.
* Knockdown overrules crippled, but crippled does not remove knockdown? I'm not sure I understand the logic but forcing those in the knowing to use skills in the right order to apply both for no concernable reason.
* Seems it's not related to a character, max AP can happen to anyone, now have it on The Red Prince. Maybe related to First Aid, since self-cut elf did cast that upon my Prince, who had 0AP, and now starts his round with 6AP, while having spend all his AP last round.
* Apparently the Meat Golems have a 85% chance to disease. I thought that kind of RNG was gone (some like me hate it, others are very happy about it)
** Add 10% chance for bleeing/muted on the knifes dropped... yeah, 0% or 100% definitely doesn't need maintained anymore.
* Meat Golems use human soundset. Can't recall hearing it from actual humans though.
* It appears some parts in the dungeon are clones, since eating them gives the same "sensual dwarf" line for example.

* More log (totally incorrect and weird absorbed values);

* Barrel has interaction rather than loot, does nothing (there's actually a second one there doing the same):

* Lizards and chairs (not surprisingly really)

* I'm going to assume that's supposed to be on the table, not floating (torture room)

* Placeholder (probably know, mentioning it anyway):


* Typo; Is has:

* Apparently the Meat Golems (enraged) attack of opportunity means they get 4(!) attacks on the poor sod crosing them. I don't think AoO is supposed to work like that!
** Though running past another meat golem (this one was dead now) later on triggered no AoO's at all!

* Loremaster level too low? LIES!

Re: HH's v2.0.164.992 Bug Topic [Re: Hassat Hunter] #587065
19/09/16 12:57 AM
19/09/16 12:57 AM
Joined: Apr 2011
Posts: 1,771
Hassat Hunter Offline OP

Hassat Hunter  Offline OP


Joined: Apr 2011
Posts: 1,771
Calling it an evening, here's the last of today...

* Well, casting first aid on Ifan, he was the only one starting with 6AP while all others had 4AP. However as combat progressed also The Red Prince and Sebille started with 6AP, having used all, no first aid applied. Still not quite sure what causes these.
* In the book in the room besides it says Silent Monks don't act just respond, yet the Elf-turned-Monk immediately joins the fight to kill you?
* I got control over Lohse even though she was frozen. Only think I could do was end turn.
* When eating the elf-turned-silent-monks meat (and the other one, not sure of which I looted that), all I get is "Bon Apetit", no dialogue from Sebille.
* Paiting of a knight in that room has a ? icon
* So Nebora takes off your color but leaves it on the rest of your team???
* If caught without collar your items go into the worn-out chest rather than the evidence chest? (It's still listed as looted from before so I almost missed it too)
* The silent monks now appear as hostile inside the fort (with a sword icon over them), even if they don't attack at all.
* Why do Yarrow and dad attack you for not wearing a collar after you helped them and all? They even gave you this key, helped you in the fort and told you to get the hell out smirk
** Killing Yarrow and dad re-opens the quest with a "The Gheist I encountered is dead" with no way to close the quest anymore.
* After destroying the soul-urn of Withermoore returning all I find is his dead body - no questupdate.
* Why does my True Love Butter participate in the Griff fight? (Even the more "noooo" is reading her diary afterwards)
* Killing Garwin in the camp drops his robe, which according to the description he should not have there. Also has closing placeholder tag, but not opening. Lastly killing him doesn't update "The Teleporter" quest.
* Killing the mother doesn't close "A mother's nightmare" quest (or atleast updates it)
* After killing Griff, keeping the Drundae, you cannot offer that Drundae to Stingray for his dreams? Should be possible.
* People in town say "I'm alone for this, I see" even if they have others joining the fight.
* The final line of not giving up Stingray to Griff makes little sense, it's talking about the oranges. Should be re-written.
* If I cripple Silence I cripple Stingray too (probably same with other "other enemies" skills). And then Stingray actually *becomes* my enemy, wanting to kill me smirk
* Make invisible is also very easy to counter without text, the camera follows the invisible opponent smirk

* Stool in wall (default placement):

* Okay, I can understand the big ones being 150 (okay, not really, still)... But this tiny one??? (Yes, all three weigh 150):

* Quite A common sight:

* Hall pf Penitence (OF):

(If you get to jail once for missing your collar all items are returned, second time around though, the sheer majority of your items WILL be lost!)

* Exactly repeating dialogue:

* It appears Hilde drops her inventory at death. Bit excessive and other vendors don't do the same.

* End of the world looks baaaaaaad:

* Graphical distortion near crocodiles:

Last edited by Hassat Hunter; 19/09/16 01:09 AM.
Re: HH's v2.0.164.992 Bug Topic [Re: Hassat Hunter] #587875
20/09/16 06:28 PM
20/09/16 06:28 PM
Joined: Apr 2011
Posts: 1,771
Hassat Hunter Offline OP

Hassat Hunter  Offline OP


Joined: Apr 2011
Posts: 1,771
Short one since I don't know when next patch will hit or I have time to play more:

** Dxdiag.txt fileDescription is wrong when sending Crash Report.

* Player does teleport thing, breaks tree, goes down, goes through cave and says "Were am I" even though I've fully explored the location I ended up at.
* For some reason teleporting the ornate chest over near Gawin made him loose -5 reputation.
* Regain HP by cutting up a decoration (in the case, tree trunk) with Necromancy. Hardly a large way to gain XP, but probably still unintended.
* Every Mother's Nightmare completes when Gavin sets me up and leaves without me... I think that should be The Teleporter, no?
* Wheelbarrow (near Cork) has an interaction wheel, no interaction. Trying to pick it up it says [Wheelbarrow description]

Very smart, Cork:

Re: HH's v2.0.164.992 Bug Topic [Re: Hassat Hunter] #588932
24/09/16 12:28 AM
24/09/16 12:28 AM
Joined: Apr 2011
Posts: 1,771
Hassat Hunter Offline OP

Hassat Hunter  Offline OP


Joined: Apr 2011
Posts: 1,771
Got another evening with D:OS2. 23 hours in, still not done with first run. Damn. Then again, I'm not exactly doing it fast, noting down all this stuff along the way.

* Hothead +critical chance is not displayed when hovering over.
** Nor is your x% critical chance with spells having Savage Sortile
* Appears you get the "Identifying level too low" error if the person with Loremaster has no identifying glasses in his/her inventory, even if the party has 5 and skillelvel of Sebille is 2 (item needs 1). Giving her a lens allows me to identify, alos in others inventory.
* If an item has physical and magical armor the physical armor icon does not show.
* Inside the tent ontop the Magister stronghold (where a scale armor resides) are also a lot of empty books. And a table without collission you can walk through.
* Jugs have ? icon
* For some reason everyone is floating over the main bridge.
* Rain appears to only affect area around caster (shown as range) rather than target you're aiming at (which has a seperate range indicator)? Finally explains why so many of my rains fail even if I aim properly, it disregards it.
* Decomposing Swashbuckler used Musquito Swarm... since he's a zombie, he harms himself with that aswell!
* X is adrenaline - X is no longer adrenaline - looks bad.
* Source Hound runs away when skeleton combat starts. Stays away. Dialogue makes fairly little sense at new location.
* Persuasion DOES NOT WORK; http://larian.com/forums/ubbthreads.php?ubb=showflat&Number=588895#Post588895
* Windego's fire keeps on going, sound effect too, very annoying.
* Windego's story repeats talking with another character to her.
* Digging a secret near Windego (not from the journal or eating) all I get is a skeleton with a wooden stick???
* Encourage description is horribly, horribly wrong (appears based on level? Just like everything else, super-unclear)
* Gareth fight is really awkward if coming from the ladder and being ontop. Everyone takes a different path to get to you, and without any action of the player you can pick off foes one by one.
* I save Gareth - "Loose those weapons if you know what's good for you" ehm... thank you would have been nice?
* I assume Whirlwhind uses weapon damage (seeing it's got my weapon's elemental damages). But it doesn't mention so?
* So I save Gareth, lead him out the stairs, have a chat... and he rans off infront of the Shrieker. Good thing he has story invernability, though it's rather implausable he would have survived that.
* Whirlwind stats does not properly reflect damage it'll do.
* Enemy tries using Infect, magic armor saves it. No damage, waste of enemy turn.
* But seriously, why are Loke and the skeletons on the same side? Why are they not attacking him?
* Magister Sang? You're dying? Good, let's trade!
* Braccus boots really only curse once, just put them on once keep them on and they're great. Probably not the intention of a curse, is it?
* Appears the Murderous Gheist only re-appeared since I had it archived. Had 2 copies. Unarchiving the completed, then re-archiving removed it from my active questlist.

* All treasures on screenshotted table are duplicated. What should be 2 hammers, 2 makeshift axes & 1 nails = 4 hammers, 4 makeshift axes and 2 nails.

* I have literally no idea what it was supposed to say there:

* These Yarrow Flowers don't highlight with alt.

* Enemies should probably not cheat-teleport to locations like this, leading to weird stuff as seen here:

* Voidowken;

* It's just one rat (not ratS):

* More rat spelling errors:

* Very stealth, much wow... PS. Don't do this for invisible enemies. Total giveaway! (another one)

* Auto-following teammates break on this ladder:

Re: HH's v2.0.164.992 Bug Topic [Re: Hassat Hunter] #591762
05/10/16 10:58 AM
05/10/16 10:58 AM
Joined: Apr 2011
Posts: 1,771
Hassat Hunter Offline OP

Hassat Hunter  Offline OP


Joined: Apr 2011
Posts: 1,771
Got another hour in, like, 2 weeks later smirk. I wonder if I'll finish before the next patch, who knows, who knows...

* Phoenix Dive - The Red Prince is fire immunity.
* Cursed Water and Cursed Steam still have placeholder text (probably know, still mentioning)
* Seems the new vicious voidwaken that spawn from the ground aren't affected by an ongoing rain? (until Rain caster's round)
* Restoration counters acid, not listed in description
* Burn my eyes description says primary attributes are raised, tooltip of clear-minded says wits. Both happen. Contradiction? Working as intended?
* It doesn't seem Stingtail actually removes your drundae from your inventory when eating it?
* Why do Han and Simone have 50% HP in the Seeker camp?
* Simone stands on her chair during the Gareth speech.
* Leya also does so pretty much everytime she speaks (so animates)
* Looting Jules corpse (white) will still give a stolen Filthy Book skillbook. Same for Klaud (and probably Matis, but he was empty for me) random loot.
* The book near Exter is empty
* Finesse potion is still called minor DEXTERITY potion. Same for wits/Perception potion.
* All the broken items of Kerban can be stolen, they are not marked as his
* Hallom's Blade does not look like a dagger at all, estoc's are daggers?
* Killing Void salamander gives no XP? Noxious void only gives 420XP aswell.
* I keep recovering weird items from corpses during combat (shield from the salamder, orange juice from voidwoken), but if I loot corpses post-combat they're generally empty. Something's up there.

* Convo-loop (dialogue shows IS option #2):

* Bad spelling (should be There's a ruin or There are ruins not There a ruins):

* AI followers also have issue with the Seeker stairs, could be because the poison flower was on it when it initially went down though:

* Line suddenly breaks:

* Gratiana persuasion; double-mentions of skill use is bit redundant:

* I think it's end, not send right?

* Not the faintest hint of decoration... have you CHECKED that shield? It has a face and a giant gem. That seems like heavy decoration to me:

* You cannot actually select this chest hidden in the Seeker's camp, so the only way to open is by AoE attacks that happen to also hit it.

Re: HH's v2.0.164.992 Bug Topic [Re: Hassat Hunter] #591834
05/10/16 03:36 PM
05/10/16 03:36 PM
Joined: Oct 2016
Posts: 1,695
Kalrakh Offline

Kalrakh  Offline


Joined: Oct 2016
Posts: 1,695
- Winterblast can't be used in extended reach area of hight advantage positions.

Re: HH's v2.0.164.992 Bug Topic [Re: Kalrakh] #591843
05/10/16 04:00 PM
05/10/16 04:00 PM
Joined: Sep 2016
Posts: 333
SlamPow Offline
SlamPow  Offline

Joined: Sep 2016
Posts: 333
Originally Posted By: Kalrakh
- Winterblast can't be used in extended reach area of hight advantage positions.

Actually, it can be. It just doesn't show the indicator going past the unextended range, which is a real pain. frown

Re: HH's v2.0.164.992 Bug Topic [Re: Hassat Hunter] #591882
05/10/16 06:29 PM
05/10/16 06:29 PM
Joined: Apr 2011
Posts: 1,771
Hassat Hunter Offline OP

Hassat Hunter  Offline OP


Joined: Apr 2011
Posts: 1,771
I think the end is approaching... will try to finish it off tonight. Meanwhile, obviously found a large number of bugs, having played 5 more hours, here they are:

* Also blood cloud has temp-place holder text.
* No XP for killing Flaming Guard or Flaming Archer in Gargoyle Maze.
* Flaming Archor & Scorcher (skeleton) screams like a human.
* Necromancer Tasmyn also does the standing on seat (and floating sword above) while the other 2 DO properly stay seated during their animations.
* Even though the necromancers are undead, they are not immune to sleeping nor bleeding (like other undead around the world)
* Only first touch of the mysterious tech curses you, any touches afterwards do not give that effect.
* In the mysterious room (illusionary dungeon) picking up stuff from the table near the 2 swords the rest will fall through it. Picking up one broken two-handed sword the other will fall through the world!
* Same room picking the stick or makeshift shield/sword the painting will fall from the wall.
* I assume global coolings animation isn't done yet? Since nothing really happened, then we took damage and that was it.
* I assume one part of the battle in the area past the mysterious room isn't working properly. He casted 2 clones to fight him, ran, then I just killed him and got XP for all 3 kills, no effort whatsoever (these others didn't even get a turn). Missing invisability?
* Braccus Ring doesn't work properly. I can just unequip it and curse will remove by itself. Journal doesn't update if teammate equips it (since personal quest). Gave to Lhose, blessed her, and now she's got a nice ring (and boots). Definitely something not working there.
* Sparkling Soul Jar and Tarnished Soul Jar don't seem to want to go into my backpack.
* Gargoyle Maze has no conclusion entry (if cheating?), same for The Vault of Braccus Rex (broke soul jar).
* Can't lift "A fate worse than death" tomb.
* Seems odd I can offer Gratiana's soul jar ("this one has your name on it") to her when I emptied it rather than took it whole?
** Even odder is she can get the source out of it after *I* got the source out of it in the cave if I give it to her.
* After giving Gratiana her soul jar and hearing her story, sharing a hug, talking to her again will re-trigger the "give me the jars!"
* Gratiana drops her entire merchant inventory upon death (they will be listed as stolen on pickup though).
* Smart Radeka used Raining Blood, harming... only herself. Seriously, girl...
* Fortify - Radeka regained 73 physical armor, started with 0, ended with 91. Somethings not adding up there.
* Ancient Reaper (undead in Radeka fight) isn't immune to sleeping. Ancient sharpshooter screams like a human woman.
* Medats notes; Could use an enter after the notation of the second and third dates.
* Very hefty "chilled blocked by magic armor" spam near Ice Dragon.
* The Purged Dragon entry starts with "I killed Radeka"... ehm okay... did the Dragon need that I guess. Makes little sense to have it before even seeing the dragon or talking to the dragon.
* Slane refers to my Source Collar when infact it has been removed on the character he talks to (my main player)
* Slane can "feel her dark heart beating" after I killed her... oops? (Or perphaps he really is just bluffing and can't feel a thing)
* Slane - "shifting between two ships is our greatest gift"... does he mean SHAPES?
* Doesn't seem the Purged Lizard closes when he flies off (or is it simply to be continued?)
* Yarrow flowers near Bear cub also do not appear with tab. Do they simply not show up with tab???
* Looted the bear's mother, but couldn't tell him the location? It's rather odd you need to tell him his mom's *probably* dead to continue. Also convo repeats if restarted after not wanting to say that and patting the bear cub instead.
* And when it finds it's mother... nothing??? No new talks, no floating text, just... nothing.
* Post Torture Man/Woman talk; Sebille and Red Prince use same dialogue.
* Used Blitz Attack on Decomposing swashbuckler, moving onto Voidwaken Deep-Dweller. Then he got an attack of opportunity, and thus I never got my damage in on the Voidwaken since the attack got interrupted due to that AoO that should never have happened in the first place!
* Undead during Voidwaken Deep-dweller fight also can sleep and sound human.
* The Teleporter quest does not update upon finding Gawin dead?
* The first venture into blessed fire harms armor?
* Found a dead Squirrel near the Shrieker that's at the fort you find Gareth at. I have a feeling it's not supposed to be dead, is it?
* No quests (collar removal anyone?) if you freed Gareth before finding the Seekers camp?

* It's corpse is flying:

* Even if the table is destroyed: The cards remain:

* You can't pull hand back from the mysterious tech, it'll just create a dialogue loop till you touch it:

* Msyterious:

* Graphical Anomaly (backpassage to Gargoyle Maze)

* Teammates also have issue with this ladder; walking around and triggering combat (also downstairs they walk around aswell):

* Now > Know

* Icy Soul Jar repeats itself:

* Mask; Ehm? Looks cool, but totally not the icon.

* More stairs that give issues (also for the enemy during combat, would explain why the ranger kept skipping turns);

Re: HH's v2.0.164.992 Bug Topic [Re: Hassat Hunter] #591969
05/10/16 10:53 PM
05/10/16 10:53 PM
Joined: Apr 2011
Posts: 1,771
Hassat Hunter Offline OP

Hassat Hunter  Offline OP


Joined: Apr 2011
Posts: 1,771
After 33 hours, I'm done. The one who checks my logs especially that last battle is probably scratching their head "what the hell is that guy doing? WHY? WHY?" But yeah... waiting for the next patch now (or maybe skip that one depending on what combat changes it brings) so here's the last report for probably quite some time.

* Kerban's slow really makes it that he needs a LOT longer to reach the harbor than the other Seekers. Why do he and Leya have it anyway?
* You cannot talk to Samandel at all anymore after the Seekers go to the harbor. I assume she was supposed to join them?
* Gareths cloak REALLY clips with his shield btw, Kerban too.
* With Han and Simone Gareth generally does his line 5/6 times before leaving again.
* Often loud thunder can be heard (also inside) without rain or anything?
* When taking the note of Tolemy, you don't actually get the note. You have to kill him to gain it from his body.
* Also the journal updates telling me about the contents of the note before reading the actual note (or from above, even gain it)
* When you do get the note then, it's "stolen"
* Duggan says Leya is "safe back at the cave"... the seekers are in no cave.
* If the rat survives the Shriekers (after all, you can make it run down after killing them) you can no longer talk to him. Also once reaching the docks, he'll return back to the stairs to wander around.
* If Slane arrives against the Shriekers The Purged Dragon completes without new entry.
* If Slane arrives against the Shriekers, and kills them before the rat reaches them, the PC will comment on the Rat's unfortunate death... which never happened.
* If Slane kills the Shriekers and you run even a little bit forward, they all run off to the boat, leaving you without backup. Even if you talk to Gareth, the support is already despawned and unavailable.
* Conversation to pick teammates seem oddly worded (trying to pick healers x2)
* The "Kerban looks at fallen comrades" makes little sense if he assists you against Alexander.
* That moment when Duggan uses Electric Discharge and... STUNS YOUR ENTIRE TEAM. *sigh*
* Feder doesn't talk in the Seeker camp.
* Gratiana is back at the Seeker camp for some reason during the assault on the ship (talked to her about her soul jar again at the harbor)
* I don't think the dialogue should say "You step onto the boat" if doing so is a manual action.
* Yarrow flower: 100% chance to set Yarrow Flower for 0 turn(s)... What the hell IS that?
* If you eat 1 shell, you know the effect of all shells. Why not with fish, since it's the same principle there?
* Carrots give +1.00 sight... that stat is no longer in the game.
* Eating a blue mushroom does nothing.

Time for the thing I saved for last, crafting-feedback;
* Pitchfork weights 2, most other spears weigh 1.
* Apparently there are 2 kinds of buckets; 1 with description, 1 without. That without should be removed.
* There are leather boots ingame with "chainmail boots" as description, and scale boots saying "Plate mail boots"
* Got one bottle of beer, wine and water that don't stack with the others... somewhere smirk Same with a mug of water, and wine.
** And bread, carrot, herring, red snapper, plaice, ham, penny bun mushrooms, amaduvour, calocera, stardust herb, wood chips, bowl, leather scraps, empty mug and most of the shells (why so many clone items?)
* Bottle of beer weighs 0.33, wine is 0.70... water is 1! Assume these should be about the same.
* Mug of wine is 0.20, water 0.25, beer is 0.33. Except poisoned beer, that's 0.03.
* Lemons, pepers and tomato's just don't stack, period (and they should)
* I got 4 peppers, only one has a description
* The bloodrose I bought doesn't stack with the 2 I found.
* Tongs, empty potion bottles, spoons, bedrolls, nails, sharp piece of metal, wooden branch and tiny pearls should stack (they don't).
* Wool weights a bit too much wink
* Can't make anything with arrow, just arrowshaft?
* No recipe of applejuice/orangejuice added when making it
* And... that's really all the recipes I could find. Rose (from forum), arrows and applejuice smirk. Can't even smash a tomato to juice or carve a pumpkinhead.

Re: HH's v2.0.164.992 Bug Topic [Re: SlamPow] #592187
07/10/16 01:20 AM
07/10/16 01:20 AM
Joined: Oct 2016
Posts: 1,695
Kalrakh Offline

Kalrakh  Offline


Joined: Oct 2016
Posts: 1,695
Originally Posted By: SlamPow
Originally Posted By: Kalrakh
- Winterblast can't be used in extended reach area of hight advantage positions.

Actually, it can be. It just doesn't show the indicator going past the unextended range, which is a real pain. frown

Impalement has the same visual bug.

Powered by UBB.threads™ PHP Forum Software 7.6.2