Divinity Banner
Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
Editor data for patch 3.0.168.526? #641589
02/02/18 01:32 AM
02/02/18 01:32 AM
Joined: Dec 2013
Posts: 871
Windemere Offline OP

old hand
Windemere  Offline OP

old hand

Joined: Dec 2013
Posts: 871
Has everything on the editor side been released at this point in order to work with patch 3.0.168.526? I am seeing strange behavior. I have three standalone campaigns. They all run normally using glasses in the editor, but when trying to play them with the game client one of them crashes when going into character creation and the other two get very strange, broken behavior in character creation. I am suspicious that despite getting an update for both the editor and the client, something is still out of sync.


DOS2 Mods: Happily Emmie After and The Noisy Crypt

Steam Workshop
Nexus Mods
Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641615
02/02/18 08:47 AM
02/02/18 08:47 AM
Joined: Mar 2016
Posts: 500
Belgium
T
Tinkerer Offline

addict
Tinkerer  Offline

addict
T

Joined: Mar 2016
Posts: 500
Belgium
A missing editor update would be more likely to cause issues when using the editor, or running your mod in the editor. It should not affect running the mod in game. So it sounds more like an issue with the game itself. With which of your campaigns does it happen, and are they downloadable?

Could you also explain what exactly goes wrong when it doesn't crash? Thanks.

Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641632
02/02/18 12:33 PM
02/02/18 12:33 PM
Joined: Sep 2017
Posts: 77
Brazil
Zerd Offline
journeyman
Zerd  Offline
journeyman

Joined: Sep 2017
Posts: 77
Brazil
I've been having issues with the editor too. The picture shows the editor is up-to-date (3.0.169.230), but my mod's story script is grayed out and it's impossible to build the story.


Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641638
02/02/18 01:08 PM
02/02/18 01:08 PM
Joined: Mar 2016
Posts: 500
Belgium
T
Tinkerer Offline

addict
Tinkerer  Offline

addict
T

Joined: Mar 2016
Posts: 500
Belgium
The greyed out story script is probably purely a cosmetic issue.

The story errors come from the fact that you did not regenerate the definitions (some Osiris API call definitions changed compared to the previous patch). It's best to always use "Generate Definitions and Build Story" so you never forget this (and the generation of definitions barely takes up any time).

Re: Editor data for patch 3.0.168.526? [Re: Tinkerer] #641641
02/02/18 01:47 PM
02/02/18 01:47 PM
Joined: Dec 2013
Posts: 871
Windemere Offline OP

old hand
Windemere  Offline OP

old hand

Joined: Dec 2013
Posts: 871
Originally Posted By: Tinkerer
A missing editor update would be more likely to cause issues when using the editor, or running your mod in the editor. It should not affect running the mod in game. So it sounds more like an issue with the game itself. With which of your campaigns does it happen, and are they downloadable?

Could you also explain what exactly goes wrong when it doesn't crash? Thanks.


I am running all of these locally from the mod path, they aren't downloaded PAK files for the exception of The Noisy Crypt (which crashes on startup).

The first one is the mod I use for my tutorial series (Launch Day Crisis). This uses the default character creation script on the wiki with some minor edits. When the module starts, I get this, which usually indicates that the character creation script is not getting executed:



You can see how it used to work here, there have been no changes:
https://youtu.be/Yq6Rm_Kqb5g?t=47m


With my other project, Shadow over Moonglow, once again it just looks like my character creation script isn't executing. When I load into character creation I get this:



There should not be any dummy players from the inherited character creation level as I set them all off stage at the beginning of character creation. The character creation script assigns the connecting player to the first "ghost" player and then begins a dialog with the gypsy, but none of that seems to be working. If I manually switch control to the ghost character I see the following:



That screenshot also indicates that the character creation frames forcing the gypsies to sit at the beginning of character creation is not executing. This is what it looked like before the update:

https://youtu.be/DYMRaZn_mEI

====

So all that said, I think I have seen weird results before when updating the editor before the game client, which is what I did last night. I'll try this on a different PC and see what happens. If it does not reproduce there, I'll try a repair/re-install on this PC exhibiting the problems.


DOS2 Mods: Happily Emmie After and The Noisy Crypt

Steam Workshop
Nexus Mods
Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641642
02/02/18 01:58 PM
02/02/18 01:58 PM
Joined: Sep 2017
Posts: 478
Belgium, Ghent
Larian_KVN Offline

addict
Larian_KVN  Offline

addict

Joined: Sep 2017
Posts: 478
Belgium, Ghent
Hey windemere,

It is not a bad update or story change on your side. There's a mismatch between the story code of the game and the editor, causing the editor-built story to not be compatible with the game. We are currently investigating.

Sincerest apologies,
Kevin

Last edited by Larian_KVN; 02/02/18 01:59 PM.

CTRL+K the elf
Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641648
02/02/18 02:52 PM
02/02/18 02:52 PM
Joined: Dec 2013
Posts: 871
Windemere Offline OP

old hand
Windemere  Offline OP

old hand

Joined: Dec 2013
Posts: 871
Whew! No worries, thanks so much for the update.


DOS2 Mods: Happily Emmie After and The Noisy Crypt

Steam Workshop
Nexus Mods
Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641688
02/02/18 11:36 PM
02/02/18 11:36 PM
Joined: Sep 2017
Posts: 478
Belgium, Ghent
Larian_KVN Offline

addict
Larian_KVN  Offline

addict

Joined: Sep 2017
Posts: 478
Belgium, Ghent
The update should be live on Steam as of now smile
Please do let us know if you have any further story issues!

Sincerely,
Kevin


CTRL+K the elf
Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641691
02/02/18 11:56 PM
02/02/18 11:56 PM
Joined: Dec 2016
Posts: 122
United States
Ameranth Offline
member
Ameranth  Offline
member

Joined: Dec 2016
Posts: 122
United States
Restarted my editor and am now being spammed with this error:

Quote:
Trying to read more from a file than the file size.
'D:/SteamLibrary/steamapps/common/Divinity Original Sin 2/Data/Mods/MyModName/Story/story.div.osi'

Category: Code
Count: 999
Timestamp: 02-02-2018 23:52:25:325
Function: ls::FileReader::Read
Location: CoreLib\FileReader.cpp (366)


Deleting story.div.osi and regenerating definitions/build seems to have solved the problem for now.

Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641692
03/02/18 12:04 AM
03/02/18 12:04 AM
Joined: Dec 2013
Posts: 871
Windemere Offline OP

old hand
Windemere  Offline OP

old hand

Joined: Dec 2013
Posts: 871
Thanks Ameranth, I had the same issue after the update and that resolves it for me too.


DOS2 Mods: Happily Emmie After and The Noisy Crypt

Steam Workshop
Nexus Mods
Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641734
03/02/18 12:33 PM
03/02/18 12:33 PM
Joined: Jul 2015
Posts: 169
D
Detect Offline
member
Detect  Offline
member
D

Joined: Jul 2015
Posts: 169
same here. Just tried to compile a script an wow errors!

_GLOBAL_TeleporterPyramids

Big list of errors

Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641738
03/02/18 01:17 PM
03/02/18 01:17 PM
Joined: Jul 2015
Posts: 169
D
Detect Offline
member
Detect  Offline
member
D

Joined: Jul 2015
Posts: 169
I think its fixed now..

BUT Root template is mess up now

Re: Editor data for patch 3.0.168.526? [Re: Detect] #641744
03/02/18 02:25 PM
03/02/18 02:25 PM
Joined: Feb 2018
Posts: 33
D
DerCapac Offline
apprentice
DerCapac  Offline
apprentice
D

Joined: Feb 2018
Posts: 33
[quote=Detect]BUT Root template is mess up now [/quote]

Do you mean all root template folders are gone with this patch? At least that's what I am seeing.

Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641745
03/02/18 02:38 PM
03/02/18 02:38 PM
Joined: Feb 2018
Posts: 5
B
Bivo Offline
stranger
Bivo  Offline
stranger
B

Joined: Feb 2018
Posts: 5
Yes, Root Template no longer has any folders, and there seems to be a lot of entries that now have an odd symbol leading the text, a red triangle shape with an exclamation mark in it

Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641752
03/02/18 04:42 PM
03/02/18 04:42 PM
Joined: Oct 2015
Posts: 16
H
helaene Offline
stranger
helaene  Offline
stranger
H

Joined: Oct 2015
Posts: 16
I'm experiencing major issues with the Editor after this patch:
* all Root Template folders are gone for me
* several nodes are missing from the tree in the Stats Editor (ItemProgression, ExtraData, Crimes, DeltaModifier, ItemColor, ItemTypes)
* also one of my mods crashed as it opened and prompted for level selection - I got that one to load by removing the whole Story folder (I had previously done the whole build/generate definitions bit fine)

@Larian_KVN - Please advise - thank you!

Root Template Editor:
https://www.dropbox.com/s/zytmc3l1rore8p6/Screen%20Shot%2002-03-18%20at%2011.35%20AM%20001.PNG

Stats Editor Sidebar: https://www.dropbox.com/s/mb4r4e1chiurn7q/Screen%20Shot%2002-03-18%20at%2011.35%20AM.PNG

Glasses Crash on Mod Load:
https://www.dropbox.com/s/3gt6ovjohe0sm9r/Screen%20Shot%2002-03-18%20at%2012.15%20AM.PNG?dl=0

Last edited by helaene; 03/02/18 04:49 PM.
Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641758
03/02/18 06:42 PM
03/02/18 06:42 PM
Joined: Feb 2018
Posts: 33
D
DerCapac Offline
apprentice
DerCapac  Offline
apprentice
D

Joined: Feb 2018
Posts: 33
And the position / rotation inputs in the lower right corner seem to be broken too.

Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641799
04/02/18 02:00 PM
04/02/18 02:00 PM
Joined: Feb 2018
Posts: 15
M
McCrunch Offline
stranger
McCrunch  Offline
stranger
M

Joined: Feb 2018
Posts: 15
I'm having issues with the Stats Editor as well, after the latest patch. Worked fine the day before the patch.

Several nodes missing, same as helaene reported. But I'm also experiencing not being able to open several of the nodes that are there.

For example, when clicking on "Armor" under Equipment, I'm getting the following error:

[StatsEditor] Can not load document.

The detailed error is the following:
[StatsEditor] Can not load document.
Detailed error message: Cannot load stats because name attribute is invalid.
Stack trace: ved Stats.StatsDataModel.Stats.Fields.StatObjectFieldContainer.<Load>b__12_0(XElement e)
ved System.Collections.Generic.List`1.ForEach(Action`1 action)
ved Stats.StatsDataModel.Stats.Fields.StatObjectFieldContainer.Load(XElement item)
ved Stats.StatsDataModel.Stats.Object.StatObject.Load(XElement item)
ved Stats.StatsDataModel.Stats.Object.StatObjectContainer.<Load>b__10_0(XElement e)
ved System.Collections.Generic.List`1.ForEach(Action`1 action)
ved Stats.StatsDataModel.Stats.Object.StatObjectContainer.Load(XElement item)
ved Stats.StatsDataModel.Stats.Stats.Load(XElement item)
ved Stats.StatsEditor.Documents.StatsDocument.Load(String filePath)

Category: Editor
Count: 1

Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641802
04/02/18 02:25 PM
04/02/18 02:25 PM
Joined: Feb 2018
Posts: 5
B
Bivo Offline
stranger
Bivo  Offline
stranger
B

Joined: Feb 2018
Posts: 5
Have noticed since the patch that once you add an atmosphere trigger, and then happen to move your initial distant light probe you end up in a state where the light probe is a black ball in the editor, and anything in shadow is super black. There seems to be no come back from this state, changing atmosphere level data, deleting the light probe and re applying, removing the atmosphere trigger, playing with the atmosphere settings etc, will not restore any of the atmospheres to there previous output, ie if it has shadows they are all super black, even the default atmosphere. Its almost like the gamma has been effected for shaded regions and the contrast is ramped up ending in black (shader issue?) I haven't tried adding cull triggers or region triggers, maybe they will have some effect, will update this post if they do.

Ok, I cant get it to work with an atmosphere trigger at all. But if you delete the trigger, and reset the level data to the atmosphere you want, then move the light probe, it will work again correctly

Last edited by Bivo; 05/02/18 12:25 AM.
Re: Editor data for patch 3.0.168.526? [Re: Windemere] #641846
05/02/18 09:48 AM
05/02/18 09:48 AM
Joined: Sep 2017
Posts: 478
Belgium, Ghent
Larian_KVN Offline

addict
Larian_KVN  Offline

addict

Joined: Sep 2017
Posts: 478
Belgium, Ghent
Hey everyone,

thanks for reporting the issues! We are aware of what's wrong and are working on an update to bring those roots and stats back as they were smile

The rotate/translate indications in the bottom right corner not updating has also been noticed. We have a fix for that but it missed the initial update unintentionally.

@Bivo, we're taking a look at your lighting issue as well smile

The hotfix also activated an older version of the Engine DLC by mistake. We updated that back to the latest version. This should solve several data-related crashes some people were having on opening any level.

Sincerely,
Kevin

Last edited by Larian_KVN; 05/02/18 10:04 AM.

CTRL+K the elf
Re: Editor data for patch 3.0.168.526? [Re: Larian_KVN] #641857
05/02/18 01:38 PM
05/02/18 01:38 PM
Joined: Feb 2018
Posts: 15
M
McCrunch Offline
stranger
McCrunch  Offline
stranger
M

Joined: Feb 2018
Posts: 15
[quote=Larian_KVN]Hey everyone,

thanks for reporting the issues! We are aware of what's wrong and are working on an update to bring those roots and stats back as they were :)

The rotate/translate indications in the bottom right corner not updating has also been noticed. We have a fix for that but it missed the initial update unintentionally.

@Bivo, we're taking a look at your lighting issue as well :)

The hotfix also activated an older version of the Engine DLC by mistake. We updated that back to the latest version. This should solve several data-related crashes some people were having on opening any level.

Sincerely,
Kevin [/quote]

Awesome, thanks for the quick fix - Stats editor works fine for me now.

Unfortunately the Filter option isn't working in the Stats Editor, which makes navigating through the long lists a bit of a hassle. Nothing gets registered when typing in the input field.
If I remember correctly a more simple search field was present before the patch, which worked.

Page 1 of 2 1 2

Powered by UBB.threads™ PHP Forum Software 7.6.2