Divinity Banner
Previous Thread
Next Thread
Print Thread
Ridiculously slow demo #169987
08/03/04 10:50 PM
08/03/04 10:50 PM
Joined: Mar 2004
Posts: 31
C
Chacranajxy Offline OP
apprentice
Chacranajxy  Offline OP
apprentice
C

Joined: Mar 2004
Posts: 31
I'm having a problem with the Beyond Divinity demo in that it runs very very slowly on my machine (even 640X480 mode with or without FSAA is slow.) The game is extremely choppy and basically unplayable.

I'm running:
Athlon 64 3200+
1 GB RAM
Radeon 9800 XT
Sound Blaster Audigy 2 ZS
Windows XP

Re: Ridiculously slow demo [Re: Chacranajxy] #169988
09/03/04 08:42 AM
09/03/04 08:42 AM
Joined: May 2003
Posts: 105
Yann Offline
member
Yann  Offline
member

Joined: May 2003
Posts: 105
Hello,

Try to install the lastest catalyst driver : www.ati.com

Re: Ridiculously slow demo [Re: Chacranajxy] #169989
12/03/04 01:19 AM
12/03/04 01:19 AM
Joined: Mar 2004
Posts: 31
C
Chacranajxy Offline OP
apprentice
Chacranajxy  Offline OP
apprentice
C

Joined: Mar 2004
Posts: 31
I tried installing the latest drivers (Updated as of March 10) and they didn't help at all. The demo still runs extremely slow. It's a shame... I got a chance to play it at a friends house and it was amazing...

Re: Ridiculously slow demo [Re: Chacranajxy] #169990
12/03/04 08:01 AM
12/03/04 08:01 AM
Joined: Mar 2004
Posts: 90
Belgique
Philippe_Jacob Offline
journeyman
Philippe_Jacob  Offline
journeyman

Joined: Mar 2004
Posts: 90
Belgique
Could you verify how the IRQs are shared?

I guess your graphic card is an AGP model.
If yes, do you have a sound card in the PCI slot that is closest to the AGP slot? If yes, you may try to move the PCI sound card to another slot. Sometimes, this slot shares IRQ with the AGP, and it is not working always fine.

In theory, IRQ should be shared, but some cards have trouble doing it correctly.

Something is wrong with your system, because with such a config as you have, the game should run as a breeze.


Good luck,
Philippe

Re: Ridiculously slow demo [Re: Philippe_Jacob] #169991
12/03/04 10:13 AM
12/03/04 10:13 AM
Joined: Mar 2003
Posts: 1,109
Duisburg, Germany
Nemisis_Dragon Offline

old hand
Nemisis_Dragon  Offline

old hand

Joined: Mar 2003
Posts: 1,109
Duisburg, Germany
Which chipset does your mainboard use? Try to update those drivers aswell. There are many known problems with VIA chipsets.

Re: Ridiculously slow demo [Re: Nemisis_Dragon] #169992
27/03/04 05:17 PM
27/03/04 05:17 PM
Joined: Mar 2004
Posts: 17
The grand country of England
ghost1234 Offline
stranger
ghost1234  Offline
stranger

Joined: Mar 2004
Posts: 17
The grand country of England
Try going to the device manager and updating each of the devices that are listed.
Also check your hardware acceleration.

Oo|GHOST|oO



Oo|GHOST|oO

Moderated by  Dom_Larian, Larian_QA, Lynn, Macbeth 

Powered by UBB.threads™ PHP Forum Software 7.6.2