Divinity Banner
Previous Thread
Next Thread
Print Thread
Page 2 of 4 1 2 3 4
Re: Graphics Adapter Not Recognized by D:OS [Re: bobwalt] #523906
20/07/14 04:17 AM
20/07/14 04:17 AM
Joined: Mar 2003
Posts: 26,719
Canada
Raze Offline

Larian Studios
Raze  Offline

Larian Studios

Joined: Mar 2003
Posts: 26,719
Canada

I don't recall this being reported before release.

Re: Graphics Adapter Not Recognized by D:OS [Re: bobwalt] #524062
20/07/14 01:02 PM
20/07/14 01:02 PM
Joined: Jul 2014
Posts: 48
A
Actarus Offline
apprentice
Actarus  Offline
apprentice
A

Joined: Jul 2014
Posts: 48
The game is really not optimized for laptop with double GPU.

Re: Graphics Adapter Not Recognized by D:OS [Re: bobwalt] #524177
20/07/14 05:07 PM
20/07/14 05:07 PM
Joined: Jul 2014
Posts: 2
I
irril Offline
stranger
irril  Offline
stranger
I

Joined: Jul 2014
Posts: 2
I start thinking this just a small glitch in video settings. When I choose to run game with nvidia card manually and show the nvidia gpu activity toolbar icon, I see that the game is running with my second gpu.
But it's very disappointing that game runs so slowly with mobile GPUs. On my i7 4700MQ, 8GB RAM, GT740M, I only could get 30 FPS when I run game in 720p and disable the most part of post processing effects.

Last edited by irril; 20/07/14 05:08 PM.
Re: Graphics Adapter Not Recognized by D:OS [Re: irril] #524246
20/07/14 07:22 PM
20/07/14 07:22 PM
Joined: Jul 2014
Posts: 20
A
antip0q Offline
stranger
antip0q  Offline
stranger
A

Joined: Jul 2014
Posts: 20
Originally Posted By: irril
I start thinking this just a small glitch in video settings. When I choose to run game with nvidia card manually and show the nvidia gpu activity toolbar icon, I see that the game is running with my second gpu.
But it's very disappointing that game runs so slowly with mobile GPUs. On my i7 4700MQ, 8GB RAM, GT740M, I only could get 30 FPS when I run game in 720p and disable the most part of post processing effects.


You're right, I've noticed the same thing with my AMD Radeon 8800M. As has been mentioned above, game isn't optimized for mobile GPUs. I hope it will be fixed soon.

Re: Graphics Adapter Not Recognized by D:OS [Re: bobwalt] #524276
20/07/14 08:33 PM
20/07/14 08:33 PM
Joined: Jul 2014
Posts: 5
M
Marther Offline
stranger
Marther  Offline
stranger
M

Joined: Jul 2014
Posts: 5
Hello, same here. We have two notebooks in our family: my, with nvidia 670MX works fine, but my wife's with amd 8800m did not recognize it, and shows only hd graphics in the video settings (with horrible 10 fps in the main menu). GPU-Z shows, however, that 8800 is kind of working - temperature going high as well as clock settings, but it obviously does not affect the game. Other games work fine (diablo 3 runs even better then my MSI with 670MX).

Thanks!

Re: Graphics Adapter Not Recognized by D:OS [Re: antip0q] #524281
20/07/14 08:43 PM
20/07/14 08:43 PM
Joined: Jul 2014
Posts: 44
M
MetaMoose Offline
apprentice
MetaMoose  Offline
apprentice
M

Joined: Jul 2014
Posts: 44
Originally Posted By: antip0q

You're right, I've noticed the same thing with my AMD Radeon 8800M. As has been mentioned above, game isn't optimized for mobile GPUs. I hope it will be fixed soon.


Yes please! Larian? Are you hearing this? *voice echoes trailing off into the distance...*

Re: Graphics Adapter Not Recognized by D:OS [Re: bobwalt] #524311
20/07/14 09:41 PM
20/07/14 09:41 PM
Joined: Jul 2014
Posts: 1
C
chemcukh Offline
stranger
chemcukh  Offline
stranger
C

Joined: Jul 2014
Posts: 1
I'm having the smae issue with my nvidia750M on my laptop. Tried everything but the game still recognizes the intel HD card. Sent a report.zip with the support tool.
I hope this gets fixed soon.

Last edited by chemcukh; 20/07/14 09:41 PM.
Re: Graphics Adapter Not Recognized by D:OS [Re: irril] #524965
21/07/14 07:53 PM
21/07/14 07:53 PM
Joined: Jul 2009
Posts: 57
Santa Clara, CA
B
bobwalt Offline OP
journeyman
bobwalt  Offline OP
journeyman
B

Joined: Jul 2009
Posts: 57
Santa Clara, CA
Originally Posted By: irril
I start thinking this just a small glitch in video settings. When I choose to run game with nvidia card manually and show the nvidia gpu activity toolbar icon, I see that the game is running with my second gpu.
But it's very disappointing that game runs so slowly with mobile GPUs. On my i7 4700MQ, 8GB RAM, GT740M, I only could get 30 FPS when I run game in 720p and disable the most part of post processing effects.


Your post caused me to do some further checking. I checked the GPU load while running the game and I found that the load was indeed coming from the NVIDIA GPU and not the on board Intel graphics processor. However, the game does not want to set it up correctly so I manually set it to high. I also question that it is using all the DX11 features. The problem is not as bad as I thought but it still needs to be addressed. I would really like more control with the settings but I will figure that out later. BTW - 30fps does not sound so bad for the GT740m as it is about as fast as my old GTX460m. It is limited to no more than a 128bit memory and it could have been setup for only 64bits. A good place to check laptop video performance is:
http://www.notebookcheck.net/Mobile-Graphics-Cards-Benchmark-List.844.0.html

Re: Graphics Adapter Not Recognized by D:OS [Re: bobwalt] #525405
22/07/14 06:37 PM
22/07/14 06:37 PM
Joined: Jul 2014
Posts: 5
M
Marther Offline
stranger
Marther  Offline
stranger
M

Joined: Jul 2014
Posts: 5
I did it! I switch game to windowed mode and that worked! Huray! 60 fps smile Strange that no one suggested that, because Larian even added "fake fullscreen" mode as probable workaround to that problem.

Last edited by Marther; 22/07/14 06:40 PM.
Re: Graphics Adapter Not Recognized by D:OS [Re: Marther] #525417
22/07/14 07:04 PM
22/07/14 07:04 PM
Joined: Jul 2014
Posts: 20
A
antip0q Offline
stranger
antip0q  Offline
stranger
A

Joined: Jul 2014
Posts: 20
Originally Posted By: Marther
I did it! I switch game to windowed mode and that worked! Huray! 60 fps smile Strange that no one suggested that, because Larian even added "fake fullscreen" mode as probable workaround to that problem.


Doesn't work for me.

Re: Graphics Adapter Not Recognized by D:OS [Re: antip0q] #525427
22/07/14 07:38 PM
22/07/14 07:38 PM
Joined: Jul 2014
Posts: 2
C
Calfaer Offline
stranger
Calfaer  Offline
stranger
C

Joined: Jul 2014
Posts: 2
Didn't work for me either. I've been playing the game with the inconsistent 20-30 fps that my intel card can handle but it's not really helping the enjoyment of the game.

Marther, are there any other settings you changed that fixed the problem for you?

Re: Graphics Adapter Not Recognized by D:OS [Re: bobwalt] #525647
23/07/14 06:54 AM
23/07/14 06:54 AM
Joined: Jul 2014
Posts: 5
M
Marther Offline
stranger
Marther  Offline
stranger
M

Joined: Jul 2014
Posts: 5
Calfaer, first, I force amd catalyst center (or whatever it called) to run the game with high-performance video card (instead of *auto* which worked for my other laptop with nvidia card). But it didn't work. Then, after a day, I run the game (fraps showed me 10 fps) and switch to the windowed mode - video card's cooler immediately starts making noise. Now we got near the 60 fps on medium settings (i have 30-40 on high with GTX670).

Sorry for my english.

Last edited by Marther; 23/07/14 03:03 PM.
Re: Graphics Adapter Not Recognized by D:OS [Re: bobwalt] #525949
23/07/14 04:37 PM
23/07/14 04:37 PM
Joined: Jul 2014
Posts: 48
A
Actarus Offline
apprentice
Actarus  Offline
apprentice
A

Joined: Jul 2014
Posts: 48
I tried it. It didn't change anything.

My setting are High but with Low Shadow quality. I get around 20fps.

Re: Graphics Adapter Not Recognized by D:OS [Re: bobwalt] #526139
23/07/14 09:26 PM
23/07/14 09:26 PM
Joined: Jul 2014
Posts: 1
R
ramzescaf Offline
stranger
ramzescaf  Offline
stranger
R

Joined: Jul 2014
Posts: 1
Same issue here. I've got a Lenovo Y510p with dual graphics (Intel HD 4600 and Geforce GT755m). Unfortunately, only the integrated HD4600 seems to be recognized, even when I switch the display to the GT755m through the Nvidia CP. It's not the first time I encounter issues with the Optimus system (Just Cause 2 comes to mind), but it's the first time it's related to a game I'm so excited about laugh Guess I'll have to be patient since I'd rather wait a bit to experience the full eye candy than play it at medium with 30fps wink Thanks in advance for some feedback about this problem.

Re: Graphics Adapter Not Recognized by D:OS [Re: bobwalt] #526797
24/07/14 06:49 PM
24/07/14 06:49 PM
Joined: Jul 2014
Posts: 48
A
Actarus Offline
apprentice
Actarus  Offline
apprentice
A

Joined: Jul 2014
Posts: 48
Any clue if Larian is working on it?

Re: Graphics Adapter Not Recognized by D:OS [Re: bobwalt] #526858
24/07/14 08:35 PM
24/07/14 08:35 PM
Joined: Jul 2014
Posts: 1
D
Dias33 Offline
stranger
Dias33  Offline
stranger
D

Joined: Jul 2014
Posts: 1
Hi all !

I've came across the same problem and manage to make the game recognize my nvidia 630m.

After some search, i've seen than in some games get the same problem too.

In our laptop type, now Bios are UEFI ones.

There is an option "secure boot device" activated, and, don't ask me why Oo, if you desactivate it, the game recognize your card (if game configured to use nvidia card in nvidia control panel).

Give it a try ! wink

This one correct only the card detection, i always have framerate drop by time pass in game ...

Re: Graphics Adapter Not Recognized by D:OS [Re: Dias33] #527491
25/07/14 05:29 PM
25/07/14 05:29 PM
Joined: Jul 2014
Posts: 2
R
Reikleb Offline
stranger
Reikleb  Offline
stranger
R

Joined: Jul 2014
Posts: 2
Originally Posted By: Dias33
Hi all !

I've came across the same problem and manage to make the game recognize my nvidia 630m.

After some search, i've seen than in some games get the same problem too.

In our laptop type, now Bios are UEFI ones.

There is an option "secure boot device" activated, and, don't ask me why Oo, if you desactivate it, the game recognize your card (if game configured to use nvidia card in nvidia control panel).

Give it a try ! wink

This one correct only the card detection, i always have framerate drop by time pass in game ...


Wow thanks for this solution. Can confirmed that it works and the game now recognises my GTX750m and can play in Ultra settings.

Re: Graphics Adapter Not Recognized by D:OS [Re: Dias33] #527541
25/07/14 06:21 PM
25/07/14 06:21 PM
Joined: Jul 2014
Posts: 20
A
antip0q Offline
stranger
antip0q  Offline
stranger
A

Joined: Jul 2014
Posts: 20
Originally Posted By: Dias33
Hi all !

I've came across the same problem and manage to make the game recognize my nvidia 630m.

After some search, i've seen than in some games get the same problem too.

In our laptop type, now Bios are UEFI ones.

There is an option "secure boot device" activated, and, don't ask me why Oo, if you desactivate it, the game recognize your card (if game configured to use nvidia card in nvidia control panel).

Give it a try ! wink

This one correct only the card detection, i always have framerate drop by time pass in game ...


Tried this, but my AMD card is still not recognized by the game

Re: Graphics Adapter Not Recognized by D:OS [Re: bobwalt] #527616
25/07/14 08:58 PM
25/07/14 08:58 PM
Joined: Jul 2014
Posts: 48
A
Actarus Offline
apprentice
Actarus  Offline
apprentice
A

Joined: Jul 2014
Posts: 48
I will try it when I get my laptop back. Stupid keyboard replacement.

Re: Graphics Adapter Not Recognized by D:OS [Re: bobwalt] #528642
26/07/14 08:16 PM
26/07/14 08:16 PM
Joined: Jul 2014
Posts: 48
A
Actarus Offline
apprentice
Actarus  Offline
apprentice
A

Joined: Jul 2014
Posts: 48
It worked! Game now recognize the Nvidia chipset and recommend Ultra setting. But I choose High to ease the system.

Great work Dias33, hope they pay you for that. No one at Larian were able to solve this.

Page 2 of 4 1 2 3 4

Powered by UBB.threads™ PHP Forum Software 7.6.2