Larian Banner
Previous Thread
Next Thread
Print Thread
Page 10 of 33 1 2 8 9 10 11 12 32 33
Re: Save Game Editor [Re: Dairymoose] #537441
05/08/14 10:18 PM
05/08/14 10:18 PM
Joined: Aug 2014
Posts: 8
J
Joel Offline
stranger
Joel  Offline
stranger
J

Joined: Aug 2014
Posts: 8
There also seems to be a duplication glitch when loading saves onto the editor usually some and in rare cases most of the mods/item list repeats several times..

I was also wondering if in future versions you plan on separating the mods per weapon/armor type in different lists? That would be cool.

Re: Save Game Editor [Re: Dairymoose] #537458
05/08/14 10:59 PM
05/08/14 10:59 PM
Joined: Aug 2014
Posts: 4
A
Almightycricket Offline
stranger
Almightycricket  Offline
stranger
A

Joined: Aug 2014
Posts: 4
Originally Posted By: Dairymoose


Are you sure you clicked the "Mods" button? When adding a mod, you can select which mod to add but you cannot input any values. The values are already defined. Perhaps you clicked the "PermBoosts" button and thought it was the mods section?

In addition, the PermBoost section contains some values that don't work (I will remove these in a later release). One example that does work is Character -> Strength (or any other base attribute).
If this still does not work, I can try this scenario myself, but I don't see why it would fail.




Ok so my steps again, after your advice,

1. Open my save via medit alpha 9

2. Select Roderick

3. Select training sword having moved it to my inventory before saving in game.

4. Select a small dmg boost mod and a leadership mod.

5. Select str perm boost with a modifier of 2

6. Hit apply, then save the save.

7. No changes once I load in game. EXCEPT I can change it's type from common to magic, that shows. Neither the perm boosts or mods are applying.

Last edited by Almightycricket; 05/08/14 11:35 PM.
Re: Save Game Editor [Re: Dairymoose] #537497
06/08/14 01:28 AM
06/08/14 01:28 AM
Joined: Aug 2014
Posts: 7
T
thid Offline
stranger
thid  Offline
stranger
T

Joined: Aug 2014
Posts: 7
You can change common -> magic -> rare -> legendary, pretty much u need to upgrade load game, save, edit save, load etc...

Another thing I notice, its impossible to remove mods, if I do that editor crash (that part is fricking annoying, even if u manage to make legendary u can't rly mod it, ex. if it allready have small crt boost u can't apply large)

Re: Save Game Editor [Re: Almightycricket] #537519
06/08/14 02:03 AM
06/08/14 02:03 AM
Joined: Jul 2014
Posts: 102
D
Dairymoose Offline OP
member
Dairymoose  Offline OP
member
D

Joined: Jul 2014
Posts: 102
Originally Posted By: Almightycricket
Originally Posted By: Dairymoose


Are you sure you clicked the "Mods" button? When adding a mod, you can select which mod to add but you cannot input any values. The values are already defined. Perhaps you clicked the "PermBoosts" button and thought it was the mods section?

In addition, the PermBoost section contains some values that don't work (I will remove these in a later release). One example that does work is Character -> Strength (or any other base attribute).
If this still does not work, I can try this scenario myself, but I don't see why it would fail.




Ok so my steps again, after your advice,

1. Open my save via medit alpha 9

2. Select Roderick

3. Select training sword having moved it to my inventory before saving in game.

4. Select a small dmg boost mod and a leadership mod.

5. Select str perm boost with a modifier of 2

6. Hit apply, then save the save.

7. No changes once I load in game. EXCEPT I can change it's type from common to magic, that shows. Neither the perm boosts or mods are applying.


Thanks for the steps to reproduce the issue, this is fixed for the alpha10 build.

Re: Save Game Editor [Re: Dairymoose] #537540
06/08/14 03:00 AM
06/08/14 03:00 AM
Joined: Aug 2014
Posts: 7
T
thid Offline
stranger
thid  Offline
stranger
T

Joined: Aug 2014
Posts: 7
Dairymoose I just tested this on alpha7 and no issuses, this bug showed up in alpha9 (maybe 8)

Re: Save Game Editor [Re: Dairymoose] #537748
06/08/14 05:20 AM
06/08/14 05:20 AM
Joined: Aug 2014
Posts: 4
A
Almightycricket Offline
stranger
Almightycricket  Offline
stranger
A

Joined: Aug 2014
Posts: 4
Originally Posted By: Dairymoose


Thanks for the steps to reproduce the issue, this is fixed for the alpha10 build.


Np, thanks for fixing it.

Re: Save Game Editor [Re: thid] #537750
06/08/14 05:29 AM
06/08/14 05:29 AM
Joined: Jul 2014
Posts: 102
D
Dairymoose Offline OP
member
Dairymoose  Offline OP
member
D

Joined: Jul 2014
Posts: 102
alpha10

Fixed issue where new game saves would cause item editing to fail
Fixed crash on mod/permboost removal
Added "Skills" editor:
-UI is very rough at the moment and I may completely redo it
-Categories might be renamed to match in-game category names

Re: Save Game Editor [Re: Dairymoose] #537755
06/08/14 05:59 AM
06/08/14 05:59 AM
Joined: Aug 2014
Posts: 4
A
Almightycricket Offline
stranger
Almightycricket  Offline
stranger
A

Joined: Aug 2014
Posts: 4
Yep works perfectly now laugh I just wanted to add some minor bonuses so I dont have an entire town trying to kill me after screwing up a convo with a guard, haha.

Re: Save Game Editor [Re: Dairymoose] #537820
06/08/14 08:40 AM
06/08/14 08:40 AM
Joined: Aug 2014
Posts: 12
N
Nevenor Offline
stranger
Nevenor  Offline
stranger
N

Joined: Aug 2014
Posts: 12
I don't want to sound annoying but I need help with editor as it doesn't work for me.
Diarymoose, can you reply? Please let me know if you need more info / I should write a PM / anything else, just don't ignore my 3rd message please. (It's looks really weird for me when messages above or below get their attention and my message is like non-existent.)
Sorry for bothering.
Click to reveal.. ("description of the problem")
I select a path to my PlayerProfiles and GameData folders, press load and nothing happens. Also I'm running a non-steam version of the game.

Re: Save Game Editor [Re: Nevenor] #538008
06/08/14 01:17 PM
06/08/14 01:17 PM
Joined: Jul 2014
Posts: 102
D
Dairymoose Offline OP
member
Dairymoose  Offline OP
member
D

Joined: Jul 2014
Posts: 102
Originally Posted By: Nevenor
I don't want to sound annoying but I need help with editor as it doesn't work for me.
Diarymoose, can you reply? Please let me know if you need more info / I should write a PM / anything else, just don't ignore my 3rd message please. (It's looks really weird for me when messages above or below get their attention and my message is like non-existent.)
Sorry for bothering.
Click to reveal.. ("description of the problem")
I select a path to my PlayerProfiles and GameData folders, press load and nothing happens. Also I'm running a non-steam version of the game.


Make sure you have selected the correct folder for the "PlayerProfiles folder". The folder should be named "PlayerProfiles" (i.e., NOT named "Dairymoose" if you had a game profile called Dairymoose). The load button will not do anything unless you have selected an existing save in the list. It is unlikely but possible that it is having trouble reading the playerProfiles.lsb or the meta.lsb files in the individual folders... but I doubt it. More likely you have the wrong folder selected.

Last edited by Dairymoose; 06/08/14 01:18 PM.
Re: Save Game Editor [Re: Dairymoose] #538012
06/08/14 01:38 PM
06/08/14 01:38 PM
Joined: Aug 2014
Posts: 7
T
thid Offline
stranger
thid  Offline
stranger
T

Joined: Aug 2014
Posts: 7
well for me alpha10 doesn't work, edtor crash after loading save, same save works on alpha7/9

Re: Save Game Editor [Re: thid] #538027
06/08/14 02:25 PM
06/08/14 02:25 PM
Joined: Jul 2014
Posts: 102
D
Dairymoose Offline OP
member
Dairymoose  Offline OP
member
D

Joined: Jul 2014
Posts: 102
Originally Posted By: thid
well for me alpha10 doesn't work, edtor crash after loading save, same save works on alpha7/9


This is a known issue with the skills editor that will be fixed in alpha11.

Re: Save Game Editor [Re: Dairymoose] #538083
06/08/14 03:24 PM
06/08/14 03:24 PM
Joined: Aug 2014
Posts: 10
W
Winzalot Offline
stranger
Winzalot  Offline
stranger
W

Joined: Aug 2014
Posts: 10
Dairymoose you got an idea why sometimes the portraits change to a ? or random icons after editing ?

I didnt change anything special just some talents. Anyway to figure out how this can be repaired ?

Last edited by Winzalot; 06/08/14 03:26 PM.
Re: Save Game Editor [Re: Dairymoose] #538191
06/08/14 04:49 PM
06/08/14 04:49 PM
Joined: Aug 2014
Posts: 1
D
Demori Offline
stranger
Demori  Offline
stranger
D

Joined: Aug 2014
Posts: 1
Hi Dairymoose, just had to create an account to thank you. Your editor rocks, thanks for the work!

Re: Save Game Editor [Re: Joel] #538216
06/08/14 05:42 PM
06/08/14 05:42 PM
Joined: Jul 2014
Posts: 102
D
Dairymoose Offline OP
member
Dairymoose  Offline OP
member
D

Joined: Jul 2014
Posts: 102
Originally Posted By: Joel
There also seems to be a duplication glitch when loading saves onto the editor usually some and in rare cases most of the mods/item list repeats several times..

I was also wondering if in future versions you plan on separating the mods per weapon/armor type in different lists? That would be cool.


Not sure what the "duplication glitch" is that you're referring to.

I like this second idea though, there could be Weapon Mods -> Axes, Weapon Mods -> Swords, Weapon Mods -> Generic, etc.

Re: Save Game Editor [Re: Dairymoose] #538222
06/08/14 05:47 PM
06/08/14 05:47 PM
Joined: Aug 2014
Posts: 7
T
thid Offline
stranger
thid  Offline
stranger
T

Joined: Aug 2014
Posts: 7
Quote:
Not sure what the "duplication glitch" is that you're referring to.

for example if u take mod unbreakable and then another mod u will have 2x unbreakable (with this mod duplication glitch shows the most often)

Re: Save Game Editor [Re: Dairymoose] #538240
06/08/14 06:32 PM
06/08/14 06:32 PM
Joined: Aug 2014
Posts: 12
N
Nevenor Offline
stranger
Nevenor  Offline
stranger
N

Joined: Aug 2014
Posts: 12
Originally Posted By: Dairymoose
More likely you have the wrong folder selected.

Click to reveal..

This is how it looks. The path leads exactly to PlayerProfiles (global folder of all profiles), not to a specific profile. Any hints?

Re: Save Game Editor [Re: Nevenor] #538256
06/08/14 07:38 PM
06/08/14 07:38 PM
Joined: Jul 2014
Posts: 102
D
Dairymoose Offline OP
member
Dairymoose  Offline OP
member
D

Joined: Jul 2014
Posts: 102
Originally Posted By: Nevenor
Originally Posted By: Dairymoose
More likely you have the wrong folder selected.

Click to reveal..

This is how it looks. The path leads exactly to PlayerProfiles (global folder of all profiles), not to a specific profile. Any hints?


I would suggest trying the "Dev" tab and see if it can open your playerProfiles.lsb file (located directly under PlayerProfiles folder), and your meta.lsb file(s). The playerProfiles.lsb file in particular is more important here. If it can succesfully display this file, then I will have to ask you to send me a copy of 1. Your playerProfiles.lsb file, and 2. one of your save games.

Earlier it was reported that certain unicode characters appearing in profile names or savegame names can cause problems, so this could be the problem you are having.

Last edited by Dairymoose; 06/08/14 07:42 PM.
Re: Save Game Editor [Re: Dairymoose] #538258
06/08/14 07:46 PM
06/08/14 07:46 PM
Joined: Aug 2014
Posts: 2
G
Gundula Bartzke Offline
stranger
Gundula Bartzke  Offline
stranger
G

Joined: Aug 2014
Posts: 2
Another thing I thought that it could be is that he's using a version of the game before they started packing the savegame files. Does your editor find these Dairymoose? Also, thanks for the updates on your great tool smile

Re: Save Game Editor [Re: Dairymoose] #538260
06/08/14 07:50 PM
06/08/14 07:50 PM
Joined: Aug 2014
Posts: 12
N
Nevenor Offline
stranger
Nevenor  Offline
stranger
N

Joined: Aug 2014
Posts: 12
Originally Posted By: Dairymoose
...If it can succesfully display this file, then I will have to ask you to send me a copy of 1. Your playerProfiles.lsb file, and 2. one of your save games.

Earlier it was reported that certain unicode characters appearing in profile names or savegame names can cause problems, so this could be the problem you are having.

When I try to open playerprofiles.lsb I get this
Click to reveal..

Page 10 of 33 1 2 8 9 10 11 12 32 33

Powered by UBB.threads™ PHP Forum Software 7.6.2