Larian Banner
Previous Thread
Next Thread
Print Thread
Page 14 of 33 1 2 12 13 14 15 16 32 33
Re: Save Game Editor [Re: Dairymoose] #545308
18/08/14 08:31 AM
18/08/14 08:31 AM
Joined: Aug 2014
Posts: 5
R
Rbx Offline
stranger
Rbx  Offline
stranger
R

Joined: Aug 2014
Posts: 5
when i simply want to edit the abilities, traits and skills of my characters, would it be better to use MooseEdit or LSTools?

Re: Save Game Editor [Re: Dairymoose] #545309
18/08/14 08:32 AM
18/08/14 08:32 AM
Joined: Aug 2014
Posts: 6
A
Accel Offline
stranger
Accel  Offline
stranger
A

Joined: Aug 2014
Posts: 6
Originally Posted By: Accel
Hello Dairymoose,
Im trying to use your editor but its not working for me.
What happens is, my game crashes when i try to load the edited save game file.

My steps are:
1. I open the MooseEdit
2. I config the Game Data folder
3. I load my save game data
4. I edit my item (like -1 AP cost for example)
5. I click on the "Save All" button
6. I try to play the game

Can you please let me know if im doing something wrong and how to fix it?

Thank You in advance.


Originally Posted By: Dairymoose
This isn't really enough information. What specifically did you do to the item?
E.g., right click equipped sword, edit item, go to PermBoosts tab, add AttackAPCost permboost with value -1, hit "Accept" button, click save button, play game


Hello again,
Even if i just open the save game file and dont edit any items at all and just edit a simple thing like a single talent point or status points it happens the same thing, after i save, my game crashes when i try to load the save game.

Thank You again.

PS: Sorry for my bad english xD

Re: Save Game Editor [Re: Accel] #545416
18/08/14 01:23 PM
18/08/14 01:23 PM
Joined: Jul 2014
Posts: 102
D
Dairymoose Offline OP
member
Dairymoose  Offline OP
member
D

Joined: Jul 2014
Posts: 102
Originally Posted By: Accel
Originally Posted By: Accel
Hello Dairymoose,
Im trying to use your editor but its not working for me.
What happens is, my game crashes when i try to load the edited save game file.

My steps are:
1. I open the MooseEdit
2. I config the Game Data folder
3. I load my save game data
4. I edit my item (like -1 AP cost for example)
5. I click on the "Save All" button
6. I try to play the game

Can you please let me know if im doing something wrong and how to fix it?

Thank You in advance.


Originally Posted By: Dairymoose
This isn't really enough information. What specifically did you do to the item?
E.g., right click equipped sword, edit item, go to PermBoosts tab, add AttackAPCost permboost with value -1, hit "Accept" button, click save button, play game


Hello again,
Even if i just open the save game file and dont edit any items at all and just edit a simple thing like a single talent point or status points it happens the same thing, after i save, my game crashes when i try to load the save game.

Thank You again.

PS: Sorry for my bad english xD


Can you please send me a copy of your save file?

Originally Posted By: Cvrtis
[img]http://www.screencapture.ru/file/16d99b94[/img]
then opens a window:
"The program "MooseEdit" not working
The Windows will close the program, and if there is a known method...
bla-bla-bla"
Windows 7 x32

PS. BB-code for the image does not work O.o
PPS. MooseEdit v15 is working! What's wrong with v16?


Can you please send me a copy of your save file?
Most likely it is because there is an issue with reading the .ini file right now. It will be fixed in the next release. I would suggest deleting the .ini file and then trying the latest version. That would probably work.

Last edited by Dairymoose; 18/08/14 01:51 PM.
Re: Save Game Editor [Re: Dairymoose] #545452
18/08/14 04:05 PM
18/08/14 04:05 PM
Joined: Aug 2014
Posts: 6
Dungeoness Offline
stranger
Dungeoness  Offline
stranger

Joined: Aug 2014
Posts: 6
Originally Posted By: Dairymoose


Can you try using the Dev tab to open the Globals.lsb file and see if that works? And also try the PAK tab and try to open Main.pak and see if that works.

The program never loaded or opened. All I ever see is the error box.

Tried the alpha16 version, and the program opens, but then crashes when I try to point it to my PlayerProfiles folder. The fault is the same file as the previous version, "libstdc++-6.dll". I can load the files you mention in the Dev and PAK tabs, but have no clue what I'm supposed to do with anything in that mess.

Re: Save Game Editor [Re: Dungeoness] #545466
18/08/14 05:58 PM
18/08/14 05:58 PM
Joined: Jul 2014
Posts: 102
D
Dairymoose Offline OP
member
Dairymoose  Offline OP
member
D

Joined: Jul 2014
Posts: 102
Originally Posted By: Dungeoness
Originally Posted By: Dairymoose


Can you try using the Dev tab to open the Globals.lsb file and see if that works? And also try the PAK tab and try to open Main.pak and see if that works.

The program never loaded or opened. All I ever see is the error box.

Tried the alpha16 version, and the program opens, but then crashes when I try to point it to my PlayerProfiles folder. The fault is the same file as the previous version, "libstdc++-6.dll". I can load the files you mention in the Dev and PAK tabs, but have no clue what I'm supposed to do with anything in that mess.


Please provide me with a copy of your playerprofiles.lsb file and I can see if this reproduces the issue.

Re: Save Game Editor [Re: Dairymoose] #545492
18/08/14 10:25 PM
18/08/14 10:25 PM
Joined: Aug 2014
Posts: 6
A
Accel Offline
stranger
Accel  Offline
stranger
A

Joined: Aug 2014
Posts: 6
Originally Posted By: Dairymoose
Originally Posted By: Accel
[quote=Accel]Hello Dairymoose,
Im trying to use your editor but its not working for me.
What happens is, my game crashes when i try to load the edited save game file.

My steps are:
1. I open the MooseEdit
2. I config the Game Data folder
3. I load my save game data
4. I edit my item (like -1 AP cost for example)
5. I click on the "Save All" button
6. I try to play the game

Can you please let me know if im doing something wrong and how to fix it?

Thank You in advance.


Originally Posted By: Dairymoose
This isn't really enough information. What specifically did you do to the item?
E.g., right click equipped sword, edit item, go to PermBoosts tab, add AttackAPCost permboost with value -1, hit "Accept" button, click save button, play game


Hello again,
Even if i just open the save game file and dont edit any items at all and just edit a simple thing like a single talent point or status points it happens the same thing, after i save, my game crashes when i try to load the save game.

Thank You again.

PS: Sorry for my bad english xD

Can you please send me a copy of your save file?


Hello,
I sent you my save game files on a PM

Thank you for all the support so far.

Re: Save Game Editor [Re: Dairymoose] #545511
19/08/14 01:46 AM
19/08/14 01:46 AM
Joined: Jul 2014
Posts: 102
D
Dairymoose Offline OP
member
Dairymoose  Offline OP
member
D

Joined: Jul 2014
Posts: 102
New version alpha17
The settings.ini file is now parsed properly
Improved loading speed of saved games (significantly)




Originally Posted By: Accel

Hello,
I sent you my save game files on a PM

Thank you for all the support so far.



You edited this file didn't you? It is a new game but the 2nd character's abilities include several abilities set to 5 (blacksmith, loremaster, crafting, etc). I don't know how you edited it but whatever you used didn't save this data correctly. The newest version of my editor will process your save file correctly now, but I don't consider this as a bug with the editor. It is a bug with whatever other program you used to edit it.
It would have been nice if you mentioned that you edited this.

Last edited by Dairymoose; 19/08/14 01:47 AM.
Re: Save Game Editor [Re: Dairymoose] #545551
19/08/14 04:37 AM
19/08/14 04:37 AM
Joined: Aug 2014
Posts: 6
A
Accel Offline
stranger
Accel  Offline
stranger
A

Joined: Aug 2014
Posts: 6
Originally Posted By: Dairymoose
New version alpha17
The settings.ini file is now parsed properly
Improved loading speed of saved games (significantly)




Originally Posted By: Accel

Hello,
I sent you my save game files on a PM

Thank you for all the support so far.



You edited this file didn't you? It is a new game but the 2nd character's abilities include several abilities set to 5 (blacksmith, loremaster, crafting, etc). I don't know how you edited it but whatever you used didn't save this data correctly. The newest version of my editor will process your save file correctly now, but I don't consider this as a bug with the editor. It is a bug with whatever other program you used to edit it.
It would have been nice if you mentioned that you edited this.


Omg i feel bad now, i thought it didn't matter cause i used the LSTools to edit it >.<
Im sorry for not saying about the LSTools ;/
And of course, thank you very much for the help.

Re: Save Game Editor [Re: Dairymoose] #545554
19/08/14 04:58 AM
19/08/14 04:58 AM
Joined: Aug 2014
Posts: 2
M
mobiusunderpants Offline
stranger
mobiusunderpants  Offline
stranger
M

Joined: Aug 2014
Posts: 2
Is the quest functionality in yet? i foolishly declined a quest from a certain npc and now that (rather important) questline is blocked off to me. can this editor let me go in and reset my dialogue status with that npc? or at least give me the quest he offered?

thanks

Re: Save Game Editor [Re: Dairymoose] #545571
19/08/14 05:36 AM
19/08/14 05:36 AM
Joined: Aug 2014
Posts: 5
R
Rbx Offline
stranger
Rbx  Offline
stranger
R

Joined: Aug 2014
Posts: 5
Originally Posted By: Dairymoose
but whatever you used didn't save this data correctly

Originally Posted By: Accel
i used the LSTools to edit it

does this mean that MooseEdit is now the preferred way of save editing (over LSTools)?

also, @Dairymoose and Norbyte: can you say what exactly LSTools does wrong and whether or not it could have negative impacts on gameplay?

thanks a lot!

Re: Save Game Editor [Re: Dairymoose] #545649
19/08/14 09:27 AM
19/08/14 09:27 AM
Joined: Aug 2014
Posts: 3
A
anom7 Offline
stranger
anom7  Offline
stranger
A

Joined: Aug 2014
Posts: 3
Hi, first of all thanks for you work Dairymoose!

I've playing this game since yesterday and I saw some items that probably I would have problems in order to obtain as soon as posible, so I thought this editor can help me to add it (Walk in Shadows).

The thing is when opening any of my savegames the application always crash just after loading the savegame (mmm likely 90% loaded, I can see all the tabs).

I tried with version 9, 16, 17 with no luck.

Can anyone try to open one of my savegame to see if its my PC problem (win7 x64), the custom installation path of the game or maybe the gamesaves itself?
http://www.speedyshare.com/v6hNQ/AutoSave-1.zip

Thanks in advance!

PD: I didn't edited the savegame, but I use some mods that change the font and improves textures quality (I don't think it causes the problem).

Last edited by anom7; 19/08/14 10:02 AM.
Re: Save Game Editor [Re: Dairymoose] #545654
19/08/14 10:13 AM
19/08/14 10:13 AM
Joined: Aug 2014
Posts: 6
A
Accel Offline
stranger
Accel  Offline
stranger
A

Joined: Aug 2014
Posts: 6
Is there a way to edit my weapon to have 100% chance of burning the target? cause the "mods" that you can apply are already set the damage and the chance, and keep adding them doesn't work either...

Does anyone knows if thats possible on the current version or not? And if yes, what should i do for it to work?

Thank You.

Re: Save Game Editor [Re: anom7] #545697
19/08/14 01:53 PM
19/08/14 01:53 PM
Joined: Jul 2014
Posts: 102
D
Dairymoose Offline OP
member
Dairymoose  Offline OP
member
D

Joined: Jul 2014
Posts: 102
Originally Posted By: anom7
Hi, first of all thanks for you work Dairymoose!

I've playing this game since yesterday and I saw some items that probably I would have problems in order to obtain as soon as posible, so I thought this editor can help me to add it (Walk in Shadows).

The thing is when opening any of my savegames the application always crash just after loading the savegame (mmm likely 90% loaded, I can see all the tabs).

I tried with version 9, 16, 17 with no luck.

Can anyone try to open one of my savegame to see if its my PC problem (win7 x64), the custom installation path of the game or maybe the gamesaves itself?
http://www.speedyshare.com/v6hNQ/AutoSave-1.zip

Thanks in advance!

PD: I didn't edited the savegame, but I use some mods that change the font and improves textures quality (I don't think it causes the problem).


This works fine for me, I just tested it with the latest version, no problems loading it. As such I'm wondering if it's an issue with your game PAK files (or you selected the wrong directory for your game data). Try to use the PAK tab to open main.pak and textures.pak and see if you can successfully extract a file (right click to extract).



@Rbx
Trait data is stored by the game as type 0x02 = short data type (16 bit signed integer). His save file contained trait data with type 0x05 = unsigned long data type (32 bit unsigned integer). I don't know if this would impact the game at all, but in my opinion it is unlikely to have any effect, even though it is not the format used by the game.

Re: Save Game Editor [Re: Dairymoose] #545724
19/08/14 04:04 PM
19/08/14 04:04 PM
Joined: Aug 2014
Posts: 3
A
anom7 Offline
stranger
anom7  Offline
stranger
A

Joined: Aug 2014
Posts: 3
Originally Posted By: Dairymoose
This works fine for me, I just tested it with the latest version, no problems loading it. As such I'm wondering if it's an issue with your game PAK files (or you selected the wrong directory for your game data). Try to use the PAK tab to open main.pak and textures.pak and see if you can successfully extract a file (right click to extract).

Yeah, you're right! smile

The file textures_1.pak is corrupted it seems. The thing is... can one mod that put some files in "public" folder, corrupt textures_1.pak? Maybe when the game is loading textures it modify the textures.pak in order to add them.

Well, I will do a clean installation of the game and try again, hope it works.

Thanks

PD: I don't know what I've done but now works. I reinstalled the game in another directory but still can't open correctly the .pak (textures_1 and textures_2), so I renamed to .paka (don't matter) and the save editor could open THE SAVE correctly (the -pak still seems corrupted). So I renamed again and... now it works with correct filename! xD (still seems corrupted .pak)
I have just edited the savegame and works perfect! (well, one game-crash because I add some weird values to an item).

Last edited by anom7; 19/08/14 05:25 PM. Reason: tested
Re: Save Game Editor [Re: Dairymoose] #545765
19/08/14 08:19 PM
19/08/14 08:19 PM
Joined: Aug 2014
Posts: 6
Dungeoness Offline
stranger
Dungeoness  Offline
stranger

Joined: Aug 2014
Posts: 6
Originally Posted By: Dairymoose

Can you try using the Dev tab to open the Globals.lsb file and see if that works? And also try the PAK tab and try to open

Please provide me with a copy of your playerprofiles.lsb file and I can see if this reproduces the issue.


I managed to solve this issue. A while back, my game crashed, and when I tried to log back in, the game didn't recognize any of my profiles. Long story short, it took some finagling, profile creation and deletion and moving around of saves to get the game to recognize both my profiles and the saves within. A "dummy" profile folder that I had deleted was still showing up in the profile list, although empty, and seemed to be causing issues with the playerprofiles.lsb file.

Now to see what trouble I can get into!

Re: Save Game Editor [Re: Dairymoose] #545786
19/08/14 11:06 PM
19/08/14 11:06 PM
Joined: Jul 2014
Posts: 102
D
Dairymoose Offline OP
member
Dairymoose  Offline OP
member
D

Joined: Jul 2014
Posts: 102
alpha18:
Fixed bug where new skills could not be added if the character skill list was currently empty
Added error messages for corrupt playerProfiles.lsb and missing Main.pak file

Re: Save Game Editor [Re: Dairymoose] #546247
20/08/14 08:32 PM
20/08/14 08:32 PM
Joined: Aug 2014
Posts: 5
S
Swaco Offline
stranger
Swaco  Offline
stranger
S

Joined: Aug 2014
Posts: 5
so i used the in game Apperence editor (mirror) to change the apperaence and when i went to the portrait it went blank and wont come back. just mimics the other charaters or leader buff icon. any way to fix this with Moose tools??

BTW great tool. thank you so much for it!

Re: Save Game Editor [Re: Swaco] #546264
20/08/14 10:22 PM
20/08/14 10:22 PM
Joined: Jul 2014
Posts: 102
D
Dairymoose Offline OP
member
Dairymoose  Offline OP
member
D

Joined: Jul 2014
Posts: 102
Originally Posted By: Swaco
so i used the in game Apperence editor (mirror) to change the apperaence and when i went to the portrait it went blank and wont come back. just mimics the other charaters or leader buff icon. any way to fix this with Moose tools??

BTW great tool. thank you so much for it!


As previously mentioned by other posters, this seems to be an issue with LSTools and not MooseEdit. Unfortunately I am not offering support for issues caused by other programs. I would advise you to seek the author's advice.

Last edited by Dairymoose; 20/08/14 10:24 PM.
Re: Save Game Editor [Re: anom7] #546301
21/08/14 03:27 AM
21/08/14 03:27 AM
Joined: Aug 2013
Posts: 161
Waltc Offline
member
Waltc  Offline
member

Joined: Aug 2013
Posts: 161
Originally Posted By: anom7
Originally Posted By: Dairymoose
This works fine for me, I just tested it with the latest version, no problems loading it. As such I'm wondering if it's an issue with your game PAK files (or you selected the wrong directory for your game data). Try to use the PAK tab to open main.pak and textures.pak and see if you can successfully extract a file (right click to extract).

Yeah, you're right! smile

The file textures_1.pak is corrupted it seems. The thing is... can one mod that put some files in "public" folder, corrupt textures_1.pak? Maybe when the game is loading textures it modify the textures.pak in order to add them.

Well, I will do a clean installation of the game and try again, hope it works.

Thanks

PD: I don't know what I've done but now works. I reinstalled the game in another directory but still can't open correctly the .pak (textures_1 and textures_2), so I renamed to .paka (don't matter) and the save editor could open THE SAVE correctly (the -pak still seems corrupted). So I renamed again and... now it works with correct filename! xD (still seems corrupted .pak)
I have just edited the savegame and works perfect! (well, one game-crash because I add some weird values to an item).


I'm using a Texture mod that uses the public folders to store the overrides without a problem (the game looks in the public folder for texture files, and *if present*, automatically loads them instead of the default game textures.) I didn't do anything with the standard texture .pak files--as there was no need to do that to load the modded textures.

After you install the modded textures to your public folder, if at anytime you want to revert back to the default textures, that is as easy as pie: just go here...

data\public\main\assets\textures

and rename the textures folder to NEW_textures (or anything you want--just so long as you change the folder name from "textures".) It will now read...

data\public\main\assets\NEW_textures

and when you boot the game it will peek in the assets folder and if no "textures" directory is present it will automatically load the game's default textures. To get the modded textures back just reverse the above process. I've done it several times in testing without issue.

Using MooseEdit has not presented me with any problems relating to texture mods, etc.

(Apologies if you already knew this...;))


I'm never wrong about anything, and so if you see an error in any of my posts you will know immediately that I did not write it...;)
Re: Save Game Editor [Re: Dairymoose] #546574
21/08/14 05:37 PM
21/08/14 05:37 PM
Joined: Aug 2014
Posts: 5
S
Swaco Offline
stranger
Swaco  Offline
stranger
S

Joined: Aug 2014
Posts: 5
Originally Posted By: Dairymoose
Originally Posted By: Swaco
so i used the in game Apperence editor (mirror) to change the apperaence and when i went to the portrait it went blank and wont come back. just mimics the other charaters or leader buff icon. any way to fix this with Moose tools??

BTW great tool. thank you so much for it!


As previously mentioned by other posters, this seems to be an issue with LSTools and not MooseEdit. Unfortunately I am not offering support for issues caused by other programs. I would advise you to seek the author's advice.


I did make a post in general issues about this issue. I dont know what LStools is by the way. ive only used your moose tools to do any editing. but thanks for the tool regardless. didnt know if there was a way to change portraits with your tool is all. though if i could over right whatever got corrupted id be good. Again thanks for the hard work on the tool

Page 14 of 33 1 2 12 13 14 15 16 32 33

Powered by UBB.threads™ PHP Forum Software 7.6.2