Larian Banner
Previous Thread
Next Thread
Print Thread
Portraits not rendering (Addon - Story) #635613
04/11/17 02:15 PM
04/11/17 02:15 PM
Joined: Sep 2017
Posts: 639
The Composer Offline OP

Moderator
The Composer  Offline OP

Moderator

Joined: Sep 2017
Posts: 639
I've been following this guide to make a custom portrait religiously, but can not seem to get it to work.

The .lsx located at C:\Games\Steam\steamapps\common\Divinity Original Sin 2\Data\Public\DivinityChronicles_23154358-f7a9-4c9e-bd0d-8fd859ddb55e\GUI - along with the relevant .dds and another .lsf file updates when ever I run the render portraits process, but no changes / content are added to either of the files.

I know this by comparing files that have changed before/after a session through github repository and comparing any changes to *any* files that was one way or another altered during that session. Every file remains identical after every attempt. To the letter.


So I'm hoping this is a bug, and a fixable one. Here's some details and screenshots:

Most of the testing was done on the inherited SYS_NPC_Portrait_A level, but I also tried to make a new level from scratch, as Windemere had reported working for him for 'new' characters, but in opposition, not working for inherited npcs. It didn't work for me with new npcs either. No success. Only difference between our projects is, his is an adventure mod, mine is an addon to story.


I am trying to render a portrait for a new asset, a character model from DOS1. At first I thought maybe that was the problem, until I realized the portraits should render regardless, but an empty / broken portrait at the very least. There's literally no change to any file in any file in and beyond /Data/ suggesting the engine is rather failing to render new icon content rather than the fault being in the content itself.


I've also tried several alternate keys beyond what the guide suggests, as I saw in the SYS_Player_Portrait level booth, the cameras do Camera_NameofRaceAndGender rather than Cam_xxxxx. No juice on either formatting.


During current testing as of speaking, the individual objects' settings looks like this:

The Character:



The Point Trigger:



The Camera:



Project Settings:




If you spot anything and this is all my fault after all, please let me know. I've gone over it at least 20 times, but am still human. Arguably.

Re: Portraits not rendering (Addon - Story) [Re: The Composer] #635621
04/11/17 03:55 PM
04/11/17 03:55 PM
Joined: Sep 2017
Posts: 159
M
monzua Offline
member
monzua  Offline
member
M

Joined: Sep 2017
Posts: 159
had exactly the same issue for my standalone adventure. smirk

Re: Portraits not rendering (Addon - Story) [Re: monzua] #635625
04/11/17 04:20 PM
04/11/17 04:20 PM
Joined: Sep 2017
Posts: 639
The Composer Offline OP

Moderator
The Composer  Offline OP

Moderator

Joined: Sep 2017
Posts: 639
Originally Posted By: monzua
had exactly the same issue for my standalone adventure. smirk


"Had" ?

Re: Portraits not rendering (Addon - Story) [Re: The Composer] #635631
04/11/17 04:47 PM
04/11/17 04:47 PM
Joined: Oct 2017
Posts: 51
NW USA
Nashes Offline
journeyman
Nashes  Offline
journeyman

Joined: Oct 2017
Posts: 51
NW USA
Did you fill in the PortraitGenerationTrigger for "The Character" with the name of the PointTrigger "Icon_DC_Icara" so when you render portraits it then does so?

Re: Portraits not rendering (Addon - Story) [Re: The Composer] #635636
04/11/17 05:36 PM
04/11/17 05:36 PM
Joined: Sep 2017
Posts: 159
M
monzua Offline
member
monzua  Offline
member
M

Joined: Sep 2017
Posts: 159
Originally Posted By: The Composer
Originally Posted By: monzua
had exactly the same issue for my standalone adventure. smirk


"Had" ?


haha - yes - i did give up on it so yep "had" hehe

Re: Portraits not rendering (Addon - Story) [Re: Nashes] #635637
04/11/17 05:36 PM
04/11/17 05:36 PM
Joined: Sep 2017
Posts: 639
The Composer Offline OP

Moderator
The Composer  Offline OP

Moderator

Joined: Sep 2017
Posts: 639
Originally Posted By: Nashes
Did you fill in the PortraitGenerationTrigger for "The Character" with the name of the PointTrigger "Icon_DC_Icara" so when you render portraits it then does so?


Yes, made sure it was set with her trigger in both the root template and the particular character in the map.

Re: Portraits not rendering (Addon - Story) [Re: The Composer] #635640
04/11/17 05:49 PM
04/11/17 05:49 PM
Joined: Oct 2017
Posts: 51
NW USA
Nashes Offline
journeyman
Nashes  Offline
journeyman

Joined: Oct 2017
Posts: 51
NW USA
Try using one that already exists in that level that might work for the character. Like, Icons_Human_female etc. That's very weird it's not working..

Re: Portraits not rendering (Addon - Story) [Re: Nashes] #635642
04/11/17 06:02 PM
04/11/17 06:02 PM
Joined: Sep 2017
Posts: 639
The Composer Offline OP

Moderator
The Composer  Offline OP

Moderator

Joined: Sep 2017
Posts: 639
Originally Posted By: Nashes
Try using one that already exists in that level that might work for the character. Like, Icons_Human_female etc. That's very weird it's not working..


Already tried that too.

Re: Portraits not rendering (Addon - Story) [Re: The Composer] #635643
04/11/17 06:12 PM
04/11/17 06:12 PM
Joined: Oct 2017
Posts: 51
NW USA
Nashes Offline
journeyman
Nashes  Offline
journeyman

Joined: Oct 2017
Posts: 51
NW USA
Off-topic sidenote I discovered a character doesn't have to be on the portrait generation level to have a portrait generated. Wonder if that's another bug. I have three characters placed in a custom level and it had an icon generated for it when I rendered portraits.

Re: Portraits not rendering (Addon - Story) [Re: The Composer] #635644
04/11/17 06:15 PM
04/11/17 06:15 PM
Joined: Sep 2017
Posts: 639
The Composer Offline OP

Moderator
The Composer  Offline OP

Moderator

Joined: Sep 2017
Posts: 639
My issue here is that the height of almost all characters from DOS1 is a little shorter than their corresponding race. So using an existing booth still wouldn't be ideal of it even worked.

Re: Portraits not rendering (Addon - Story) [Re: The Composer] #635647
04/11/17 06:40 PM
04/11/17 06:40 PM
Joined: Oct 2017
Posts: 51
NW USA
Nashes Offline
journeyman
Nashes  Offline
journeyman

Joined: Oct 2017
Posts: 51
NW USA
The bigger issue is you can't even generate a portrait. Heh.

You've definitely got it all set up correctly based on your pictures.

You could try opening a new project, do everything and if it works, then copy the generated portrait file to your original mod. Doesn't solve the original problem of course but worth a try?

Re: Portraits not rendering (Addon - Story) [Re: Nashes] #635649
04/11/17 06:48 PM
04/11/17 06:48 PM
Joined: Sep 2017
Posts: 639
The Composer Offline OP

Moderator
The Composer  Offline OP

Moderator

Joined: Sep 2017
Posts: 639
Worth a try, at the very least just to see if it somehow is project-related.

Re: Portraits not rendering (Addon - Story) [Re: The Composer] #635968
06/11/17 09:33 AM
06/11/17 09:33 AM
Joined: Sep 2017
Posts: 162
Larian_JB Offline
member
Larian_JB  Offline
member

Joined: Sep 2017
Posts: 162
Hi Composer,

I checked the tutorial and everything still seems up-to-date. Does your character have a visual set?

Re: Portraits not rendering (Addon - Story) [Re: Larian_JB] #635989
06/11/17 12:37 PM
06/11/17 12:37 PM
Joined: Sep 2017
Posts: 639
The Composer Offline OP

Moderator
The Composer  Offline OP

Moderator

Joined: Sep 2017
Posts: 639
Originally Posted By: Larian_JB
Hi Composer,

I checked the tutorial and everything still seems up-to-date. Does your character have a visual set?


That did seem to fix it for me - you typing that gave me the idea there could be an invisible set hidden around, and surprise-surprise there was. I had tried visual sets on these imports but obviously that won't work with new character assets. So putting on an invisible helper visualset was all I needed!

Woop woop!




Last edited by The Composer; 06/11/17 12:40 PM.
Re: Portraits not rendering (Addon - Story) [Re: The Composer] #635990
06/11/17 12:46 PM
06/11/17 12:46 PM
Joined: Dec 2013
Posts: 872
Windemere Offline

old hand
Windemere  Offline

old hand

Joined: Dec 2013
Posts: 872
Whoa, came out great. Nice work you two. smile


DOS2 Mods: Happily Emmie After and The Noisy Crypt

Steam Workshop
Nexus Mods
Re: Portraits not rendering (Addon - Story) [Re: The Composer] #635992
06/11/17 01:12 PM
06/11/17 01:12 PM
Joined: Sep 2017
Posts: 162
Larian_JB Offline
member
Larian_JB  Offline
member

Joined: Sep 2017
Posts: 162
Glad you managed to fix it, I added the visualset requirement to the notes on the wiki guide

Last edited by Larian_JB; 06/11/17 01:12 PM.
Re: Portraits not rendering (Addon - Story) [Re: The Composer] #636015
06/11/17 04:17 PM
06/11/17 04:17 PM
Joined: Sep 2017
Posts: 639
The Composer Offline OP

Moderator
The Composer  Offline OP

Moderator

Joined: Sep 2017
Posts: 639
Yes, thank you! Glad to be able to check off one more point on the list of things to get done!


Moderated by  Larian_Koala, Larian_KVN 

Powered by UBB.threads™ PHP Forum Software 7.6.2