Divinity Banner
Previous Thread
Next Thread
Print Thread
Game crashes to desktop #653171
20/06/19 04:06 PM
20/06/19 04:06 PM
Joined: Jun 2019
Posts: 2
Charmagon Offline OP
stranger
Charmagon  Offline OP
stranger

Joined: Jun 2019
Posts: 2
I played classic ages ago but decided recently to give the enhanced edition a go.

However I am running into an issue with the game crashing.

When I first started the game I was getting a resolution of like 300 x 600, which was like playing Minecraft. However, when I attempted to access the video options the game would crash to desktop, locking my desktop resolution to a silly low setting and requiring me to reboot (windows 10) to fix it. I managed to get around this by finding a graphics file on these forums which allowed me to play at 1200 by something resolution but it's still not ideal.

The main issue is that when I attempt to access the video options it crashes the game.

I checked the event logger and get the following error:

Faulting application name: EoCApp.exe, version: 2.0.119.430, time stamp: 0x56fd2c80
Faulting module name: EoCApp.exe, version: 2.0.119.430, time stamp: 0x56fd2c80
Exception code: 0xc0000005
Fault offset: 0x0000000000af0f2e
Faulting process ID: 0x6e8
Faulting application start time: 0x01d527804133ebd6
Faulting application path: D:\Games\steamapps\common\Divinity Original Sin Enhanced Edition\Shipping\EoCApp.exe
Faulting module path: D:\Games\steamapps\common\Divinity Original Sin Enhanced Edition\Shipping\EoCApp.exe
Report ID: b048cd0d-9aaa-4766-a776-a61062408ae6
Faulting package full name:

No idea what any of this means, but thought i'd share it.

Thanks in advance!

Re: Game crashes to desktop [Re: Charmagon] #653187
21/06/19 04:01 AM
21/06/19 04:01 AM
Joined: Mar 2003
Posts: 26,492
Canada
Raze Offline

veteran
Raze  Offline

veteran

Joined: Mar 2003
Posts: 26,492
Canada

Are you shutting down all non-essential programs (especially anti-virus) before starting the game? Firewalls can cause conflicts (generally on startup or loading screens, though) and overlays from graphics tweaking/monitoring programs or chat programs can also caused issues.

Try verifying local files: in the Steam library, right click on the game and select Properties, switch to the Local Files tab and then click on the 'Verify Integrity of Game Cache...' button.

Try exiting out of the Steam client, and starting the game directly from the 'EoCApp.exe' program file, by right clicking and running as administrator.
Try right clicking the executable, select Properties, switch to the Compatibility tab and check off the 'Override high DPI scaling behavior' option (set it to Application), run as administrator and disable fullscreen optimization, and maybe set a Win 7 or 8 compatibility mode, to see if that will make a difference getting into the graphics options.

Try doing a clean boot and then test the game. Click Start, or hit WinKey-R, type in msconfig and hit enter; in the General tab, click Selective Startup, uncheck Load startup items (if required) and leave Load system services and Use original boot configuration options checked. Next, click on the Services tab, check the box to Hide all Microsoft services, then click the Disable All button (maybe make a note of which are currently enabled/disabled), then click OK and reboot the computer.
Run msconfig again to switch back to the normal boot configuration.



You can manually change the resolution and display mode by editing the graphicSettings.lsx file (in the '..\Documents\Larian Studios\Divinity Original Sin Enhanced Edition' folder), in Wordpad or other text editor.

To change the resolution, search for 'ScreenHeight', and edit the resolution in the value="xxxx" terms (shown below for 2560x1600 resolution):

<node id="ConfigEntry">
<attribute id="MapKey" value="ScreenHeight" type="22" />
<attribute id="Type" value="0" type="5" />
<attribute id="Value" value="1600" type="4" />
</node>
<node id="ConfigEntry">
<attribute id="MapKey" value="ScreenWidth" type="22" />
<attribute id="Type" value="0" type="5" />
<attribute id="Value" value="2560" type="4" />
</node>


Search for 'fake' near the start of the file to set the display mode. Edit the number in value="0" or value="1" in the second line after FakeFullscreenEnabled and / or Fullscreen; if both FakeFullscreen and Fullscreen are set to zero, it will be in Window mode).

<node id="ConfigEntry">
<attribute id="MapKey" value="FakeFullscreenEnabled" type="22" />
<attribute id="Type" value="0" type="5" />
<attribute id="Value" value="0" type="4" />
</node>

(and a couple entries lower)

<node id="ConfigEntry">
<attribute id="MapKey" value="Fullscreen" type="22" />
<attribute id="Type" value="0" type="5" />
<attribute id="Value" value="1" type="4" />
</node>

Re: Game crashes to desktop [Re: Raze] #653307
24/06/19 06:48 PM
24/06/19 06:48 PM
Joined: Jun 2019
Posts: 2
Charmagon Offline OP
stranger
Charmagon  Offline OP
stranger

Joined: Jun 2019
Posts: 2
Originally Posted by Raze

Try right clicking the executable, select Properties, switch to the Compatibility tab and check off the 'Override high DPI scaling behavior' option (set it to Application), run as administrator and disable fullscreen optimization, and maybe set a Win 7 or 8 compatibility mode, to see if that will make a difference getting into the graphics options.


Doing the things listed above fixed the issue.

Thanks for the support.


Powered by UBB.threads™ PHP Forum Software 7.6.2