Larian Banner
Previous Thread
Next Thread
Print Thread
DOS2 Definitive Edition Poor Performance #667264
14/05/20 01:52 AM
14/05/20 01:52 AM
Joined: Jun 2017
Posts: 48
K
Kawall Offline OP
apprentice
Kawall  Offline OP
apprentice
K

Joined: Jun 2017
Posts: 48
My buddy and I decided to play DOS2DE yesterday and I had terrible performance issues. First of all I finished OG DOS2 two times in the past on the some computer I'm playing now, and never had any problems with it. Second is that my friends pc is worse than mine yet he had no issues at 1080p and everything at medium. My pc on the other hand gets consistant 8-12 fps. Doesn't matter if I put everything on low and lower the resolution to 720p. I tried couple of the "fixes" and nothing seems to work. I set high-performance nvidia processor as preffered, tried setting DOS2 as high priority on the task manager and changed the affinity of the cores. Nothing worked.

My specs;
Intel i7-7700HQ 2.80GHz
NVIDIA GeForce GTX 1060
16GB RAM

Re: DOS2 Definitive Edition Poor Performance [Re: Kawall] #667266
14/05/20 10:30 AM
14/05/20 10:30 AM
Joined: Mar 2003
Posts: 27,530
Canada
Raze Offline

Larian Studios
Raze  Offline

Larian Studios

Joined: Mar 2003
Posts: 27,530
Canada

Do you have the same problem if you start the Classic version of the game?

If Classic is fine, someone reported this issue in a Steam discussion a couple months ago, which (in a couple of cases, but not for the OP) could be fixed by disabling the hardware accelerated GPU-scheduling option in the graphics drivers.

​If you switch the game to run on the integrated graphics, is the performance comparable between Classic and the Definitive Edition?
Integrated graphics are not officially supported, but the HD Graphics 630 has hardware support for DirectX 11, so should be able to run the game.
Also try resetting your graphics driver's 3D settings to default.

Try doing a clean boot and then test the game. Click Start, or hit WinKey-R, type in msconfig and hit enter; in the General tab, click Selective Startup, uncheck Load startup items (if required) and leave Load system services and Use original boot configuration options checked. Next, click on the Services tab, check the box to Hide all Microsoft services, then click the Disable All button (maybe make a note of which are currently enabled/disabled), then click OK and reboot the computer.
Run msconfig again to switch back to the normal boot configuration.

Try a clean re-install of the nvidia graphics drivers. See here or here, for example.

Re: DOS2 Definitive Edition Poor Performance [Re: Raze] #667270
14/05/20 05:21 PM
14/05/20 05:21 PM
Joined: Jun 2017
Posts: 48
K
Kawall Offline OP
apprentice
Kawall  Offline OP
apprentice
K

Joined: Jun 2017
Posts: 48
Classic works just fine. I get steady 60 fps at 1080p and high settings. No luck for definitive edition. If I switched to integrated it becomes even worse. Atleast with nvidia, main menu is around 30 and in games it rises to 50 occasionally. None of the fixes you suggested worked either.

What's weird is that first 5-10 minutes game runs normal, but after couple of minutes it starts to stutter like crazy.

Last edited by Kawall; 14/05/20 06:37 PM.
Re: DOS2 Definitive Edition Poor Performance [Re: Kawall] #667272
14/05/20 09:28 PM
14/05/20 09:28 PM
Joined: Mar 2020
Posts: 51
KillerRabbit Offline
journeyman
KillerRabbit  Offline
journeyman

Joined: Mar 2020
Posts: 51
I had all sorts of problems with my GTX 880m -- two generations back from your card. Terrible performance on the lowest setting and crashing, crashing, crashing. Which was strange because my 3.3GHz laptop usually handles everything. And then I found some advice buried deep in a forum somewhere.

Try *under* clocking. I used MSI afterburner to set my clock to -42 and the game has performed flawlessly. I think Larian has a problem with GTX cards -- for some reason my card was spiking to maximum output / max heat all the time. All of which is ironic since the NVIDIA flashscreen pops up every time I start the game.

Re: DOS2 Definitive Edition Poor Performance [Re: Kawall] #667274
15/05/20 12:51 AM
15/05/20 12:51 AM
Joined: Mar 2003
Posts: 27,530
Canada
Raze Offline

Larian Studios
Raze  Offline

Larian Studios

Joined: Mar 2003
Posts: 27,530
Canada

If you quit and restart immediately when the performance drops, do you get another 5-10 minutes of normal performance, or is it less?
Is there any additional drop in performance over time?

A few people have slightly underclocked their video cards (MSI Afterburner) to avoid DirectX 'device removed' errors (topic), as well (one person recommending to lower the Core Clock and Memory Clock options by around 100 for that issue).

Make sure the Virtual Memory setting in Windows is set to automatic / system managed, rather than being disabled or set to a fixed size. To check or change virtual memory settings: Win 7/8 or Win 10.


Powered by UBB.threads™ PHP Forum Software 7.6.2