On the Switch did you try changing your TV Output settings (ie from Surround to Stereo or Automatic)?
Also, check if you have 'mute when headphones are disconnected' on in your System Settings, and if so change it to off to see if that helps.