'Epic Encounters' is an Enhanced Edition mod only, as well as 'Book of the Dead' or 'XC_Encounters' (if you referred to this mod as 'EC Encounters'). Though in DOS 1 it's only possible to activate/play with one module at a time and you have to start a new game to use mods like 'Epic Encounters' or 'XC_Encounters' or 'Book of the Dead', so you either have to choose one of those mods or manually merge the mods, which requires some modding knowledge.

I don't know what the 'legacy mod error' means in this context, maybe it's just a side-effect of trying to play with several mods, or another kind of version mismatch. Raze might know more.


My mods for DOS 1 EE: FasterAnimations - QuietDay - Samaritan