Larian Studios
Hey everyone!

Today, we’re rolling out Larian Accounts, which are opt-in accounts that will grant you access to Larian services across the many platforms we release our games on.

It’s early days, but signing up now helps us stress-test the service as we roll out more features. It’s entirely optional (you don’t need an account to play Baldur’s Gate 3), but in the future it’ll be the account that links your adventures together.

For example, your account will be how we facilitate cross-saves for Baldur’s Gate 3 across Steam, Stadia, and GOG, as well as potential future platforms if and when released.

This is also where you’ll get access to the Twitch extension so your audience can vote on different decisions your character will make throughout the game.

Cross-play multiplayer between future platforms will also be happening through the Larian account, though this feature is not available Day 1 of Baldur’s Gate 3’s Early Access.

We understand that you may have multiple accounts across our channels at the moment. The Larian Account is not currently connected to our merch account. This service is very much in the same spirit as Early Access, and we have a roadmap of features to add over time.

Signing up early helps us make the service better, and while we’re excited to offer you cross-saves now, the future of your Larian Account is all the brighter for having you on board from day 1!

Join our party by signing up for a Larian Account at the following link: Larian Account


[Linked Image]
I signed up and verified my e-mail, but now I can't log in - every time I try, I immediately get redirected to the login page. I didn't get any error messages, so no idea what's going wrong...
I think there may be a slight hiccup; they are aware, but it may have cleared itself if you wait a while (it did with me, anyway...)
Okay, thanks, I'll give it a while. Hiccups are to be expected when stress-testing.
Working just fine for me!

If waiting doesn't help, try logging in to the account in a different browser, if available, or disable any browser add-ons, etc, that might cause an issue.
Alternately, try opening a new private browsing session to test (unless this was moved in recent updates, Opera has a 'New Private Window' entry in the main menu [Ctrl+Shift+N], and Firefox has the same in the menu [Ctrl+Shift+P]).

Quitting the browser and restarting may help, or at least close any other tabs open to that site (if you opened the verification link in a different tab/window, etc).
Worked for me. If you are not receiving any email for activation, just check your junk email.

Got registered with no issue. Just can’t enable two-factor authentication. Either by SMS or Google Authenticator. —-

Update:
I ended up putting the “+” in the phone number and it worked. Haven’t tried google authentication again as of yet.

Are you getting an error message when trying to enable 2FA?

Try logging out and then log back in, especially if you may have a tab open from before verifying your email address.

For SMS, the phone number needs to be prefaced by a + and the country code, so for North America +12345556789. I don't know if extra formatting of the phone number may cause a problem, but it at least requires the +.

There isn't an option currently to change the phone number, but you should be able to remove 2FA and enable it again.
I think there may be an issue with forum passwords which are 6 characters long as I am getting stuck at the registration stage. Is the same password used for both the account and posting on the forum?
Originally Posted by mfr
I think there may be an issue with forum passwords which are 6 characters long as I am getting stuck at the registration stage. Is the same password used for both the account and posting on the forum?

I'm not certain, though my inclination is "probably not" as there's no forum integration AFAIK. On the contrary, I would recommend not using the same password as the forum as the forums are not currently as secure as we would like (we are working on an https update right now, but at present connections are not encrypted).
Thanks for the reply. I eventually managed to beat the system into submission, but it was a close thing! I still haven't cracked the NHS login system, which creates ever decreasing cicrles.
Originally Posted by mfr
Thanks for the reply. I eventually managed to beat the system into submission, but it was a close thing!

Sometimes it just needs a good stern Look™.

Originally Posted by mfr
I still haven't cracked the NHS login system, which creates ever decreasing cicrles.

D:

The joy that is NHS IT. Don't they still mandate IE6?
Exciting news! I was able to sign up, connect my game accounts and enable 2FA with ease.
I connected all the things. Good job web team
Is there a difference between this new account and the forum one?
© Larian Studios forums