Larian Studios
Mahlzeit.

Habe heute mein Spiel bekommen und bin im Grunde auch total begeistert davon. Jedoch bin ich etwas irritiert, was die Grafik angeht. Mein Spiel läuft superflüssig (1900x1080), aber die Wasseranimationen zuckeln mit gefühlten 3 Frames pro Sekunde vor sich hin. Das stört irgendwie. Auch die Schatten von Bäumen und Gräsern, sowie weit entfernte Gegner, zuckeln gemütlich vor sich hin. Ich habe spaßeshalber die Auflösung auf 640x480 eingestellt. Dort ist es das gleiche.

Habt ihr das selbe Problem ?
Originally Posted by Squallie
Mahlzeit.

Habe heute mein Spiel bekommen und bin im Grunde auch total begeistert davon. Jedoch bin ich etwas irritiert, was die Grafik angeht. Mein Spiel läuft superflüssig (1900x1080), aber die Wasseranimationen zuckeln mit gefühlten 3 Frames pro Sekunde vor sich hin. Das stört irgendwie. Auch die Schatten von Bäumen und Gräsern, sowie weit entfernte Gegner, zuckeln gemütlich vor sich hin. Ich habe spaßeshalber die Auflösung auf 640x480 eingestellt. Dort ist es das gleiche.

Habt ihr das selbe Problem ?


JA habe das gleiche Problem
Scheint normal zu sein im Test von PC-Games wird das sogar negativ bewertet.
Vllt bewirkt der Release-Patch ja Wunder :o
Aha - dachte ich mir schon. Dann hoffen wir mal, dass wirklich bald ein Patch kommt.
gebt mir mal nen Screenshot vom Menü für die Grafikeinstellungen. Vielleicht lässt sich ja was ableiten.
Ja das zuckeln des Wassers ist nicht wirklich schön anzusehen, hoffentlich wird dieser BUG balt behoben.
[Linked Image]


Alles auf Max ;-)
dynamische Reflexionen ausstellen. dann sollte das geruckel und gezuckel beim Wasser weg sein. Sieht dann zwar grafisch nicht mehr ganz so top aus, aber es ist weg wink
uno momento - wird sofort probiert grin
Nö, das hat leider nichts gebracht. Auch die anderen Einstellungen zu deaktivieren hilft nicht. Jetzt besitzt das Spiel zwar gefühlte 60 Frames, aber das Wasser und die Schatten ruckeln immer noch. Da ist nicht die kleinste Verbesserung zu sehen. Aber trotzdem danke.
think hmmm... das ist seltsam... für gewöhnlichen machen Dynamische Reflexionen den effekt beim Wasser.
Was du noch versuchen könntest, wäre die Schatten mal zu deaktivieren. Ich hab das Gefühl das geruckel beim Wasser ist auch auf diese zurück zu führen.
Originally Posted by Trasza
dynamische Reflexionen ausstellen. dann sollte das geruckel und gezuckel beim Wasser weg sein. Sieht dann zwar grafisch nicht mehr ganz so top aus, aber es ist weg wink


Hat bei mir leider auch nichts gebracht frown
Ich will ja net Flamen, aber es stört schon ziemlich xD
Bringt leider auch nix. Und ohne Schatten sieht das Spiel nicht besonders doll aus. Also schalte ich sie lieber wieder an und nehme es eben hin. Ist zwar nur ne Mutmaßung, aber kann es vielleicht sein, dass das Wasser nur aus animierten Texturen besteht, bei denen die Texturem ein wenig zu langsam abgespielt werden ? grin
Originally Posted by Squallie
Bringt leider auch nix. Und ohne Schatten sieht das Spiel nicht besonders doll aus. Also schalte ich sie lieber wieder an und nehme es eben hin. Ist zwar nur ne Mutmaßung, aber kann es vielleicht sein, dass das Wasser nur aus animierten Texturen besteht, bei denen die Texturem ein wenig zu langsam abgespielt werden ? grin


Also ich glaube ja es fehlen Animationen und deswegen ruckelts.

@Trasza: Wenn ich Schatten ausstelle, stürzt das Spiel ersteinmal gepflegt ab.^^
Lol? confused
es stürzt ab, wenn du die Schatten ausstellst?

Ich könnt nur noch empfehlen mal alles ganz runter und aus zuschalten. Wenns dann weg ist langsam wieder nach oben drehen und schauen woran es liegt.
Originally Posted by Trasza
Lol? confused
es stürzt ab, wenn du die Schatten ausstellst?

Ich könnt nur noch empfehlen mal alles ganz runter und aus zuschalten. Wenns dann weg ist langsam wieder nach oben drehen und schauen woran es liegt.


Naja solange ich die Schatten nicht ausstelle ist ok auf niedrig und mittel kann ich sie stellen, nur ganz aus geht halt net.
Achja und wie ich bemerkt habe gibts es bei bestimmten auflösungen wie 1360x768 oder 1600x900 das Problem das der Bildschirm schwarz weiße Kästchen zeigt bei anderen Auflösungen ist alles normal Oo

Ohman mein PC ist seltsam -.- aber das macht ihn einzigartig^^
Jetzt ist es offiziell: Habe gerade den Test der PCGames gelesen. Hier ein kleiner Auszug bezüglich des Animationspromblems:

"Divinity 2 greift auf die Gamebryo- Engine zurück, die auch anderen Rollenspielen wie Fallout 3 (dt.) oder Oblivion schon als Grundgerüst diente. Die Larian Studios schaffen es aber nicht, eine gleichbleibende Qualität aufrechtzuerhalten. Während die Landschaften zu Beginn recht hübsch aussehen, bietet das Spiel Ihnen später verwaschene Texturen oder eine geringe Weitsicht - die gerade in den Flugpassagen negativ auffällt. Ebenso auffällig: Bei allen sich bewegenden Objekten scheinen Animationsstufen zu fehlen. Deshalb ruckeln Bäche, Wasserfälle oder Mühlsteine vor sich hin, statt geschmeidig zu fließen. Das raubt der größtenteils passabel umgesetzten Welt einiges an Glaubwürdigkeit."
Irgendwie fällt es mir schwer zu glaube, dass da Animationen fehlen... vielleicht mal neu installieren?
Originally Posted by Trasza
Irgendwie fällt es mir schwer zu glaube, dass da Animationen fehlen... vielleicht mal neu installieren?


Im PC-Games Test schreiben sie das doch auch:

"Divinity 2 greift auf die Gamebryo- Engine zurück, die auch anderen Rollenspielen wie Fallout 3 (dt.) oder Oblivion schon als Grundgerüst diente. Die Larian Studios schaffen es aber nicht, eine gleichbleibende Qualität aufrechtzuerhalten. Während die Landschaften zu Beginn recht hübsch aussehen, bietet das Spiel Ihnen später verwaschene Texturen oder eine geringe Weitsicht - die gerade in den Flugpassagen negativ auffällt. Ebenso auffällig:Bei allen sich bewegenden Objekten scheinen Animationsstufen zu fehlen. Deshalb ruckeln Bäche, Wasserfälle oder Mühlsteine vor sich hin, statt geschmeidig zu fließen. Das raubt der größtenteils passabel umgesetzten Welt einiges an Glaubwürdigkeit."
Wurde ja auch in den Previews schon erwähnt.
Allerdings schreiben sie "scheinen" was nicht bedeutet dass es so ist.
außerdem scheint es nicht bei allen aufzutreten von daher denke ich nicht, dass die Animationen wirklich "fehlen".
Also bei mir drehen sich die Mühlräder usw. ganz geschmeidig auch sonstige Animationen bei bewegten Objekten funktioniert ohne Probleme. Einzig das Wasser fängt an zu ruckeln, wenn ich mich während dessen selbst bewege, wenn ich still stehen sieht es wieder top aus.

(System: WinXP SP2, AMD AthlonX2, 4gb Ram, GForce8800GTX)
ok... scheint ATI lastig zu sein. Bzw scheint bei Spezies Q die Systemanforderung nicht perfekt erfüllt zu sein oder die driver zu alt.
Spezies Q?

wasn das?^^
Kein Antwort?^^
Spezies Q ist der Name von Spezies Q.
Kein Plan was du mit meinem Nick willst smile Aber so nenne ich mich schon seit Jahren in den Foren.
Ich vollpfosten!^^

Sorry!
Also, ich kann jetzt einwandfrei sagen, dass es nicht ATI lastig ist. Das AA lässt sich mit den Nvidia drivern übersteuern. Daher werd ich heute nachmittag noch ein paar einstellungen austesten .. vielleicht kommt was bei raus.
Diese Antwort der Devs sollte alle unklarheiten beseitigen.

Originally Posted by Lar_q
We realize that it was a mistake not to expose sliders which allow you to control the update speeds of these animations, and hope to make that feature available in a forthcoming patch together with a number of other options which will further increase the graphical quality. It was really an oversight on our side as it wasn't flagged during playtesting (probably because people got used to it), but as the engine actually allows a lot more and we see now that there is a demand for this, we'll work towards bringing this to you.
Das ändert allerdings nichts daran, dass man das problem mit einer Übersteuerung durch den Grafiktreiber auch lösen könnte. Versuch macht klug.
Übersteuerung? Man kann im Graka Treiber die Animations-Update-Geschwindigkeit erhöhen?

Raus mit den Tipps! laugh
Gib mir doch mal zeit, das ganze zu testen... *sigh*
Kann das ganze vielleicht mit dem PhyX-Treibern zusammenhängen ? Alle physikbasierenden Animationen (z.B. Zerschlagen von Kisten, Erdrutsche, usw.) "ruckeln". Vielleicht gehört das Wasser da mit rein.
Die animation von magischen Sprüchen scheint auch zu ruckeln, das stört mich am meisten, wenn mein Feuerball sich abgehackt auf den Gegner zu bewegt.
Originally Posted by Squallie
Kann das ganze vielleicht mit dem PhyX-Treibern zusammenhängen ? Alle physikbasierenden Animationen (z.B. Zerschlagen von Kisten, Erdrutsche, usw.) "ruckeln". Vielleicht gehört das Wasser da mit rein.


Das könnte natürlich sein - wenn PhyX überhaupt genutzt wird in dem Spiel... ich glaube persönlich nämlich nicht.
Da man die Physx-Treiber installieren muss, gehe ich mal fest davon aus, dass die auch im Spiel gebraucht werden ;-)
Also bei älteren Grafikkarten brauchte man noch eine extra PhysX Karte d.h. evtl habt ihr gar kein PhysX da eure Grafikkarte noch aus der Zeit vor der Fusion von PhysX und NVidia bzw AMD (weis der Geier)ist. Die Treiber sind demnach nur vorsorglich dabei für die neuen Grafikkarten.
Schade... habe dieselben Probleme. Hinzu kommt das nicht funktionierende Antialiasing.

Mein System (mit eigentlich aktuellen Treibern):

CPU: AMD Phenom II X4 940 BE
RAM: 4 GB 1066Mhz DDR2
Grafik: ATI Radeon 4890
Betriebssystem: Vista Home Premium (64 Bit)

Da läuft Oblivion und Fallout ganz hervorragend drauf und sieht wesentlich besser aus.
Lar_Q hat heute gepostet dass dieses Problem eine Einstellung der Engine ist. Soll heissen:

es wird ein Patch erscheinen (nein nicht der 1. Patch, der für heute erwartet wird) in dem im Optionsmenü Punkte hinzugefügt werden, mit denen man die Geschwindigkeit bzw. Qualität der Animationen steuern können wird. Nachzulesen in diesem Thread.
OT: - Kleiner "Physik/Wirtschafts"-Exkurs
Originally Posted by Spezies Q
... vor der Fusion von PhysX und NVidia bzw AMD (weis der Geier)ist.


Stimmt schon:
Physx (vormals Ageia) = NVidia
wink

AMD hat´s "verschlafen":
Havok (Konkurrenztechnologie) = Intel

Aber über eine Partnerschaft von AMD mit Intel herrscht wieder Waffengleichheit.
biggrin


Gruß,
Ragon, der Physik-Magier
(ähh, nicht wirklich... [Linked Image] - wink )
Originally Posted by Squallie
Da man die Physx-Treiber installieren muss, gehe ich mal fest davon aus, dass die auch im Spiel gebraucht werden ;-)

Hm bei mir kam garnicht die PhysX-Treiberinstallation aargh

Kann natürlich daran liegen, dass ich vielleicht schon die aktuellsten installiert habe.

Aber wie der Dev schon schrieb, es liegt wohl an einem Fehlenden Schieberegler im Grafikmenü. Hoffentlich schieben sie diesen schnellstens nach!
Hm...das mit dem Schieberegler finde ich irgendwie seltsam. Mir fällt zumindest kein Spiel ein, wo man per Schieberegler die Animationsphasen einstellen konnte. grin
Mir schon hehe Everquest 2
Nie gespielt, aber ich glaube dir ;-)
Hmm wenn es dafür einen Schieberegler geben sollte (auch wenn er nicht implementiert ist) müsste es nicht vielleicht einen Weg geben das ganze 'manuell' einzustellen? Also per ini Datei oder so?
Also ich hab das Problem, dass ich 60 FPS habe laut Fraps. Das ist die Maximal-Leistung meines Monitors für die 1280*1024iger Auflösung.

Auf 1024*768 hab ich eigentlich 85FPS aber im Spiel auch wieder nur 60. Wieso?

Ich hab außerdem bemerkt, dass trotz 60FPS beim laufen das Spiel ruckelt. Das zuckelt alles so komisch trotz 60 Frames? Wie kann das sein? Hat das auch mit der Engine zu tun? Ich mein dabei nicht Wasserfälle oder so, sondern das Spiel allgemein.
Das ruckeln könnte durch das Nachladen von Texturen etc. kommen, das hat dann weniger mit dem CPU und GPU zu tun sondern mit der Menge des Grafik und Hauptspeichers (und dessen Geschwindigkeit).

Ich hab auch immer 60FPS, das SPiel ist vielleicht absichtlich auf diese Frequenz gebremst?
Ich hab mal ein Vide gemacht wo das deutlich wird. Schaut euch mal bitte die "Ruckler" des Spiels vor allem am Rand an bei dem Weg. Das is doch Mist was kann man da ändern?

Video: Ruckelvideo bei 60FPS


System:
[Linked Image]
Originally Posted by technotica
Das ruckeln könnte durch das Nachladen von Texturen etc. kommen, das hat dann weniger mit dem CPU und GPU zu tun sondern mit der Menge des Grafik und Hauptspeichers (und dessen Geschwindigkeit).
Nein, hat damit eindeutig nichts zu tun.

Ich würde sagen aus irgendeinem Grund wird die Wassertexturanimation nur ~ 10 x pro sekunde upgedatet. Keine ahnung wie man auf so eine idee kommen kann, im Zweifelsfall beschuldige ich mal die Xbox :P
Die zuckeln habe ich auch und ich habe sogar ne 285 GTX mit 1 Gig Ram. Man hat Gefühl, als ob ständig auf die Festplatte zugegriffen wird. Mir macht das spielen so keinen Spaß. GErade einmal 1 Stunde habe ich jetzt gespielt, aber für mich ist das zuckeln unerträglich und tut mir richtig in den Augen weh. Spielspaß ist was anderes.
Hehe genau die ganzen Spielekonsolen sind schuld, bei denen müssen die Entwickler nicht soviel beachten und PC Version guckt dann aus der Röhre. Denke daher ist auch die Grafik ein wenig begrenzt.
Originally Posted by Durante
Originally Posted by technotica
Das ruckeln könnte durch das Nachladen von Texturen etc. kommen, das hat dann weniger mit dem CPU und GPU zu tun sondern mit der Menge des Grafik und Hauptspeichers (und dessen Geschwindigkeit).
Nein, hat damit eindeutig nichts zu tun.

Ich würde sagen aus irgendeinem Grund wird die Wassertexturanimation nur ~ 10 x pro sekunde upgedatet. Keine ahnung wie man auf so eine idee kommen kann, im Zweifelsfall beschuldige ich mal die Xbox :P


Es geht da grad um die Ruckler die NICHT Wasser-Betreffend sind, wie in meinem Video zu sehn.
Ah, sorry, das kommt davon wenn man den thread nur halb liest! (Und sich dabei noch über den aufregt der das wasser verbrochen hat ;))
© Larian Studios forums