Larian Studios
Posted By: SixGen Anti-aliasing (AA) mit ATI-Karten - Anleitung - 30/07/09 01:06 AM
Anti Aliasing aktivieren (verwenden) mit ATI Grafikkarten cheer .

Für das Spiel div TEIL 2


Spielversion: Release-Patch 1.01 (Deutsch).

Getestet mit ATI Catalyst 8.5 und nun auch mit 9.7. Beide Treiber unterstützen meine Anleitung zur Aktivierung von Anti-aliasing.
Ferner gab es positives Feedback einiger User die u. A. mit Windows 7 64-Bit Edition, und auch mit einer ATI Radeon HD 4870 arbeiten. crazy

Hallo erst einmal,

ich habe es nun hinbekommen Anti aliasing für meine ATI Radeon HD 4850
für Divine Divinity 2 zu [color:#FFFFFF]aktivieren
.[/color]

Kleines Vorwort

Mögen mir die User verzeihen die es nicht bekommen werden. Aber versucht eurer Können bzw. Glück. Anleitung folgt mit Bildern und Links. smile Ich werde völlig auf direkte Weise genau das beschreiben was notwendig ist um Anti Aliasing hinzubekommen (und es sieht verdammt schick aus). Also, los geht’s:

[color:#33CC00][u]VORBEREITUNG[/u]

Deaktivieren der Überprüfung von digitalen Signaturen

1) Start > Ausführen
2) cmd eingeben und RETURN drücken (es müssen administrative Rechte vergeben sein, sonst geht es womöglich nicht)
3) Bcdedit.exe /set nointegritychecks ON eingeben und RETURN drücken.
4) exit eingeben und RETURN drücken.
5) Computer neu starten (Windows-Neustart)

[u]ALTERNATIVE[/u]
[u]Wenn das Deaktivieren mit dem [b][color:#FFFFFF]Bcdedit.exe-Befehl nicht funktioniert:[/u][/b][/color]

Man kann den Signatur-Zwang auch deaktivieren mit einem Tool namens Ready Driver Plus (V. 1.1). DOWNLOAD HIER. Alternativ kann man bevor Windows geladen wird F8 drücken und (leider jedes mal wieder) den Signaturzwang somit ausschalten. Trotzdem immerhin eine simple Möglichkeit, denn man muss ATI Tray Tools nicht jedes Mal geladen haben, sondern lediglich nur einmalig alles einstellen (habe ich getestet, das funktioniert mit dem Auslassen der ATI Tray Tools im Nachhinein). wink

Ich besitze Windows Vista 64-Bit. Ladet die Software ATI TRAY TOOLS v.1.6.9.1372 Beta (oder neuer!) runter (Download)

Ich habe meine Benutzerkontensteuerung komplett deaktiviert. Startet die Installation. Dabei habe ich bei der ersten Auswahl was installiert werden muss ALLES deaktiviert. Nur das was benötigt ("required") wird...

[Linked Image]

...Im darauf folgenden Punkt "disable I2C access" aktiviert (Häkchen setzen)...

[Linked Image]

...Dann auf NEXT und das Programm jedoch nicht starten am Ende der Installation. Nach der Installation ins Startmenü gehen und "Low Level Driver Installation" starten. Dort auf INSTALL klicken. Danach mit CLOSE beenden:

[Linked Image]

[Linked Image]

Catalyst Control Center

Öffnet den Catalyst Control Center. Dort stellt Folgendes ein:

[Linked Image]

ATI TRAY TOOLS

Nun "ATI Tray Tools" starten. Wenn Ati Tray Tools bei euch nicht starten will (Vista 64-Bit), dann schaut nach warum es nicht funktioniert. Wie oben schon erwähnt: Ich habe für JEDES anzunehmende Problem, weshalb ATI Tray Tools nicht starten will, eine Lösung geschrieben ganz oben in meiner Anleitung.

IN DAS MENÜ GEHEN UND FOLGENDES EIN/UMSTELLEN....
[Linked Image]

Bild 01: ANWENDUNGSGESTEUERT einstellen
[Linked Image]

Bild 02: Ebenfalls ANWENDUNGSGESTEUERT...
[Linked Image]

Bild 03: HOHE QUALITÄT
[Linked Image]

Bild 04: Ebenfalls HOHE QUALITÄT
[Linked Image]

Bild 05: IMMER AUS einstellen
!!! Ist die VERTIKALE SYNCHRONISATION eingeschaltet, klappt kein Anti Aliasing. Das habe ich mehrfach getestet. Ich weiß, das klingt komisch, aber anders geht es wirklich nicht.
[img]http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/05.jpg[/img]

Bild 06: ANWENDUNGSGESTEUERT einstellen
[img]http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/06.jpg[/img]

Bild 07: "3" einstellen
[img]http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/07.jpg[/img]

Bild 08: Alle Punkte aktivieren, außer PIXELMITTE ABWECHSELN!
[img]http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/08.jpg[/img]

Bild 09: Beide Punkte aktivieren
[img]http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/09.jpg[/img]

Bild 10: AUS einstellen
[img]http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/10.jpg[/img]

Bild 11: 24 BIT ERZWINGEN einstellen
[img]http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/11.jpg[/img]

Bild 12: DREIFACHES BUFFERING aktivieren
[img]http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/12.jpg[/img]

Nun in das MENÜ gehen (auf EINSTELLUNGEN drücken)
[img]http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/Menue_01.jpg[/img]

Hier folgendes einstellen (siehe Bild). Alternativ für NICHT-Hardcore-User bringt es etwas an zusätzlicher Performance, wenn man unter FILTER: BOX einstellt und nicht Edge-detect (circa 5 bis 10 Frames Performancezuwachs auf meinem Rechner. Habe ich getestet). Danke an den User Tom alias Slochy. smile
[img]http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/Menue_02.jpg[/img]

Nun oben auf den Menüpunkt/Reiter "ERWEITERT" klicken und folgendes einstellen:
[img]http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/Menue_03.jpg[/img]

TIPP: Wenn das Spiel zu "pixelig/körnig" aussieht, dann stellt man den Regler unter [color:#FFFFFF]Detaillevel (LOD) Bias auf 0 ("Null"). Ich persönlich mag aber dieses "körnige" im Spiel; warum auch immer...
[/color]

Den Einstellungen noch einen Namen als PRESET geben. Hierzu einfach auf das Disketten-Symbol klicken, einen Namen geben und auf OK klicken (alle Fenster schließen).

[img]http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/Menue_04.jpg[/img]


SPIEL STARTEN

Mit ALT + TAB könnt ihr vom Spiel zum Windows-Desktop wechseln um weiter zu lesen. Das geht ohne, dass es abstürzen sollte).

Ummittelbar nach dem Starten des Spiels klickt ihr auf OPTIONEN, dann auf GRAFIK und nehmt alle Einstellungen wie folgt vor (Anti Aliasing wird bei jedem Spielstart sowieso wieder resettet, es ist also egal was ihr dort vorerst einstellt):

[img]http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/Grafikeinstellungen_1.jpg[/img]

Beendet nun das Spiel. Start das Spiel erneut und ladet einen Spielstand. Nun geht irgendwo ins Freie (kein Dungeon und auch kein Haus/Gebäude, um Irrtümer zu vermeiden (Kerzen in Dungeons und andere Kleinigkeiten sehen meist trotzdem ein bisschen pixelig/abgehackt aus wegen den Lichteffekten oder unsauber geschnittenen Texturen, glaub ich.). Geht ins Freie. Schaut euch Holzplanken, Dächer, oder gar Steine an und geht wieder in die Grafikeinstellungen. Stellt nun 8-Fach-Anti-Aliasing ein (oder auf 4 Fach, egal) und übernehmt die Einstellung mit der rechten Maustaste und geht wieder ins Spiel hinein. Anti Aliasing sollte nun aktiviert sein.

Schaut euch wie gesagt die Dächer, die Holzplanken die irgendwo herumstehen an oder die Äste von den Bäumen, als Vergleich.

Hier zwei screenshots von mir OHNE und MIT aktiviertem Anti Aliasing:

Bild OHNE Anti-aliasing (in den Grafikeinstellungen auf "1 x AA" gestellt) Wenn euch das Bild zu "körnig" aussieht (Siehe Baumstämme etc), dann schaut unten nach dem Tipp Nr. 2.

http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/Divinity22009-07-3003-05-02-32.jpg

Bild MIT Anti-aliasing

http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/Divinity22009-07-3003-02-25-45.jpg

Weitere Bilder mit Anti Aliasing:

http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/Divinity22009-07-3016-50-49-94.jpg

http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/Divinity22009-07-3016-57-08-16.jpg

http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/Divinity22009-07-2922-42-29-80.jpg

http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/Divinity22009-07-2922-47-31-94.jpg

TIPP 1: Nach JEDEM Spielstart (Version 1.01 zumindest) und nach dem geladenen Spielstand MUSS man wieder in die Grafikeinstellung gehen und Anti-aliasing auf 2x, 4x oder 8x manuell setzen. Anti-aliasing wird nicht gespeichert, da der Hersteller (meiner Meinung nach) einfach vergessen hat diese Einstellung in der Datei "graphicsettings.xml" mit anzugeben. In Windows Vista befindet sich diese Datei übrigens im Pfad: C:\Users\[Benutzername]\AppData\Local\Divinity 2\Profile\

Tipp 2: Wenn das Spiel zu "pixelig/körnig" aussieht, dann stellt man den Regler in ATI TRAY TOOLS unter 3D-Einstellung -> Einstellung -> Erweitert unter [color:#FFFFFF]Detaillevel (LOD) Bias auf 0 ("Null"). Ich persönlich mag aber dieses "körnige" im Spiel; warum auch immer...

Tipp 3: Mehr Frames pro Sekunde (FPS) bzw. einen flüssigeren Bildaufbau gibt es wenn man Ansiotropisch auf "nur Gelände" und auf 4x stellt. Siehe Bild zur Veranschauung:[/color] http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/Divinity22009-07-3017-02-40-91.jpg

Tipp 4: Der User Tom alias "Slochy" machte darauf aufmerksam, dass die Performance mit "Box anti aliasing" nicht so viel Performance einbüßt wie "Edge detect anti aliasing". Ihr könnt in den [color:#FFFFFF]ATI Tray Tools unter 3D-Einstellungen -> EINSTELLUNGEN -> unter FILTER auf BOX anstatt "Edge-detect" umstellen und ausprobieren ob die FPS zunehmen. Ich habe nun einen leichten Performancezuwachs von 5 bis 10 FPS.[/color]

[/color]
Falls Ich in meiner Anleitung noch Aktualisierungen vornehme bzw. vornehmen muss, dann poste ich diese in einem angegangenen Teil meines Threads, da ich ja nur einige Tage meinen ersten Eintrag editieren kann (Danke für diesen Tipp @ Spezies Q).

Liebe Grüße,

Mathias ("SixGen")


Schöne Hilfe, muss man sagen smile. Hab zwar keine Ati-Karte, aber sonst würde ich deine Anleitung beherzigen laugh

Takashi
Bitte in das Technikforum verschieben.
Originally Posted by Spezies Q
Bitte in das Technikforum verschieben.


Guten Morgen erst einmal!

Warum "Technik-Forum?"

Mein Thema ist eindeutig ein Tipp bzw. Trick und hat mit Hardware im diesen Sinne primär erst einmal nichts zu tun. Ich denke ich habe das Recht selbst auszusuchen als "poster" in welchem Teil des Forums mein Eintrag am besten hineinpasst. ..aber über einen konstruktiven Beitrag würde ich mich freuen, insofern Du eine ATI Karte besitzt. Teste doch mal ob AA nun funktioniert.

Lieben Gruß
SixGen
Originally Posted by ppTakashi
Schöne Hilfe, muss man sagen smile. Hab zwar keine Ati-Karte, aber sonst würde ich deine Anleitung beherzigen laugh

Takashi


Hallo Takashi, vielen Dank für Dein Kommentar!.... smile

Lieben Gruß
SixGen
Danke für die ausführliche Anleitung, werde das heute abend gleich mal testen.

Eigentlich schade das man als Käufer eines Spiels zu solchen "Tricks" greifen muss um ein Feature zu haben das eigentlich funktionieren sollte.
Originally Posted by On3winged
Danke für die ausführliche Anleitung, werde das heute abend gleich mal testen.

Eigentlich schade das man als Käufer eines Spiels zu solchen "Tricks" greifen muss um ein Feature zu haben das eigentlich funktionieren sollte.


Es gibt ja viele Spiele, da stellt man alle Grafikeinstellungen vor bzw. im Spiel ein, und zwar SÄMTLICHE, und es funktioniert einfach! Zum Beispiel Fallout 3 von Bethesda Softworks. Ja. So sollte es sein. Ich finde es JÄMMERLICH wenn Spiele raus kommen und der Gamer dafür stundenlang sorgen muss gewisse "Dinge" einzustellen, die ja eigentlich selbstverständlich sind. Dazu gehört nun mal auch Anti-aliasing. Finde ich.

Originally Posted by SixGen
Originally Posted by Spezies Q
Bitte in das Technikforum verschieben.

Warum "Technik-Forum?"

Mein Thema ist eindeutig ein Tipp bzw. Trick und hat mit Hardware im diesen Sinne primär erst einmal nichts zu tun. Ich denke ich habe das Recht selbst auszusuchen als "poster" in welchem Teil des Forums mein Eintrag am besten hineinpasst.


tip & tricks sind spielinhalte, AA und co ist technik/software und damit hardware eindeutig. zumal es ja schon paar andere threads zum thema da gibt. aber trotzdem ganz hilfreich wer auf AA steht smile

Originally Posted by ebenholzjunge
Originally Posted by SixGen
Originally Posted by Spezies Q
Bitte in das Technikforum verschieben.

Warum "Technik-Forum?"

Mein Thema ist eindeutig ein Tipp bzw. Trick und hat mit Hardware im diesen Sinne primär erst einmal nichts zu tun. Ich denke ich habe das Recht selbst auszusuchen als "poster" in welchem Teil des Forums mein Eintrag am besten hineinpasst.


tip & tricks sind spielinhalte, AA und co ist technik/software und damit hardware eindeutig. zumal es ja schon paar andere threads zum thema da gibt. aber trotzdem ganz hilfreich wer auf AA steht smile



Ich ändere aber nichts an der Hardware. Ich tune nichts. Oder stelle keine Hardware um. Sondern ich ich gebe Tipps wie ich Anti Aliasing zum Laufen bringe. Und von daher lastet mein Tipp eher in Richtung software. Und meine Hardware ist auch nur Nebensache.
Wer AA nicht aktiviert bekommt oder nicht weiß, wie das auf seinem System geht, hat ein technisches Problem, und dafür wurde nun mal jenes Forum eingerichtet.

Hier geht's um Hilfe, Tips und Tricks zu den Spielinhalten, insofern waren die Einwände schon richtig.

Möchte deine Arbeit und Mühe damit nicht schmälern, dennoch steht dein Post im "falschen" Forum. wink
Originally Posted by SixGen
Originally Posted by ebenholzjunge
Originally Posted by SixGen
Originally Posted by Spezies Q
Bitte in das Technikforum verschieben.

Warum "Technik-Forum?"

Mein Thema ist eindeutig ein Tipp bzw. Trick und hat mit Hardware im diesen Sinne primär erst einmal nichts zu tun. Ich denke ich habe das Recht selbst auszusuchen als "poster" in welchem Teil des Forums mein Eintrag am besten hineinpasst.


tip & tricks sind spielinhalte, AA und co ist technik/software und damit hardware eindeutig. zumal es ja schon paar andere threads zum thema da gibt. aber trotzdem ganz hilfreich wer auf AA steht smile



Ich ändere aber nichts an der Hardware. Ich tune nichts. Oder stelle keine Hardware um. Sondern ich ich gebe Tipps wie ich Anti Aliasing zum Laufen bringe. Und von daher lastet mein Tipp eher in Richtung software. Und meine Hardware ist auch nur Nebensache.


das technik forum ist ja kein reine hardware forum, da gehört auch die software dazu. technik am pc ist immer hard- und software. so wie es in jeden anderen spieleforum auch geregelt ist. tips und tricks sind spielinhalten einfach nur. und nun mal ganz gemein klugscheißen *g*: AA wird durch hardware erzeugt wink

tips und tricks ist für spielinhalte. deine posting ist zwar auch ein tip, aber es ist ein techniktip, kein spieltip, also leider falsches forum wink
Originally Posted by ebenholzjunge
Originally Posted by SixGen
Originally Posted by ebenholzjunge
Originally Posted by SixGen
[quote=Spezies Q]Bitte in das Technikforum verschieben.

Warum "Technik-Forum?"

Mein Thema ist eindeutig ein Tipp bzw. Trick und hat mit Hardware im diesen Sinne primär erst einmal nichts zu tun. Ich denke ich habe das Recht selbst auszusuchen als "poster" in welchem Teil des Forums mein Eintrag am besten hineinpasst.


tip & tricks sind spielinhalte, AA und co ist technik/software und damit hardware eindeutig. zumal es ja schon paar andere threads zum thema da gibt. aber trotzdem ganz hilfreich wer auf AA steht smile



Ich ändere aber nichts an der Hardware. Ich tune nichts. Oder stelle keine Hardware um. Sondern ich ich gebe Tipps wie ich Anti Aliasing zum Laufen bringe. Und von daher lastet mein Tipp eher in Richtung software. Und meine Hardware ist auch nur Nebensache.


das technik forum ist ja kein reine hardware forum, da gehört auch die software dazu. technik am pc ist immer hard- und software. so wie es in jeden anderen spieleforum auch geregelt ist. tips und tricks sind spielinhalten einfach nur. und nun mal ganz gemein klugscheißen *g*: AA wird durch hardware erzeugt wink

tips und tricks ist für spielinhalte. deine posting ist zwar auch ein tip, aber es ist ein techniktip, kein spieltip, also leider falsches forum wink [/quote]

Okay. Gut. Also, wer mag denn nun meinen Thread ins Technikforum verschieben?... Ich weiß garnicht ob ich das überhaupt tun kann. Ist denn hier kein Admin der sich darum kümmert?

Ich habe gesehen, dass mein Thread ja immernoch nicht verschoben wurde. Allem Anschein nach habe ich doch damit Recht, dass mein Thread wohl eher in die Tipps und Tricks-Ecke reinpasst.

wink Tja. Ich denke, dass ich hier ganz richtig aufgehoben bin. Mit Technik hat mein Thread REIN GARNICHTS zu tun. Habs grad noch mal so überdacht.

Edit: Super geschriebene Anleitung - scheint zu funktionieren...danke! laugh
Danke für Dein Lob. ...dann denke ich, dass es dann auch noch bei anderen Usern hinhauen sollte. Wenn es Probleme gibt, dann nur zu.... irgendwie gibt es IMMER Probleme... horsey biggrin

smile
Jo echt gute Anleitung und hat wunderbar ohne Probleme funktioniert bei folgender Systemzusammenstellung:
Intel Q9550, ATI HD 4870, Win Vista x64.

Merkt man auch daran das die Framerate gleich mal auf unter 30 FPS ging bei 8x AA trotz ziemlich guten System^^

Nur eins vielleicht. Kann man in dem ATI Tray Tools die Anzeige der FPS oben rechts in der Ecke deaktivieren? Hab da spontan beim Durchschauen der Einstellungen nix gefunden.
Originally Posted by CmdrSAMU
Jo echt gute Anleitung und hat wunderbar ohne Probleme funktioniert bei folgender Systemzusammenstellung:
Intel Q9550, ATI HD 4870, Win Vista x64.

Merkt man auch daran das die Framerate gleich mal auf unter 30 FPS ging bei 8x AA trotz ziemlich guten System^^

Nur eins vielleicht. Kann man in dem ATI Tray Tools die Anzeige der FPS oben rechts in der Ecke deaktivieren? Hab da spontan beim Durchschauen der Einstellungen nix gefunden.


Hi! smile

Befolge meinen Tipp Nr. 3 ganz unten in meiner Anleitung. Das bringt enorm viel Performance. Bei mir zumindest. Und ich habe sogar nur eine 4850er Graka. *grins*

Ich habe gar keine FPS-Anzeigen oben Rechts wenn ich spiele. Weißt Du was mir grad auffällt? Beende mal ATI Tray Tools unten rechts. Und starte dann das Spiel. A) Ich merke grad, es wird dann nicht mehr benötigt und B) Dann dürfte auch keine FPS-Anzeige mehr angezeigt werden.....

smile

PS: Find ich gut. Nun schon der Zweite bei dem es klappt mit Anti-aliasing.
Tach zusammen!

Ich habe mich hier aufgrund dieses Threads registriert, um ein, in meinen Augen wichtiges Detail, richtig zu stellen. Und zwar geht's dabei um's "Edge-detect"-Anti-Aliasing, von welchem ich den meisten Usern unbedingt abraten möchte, sofern sie nicht über aktuelle High-End-Grafikkarten verfügen.

Dieser "Edge-detect"-Modus greift nämlich NUR dann, wenn man Anti-Aliasing in den Spieloptionen (egal in welchem Spiel) entweder auf 4x oder 8x gestellt hat. Spezielle ATi-Logarithmen sorgen dafür, dass dieses "Edge-detected"-AA das normale AA noch einmal um den dreifachen Faktor aufwertet. Sprich: 4xAA wird via "Edge-detect" auf 12xAA aufgewertet, bei 8x sind es sogar 24xAA. Bei eingestelltem 2xAA in den Spieloptionen passiert überhaupt nichts, sprich, das Spiel läuft hier weiterhin ohne jegliches AA. Ich wiederhole mich an dieser Stelle: "Edge-dectect" greift wie gesagt AUSSCHLIESSLICH nur dann, wenn man in den Optionen eines Spiels 4xAA oder 8xAA auswählt und wertet dies entsprechend auf.

"Edge-detect" bringt den Vorteil mit sich, dass es deutlich besser performt, als würde man theoretisch den (in dieser Höhe nicht vorhandenen) normalen AA-Modus auf 12x oder gar 24x stellen. Trotzdem, und das ist das eigentlich Wichtige in diesem Fall, wird hier mehr Performance gezogen als im normalen "Box"-AA-Modus auf 4x oder 8x.

Ich möchte daher unbedingt empfehlen, statt "Edge-detect" auf "Box" umzustellen, um die normalen Anti-Aliasing-Modi nutzen zu können. Eure Performance wird es Euch danken und sollte sich spürbar erhöhen UND schickes Anti-Aliasing bieten.

Also, SixGen, an Deiner Stelle würde ich Deinen (wirklich toll gelungenen!) Guide noch einmal anpassen, was dieses Detail angeht. Edge-detect ist ein unnötiger Performance-Fresser, den ich wie gesagt nur bei aktuellen High-End-Karten empfehlen würde. 12x oder gar 24xAA brauchen schließlich nur Hardcore-User, und dazu zählen die normalen Divinity-Spieler höchstwahrscheinlich nicht smile

Sollten zu dieser Thematik noch Links erwünscht sein, die mein Geschreibsel hier stützen, so poste ich die gerne zum nächstmöglichen Zeitpunkt.

Beste Grüße vorerst,

Tom
Originally Posted by Slochy
Tach zusammen!

Ich habe mich hier aufgrund dieses Threads registriert, um ein, in meinen Augen wichtiges Detail, richtig zu stellen. Und zwar geht's dabei um's "Edge-detect"-Anti-Aliasing, von welchem ich den meisten Usern unbedingt abraten möchte, sofern sie nicht über aktuelle High-End-Grafikkarten verfügen.

Dieser "Edge-detect"-Modus greift nämlich NUR dann, wenn man Anti-Aliasing in den Spieloptionen (egal in welchem Spiel) entweder auf 4x oder 8x gestellt hat. Spezielle ATi-Logarithmen sorgen dafür, dass dieses "Edge-detected"-AA das normale AA noch einmal um den dreifachen Faktor aufwertet. Sprich: 4xAA wird via "Edge-detect" auf 12xAA aufgewertet, bei 8x sind es sogar 24xAA. Bei eingestelltem 2xAA in den Spieloptionen passiert überhaupt nichts, sprich, das Spiel läuft hier weiterhin ohne jegliches AA. Ich wiederhole mich an dieser Stelle: "Edge-dectect" greift wie gesagt AUSSCHLIESSLICH nur dann, wenn man in den Optionen eines Spiels 4xAA oder 8xAA auswählt und wertet dies entsprechend auf.

"Edge-detect" bringt den Vorteil mit sich, dass es deutlich besser performt, als würde man theoretisch den (in dieser Höhe nicht vorhandenen) normalen AA-Modus auf 12x oder gar 24x stellen. Trotzdem, und das ist das eigentlich Wichtige in diesem Fall, wird hier mehr Performance gezogen als im normalen "Box"-AA-Modus auf 4x oder 8x.

Ich möchte daher unbedingt empfehlen, statt "Edge-detect" auf "Box" umzustellen, um die normalen Anti-Aliasing-Modi nutzen zu können. Eure Performance wird es Euch danken und sollte sich spürbar erhöhen UND schickes Anti-Aliasing bieten.

Also, SixGen, an Deiner Stelle würde ich Deinen (wirklich toll gelungenen!) Guide noch einmal anpassen, was dieses Detail angeht. Edge-detect ist ein unnötiger Performance-Fresser, den ich wie gesagt nur bei aktuellen High-End-Karten empfehlen würde. 12x oder gar 24xAA brauchen schließlich nur Hardcore-User, und dazu zählen die normalen Divinity-Spieler höchstwahrscheinlich nicht smile

Sollten zu dieser Thematik noch Links erwünscht sein, die mein Geschreibsel hier stützen, so poste ich die gerne zum nächstmöglichen Zeitpunkt.

Beste Grüße vorerst,

Tom


Hi Tom!

Da hast Du Recht. Ich habe das noch einmal getestet und sehe (ich habe genaue Augen) zwischen "4 x Box Anti-aliasing" (man möge mir meine eigene "Bezeichnung" jetzt verzeihen) und Edge-detect-anti-aliasing kaum Optische Unterschiede. Ich werde meinen Thread entsprechend anpassen und als "Tipp Nr. 4" aktualisieren.

Finde ich aber echt schön, dass hier seit der Eröffnung bisher nur Positives gekommen ist als Feedback.

Lieben Gruß
Mathias (SixGen) smile

Nachtrag: Ja stimmt. BOX hat bei mir 5 bis 10 FPS mehr gebracht. Danke. hehe
Originally Posted by CmdrSAMU

Nur eins vielleicht. Kann man in dem ATI Tray Tools die Anzeige der FPS oben rechts in der Ecke deaktivieren? Hab da spontan beim Durchschauen der Einstellungen nix gefunden.


"Werkzeuge & Einstellungen" - "BildInBild Anzeige" - Haken bei BildInBild Anzeige entfernen.

Bei laufendem Game gegebenenfalls Spiel neu starten.



@ SixGen

Zunächst einmal vielen Dank für die mühevolle Arbeit deiner Anleitung. Ich habe meinen kurzen Ausflug ins NVIDIA-Lager beendet und wieder meine ATI-Radeon HD4870 eingebaut.

Ich verwende Windows 7 RC 64bit und die ATI Tray Tools v. 1.6.9.1386 Beta (das ist die derzeit aktuellste Version).
Graka-Treiber: ATI Catalyst 9.7 .

Das Wichtigste zuerst: Es funktioniert und sieht toll aus! Vielen Dank für deinen Tipp!

Mich wundert aber, dass du nichts von Problemen beschrieben hast, die sich bei Verwendung der ATI Tray Tools mit den 64bit-Versionen von Windows Vista bzw. Windows 7 ergeben:

Beide 64bit-Versionen verlangen hier eine digitale Treibersignatur, die die ATI Tray Tools aber aus Kostengründen nicht haben. Und somit lassen sich weder die ATI Tray Tools noch die "Low Level Driver" starten. Hier muss zuerst beim Booten (über Taste F8) der Signaturzwang deaktiviert werden. Ich habe dies mittels des Tools "Ready Driver Plus" (v. 1.1) automatisiert, um nicht bei jedem Booten erst umständlich über die Taste F8 die entsprechende Menüzeile auswählen zu müssen.

Ich frage mich also, wie du die ATI Tray Tools - offenbar ohne Deaktivierung des Signaturzwangs - hast zum Laufen bringen können (denn am Anfang deiner Anleitung gibst du ja an, Vista 64bit zu verwenden). Ich habe es Anfangs auch so versucht, aber es ging nicht; es gab entsprechende Hinweis- und Fehlermeldungen. Die Deaktivierung der Benutzerkontensteuerung bringt diesbezüglich gar nichts.

Nun denn, bei mir funktioniert es jetzt. Vielen Dank nochmals.

Noch ein Wort zu den verschiedenen AA-Modis: Es stimmt schon, dass alle anderen Modis als "Box" die Frames nach unten drücken. Ich selbst nutze "Wide-tent", weil ich finde, dass z.B. die Haus-Fassaden dadurch "weicher" aussehen - Geschmackssache. Die Frames sind bei mir dann noch immer ausreichend, wenn auch um 10-15 FPS reduziert.

Gruß Michael
also bei mir hats trotz vista64 auch auf Anhieb geklappt...hab eben tray tools als admin gestartet (kannst auch benutzerkontensteuerung ganz abschalten, so wie der TE)
Hatte ich ja auch beides versucht, aber bei mir (Windows 7 RC 64bit) ging das alles nicht.

In der aktuellen pcgames-hardware (08/2009) wird eben diese Geschichte mit dem Signaturzwang der ATI Tray Tools unter Vista 64bit - und wie man diesen umgeht - beschrieben. Weiß also nicht, wie ihr das ohne Eingriffe geschafft habt. Denn der Artikel sagt ja gerade, dass die ATI Tray Tools unter Vista 64bit nicht so ohne Weiters funktionieren - was ich dann ja auch selbst feststellen musste (wenn auch unter Windows 7 64bit).

Michael
Originally Posted by Perrin
@ SixGen

Zunächst einmal vielen Dank für die mühevolle Arbeit deiner Anleitung. Ich habe meinen kurzen Ausflug ins NVIDIA-Lager beendet und wieder meine ATI-Radeon HD4870 eingebaut.

Ich verwende Windows 7 RC 64bit und die ATI Try Tools v. 1.6.9.1386 Beta (das ist die derzeit aktuellste Version).

Das Wichtigste zuerst: Es funktioniert und sieht toll aus! Vielen Dank für deinen Tipp!

Mich wundert aber, dass du nichts von Problemen beschrieben hast, die sich bei Verwendung der ATI Tray Tools mit den 64bit-Versionen von Windows Vista bzw. Windows 7 ergeben:

Beide 64bit-Versionen verlangen hier eine digitale Treibersignatur, die die ATI Tray Tools aber aus Kostengründen nicht haben. Und somit lassen sich weder die ATI Tray Tools noch die "Low Level Driver" starten. Hier muss zuerst beim Booten (über Taste F8) der Signaturzwang deaktiviert werden. Ich habe dies mittels des Tools "Ready Driver Plus" (v. 1.1) automatisiert, um nicht bei jedem Booten erst umständlich über die Taste F8 die entsprechende Menüzeile auswählen zu müssen.

Ich frage mich also, wie du die ATI Tray Tools - offenbar ohne Deaktivierung des Signaturzwangs - hast zum Laufen bringen können (denn am Anfang deiner Anleitung gibst du ja an, Vista 64bit zu verwenden). Ich habe es Anfangs auch so versucht, aber es ging nicht; es gab entsprechende Hinweis- und Fehlermeldungen. Die Deaktivierung der Benutzerkontensteuerung bringt diesbezüglich gar nichts.

Nun denn, bei mir funktioniert es jetzt. Vielen Dank nochmals.

Noch ein Wort zu den verschiedenen AA-Modis: Es stimmt schon, dass alle anderen Modis als "Box" die Frames nach unten drücken. Ich selbst nutze "Wide-tent", weil ich finde, dass z.B. die Haus-Fassaden dadurch "weicher" aussehen - Geschmackssache. Die Frames sind bei mir dann noch immer ausreichend, wenn auch um 10-15 FPS reduziert.

Gruß Michael


Hi! Na DAS ist ja mal ein Lob. Danke, freue mich...

Ich kann mich daran erinnern, dass ich unter START -> AUSFÜHREN in der DOS-Box (cmd eingeben und Return drücken): Bcdedit.exe /set nointegritychecks ON eingegeben habe. Ich weiß allerdings nicht ob es darn lag bei mir. Ich füge noch einmal extra hinzu, dass mein ATI TRAY TOOLS schon VORHER funktionierte, trotz "Mahnung", die Software sei nicht digital signiert.

Kann auch daran liegen, dass ich Services deaktiviert habe. Ich habe ferner keine Firewall und auch keine Benutzerkontensteuerung aktiv. Ich mag es nicht mir von MS vorschreiben zu lassen was ich tun oder lassen soll. Diese beiden Dinge gehören nun mal einfach dazu. MS Defender, Remote-Registrierung und etliche andere Dinge sind ebenfalls "tot" in meinem Vista.. wink

Wie man die digitale Treibersignatur-Überprüfung deaktiviert habe ich nun in meiner Anleitung als allererstes angegeben.

Vielen Dank noch einmal für diese guten Beiträge. Ich fahre für ca. 2 Wochen weg. Ich werde ab morgen nicht online kommen könnnen.... Aber jetzt habe ich ja glaub ich alles erwähnt was notwendig ist für das Aktivieren von Anti-aliasing..... : -)

Lieben Gruß
SixGen

Nachtrag: "Wide-tend" sollte ich auch mal ausprobieren. Weiche Hausfassaden etc finde ich toll! smile

Hier meine abgeschalteten Services (ich weiß nicht ob es für manche eine Hilfe sein könnte)...

http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/services1.jpg
http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/services2.jpg
http://www.sixgen.com/temp/DivineDivinity2/Tip1_AntiAliasing/services3.jpg
Die Methode des Deaktivierens der Überprüfung von digitalen Signaturen mittels cmd-Befehl (Bcdedit.exe /set nointegritychecks ON) funktioniert bei mir nicht. Ich habe diesen Befehl als Administrator ausgeführt und die Ausführung wurde im Fenster auch bestätigt.

Doch nach einem Neustart kamen wieder jene Fehlermeldungen, die ich weiter oben beschrieben hatte und die ATI Tray Tools wurden nicht gestartet.

Dass diese Methode nicht bei jedem funktioniert, kann man auch im Internet finden, wenn mann da ein wenig googelt. Jedenfalls funktioniert diese Methode bei Windows 7 RC 64bit nicht. Und pcgames-hardware hätte jene Methode dann bestimmt auch beschrieben. Haben sie aber nicht sondern eben folgende:

Ich muss also weiterhin bei der Methode übers Booten (automatisiert unter Zuhilfenahme des Tools "Ready Driver Plus - ebenfalls weiter oben beschrieben) bleiben.

Michael
Originally Posted by Perrin
Die Methode des Deaktivierens der Überprüfung von digitalen Signaturen mittels cmd-Befehl (Bcdedit.exe /set nointegritychecks ON) funktioniert bei mir nicht. Ich habe diesen Befehl als Administrator ausgeführt und die Ausführung wurde im Fenster auch bestätigt.

Doch nach einem Neustart kamen wieder jene Fehlermeldungen, die ich weiter oben beschrieben hatte und die ATI Tray Tools wurden nicht gestartet.

Dass diese Methode nicht bei jedem funktioniert, kann man auch im Internet finden, wenn mann da ein wenig googelt. Jedenfalls funktioniert diese Methode bei Windows 7 RC 64bit nicht. Und pcgames-hardware hätte jene Methode dann bestimmt auch beschrieben. Haben sie aber nicht sondern eben folgende:

Ich muss also weiterhin bei der Methode übers Booten (automatisiert unter Zuhilfenahme des Tools "Ready Driver Plus - ebenfalls weiter oben beschrieben) bleiben.

Michael


Hi,

ich habe meine Anleitung entsprechend aktualisiert. Nun dürfte es jeder User hinbekommen, der sich ganz gut mit seinem Computer auskennt.

Lieben Gruß
Mathias (SixGen)
Hallo,

ja genau, jetzt ist für jeden was dabei. thankyou

Gruß Michael
*grins* .... Diese Smileys aus diesem Forum sind einfach nur GENIAL groovy
Mich wundert, dass ihr den ATT Loader gar nicht erwähnt, der hat schließlich im "offiziellen" Tray-Tools-Forum auf Guru3D einen eigenen Sticky, in dem simpel gezeigt wird, wie man diese Geschichte löst:

http://forums.guru3d.com/showthread.php?t=275261

Es reicht sogar schon, eine Verknüpfung zur ATTLoader.exe in das Autostart-Menü zu stecken. Den unnötigen Ready-Driver-Plus-Quatsch kann man sich dadurch komplett schenken smile
@ Slochy

Die ATT Loader-Geschichte mag mit Vista 64bit funktionieren, mit Windows 7 RC 64bit funktioniert es nicht (auch in den Foren nachzulesen; sogar in dem, auf den zu verlinkt hast: Seite 2 ab #42 - und ich habe es selbst unter Windows 7 RC 64bit erfolglos probiert; sogar mit beiden Methoden: ATTLoader.exe nur in den Autostart und dann erweitert mit dem Aufgabenplaner. So simpel ist es nun leider nicht.

Außerdem finde ich - bezüglich Windows 7 - die Methode über ReadyDriverPlus weder unnötig noch ist sie "Quatsch".

Es gibt noch eine weitere Methode, die auch unter Windows 7 RC 64bit funktioniert:

Ati Tray Tools with Win7 RC 64bit

dseo 1.3b

Mittels dieser exe kann man Windows 7 in den sogenannten Testmodus versetzen und die beiden unsignierten Treiber der ATT mit einer Testsignatur versehen. Auch so lassen sich die ATT starten, aber mit dem Unterschied, dass der Signaturzwang und somit der ursprünglich von Microsoft damit beabsichtigte Schutz vor schädigenden Treibern erhalten bleibt.
Gruß Michael rpg005
Originally Posted by Perrin
@ Slochy

Die ATT Loader-Geschichte mag mit Vista 64bit funktionieren, mit Windows 7 RC 64bit funktioniert es nicht (auch in den Foren nachzulesen; sogar in dem, auf den zu verlinkt hast: Seite 2 ab #42 - und ich habe es selbst unter Windows 7 RC 64bit erfolglos probiert; sogar mit beiden Methoden: ATTLoader.exe nur in den Autostart und dann erweitert mit dem Aufgabenplaner. So simpel ist es nun leider nicht.

Außerdem finde ich - bezüglich Windows 7 - die Methode über ReadyDriverPlus weder unnötig noch ist sie "Quatsch".

Es gibt noch eine weitere Methode, die auch unter Windows 7 RC 64bit funktioniert:

Ati Tray Tools with Win7 RC 64bit

dseo 1.3b

Mittels dieser exe kann man Windows 7 in den sogenannten Testmodus versetzen und die beiden unsignierten Treiber der ATT mit einer Testsignatur versehen. Auch so lassen sich die ATT starten, aber mit dem Unterschied, dass der Signaturzwang und somit der ursprünglich von Microsoft damit beabsichtigte Schutz vor schädigenden Treibern erhalten bleibt.
Gruß Michael rpg005


Komische Sache, die ich, was meine Person angeht, nicht bestätigen kann. Bei mir läuft die ATT Loader Geschichte auch unter W7 64-bit (RTM) vollkommen problemlos. Daher auch meine schnippische "Quatsch"-Bemerkung, da ich nicht wusste, dass es offenbar User zu geben scheint, bei denen es, aus welchen Gründen auch immer, nicht funktioniert.

Tom
Nun, bei der "RTM"-Version handelt es sich ja um eine neuere Version als der RC (RC=Build 7100; RTM=Build 7600), die aber für den "Otto-Normalverbraucher" nicht so ohne Weiteres offiziell zu bekommen ist. Lediglich Software- und Hardwarehersteller sowie TechNet- und MSDN-Abonnenten können die finale Version herunterladen (und das eigentlich erst ab 06.08.2009); ich also nicht. confused

In dieser RTM-Version wird demnach das ein oder andere geändert worden sein, so dass es schon sein kann, dass die ATT-Loader-Geschichte da funktioniert. Im RC deffinitiv nicht.

Gruß Michael
Ich habe die CCC Einstellungen wie beschrieben eingestellt, aber ATI Tray Tools benutze ich nicht. Es funktioniert trotzdem. smile
Originally Posted by Perrin
Nun, bei der "RTM"-Version handelt es sich ja um eine neuere Version als der RC (RC=Build 7100; RTM=Build 7600), die aber für den "Otto-Normalverbraucher" nicht so ohne Weiteres offiziell zu bekommen ist. Lediglich Software- und Hardwarehersteller sowie TechNet- und MSDN-Abonnenten können die finale Version herunterladen (und das eigentlich erst ab 06.08.2009); ich also nicht. confused

In dieser RTM-Version wird demnach das ein oder andere geändert worden sein, so dass es schon sein kann, dass die ATT-Loader-Geschichte da funktioniert. Im RC deffinitiv nicht.

Gruß Michael


Moin Michael,

Naja, man muss kein Meisterdetektiv sein, um an die jeweils aktuellsten Version heranzukommen wink

Anyway, und auch hier decken sich meine Erfahrungen leider nicht mit Deinen: Auch mit dem Release Candidate hatte ich keinerlei Schwierigkeiten, was diese Problematik betrifft. Vielleicht liegt's an der UAC? Die habe ich nämlich auf das absolute Minimum gestellt. Ansonsten wüsste ich nicht, was hier im Argen liegen könnte und dafür sorgt, dass es bei dem einen läuft, bei dem anderen hingegen nicht.

Aber ist ja auch eigentlich unwichtig, die Hauptsache ist ja, dass es überhaupt funktioniert wink

In diesem Sinne, beste Grüße!

Tom
Ja, da hast du wohl recht. Die UAC habe auch ich deaktiviert. Weiß dann auch nicht, woran es liegt, dass es bei einem geht, beim anderen nicht. Es gibt schon wieder eine neue Version der ATT (1391). Aber auch mit der funktoniert der einfache Weg nicht.

Und nur mit dem CCC (also ohne ATT) gehts bei mir ebenfalls nicht.

Was soll's. Auch ich habe einen Weg gefunden, und es geht. Schließlich will ich auch spielen und nicht nur herumprobieren.

Grüße Michael
Vielen Dank für die Anleitung. Hätte nicht gedacht das es so schwer sein kann AA in einem Spiel zu aktivieren. Schande auf euch, Entwickler!
wo sind die Bilder?
Originally Posted by BugMeNot
wo sind die Bilder?


Ja, ohne die ist es schwer der Anleitung zu folgen.
Hat sonst noch jemand einen Tipp wie ich endlich AA zum Laufen bekommen?
Ich habe es bist jetzt nur mit dem Umbenennen der .exe in UT3 geschafft - leider entstehen dabei aber Grafikfehler. Ich wäre wirklich für jeden weiteren Vorschlag dankbar.

Gruß
Lucky
© Larian Studios forums