Larian Studios
Posted By: caninelegion Hung up on Loading Page (GOG Version) - 15/06/17 03:43 AM
Well, maybe I won't be finishing this playthrough and having one more try later - on loading, it hangs up on the load screen (where it says "Divine Divinity" and has the road from the initial video). It started after I got a message saying it couldn't be rendered in a window, do you want to try full screen (I said no). Each try to load thereafter results in the hung load page. I guess I could try reinstalling (I think it'll retain my current game just after clearing the wastelands).

Any ideas on a fix before I try that?

Running the same as always - as administrator and in WinXP compatibility on a dual core Win7 PC.

EDIT: Should this have been posted in the "technical" section?
Posted By: Raze Re: Hung up on Loading Page (GOG Version) - 15/06/17 04:16 AM

The game doesn't support a windowed mode, though some people have been able to get it running in a window using third party programs.

Try running the configuration program, hit the reset button, then set the resolution again. If that doesn't get the game to load properly after you click Apply $ Close, try switching to Software mode rather than Direct3D.

Try the Windows 8 Performance "Patch" (works in Win 7 and 10, as well); that can help with some startup crashes.

You can manually zip or copy saves from the '..\Divine Divinity\Savegames' install folder. If you have a lot of saves, 7-Zip can get significantly better compression with the .7z format than zip.
I tried plan A prior to the post several times. Just tried Plan B (software mode) with the same result. I'll try the patch but nothing has changed on my end that I am aware of. Games been running fine and I did nothing like using third party software. Not sure why suddenly my the game thinks that I am. I'll go ahead and save those files in a new location. I'm assuming I'll be reloading the game from GOG Galaxy soon.

EDIT: I guess the patch loaded. I hit install and got a text box that said hit any key to continue which I did. Anyway, nothing after that so I tried launching the game again and got the same result.

OK, the reinstall was a success. One interesting note, just prior to the install completing, I got an error message saying that Windows redistributable needed to be uninstalled or repaired. That may have been the issue.

However ---- I have a new issue. When I tried to load the savegame, I got a message saying it was old and not compatible with this version of the game. can I finish my old game or am I hosed?
Posted By: Tarnum Re: Hung up on Loading Page (GOG Version) - 16/06/17 08:30 AM
That's the reason why I am still using CD version of the game with patch 1.33 (protected by Safedisc 2.90.040, CD3 is needed to run the game) in Glide mode with Glide emulator (nGlide 1.05).

P.S. By the way, Direct3D doesn't work on my system and Software mode is very slow. So Glide is the only option for me. wink
Posted By: Raze Re: Hung up on Loading Page (GOG Version) - 16/06/17 10:33 AM
Originally Posted by caninelegion
I got a message saying it was old and not compatible with this version of the game. can I finish my old game or am I hosed?

What is the version number in the bottom right corner of the main menu? It should be 1.0062A, the same as the first time you installed the game, if that was remotely recently.

If you select the saves in the load window, what is the 'Savegame version' listed on the right? For the disk or download version, it should be V0.935 25-02-2002.

There is a known issue with games started in the updated disk version, loaded in the download version (specifically with the inventory files), which will either cause a crash, or disable saving).

Zip your latest save folder and email it to me (raze@larian.com), and I'll take a look at it.
Bottom right number matches, ie V1.0062A. So does the download version. The game is download version - I don't have a disc/box version. I'll go ahead and send the e-mail.
Posted By: Raze Re: Hung up on Loading Page (GOG Version) - 17/06/17 03:43 AM

Many of the files in the the latest save are corrupt. That is why the zip is half the size of the other 2 saves, even though it contains extra files, added for the Black Ring dungeon. If you open the zip file in Windows Explorer, one of the columns in details view lists the compression ratio; getting 70-90% for large files in the save is normal, but 100% is not.
In particular, the data.000 file (which contains the character and all NPC data, as well as some quest information, etc) is entirely zeros, so the game can not read the save version, which triggers the warning about it being an old version.

The previous save is immediately before that point, though, so you can just continue from there.
I really thought I replied to this last evening but, nothing here.

I just wanted to say thanks and apologize for my apparent problem with assumptions (this wasn't the first time). I guess because of the particular error message I assumed the other two wouldn't work without even trying them. I think that I likely had a power bump that fried the file and the windows redistribtable since it happens so often here (I have solar power so the batteries often go too low and shut down the power until the generator charges them high enough). I'm glad I don't have to restart as that one was already a restart (even though I built my melee warrior differently).
Posted By: Raze Re: Hung up on Loading Page (GOG Version) - 18/06/17 07:05 AM

The first computer I got I lived in an old neighbourhood that that had occasional, brief brownouts (enough for lights to flicker, and computers to shut off or reboot). After that got annoying I bought a UPS... and didn't get another brownout for probably the better part of a year.
Posted By: vometia Re: Hung up on Loading Page (GOG Version) - 18/06/17 01:27 PM
The obvious conclusion is that your UPS protected the whole neighbourhood from brownouts. Awesome!
© Larian Studios forums