Larian Studios
Posted By: joliekiller bug?? - 08/03/12 08:07 PM
i have a prob with my blaksmith. When i want to enchant it says "you dont have any weapons or armor in inventory. But i have plenty of stuff including the ones i'm wearing.

Bug or not?
i havent saved my game yet (becaus i forgot and died smile ).
Posted By: Raze Re: bug?? - 08/03/12 08:52 PM

Which enchanter do you mean? If Dreaven in Broken Valley, did you give him some red ore to get the enchantment machine going? If you meant the battle tower enchanter, try using the machine yourself rather than talking to him.

If you are relatively early in the game, do you have equipment with enchantment slots? IIRC they should start showing up on random equipment before you get to Dreaven, or you could buy something from Derk in the Broken Valley village to bring to him (the Ranger's Rest bow has one enchantment slot filled with Increased Magical Damage level 4, which you should have the option to remove at the enchanter).
Posted By: joliekiller Re: bug?? - 09/03/12 05:33 AM
I'm talking about the battle tower and it doesnt matter wether i talk to him or use the machines myself same result.
Posted By: ChrisHLD Re: bug?? - 09/03/12 05:44 AM
That never happened to me.

Once my dragon wouldn't target enemies so I went to a previous save file and retracked my steps. That worked.
Posted By: Raze Re: bug?? - 09/03/12 05:55 AM

Did you load an earlier save (if available), at least to help determine if the problem is with the current save or the game itself?

You could send all your equipment to the battle tower, then teleport there, retrieve some of it from the chest, and try the enchantment machine again. Save first; if that doesn't get the game to recognize the equipment in your inventory, it would probably be easier to reload than retrieve everything from the chest.

Try emailing, with a description of the problem and maybe a link to this topic. See the DKS support page.

In XP the saves are in the folder

C:\Documents and Settings\ %username% \Local Settings\Application Data\Divinity 2\Savegames

or in Vista / Win 7

C:\Users\ %username% \AppData\Local\Divinity 2\Savegames

You may need to set Windows Explorer to show hidden files and folders (XP, Vista, Win 7).
Posted By: Kein Re: bug?? - 09/03/12 09:24 AM
Do you have weapons with enchantment slots?
Posted By: joliekiller Re: bug?? - 10/03/12 06:55 AM
i've found the problem. you need to have at least 1 item in inventory that can be enchanted. Only then you can use it. the rest of the equip also shows grayed out. I've send the item that could be enchanted back and then i got that message again. So i say: prob solved :))
Posted By: Kein Re: bug?? - 11/03/12 08:29 AM
Haha, my thoughts exactly.
Glad you figured it out.
© Larian Studios forums