Larian Studios
Posted By: EddyCosta32 Troll's Bounty quest not starting! - 15/07/14 04:50 AM
I can't find this in any forum, so i apologize if there's a post about that already. Anyway, i read that Brandon gives a quest in Silverglen asking you to get some tenebrium from the troll king's cave. The problem is that he doesn't give me that quest! Is there anything i must do first to start the quest or is this another bug?
Posted By: EddyCosta32 Re: Troll's Bounty quest not starting! - 17/07/14 04:05 AM
Well, i've discovered why... I've refused to help Brandon in his "shady" quest and i've lost the opportunity to do the quest forever, and apparently i won't be able to finish "the naked truth" quest either. I mean, this is pretty unfair, because i won't be able to use the most powerful weapons in the game AND the only weapons that can hurt void demons! Only one of my characters will be able to use it, and this will unbalance my party because that char will be much more powerful than the rest. Is there really any other way to: 1 - finish the "naked truth" quest without doing "troll's bounty"? 2 - get the tenebrium skill for the rest of my characters without doing said quest? Because if the anwser is no this is something larian should look into, because it's VERY unfair that just because i refused to help someone to do his shady dealings my game will be completely compromised...
Posted By: Issh Re: Troll's Bounty quest not starting! - 17/07/14 08:55 AM
I'll forward this to design, thanks. About Tenebrium ability, there should be skillbooks in the game that give you this ability regardless of having done the quest.

(spoiler: there should be a book in Attenberrah's shop - in the Immaculate Village)
Posted By: EddyCosta32 Re: Troll's Bounty quest not starting! - 17/07/14 05:25 PM
Thanks for the reply! I've already found that book and gave the ability to one of my characters, but from what i read there's only one of those books, that it is on Attenberrah's shop. Is there any other tenebrium skillbooks forward in the game?
Posted By: EddyCosta32 Re: Troll's Bounty quest not starting! - 18/07/14 12:05 AM
Posted By: Farden Re: Troll's Bounty quest not starting! - 23/07/14 08:41 PM
I've also had the same exact issue, I turned down that quest so am unable to get the Tenebrium skill. Additionally I got in a, err... small fight with the fine people of Sacred Stone and the skill book isn't on top of the shelf that i've seen in other peoples screenshots.

Don't get me wrong, this is a fantastic game but this has basically broken it for me =(

Pleeeeease tell me theres a fix in the works and coming soon =/
Posted By: Farden Re: Troll's Bounty quest not starting! - 24/07/14 11:07 AM
bump =(
Posted By: Armillary Re: Troll's Bounty quest not starting! - 26/07/14 03:24 AM
I've got a workaround that is a serious hack. Only for advanced users. It involves hex editing "Globals.lsb", which could very well destroy your save and possibly render any progress impossible. I just successfully changed my save so that I could talk to Brandon again, get the quest, complete it, and then get the Tenebrium skills as expected. Who knows if my save will be bugged in some way I can't foresee quite yet.

If you're interested in trying it out, I'd suggest getting an open source hex editor like "Frhed". Navigate to your save folder (eg. <My Documents>\Larian Studios\Divinity Original Sin\PlayerProfiles\<PROFILE>\Savegames\QuickSave_4\) and load up Globals.lsb in your hex editor. PLEASE BACK UP YOUR SAVE BEFORE YOU MAKE CHANGES.

In the editor you will probably see a bunch of hexadecimal code on the left, and some text on the right which is a text representation of that code. You'll notice some keywords that look familiar. Do a "Find" for "LUC_Brandon_Bothered". This will get you to the section of the save that records quest and dialogue progress. We can modify it so that the progress is corrupted and reset to default.

After you search for "LUC_Brandon_Bothered" in "Globals.lsb" of your save, you can begin editing the code on the left. Look for the following patterns:

"4c 55 43 5f 42 72 61 6e 64 6f 6e 5f 42 6f 74 68 65 72 65 64 00 0c 00 00 00 04 00 00 00 XX 1d 00 00 0a" where "XX" may be something random (it was 5d in my save)
"4c 55 43 5f 42 72 61 6e 64 6f 6e 5f 50 6c 61 6e 00 0c 00 00 00 04 00 00 00 XX 1d 00 00 0a" where "XX" may be something random (it was 46 in mine)

Whatever you have where the "XX" is in those lines, change it to "00". This should clear the quest progress and let you talk to Brandon as if he were a fresh NPC again. Don't change the other "LUC_Brandon" entries, or you may automatically complete the quest with unpredictable results. The first part of those two lines are the labels "LUC_Brandon_Bothered" and "LUC_Brandon_Plan", and the second half contains code for the quest progress. By changing the segment before "1d" in those lines, we reset the status.

I can't guarantee that this will work for you, but it allowed me to get and complete the Troll King quest. It's not for the faint of heart.
Posted By: Purinsu Re: Troll's Bounty quest not starting! - 12/08/14 06:24 PM

I've tried Armillary's approach but unfortunately it didn't work for me. I can only make assumptions why. What makes me seriously angry, though, is the fact that there apparently hasn't been a fix for this critical issue up until now. Although it's not entirely game-breaking it messes up the progress and for any player who strives for some kind of "efficiency" it just kills the fun.

@ Larian Studios. The game is exceptionally well designed but pretty please with sugar on top, fix this. Or if you don't intend to fix it for whatever reasons, please tell us whether Armillary's approach makes sense or rather contribute to the approach to reliably work as a means of a workaround.
Posted By: dwade Re: Troll's Bounty quest not starting! - 16/08/14 03:31 PM
Armillary's solution worked. Spoke to Brandon and got the quest in my log. Haven't finished it though, so not sure what's going to happen afterwards. Nevertheless, a step in the right direction.

FWIW the hex value I had after XX was not 1d. I had different values for both lines.
Posted By: Leni Re: Troll's Bounty quest not starting! - 16/08/14 06:36 PM
Armillary, thanks for the help with hex editing the savegame although your solution might not work for all as it didn't work for me. For whom it doesn't work I have another (very similar suggestion): when you open the Globals.lsb (make backup before) in Frhed (hex editor), do as Armillary says, find LUC_Brandon_Bothered line and find your own XX value. What worked for me is that I changed it NOT to "00" but "f6" instead. The reasoning behind: I noticed a line before LUC_Brandon_Bothered, and it is LUC_Brandon_LeftSilverglen, where the answer (=NO) is value "f6". So instead of changing "XX" to "00" as Armillary wrote, change it to "f6" in both places. Hope it works for you, too! I should also say this: don't know if my save will be corrupted somewhere along, hopefully not! Try this at your own risk!
Posted By: PapBek Re: Troll's Bounty quest not starting! - 18/08/14 11:16 PM
Armillary's solution worked for me too. I had already killed the troll king, and changing the hex values to 00 made it so I got the quest from Brandon, and the Tenebrium container. I then just put 5 Tenebrium ore in the container and handed it in, and voila, Tenebrium skill for everyone! laugh

And as for Larian, please change this quest so it is possible to get the Tenebrium skill on all your party members without this quest. The one skillbook just isn't enough, as I read it with my main, a mage, as soon as I picked it up, which I didn't realize until much later, when it was too late to return to a previous save!

In any case, thanks Armillary, and let's hope this doesn't result in a bugged save later on!
Posted By: Purinsu Re: Troll's Bounty quest not starting! - 23/08/14 09:53 AM
Unfortunately this didn't work for me either... Brandon still won't give the quest to me. And there still is no standard fix.

Posted By: Tenzin Re: Troll's Bounty quest not starting! - 24/08/14 11:36 PM
My biggest frustration with this bug is that I did not even choose to turn down Brandon's quest. My companion chose to and overrode me in the rock/paper/scissors game. I figured it was another thing like the Fabulous Five, so I didn't bother reloading to ensure a victory. Little did I know it would essentially cripple my ability to finish this game...

I've tried the fix mentioned above. Armillary's solution did nothing for me, but Leni's solution changed some of Brandon's dialogue. I then changed the 1d value listed above (it was 1e in both places), which gave me some weird dialogue. Brandon first told me "Fine, I won't share my secrets" (or whatever his exact words were) but then I had the dialogue option to continue the conversation as if I had accepted his request. I now have the Troll King quest, but my quest log under the Troll King now states (in this order [not exact words]) "We have found some Tenebrium to give to Brandon." "We should go find the Troll King." Unlike Papbek, . I still have yet to find Maradino's cave to finish the quest, but I did have some Tenebrium from the Tenebrium Mines. Unlike Papbek's solution, I was not able to just put some Tenebrium in the container and hand it in, but maybe after I kill the Troll King all will be well.

All in all, I'm very frustrated with this. I love this game to bits and I will continue playing it multiplayer with my friends and with mods, but if I can't get this hex editor option to work for me, I don't know if I'll be able to finish the main game. At least not for a while. I'll have to basically start Luculla over again - and boy oh boy did I hate those mines.
Posted By: simon3000 Re: Troll's Bounty quest not starting! - 20/09/14 07:34 PM
For those of you who couldn't get the hex hack to work, please check which QuickSave is actually the latest one, it's not always QuickSave_4, since it rotates.
Posted By: kai1 Re: Troll's Bounty quest not starting! - 25/12/14 06:13 AM
Obviously the people who gave you good reviews overlooked the fact that a companion can override and destroy the game. This is exactly what happened to me as well. Thanks for wasting hours of my life while I tried in vain to find a way to handle this BS ore... Terrible game design. All my characters are contaminated I assumed that further down the story they might be healed. And I'd be able to handle the stuff. Nope. I'm stuck waiting for a book to give to one character... Brilliant guys!
Posted By: Raze Re: Troll's Bounty quest not starting! - 25/12/14 07:06 AM

All the characters should be able to use the book.

If you don't want to deal with the consequences of setting an AI personality for a main character, you can change that using a mirror in the living quarters in the homestead.
Posted By: Gothmog_ Re: Troll's Bounty quest not starting! - 01/01/15 02:34 PM
As the bytes you suggested to zero-out have different values in different savegames, I suspect they may hold additional information. So I tried to find a minimally invasive way.

First, (for me) it suffices to change the second byte you mentioned. For the record, in the sequence
4c 55 43 5f 42 72 61 6e 64 6f 6e 5f 50 6c 61 6e 00 0c 00 00 00 04 00 00 00 XX 1d 00 00 0a
corresponding to "LUC_Brandon_Plan...".

Second, it is not necessary to set it to zero. At least here, it sufficed to set the 4th bit (counted from the lowest valued bit, i.e. from the right) to zero.

I hope this is less likely to trigger unintended side-effects.
Posted By: ZiZaXX Re: Troll's Bounty quest not starting! - 19/01/15 01:13 PM
I loaded a save where I never been at Luculla, talked to Brandon and quit.

The original state of LUC_Brandon_Plan is "AD 1C" and LUC_Brandon_Bothered is absent, but that does not help.

LUC_Brandon_Bothered ... 00 _6C_ 1D 00 00 0A (subtract 1 from 6D)
LUC_Brandon_Plan ... 00 _00_ 1D 00 00 0A (set to 00)

And the dialogue option is there again.
© Larian Studios forums