Larian Studios

My GM Campaign Mod Loads Black Screen on Create

Posted By: Dima01

My GM Campaign Mod Loads Black Screen on Create - 03/01/18 08:05 AM

My own Mod (Pyramid of Shadows) loads fine when I Prepare a campaign. When I go back to Create a Campaign for others to join and play, we load in, but we load into a black screen. I can look around with the middle button (at least, I THINK I'm looking around) but the whole screen is black. All my players get the same black screen and no option to start making their characters.



Above image shows my settings for the mod. I have it set to Adventure so the Story Script works (Primarily for Event Triggers, Automated faction changes, and who am I kidding... a whole ton of other stuff)

I have tried various combinations in the general settings. Even leaving the main levels blank. When they ARE blank I (and my players) get loaded into, what I think, the GM character photobooth or character creation level. But I cannot do anything from there and neither can my players. No character creation window shows up for them, and no GM overlays show up for me.

I have published this as an Add-on but that takes away ALL of my Story Scripting (Display Auto Dialog for hints, Event Triggers, Secret areas, etc...)

There's a lot of good stuff there... I'd like to keep it for others to enjoy. Why not? You know? If this is a feature that was taken away, I'm strongly against it as I have spend a lot of time Scripting before the update.

If anyone stumbles onto an amazing solution, please let me know. Here is my Modding Discord community where you can get in touch with me -> The Black Thorn or https://discord.gg/BjGXhbn

You can check out the bug being played out here -> https://www.youtube.com/watch?v=ehCxYq97zgU
Posted By: Larian_KVN

Re: My GM Campaign Mod Loads Black Screen on Create - 03/01/18 02:35 PM

Hey Dima!

I looked through the files/scripts/... and tested it out and your settings/scripts are fine smile
The fix should be in the next game patch smile

Our apologies for the inconvenience until then.
Sincerely,
Kevin
Posted By: Fauvic

Re: My GM Campaign Mod Loads Black Screen on Create - 27/04/18 01:02 PM

[quote=Larian_KVN]Hey Dima!

I looked through the files/scripts/... and tested it out and your settings/scripts are fine :)
The fix should be in the next game patch :)

Our apologies for the inconvenience until then.
Sincerely,
Kevin [/quote]

I'm experiencing the same issue as above.

Has anyone found out a way to resolve this yet?
© 2020 Larian Studios forums