Larian Studios
Posted By: Uth Abilies in magic Mirror on Lady Vengenance - 21/10/17 08:25 PM
Hey Community

What am I doing wrong.

Changed my toon from Summoning 8 - Air 1 - Geomancer 1
to Summoning 8 - Warfare 2

Couldn't access any warfare and all warefare books I trained got "eaten" It was learned but no access with K (open spellbook)

I tried retraining to Summoning 10 and a big champion came forth....

Something is working and something is not...

Do I have to start all over to get away from Air 1 and Geomancer 1?

Best regards Kris
Summoning 10 gives you an incarnate champion.

Did you take all your gear off and then try to respec?
What exactly do you mean by "no access with K"? I'd like to point out this problem, regardless: when you "learn" the skill, make sure you are actually selecting the character you want to learn the skill. It doesn't matter whose inventory the skill book is in; it is the character you're selecting that will learn it. You don't have to give the skill book to the character, but you have to select them when you learn the skill.

For example, in my case, this one time Lohse was having a bunch of Warfare books, I wanted the Red Prince to learn them, but didn't notice I was selecting Sebille, so Sebille ended up learning all those skills instead.

Is this by any chance what's happening in your case?
Posted By: Uth Re: Abilies in magic Mirror on Lady Vengenance - 23/10/17 02:20 PM
Thank you very much.

It helped to strip all gear off.
Apparently that made me able to learn skills and let them show in spellbook by pressing K (My reference to what I meant by K)

I knew that something was working since I could summon champion when I put 10 points in summoning. It was my Failsafe test.

But now I got rid of my air and geomancer futile skills and got into warfare. <3 Summoner with warfare is working for me in the setup I run with my buddies.
© Larian Studios forums