Larian Studios
So I had a save game conflict and haven't played in a couple weeks waiting for the resolution of my ticket. Gave up waiting, decided to start again. . .And I am not sure I ran into another bug, or if I missed something.

So after the Githyanki at the bridge, I took the backdoor into Goblin town and cleared it out, then rode the log into The Swampy Teahouse. Walked in the back door, forced the hag to reveal herself, knocked her down to half health and she disappeared into the fireplace. Followed through, ignored the gallery, snuck by the Masks, rappelled past the traps and ladders. . .But she wasn't there. I went through her office and stole all her things, lowered the cage, but the chick inside won't speak to me and the hag won't come out of hiding. Did I screw something up or is my game state bugged?
Had the exact same problem on my first playthrough. On my second she appeared, told me shed rip my spine from my arsehole and then stood still and let me kill her. On both playthroughs I did not pass the dice rolls with the door and just walked through it. Maybe that has something to do with it.
I passed the Arana and the Persuasion.

Thanks though man, at least now I know I am not alone. I could have sworn I remembered fighting her previously, but I have slept since then and am doing this differently and thought I might have missed a trigger somewhere.
first time I went in there, I snuck past the room with the cauldron and all her "victims" which did not trigger her to appear in that room and talk to me correctly and when I came out of stealth she appeared but didn't talk to me, so I attacked her and killed her. Also I was sneaking in the boss fight room and she didn't appear right away until I walked in her cone of sight while she was invisible and I had to unstealth myself for it to trigger.

There may have been a flag you didn't trigger to move her into the right room, so she isn't appearing. Also going in the back door may have jacked it up. I don't know if each spawn of her is the same NPC/asset or if they have individual identifiers. If it is the same ID to designate that NPC maybe she isn't appearing because she is stuck somewhere else in the world. Try killing her in the cauldron room maybe if she is there to force her to despawn and move?
Alright, I will give that a try tomorrow. Thanks, it didn't even occur to me she might be present and invisible. I will run through and see if I get het to proc.
The entire hag encounter is broken for me. I've tried it with three different characters but it never triggers properly, or it bugs out. I've not finished the quest once.
I almost kill her upstairs because she's too busy with the blarney, then she stands there downstairs like the stone itself. I'm fine with that, I was soiling my +1 leathers.
© Larian Studios forums