Larian Studios
Posted By: lockedknoose Not even able to get past the launcher. - 16/10/21 08:38 AM
Like the title suggests, my game is crashing before it even loads. It appears in my taskbar for a millisecond before reccommending I verify the files, which I have done. About 15 times. I've never had mods, I've deleted my save data just in case that was causing any issues. Anybody else ran into this problem? Or know how to fix it?
Posted By: Canonfin Re: Not even able to get past the launcher. - 16/10/21 10:20 AM
Only here to see if any responses as I am having the same issue. States my driver needs to be updated, but driver itself states it is up to date and I cannot upgrade to the recommended driver. It was playing absolutely fine on patch 5, but now, after a few hours of play in patch 6 I cannot get back into the game. I get to the load campaign screen, then get kicked out after about 30 secs of loading.

As an afterthought, I tried to start a new game and it did so fine. I went back to my last save of the previous campaign, tried loading afterwards and it crashed again.
I can't even get the game to load, it instantly crashes after pressing play, I've got my latest driver updates and everything.
Posted By: Tavvy Re: Not even able to get past the launcher. - 16/10/21 12:52 PM
Same problem as @lockedknoose here: both the Vulcan and DirectX variants crash right after I click on the launcher. There is a short delay, the screen goes black (probably entering full-screen mode) and then I get the crash reporter.

This did not happen with Patch 5.

I have tried deleting Documents/Larian/Baldurs Gate 3 to get rid of the files from Patch 5. No luck. frown
Yep, exact same thing. Glad I'm not the only one, thought I was going insane. If you find a fix let me know please! I've spent the past 4 hours trying to find something that will work.
Posted By: Tavvy Re: Not even able to get past the launcher. - 16/10/21 01:55 PM
I have contacted Larian support ... not holding my breath before Monday. cry
I'll let you know if there are any developments.
Sweet, cheers. I've tried asking on Reddit also and no fix seems to be working thus far, so it might be a wait for hotfix type of scenario which sucks, wanted to sink some time into it this weekend.
Posted By: Tavvy Re: Not even able to get past the launcher. - 16/10/21 04:50 PM
I had originally installed using the GOG offline installer. Don't ask me why, but on a whim I decided to install again using the GOG Galaxy installer ... now it works. I'll try to confirm using a different computer, but it looks as if the offline installer is broken.
Ah I'm using Steam, so I doubt this issue would apply to me. Congrats on getting it working though!
Posted By: Tavvy Re: Not even able to get past the launcher. - 16/10/21 06:05 PM
Thanks. I can confirm that the offline installer does not work while using the GOG Galaxy installer does.

Have you tried uninstalling and re-installing?
Yeah, I've reinstalled it twice now.
HI all mine is crashing randomly. I heard back from support for DX11 and Vulcan crashing. I Censored mine and reps names. But here it is! I hope it helps!


Are you shutting down all non-essential programs (especially anti-virus) before starting the game? Firewalls can cause conflicts (generally on startup or loading screens) and overlays from graphics tweaking/monitoring programs or chat programs can also cause issues.

There's a known issue with the ASUS Sonic Studio Virtual Mixer that can cause a crash on startup; if applicable, try disabling or uninstalling the program.

For a Vulkan Device_Lost error, there is a known conflict with Ubisoft Connect; if you are running that in the background, try exiting out of it.

If you have any generic or obscure USB controllers (or other devices) plugged in, try disconnecting them. Crashes on startup with faulting module names of ntdll.dll and EZFRD64.DLL, can (particularly for the latter) be related to USB controllers or PS2 to USB adapters (for various games). Such crashes usually happen immediately, though, before the game starts to load.

Try exiting out of the Steam client, if applicable, and starting the game directly from the '..\SteamApps\common\Baldurs Gate 3\bin' folder, by right clicking the executable (bg3.exe for Vulkan, or bg3_dx11.exe) and running as administrator.
Try right clicking the executable, select Properties, switch to the Compatibility tab and check off the 'Override high DPI scaling behavior' option (set it to Application), maybe run as administrator and disable fullscreen optimization, and set a Win 7 or 8 compatibility mode.

Try verifying local files: in the Steam library, right click on the game and select Properties, switch to the Local Files tab and then click on the 'Verify Integrity of Game Files...' button.
With the GOG version, in the (optional) Galaxy client, select the game, then the settings icon at the top right (beside the Play button) and under Manage Installation select 'Verify / Repair'.

Especially if you have a relatively high desktop resolution, you can try temporarily lowering it, to limit what the game will auto-detect. If that allows the game to start, you can then exit and restore your desktop resolution.

If you check the Event Viewer, are there any events listed for the game, if it is at least starting to load? If so an error code or 'Faulting Module' file name might help identify the cause of the crash.
- click Start (or WinKey-R), then type "event viewer" into the search box. in Windows 10, 'event' should bring up 'View event logs'.
- after starting the Event Viewer, expand 'Windows Logs' in the left column and select 'Application'
- in the center column, look for a recent error for the game (maybe sort by Date and Time, or search for 'bg3')
- check the information under the 'General' tab below the list of events, starting with "Faulting application name..."

Check for updated graphics drivers, and Windows updates in general.

For Windows 7, please make sure you have Service Pack 1 installed. That is the minimum required version of Windows (64 bit).

Try browsing to the '..\Documents\Larian Studios' folder and delete the 'Baldur's Gate 3' folder.
This folder contains the saved games, profiles and configuration files. Normally I would suggest renaming the folder for troubleshooting purposes, but if you don't have any saved games that isn't an issue.
Next, extract the replacement folder from the download below into your '..\Documents\Larian Studios' folder, and see if that will let you start the game.
The graphicSettings.lsx file is set to 1280x720 Windowed mode, Very Low quality preset and low audio quality, which you can change in the options (manually, or hit autodetect) if this gets the game working.

Try doing a clean boot and then test the game. Click Start, or hit WinKey-R, type in msconfig and hit enter; in the General tab, click Selective Startup, uncheck Load startup items (if required) and leave Load system services and Use original boot configuration options checked. Next, click on the Services tab, check the box to Hide all Microsoft services, then click the Disable All button (maybe make a note of which are currently enabled/disabled), then click OK and reboot the computer.
Run msconfig again to switch back to the normal boot configuration.

If that doesn't help, please reply with a dxdiag report (WinKey-R, type in dxdiag and hit enter, then when it finishes loading click on the 'Save All Information...' button and save the report somewhere handy). Also check the '..\SteamApps\common\Baldurs Gate 3\bin' folder, and if there are any CrashDump files being created, zip a few together to include.
Tried all of these and still nothing. I might just have to sit and wait for a hotfix to roll out.
Hey All, I Debugged my latest crash logger file (10-17-21) Any Ideas maybe? TIA!

Microsoft (R) Windows Debugger Version 10.0.22415.1003 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [F:\SteamLibrary\steamapps\common\Baldurs Gate 3\bin\CrashDump - 10-17-2021 20h 11m 23s.dmp]
User Mini Dump File: Only registers, stack and portions of memory are available

Symbol search path is: srv*
Executable search path is:
Windows 10 Version 19043 MP (8 procs) Free x64
Product: WinNt, suite: SingleUserTS
Edition build lab: 19041.1.amd64fre.vb_release.191206-1406
Machine Name:
Debug session time: Sun Oct 17 13:11:24.000 2021 (UTC - 7:00)
System Uptime: not available
Process Uptime: 0 days 0:28:53.000
This dump file has an exception of interest stored in it.
The stored exception information can be accessed via .ecxr.
(2548.2fcc): Access violation - code c0000005 (first/second chance not available)
For analysis of this file, run !analyze -v
00007ffb`842aeba4 c3 ret
0:024> !analyze -v
* *
* Exception Analysis *
* *

*** WARNING: Unable to verify checksum for SDL2.dll
*** WARNING: Unable to verify checksum for DWrite.dll
*** WARNING: Unable to verify checksum for CChromaEditorLibrary64.dll


Key : AV.Fault
Value: Read

Key : Analysis.CPU.mSec
Value: 5390

Key : Analysis.DebugAnalysisManager
Value: Create

Key : Analysis.Elapsed.mSec
Value: 76862

Key : Analysis.Init.CPU.mSec
Value: 499

Key : Analysis.Init.Elapsed.mSec
Value: 26927

Key : Analysis.Memory.CommitPeak.Mb
Value: 297

Key : Timeline.Process.Start.DeltaSec
Value: 1733

Key : WER.OS.Branch
Value: vb_release

Key : WER.OS.Timestamp
Value: 2019-12-06T14:06:00Z

Key : WER.OS.Version
Value: 10.0.19041.1

Key : WER.Process.Version

CONTEXT: (.ecxr)
rax=0000000000000258 rbx=0000000000000258 rcx=0000000000000000
rdx=0000000000000001 rsi=0000022a14774740 rdi=0000022a0fcbe820
rip=00007ff7194bc9bf rsp=0000004111dff1c0 rbp=0000004111dff229
r8=0000000000000024 r9=00007ff4055ac000 r10=0000000000000000
r11=0000000411601401 r12=000000000000000f r13=0000000000000002
r14=0000022a0046f9c0 r15=0000000011dff38c
iopl=0 nv up ei ng nz ac po cy
cs=0033 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00010297
00007ff7`194bc9bf 498b07 mov rax,qword ptr [r15] ds:00000000`11dff38c=????????????????
Resetting default scope

ExceptionAddress: 00007ff7194bc9bf (bg3_dx11+0x000000000357c9bf)
ExceptionCode: c0000005 (Access violation)
ExceptionFlags: 00000000
NumberParameters: 2
Parameter[0]: 0000000000000000
Parameter[1]: 0000000011dff38c
Attempt to read from address 0000000011dff38c

PROCESS_NAME: bg3_dx11.exe

READ_ADDRESS: 0000000011dff38c

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%p referenced memory at 0x%p. The memory could not be %s.


EXCEPTION_PARAMETER1: 0000000000000000

EXCEPTION_PARAMETER2: 0000000011dff38c

00000041`11dff1c0 00007ff7`194bc1ae : 02800001`00000150 00007ff3`bdd58d40 0000022a`0046f9c0 02800001`00000057 : bg3_dx11+0x357c9bf
00000041`11dff290 00007ff7`194bb22f : 00007ff3`c00e7130 00007ff3`000000fb 42400001`0000039e 0000022a`665dc590 : bg3_dx11+0x357c1ae
00000041`11dff530 00007ff7`186c2550 : 00000041`11dff630 0000022a`03ef53a8 0000022a`03ef53b8 0000022a`001f5920 : bg3_dx11+0x357b22f
00000041`11dff6e0 00007ff7`1b7b7f47 : 0000022a`03ef5358 0000022a`001f5920 00000041`11dff6d0 0000022a`001f5920 : bg3_dx11+0x2782550
00000041`11dff740 00007ff7`18546569 : 0000022a`001f5920 0000022a`001f5920 0000022a`00240360 ffffffff`fffffffe : bg3_dx11+0x5877f47
00000041`11dff790 00007ff7`17a6505a : 0000022a`00422140 0000022a`00422140 0000022a`001f5860 0000022a`00380270 : bg3_dx11+0x2606569
00000041`11dff7c0 00007ff7`1b9859ec : 00000000`00000148 00000000`00002fcc 0000022a`00002fcc ffffffff`fffffffe : bg3_dx11+0x1b2505a
00000041`11dff820 00007ffb`83407034 : 00000000`00002fcc 00000000`00000000 00000000`00000000 00000000`00000000 : bg3_dx11+0x5a459ec
00000041`11dff860 00007ffb`84262651 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : kernel32!BaseThreadInitThunk+0x14
00000041`11dff890 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlUserThreadStart+0x21

SYMBOL_NAME: bg3_dx11+357c9bf

MODULE_NAME: bg3_dx11

IMAGE_NAME: bg3_dx11.exe

STACK_COMMAND: ~24s ; .ecxr ; kb

FAILURE_BUCKET_ID: INVALID_POINTER_READ_c0000005_bg3_dx11.exe!Unknown

OS_VERSION: 10.0.19041.1

BUILDLAB_STR: vb_release


OSNAME: Windows 10


FAILURE_ID_HASH: {b9b78c06-9170-b260-f7a7-6601940cd691}

Followup: MachineOwner
Sorry OP, Just trying as I find info. My RX580 fan goes almost full bore RPM as soon as I start at beach. Weird 8GB SSD running game off of.
I've fixed my issue by simply deleting both "Mods" folders (from installation folder and documents), I did have mods installed on previous versions though. Worth trying nevertheless I suppose
Posted By: ClarkA Re: Not even able to get past the launcher. - 18/10/21 07:56 PM
I went through all the steps listed in this thread and couldn't get the game to launch--other than full uninstall/reinstall as that's a very large download. I've never had any mods--just the default game since EA started. I tried a couple of verification passes which didn't fix it.

I did just get it to work on my system though. I did a few things since the last attempt so I'm not sure which step fixed the issue:

1) Manually went through all the files installed in the game directory and subdirectories and deleted any older than 2021-10-17.
2) Did another Verify/Repair pass (GOG).
3) Clicked Play in GOG, but then logged out of LariLauncher and closed it.
4) Clicked Play in GOG again, this time logging in with LariLauncher and then launching the game.
5) Success.

Hope this helps others!
© Larian Studios forums