Larian Banner: Baldur's Gate Patch 9
Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
Joined: May 2003
apprentice
OP Offline
apprentice
Joined: May 2003
Hello.

This is an issue I'm having with the Impulse version of the game, in Raze's and Stone's flying fortresses. The background seems to be missing texture, and appears white, which becomes blinding if HDR is enabled.

The rest of the game looks fine (well, so far).

It's best that you watch the video for context, especially with the morph to dragon.

(Right click, save as)
http://www.crawspace.com/ss/errors/divinity2_very_bright.wmv

My diag file: http://www.crawspace.com/ss/errors/div2diag.txt

Turning down all settings makes the game playable on these levels, but still very annoying.

I had this same computer when I played the retail version of the game, and did not experience these issues then.

Thanks!

Joined: May 2003
old hand
Offline
old hand
Joined: May 2003
In Options and Graphics click on Advanced Settings and uncheck "use HDR". After your done with the flying fortresses enable this again or the game won't look right.

Last edited by LightningLockey; 11/02/11 12:08 AM.

Every time there I run into trouble on the road, there is always a dwarf at the bottom of it. Don't they know how to drive above ground?
Joined: May 2003
apprentice
OP Offline
apprentice
Joined: May 2003
Unfortunately, with HDR disabled, it's less bright, but still too bright to play.

EDIT: Screenshot with all settings at their lowest, including HDR being disabled.

http://www.crawspace.com/ss/errors/divinity2_very_bright.jpg

Last edited by Crawdaddy79; 11/02/11 01:14 AM.
Joined: Aug 2009
Location: Soviet Empire
veteran
Offline
veteran
Joined: Aug 2009
Location: Soviet Empire
Oh shi... there is definitely sumtin wrong.

Visit this thread: http://www.larian.com/forums/ubbthreads.php?ubb=showflat&Number=425051#Post425051

Download tool, generate teh report and send to support@larian.com with issue description.

Joined: Jan 2006
Location: Belgium
ava Offline
member
Offline
member
Joined: Jan 2006
Location: Belgium
Very weird... We tried to reproduce the problem with the exact same hardware configuration as you have, but failed frown

Can you try to move the files in C:\Documents and Settings\All Users\Application Data\Divinity 2\ to a temporary folder, then start the game in that same level, see if there's a difference?


It is a mistake to think you can solve any major problems just with potatoes.
Douglas Adams
Joined: May 2003
apprentice
OP Offline
apprentice
Joined: May 2003
Originally Posted by ava
Very weird... We tried to reproduce the problem with the exact same hardware configuration as you have, but failed frown

Can you try to move the files in C:\Documents and Settings\All Users\Application Data\Divinity 2\ to a temporary folder, then start the game in that same level, see if there's a difference?


No difference. frown

As for the configuration, are you using the Impulse version of the game (Dragon Knight Saga)?

Also, something that might be affecting it, is I have had the retail version of Ego Draconis installed on this same PC (but did uninstall it long before I got DKS).



I did do the support tool thing a few days ago.

Joined: Mar 2003
Location: Canada
Support
Offline
Support
Joined: Mar 2003
Location: Canada

Try running the game as administrator, and in the compatibility options disable desktop composition (in Vista/7).

A couple people had missing or corrupt textures fixed by doing a clean reinstall of the game. Does Impulse have a tool to verify the install? If not, uninstall DKS, reboot, shut down all non-essential programs (especially anti-virus), make sure there is nothing left in the D2 folder (saves are stored elsewhere), then install DKS and the patch.

Did you try changing the texture quality setting? How about a lower game resolution?


Missing Water Textures ?

Joined: May 2003
apprentice
OP Offline
apprentice
Joined: May 2003
Impulse used to have a tool to verify installations, there's even a bit about it in the manual, but it's missing from the program.

Easier said than done on the uininstall/reinstall. But I did it anyway... Nothing has changed.

The screenshot I posted in my previous post (#438525) is with all settings turned down, and changing the resolution doesn't make a difference either.

I have noticed though, that it's not a difference between the dragon/human form that makes it so much brighter. It's when you reach above a certain altitude that the ground turns completely white.

The water has looked completely fine throughout the game, but I'm somewhat certain that this issue is similar to that one (and it doesn't seem to be resolved in that thread).

Joined: Mar 2003
Location: Canada
Support
Offline
Support
Joined: Mar 2003
Location: Canada

Did you try unchecking the 'depth of field' option?
If the problem is height based, the issue could be with low resolution textures, or some blur or fog effect used at longer distances.

Joined: May 2003
apprentice
OP Offline
apprentice
Joined: May 2003
Yeah, in that screenshot I turned everything off and every adjustible setting is on its lowest (except resolution).

I think it's specifically the moving fog texture missing (it sits on a plane, at a certain height in the game world, only in the flying fortress), along with some others in the background.

Here's another video... it's not very good because I kept getting attacked, but I think it shows what I'm talking about.

http://www.crawspace.com/ss/errors/divinity2_very_bright2.wmv

Joined: May 2003
old hand
Offline
old hand
Joined: May 2003
Did you try a new install? That would have been my first move, back up the saved games first.

And I mean total removal of the directory (you'll manually move your saved games back in the saved games folder). Nothing at all saved, all user settings gone (hot keys for potions and spells should be saved in your actual saved game file).

Also if you have the any divinity 2 demo installed, get rid of that too.

Last edited by LightningLockey; 15/02/11 06:32 AM.

Every time there I run into trouble on the road, there is always a dwarf at the bottom of it. Don't they know how to drive above ground?
Joined: May 2003
apprentice
OP Offline
apprentice
Joined: May 2003
Yeah I did the whole uninstall. It automatically removes all game folders when this is done, so there wasn't any chance that corrupted files were kept in place. I kept the save games of course, otherwise how could I have gotten to the flying fortress? [Linked Image]

I'm worried that this is an issue with the Impulse version, maybe something changed when they re-did the patch last month or something, and it hasn't gone through complete testing, and I'm the first one to get to this point in the game... It really looks like it's a missing texture, and because this is the same hardware configuration I had when I played the retail version of the game, I'm leaning away from that being a problem (though I am running newer drivers).

I'm going to post on their forum and see what happens.

I also updated the video... hopefully it better shows what I'm talking about, in the event the last one didn't.

Same URL: http://www.crawspace.com/ss/errors/divinity2_very_bright2.wmv (10 MB - right click, save as, run with WMP otherwise it might not work)

(it was made with HDR off - I'm not sure of other settings)

Joined: Aug 2009
Location: Soviet Empire
veteran
Offline
veteran
Joined: Aug 2009
Location: Soviet Empire
Quote
he background seems to be missing texture, and appears white, which becomes blinding if HDR is enabled.

Calculate the MD5 of Textures*.dv2 and post here.

Joined: Mar 2003
Location: Canada
Support
Offline
Support
Joined: Mar 2003
Location: Canada

Doesn't the support tool check file integrity?

Anyway, the small freeware program Hash can be used to calculate MD5, SHA1 and CRC32 checksum values of a number of files.

Joined: Feb 2011
T
stranger
Offline
stranger
T
Joined: Feb 2011
Seems I have this exact same problem and have the game off of Impulse too. So this begs another question, have you tried to go through Raze's fortress? All the other fortresses have this visual anomaly but are otherwise playable. Raze's is fubar, can read my exp here.

Joined: May 2003
apprentice
OP Offline
apprentice
Joined: May 2003
Originally Posted by Trilarian
Seems I have this exact same problem and have the game off of Impulse too. So this begs another question, have you tried to go through Raze's fortress? All the other fortresses have this visual anomaly but are otherwise playable. Raze's is fubar, can read my exp here.


Oh wow. Yep. Before, I didn't try actually going through the fortress, but I just did because of your post, and sure enough I have the exact same issues. Invisible walls in otherwise clear paths (could be more missing texture issues), and platforms/ramps that you can see, but can't stand on.


Thanks Raze, for the Hash link. I had no idea what MD5 was. I did do the support tool thing and sent that to Larian, about 30 minutes after I started this thread, and linked this thread when I did it. No response yet, so I don't know if it did any good.

MD5 calculation (is this what you're looking for?)

Textures.dv2

Size: 1683619840 bytes
Modified: Thursday, November 04, 2010, 4:03:06 PM
MD5: 0072AD18404C688973B54A443A855FDC
SHA1: B98E671D4537F5EE0839A60128E014CDB28619C1
CRC32: 276A7224

Textures2.dv2

Size: 1220280320 bytes
Modified: Thursday, November 04, 2010, 4:01:52 PM
MD5: 2F11AC9E177453FBC029C14F8C308561
SHA1: 228DB92E640D8F425784CF8A3F1D8F079F5959F2
CRC32: 125E75FC

EDIT: And while I'm here:

FlyingFortresses.dv2

Size: 21069824 bytes
Modified: Thursday, November 04, 2010, 4:02:09 PM
MD5: B5094331B6E25BAE9E41232285C6569E
SHA1: 80C0C8F35FA5175F1ACC24F42DAE96F23AE9412E
CRC32: EB8C8A51

Last edited by Crawdaddy79; 18/02/11 03:22 AM.
Joined: Aug 2009
Location: Soviet Empire
veteran
Offline
veteran
Joined: Aug 2009
Location: Soviet Empire
Full match. It has nothing to do with your game installation.

What is your spec?

Joined: May 2003
apprentice
OP Offline
apprentice
Joined: May 2003
I am still hesitant to rule it out. It may not be in the .dv2 files, but I'm experiencing the same things as Trilarian (above), with invisible walls and platforms that don't work.

My spec is completely different from his, and we are both using the Impulse version, which was just patched a few weeks ago. (my spec: http://www.crawspace.com/ss/errors/div2diag.txt )

Last edited by Crawdaddy79; 18/02/11 01:56 PM.
Joined: Aug 2009
Location: Soviet Empire
veteran
Offline
veteran
Joined: Aug 2009
Location: Soviet Empire
Try to disable AI Catalyst. ANd I hope you updated your drivers, because well.. ya'now... it's ATI.

Also, can you try to monitor GPU temperature while playing? Tell the results.

Joined: May 2003
apprentice
OP Offline
apprentice
Joined: May 2003
Well, for what it's worth ATI's drivers have been solid for every game I play (though, some flashing textures in BC2), and I have played a lot of games.

When the card is overheating, things start looking weird (this card hasn't - it stays at about 70C under load), but what's showing in the Flying Fortresses is very uniform; not to mention that the rest of the game looks and plays great.

They just released a new driver set in February and I got it, and of course nothing has changed. As for graphics cards settings, I assure you I've tried everything without going into the registry.

What seals it for me though, is Raze's Fortress and Trilarian's issues with it matching mine, as we both have Impulse versions.

Impulse released a patch in mid-January, that broke the game's activation and anyone who patched it couldn't play the game any longer. They released a new patch after that, and I think this mix-match is what broke the Flying Fortresses, otherwise there would be a lot more people complaining about this before.

Page 1 of 2 1 2

Moderated by  Bvs, ForkTong, Larian_QA, Lar_q, Lynn, Macbeth, Nicou, Raze 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5