Larian Banner
Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
#439633 25/02/11 01:09 PM
Joined: Feb 2011
W
stranger
OP Offline
stranger
W
Joined: Feb 2011
Hi, I didn't bother with Divinity 2 first time around but after hearing good things about DKS I thought I'd give it a go.

My pc is running Windows 7 32bit on an i7@4ghz, 4gb of ram and a Radeon 5970 graphics card, I'm getting a consistently low frame rate everywhere, at all detail settings.

I'd guess it's around 30-40fps, I've tried the hotfix, the XML fps edit, the latest auto update patch, disabled crossfire, disabled multi-core, all the shadow stepping and threading options.

Absolutely nothing I do will make this game run at 60fps, the one thing I haven't tried is a driver update for my Radeon, 10.10e hotfix is recent and stable and I'd rather not change it.

Any suggestions?

Thanks.

Joined: Dec 2010
Location: Australia
T
enthusiast
Offline
enthusiast
T
Joined: Dec 2010
Location: Australia
I believe the game is capped at 30 FPS unless you edit a config file. Make sure you have all the patches before-hand, and backup all files before editing!

I think you need to edit: 'c:\users\<username>\Appdata\Local\Divinity2\Profile\GrahpicsOptions.XML'. That should be the correct file if you're running the Steam version on Windows 7 (not sure about other OS/versions).

Increase the 'FPSCap' value to 60 (instead of the existing value of 30).

(Edit: ok, I just noticed that you'd already done the XML FPS hack - so sorry, can't help any further, it worked for me...)




Last edited by Trippy; 25/02/11 03:25 PM.
Joined: Feb 2011
W
stranger
OP Offline
stranger
W
Joined: Feb 2011
Thanks for the reply but yep, as you can see I tried it, I think I've tried everything in the FAQ now, can anyone from Larian offer more suggestions?

Joined: Mar 2003
Location: Canada
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Location: Canada

Did you email support@larian.com? Maybe a dxdiag report or the one from their support tool (see the DKS support page) would help diagnose the problem.

Joined: Feb 2011
W
stranger
Offline
stranger
W
Joined: Feb 2011
I just installed today and had the same exact problem with the same exact video card. I fixed the problem by enabling "timeslice shadows". I know this is not intuitive because the FPS problems are present when shadows are completely disabled but it worked for me. Please let us know how this works for you.

I run at 1920x1200, Monitor refresh 75hz, FPS limit 75, all settings on "Extreme Mode" Vsync enabled. FPS was poor at these settings (and any other settings) until I enabled "timeslice shadows" and now my FPS is good.

Last edited by wesleyshaver; 26/02/11 05:12 AM.
Joined: Feb 2011
W
stranger
OP Offline
stranger
W
Joined: Feb 2011
I tried the timeslice option again just to be sure, no improvement at all sad

Out of interest, what version of Catalyst are you using?

Last edited by WDeranged; 26/02/11 06:45 AM.
Joined: Aug 2009
Location: Soviet Empire
veteran
Offline
veteran
Joined: Aug 2009
Location: Soviet Empire
WDeranged
Have you installed latest patch, by chance? If so, you don't need to edit XNL-file in game's dir, there is an in-game option for that already. Changing "[...]\Divinity2_DKS\data\config.xml" won't affect anything on versions above hotfix one.

Just a fun observation: all ppl who has issues with GFX/fps here uses ATI. It could be fun if it wasn't so sad.

Joined: Feb 2011
W
stranger
OP Offline
stranger
W
Joined: Feb 2011
Yeah, I've tried the latest patch, no difference at all, I'm convinced it's an ATI/Radeon issue, the game still runs bad on the lowest of low settings.

Joined: Feb 2011
W
stranger
Offline
stranger
W
Joined: Feb 2011
Sorry I spoke too soon, I was just in an area with better framerate. Timeslice shadows make no difference. I'm using Catalyst 10.11.

My new theory is that it's due to PhysX being supported horribly/not at all on ATI video cards (PhysX is an Nvidia thing). For example when I try to enable PhysX in Arkham Asylum the game turns into a slideshow. At least Arkham Asylum lets me disable PhysX! I can't find a way to do this in Divinity 2.

If anyone could tell us how to disable PhysX we might get to the bottom of this. Thanks,

Joined: Feb 2011
W
stranger
Offline
stranger
W
Joined: Feb 2011
OK I downloaded FRAPS for some proper testing. With timeslice shadows off I get 40fps. With timeslice shadows on I get 75fps (max for my vsync refresh rate). However the game just looks juttery... like it's not really running at 75 fps. This might be due to a lack of motion blur or something. It's still a huge improvement.

Joined: Feb 2011
W
stranger
OP Offline
stranger
W
Joined: Feb 2011
This wouldn't surprise me, games that use the Gamebryo engine never fail to cause me headaches.

Last edited by WDeranged; 27/02/11 01:34 AM.
Joined: Dec 2010
Location: Australia
T
enthusiast
Offline
enthusiast
T
Joined: Dec 2010
Location: Australia
Originally Posted by wesleyshaver
Sorry I spoke too soon, I was just in an area with better framerate. Timeslice shadows make no difference. I'm using Catalyst 10.11.

My new theory is that it's due to PhysX being supported horribly/not at all on ATI video cards (PhysX is an Nvidia thing). For example when I try to enable PhysX in Arkham Asylum the game turns into a slideshow. At least Arkham Asylum lets me disable PhysX! I can't find a way to do this in Divinity 2.

If anyone could tell us how to disable PhysX we might get to the bottom of this. Thanks,


That's a good point - I have an NVidia GTX 295 (which is a dual SLI on a single card, fastest NVidia card I could get a year ago when I built my system), and I recent'y added a 9800GTX from an old PC to use as a dedicated Phys-X processor.

I noticed frame rate increases immediately on Phys-X games (Arkham Asylum was completely smooth, whereas it used to stutter occasionally in stereo-3D vision at full HD).

So even with fairly high-end NVidia hardware, Phys-X seems to be a drain...

Joined: Feb 2011
W
stranger
OP Offline
stranger
W
Joined: Feb 2011
When I replaced my GTX 280 with this Radeon 5970 I actually had a slight drop in the performance of PhysX games, some games simply can't take advantage of these Crossfire cards.

Ultimately the games are still perfectly playable, no where near as bad as the performance I'm getting from DKS, the problem on my PC seems related to something else.

It's a shame, my excitement for the game is definitely waning after five days of fiddling around with hardware settings.

Joined: Aug 2009
Location: Soviet Empire
veteran
Offline
veteran
Joined: Aug 2009
Location: Soviet Empire
You can't disable PhysX on ATI cards because it is not enabled at all. All PhysX things calculated on CPU is this case (just like if you disable PhysX in for nvidia cards in it's Nvidia control panel).

Joined: Feb 2011
W
stranger
OP Offline
stranger
W
Joined: Feb 2011
*bump*

Still having no joy here, I tried different drivers and the game still runs terribly, regardless of detail settings.

It's a shame to have to give up on what seems like a pretty good game.

Joined: Mar 2011
R
stranger
Offline
stranger
R
Joined: Mar 2011
I have similar issues.

Tinkering around I can get:

AA to work, but no crossfire.

Crossfire to work, but no AA.

Both break shadows in one way or another, HDR breaks both, but it looks great still minus some odd terrain anomalies, at 15fps or so.

I can get it to "play nice" at 60+ FPS with no eye candy what so ever, but, it looks terrible.

Grrr.

Edit:
Kind of fixed.

Giving up on HDR/Crossfire is the key.

Morphological AA is okay, too.

Last edited by Rupert; 17/03/11 09:56 PM. Reason: I lost my pants.
Joined: Apr 2010
Location: USA
member
Offline
member
Joined: Apr 2010
Location: USA
To OP:

Contact Larian support, as recommended earlier. They have a pretty decent turn-around time (usually about 24-48 hours), and you reference this thread if needed. Provide all your comp info for them, and the trouble shooting steps you've already tried, as well as the problems you're having. I'm fairly certain they will be able to help you.

You can email them at support@larian.com-- I believe Lynn is the one who 'answers'. She answered an email question I sent within about 24 hours of me sending it. Was very pleased with the assistance I received. That's my suggestion, since the forums have not provided an answer for you (and I don't have any suggestions, because I'm not that computer-literate!).

Best wishes. Ego Draconis was a lot of fun to play, and I'm working on the revamped version now (DKS) (going slower, though, because I have less time then when I first got ED).

All best,
~~CierraShore



"I don't need to get a life. I'm a gamer, I have LOTS of lives!"
Joined: Feb 2003
Location: Ghent (Belgium)
veteran
Offline
veteran
Joined: Feb 2003
Location: Ghent (Belgium)
Yes indeed, contact support@larian.com wink

To gain some more information about your issue, please provide us with the report generated by the following support tool.

http://www.larian.com/hotfixes/supporttool/LPC_Divinity2.exe

Please send the report to support@larian.com
And maybe reference this forum thread.

Thank you,
Lynn

Joined: Nov 2010
journeyman
Offline
journeyman
Joined: Nov 2010
1) Why do you need 60FPS? Normal video runs at <=30FPS.

2) what's the res of your screen? I have a 2560x1600 and to run with max settings on everything, I had to scale down and use 1920x1200 (which is still >HDTV's 1920x1080, BTW)...

@ max settings almost everywhere, (I timeslice shadow updates), I will usually ~ 30FPS -- sometimes up in the 50's and sometimes down around 15-20 -- but the extremes are special cases, like the highs are 'indoors' (so no great depth of field or lots of graphics to compute), and the 15-20 were in one of the floating-islands (Stone's I think), that had lots of blackened field-grass everywhere -- that really slowed things down.

Other than that, given my setup (24GB@1333GHz mem, 6-core, 3.4GHz Xeon Win7-64, w/1.7GB graphics on dual-GPU, GTX295 card), I was surprised at how taxing this game is vs. similar settings for a game like Oblivion which seems to have more external textures and a huge depth of field/view, though I think the people models are lower-res.

So, I dunno... 60FPS might be nice, and I can get it if I turn down the settings, but things don't look as nice, and I really don't think my reflex care I get 33ms response time vs. 16.7ms response time, since human reflexes, at their fastest are easily slower than 50ms... but are you human? hehe

Dude, your cover is blown! Seriously, I understand the desire for 60FPS, but for what **looks best** while still being quite playable, 60FPS means you've got a game that doesn't take advantage of your graphics/cpu. You want the highest res you can get, while 'bottoming out' at 24-25FPS. If you are frequently below 24, then you need to reduce the graphics complexity and/or screen resolution.

So what are you using for resolution and settings?




Joined: Nov 2010
journeyman
Offline
journeyman
Joined: Nov 2010
You never mentioned what resolution you were trying to run at...

Though you said you tried all the options, so presumably you tried lower resolutions as well?


Page 1 of 2 1 2

Moderated by  Bvs, ForkTong, Larian_QA, Lar_q, Lynn, Macbeth, Raze 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5