Larian Banner
Previous Thread
Next Thread
Print Thread
#519133 14/07/14 05:52 PM
Joined: Jul 2014
W
Writhan Offline OP
stranger
OP Offline
stranger
W
Joined: Jul 2014
Hola,

There's definately issues with pressure on the graphics card on some systems. Unless this is just the engine thats poorly optimized, but I am hoping that's not the case.

My 670 GTX idles at around 40 degrees, at maximum I usually experience it peak at 55 degrees or so in most games (Crysis etc). But in D:OS it goes all the way up to 70+. Yes, I know this is not "dangerous" and it's still viable to play at these temperatures - but that's not the point. I'd advice you investigate if there's something linked to certain resolutions or graphic cards that can be the cause.

System specs:
- Windows 7 64 bit
- 670 GTX (Driver 337,88 atm)
- Resolution 2560x1440

And before anyone has any generic response:
- Yes, the card has been dusted off.
- Yes, I tried with the newest and/or older drivers.
- Yes, my airflow is just fine.
- Yes, it's only in D:OS I have these "extreme" temps.
- Yes, I tried with and without Vsync.
- Yes, I disabled shadows.
- Yes, I basically tried in lowest graphic/Highest graphics with same results.
- Yes, I remember to wash hands after I visit the bathroom.


Thanks.

/A concerned customer.

Joined: Jul 2014
A
stranger
Offline
stranger
A
Joined: Jul 2014
Agreed. From what I've read Radeon graphics have a hard time with this game. I've tried adjusting settings back and forth in game and in my control center outside of the game with no improvements. The second I start up the game my video card fan starts running like wild. When I alt-tab out of the game my video card fan spools down; When I alt-tab back into the game my video card fan starts to spool up like crazy again. It's overheated my video card multiple times.

Like you say other hardware intensive games (Crysis, Skyrim etc) run without any problem on max graphics. My computer is freshly cleaned, up to date and has no airflow problems as you have stated.

This is somewhat disappointing as the game itself seems great. I will hold out hope that it gets optimized. As it is still a new game I understand that there could be/are unforeseen problems. I just hope that this gets fixed in a timely manner.

If you find any fixes please do share with the community.

System specs:
ATI Radeon HD 5700
Resolution 1440x900
AMD Athlon II X2 250
6.00 GB Dual-Channel DDR2
Windows 7 Ultimate 64 bit

Thanks!


Joined: Jun 2014
I
stranger
Offline
stranger
I
Joined: Jun 2014
For me its particle effects that kill it. But then again, my card is prehistoric and was already shit when it came out so i dont want to make too much of a issue of it, just indicating whats really bad. Although a option to turn them off even if it looks terrible would be nice (it already looks terrible since i turned everything way down).

Last edited by i30817; 15/07/14 10:40 AM.
Joined: Jul 2014
Z
apprentice
Offline
apprentice
Z
Joined: Jul 2014
(before you dismiss this post, which is kinda wordy, jump down to the bolded part if you wanna skip right to the POSSIBLE solution)

Im paranoid about GPU temps. Ever since my nvidia 8800GT melted when it hit 90C for too long (yes, the plastic cover melted, dripping onto the fan, which stopped the fan and the card went sizzle sizzle) ive been really strict about how hot my GPUs get.

Regardless of the card, I like to keep the temps, at load, around 70C.
For me, the biggest culprets for drastically heating up the GPU are as follows:

Ambient Occulusion
Shadows
Super high particle effects
Vsync being off in a game that gets 100+ FPS

Typically, in that order too. For whatever reason, AO REALLY puts your GPU to work, causing the biggest amount of temp increases in pretty much any game. All for a bit more shaded depth in the visual department. Games that dont give an option to disable AO, I typically dont play. (good thing DoS does. Props to the devs)

The other thing that ups my temps is when a game isnt using vsync, and is performing WAY above what it needs to be. IE: a good example, Dawn of War 2, I get 400 FPS on the menu screen. Thats 340 more FPS than I need, and all those extra frames are work the GPU is doing, upping the temp of the game. Enabling vsync (and capping the FPS at 60), is often one of the best ways for me to control my GPU temps.

Now you say you have disabled things, and set the game on low, Here is something many people dont realize... its concerning vsync (which you say you have tried on and off).

Vsync, doesnt always work, even when you turn it on. It really depends on your screen mode. Some screen modes dont seem to support it when its a built in game setting. Some games totally ignore your GPU driver settings. Its a total gamble which is going to work.

So first, why is vsync important when it comes to GPU temps? Thats easy. Vsync caps your framerate. If your card is strong enough to be OVER performing (ie: getting 150 fps, when 60 is decent enough), thats extra work your GPU is doing, which causes the temps to go up. Vsync essentialling limits the amount of work your GPU needs to be doing.

Second, how can you be sure that vsync, when check "on" is actually working like it should? First, you need a tool that can measure your framerate. For me, I purchased Fraps a long time ago, and it has a nice little numeric overlay in the upper corner that can show me my framerate in any game. There are LOTS of programs that can do the same thing for you as well. Just google it. Once you have one of these installed, and can see your framerate, you will be able to see if vsync is actually working. You need to know what the refresh rate of your monitor is. For most, this is usually 60. This means if vysnc is actually working, your FPS shouldnt ever go higher than 60.

With Divinity, I quickly noticed that even with vsync checked on, not all the screenmodes supported it, and saw that my FPS was going well above the refresh rate cap of 60. Without being able to see my framerate, I would have just assumed vsync was working, and my temps would have gotten a lot higher playing the game.

So how to fix it... Enable vysnc. If it shows your FPS going above 60, switch your screenmode to a different mode. There are 3 that Divinity supports. Try different modes with vsync ON, until you find one where your framerate doesnt ever go above 60.

If you have a monitor that has a much higher refresh rate, Or, no matter which screenmode you select, vsync doesnt seem to be capping your framerate, you are still in luck. Divinity has a neat little feature that lets you manually cap your framerate. You can enable this, and then set it to 60 manually, even without the use of vsync.

The only downside about manually capping the framerate this way, from what Ive experienced, is that it seems to cause a bit of stutter sometimes (which it shouldnt). Surprisingly, vsync (with adaptive set in my driver settings), runs the game smoother, even though its still basically doing the same thing of capping the rate at 60.

Try it out. Let us know if you find any different results.

Last edited by Zewks; 15/07/14 05:01 PM.
Joined: Jul 2014
stranger
Offline
stranger
Joined: Jul 2014
I definitely had lots of BSODs with DOS, which were quite unpleasant even with save-anywhere (extra thanks to the devs for the latter btw; many games are really sloppy with saving lately), since you are just waiting for it to happen again instead of enjoying the game. I was able to localize them to the graphics by trying several things. What seemed to have helped so far was to set low-ish settings, window mode, and vsync to 50. I suppose vsync only makes a difference if your actual framerate would be higher without it, so that capping it would give the GPU some breathing space. Also, the issue seems to be relatively sporadic, since when I was running it with the temp monitor, it was within sane limits most of the time.


Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5