Larian Banner
Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
#572151 27/10/15 06:01 PM
Joined: Sep 2015
C
stranger
OP Offline
stranger
C
Joined: Sep 2015
I have a Logitech 3gc controller and the game will not let me select controller option.

I tried using the 360 emulator but still doesn't work.

Are a any other controllers supported?

Joined: Oct 2015
K
stranger
Offline
stranger
K
Joined: Oct 2015
Same here..anyone know something abount it ?

Joined: Aug 2015
N
apprentice
Offline
apprentice
N
Joined: Aug 2015
Originally Posted by CottonEyeJoe

I tried using the 360 emulator but still doesn't work.


Which emulator are you using? X360CE?


Last edited by Nehm89; 27/10/15 07:29 PM.
Joined: Sep 2015
C
stranger
OP Offline
stranger
C
Joined: Sep 2015
Originally Posted by Nehm89
Originally Posted by CottonEyeJoe

I tried using the 360 emulator but still doesn't work.


Which emulator are you using? X360CE?



Yes the 360ce tried both 64 and regular

Joined: Aug 2015
N
apprentice
Offline
apprentice
N
Joined: Aug 2015
Are you sure you're using a Logitech 3GC? Isn't that a Steelseries brand gamepad?

Scratch that, kind of an irrelevant question. Trying to get my DirectInput gamepad to work with X360CE.

I'll update if I find a fix.

Last edited by Nehm89; 27/10/15 07:45 PM.
Joined: Aug 2015
N
apprentice
Offline
apprentice
N
Joined: Aug 2015
I got the game working with my PS2 to USB converter with X360CE. While not the same gamepad, they are both directinput devices, so this should also work for you:

1. Download the 64bit version and place the x360ce_x64 application inside the same folder as the game launcher -- "EoCApp.exe" (should be located in steamapps/common/Divinity Original Sin Enhanced Edition/Shipping).

2. Launch x360ce_x64 from inside that folder and create the profile as you normally would.

3. Select the "Game Settings" tab in x360CE. Select "x360ce_x64.exe", check all 64-bit checkboxes under the Xinput Files on the right. Push "Apply/Synchronize Settings". Do the same with EoCApp.exe -- if they are already checked, great! (If you get any popups, just click continue.)

Save, close X360CE and then launch D:OS EE.

I hope this works for you, as playing this with a controller is pretty darn slick.

Joined: Sep 2015
C
stranger
OP Offline
stranger
C
Joined: Sep 2015
yes my mistake it is a steel seeries

Nehm89 thanks for the instructions but still does not work for me frown
it says executable not found when trying to sync but the checkbox it ticked

Joined: Aug 2015
N
apprentice
Offline
apprentice
N
Joined: Aug 2015
But you do see the EoCApp.exe on the list?

Joined: Sep 2015
C
stranger
OP Offline
stranger
C
Joined: Sep 2015
yes it's on the list

i deleted the exe and am now doing a steam validating to reinstall it. Hopefully that works

That didn't work

Last edited by CottonEyeJoe; 27/10/15 09:39 PM.
Joined: Aug 2015
N
apprentice
Offline
apprentice
N
Joined: Aug 2015
What does it say under "Full Path" for EoCApp.exe?

The executable X360CE is looking for is not there. You need to link the D:OS EE exe file to X360CE.

For example, my D:OS EE exe is located in "D:\Games\steamapps\common\Divinity Original Sin Enhanced Edition\Shipping\EoCApp.exe"

You can click "Add" at the top and browse until you find the correct location.

Last edited by Nehm89; 27/10/15 09:52 PM.
Joined: Sep 2015
C
stranger
OP Offline
stranger
C
Joined: Sep 2015
The path was correct.

I deleted what was there than added it again.

That did it controller is now working. Well sort of.

The right analog stick operates triggers instead. I seen a work around for this before
by deleting and replacing a file which I did. But didn't help/

Still thanks for all the help. I might not be able to rotate camera but I can deal with
that for now until I can find a fix.

Last edited by CottonEyeJoe; 27/10/15 10:25 PM.
Joined: Aug 2015
N
apprentice
Offline
apprentice
N
Joined: Aug 2015
You're most welcome!

Short of remapping your right stick in X360CE, I can't think of anything else to fix your other problem, heh.

Joined: Jan 2016
_
stranger
Offline
stranger
_
Joined: Jan 2016
I tried the same thing using Windows 7 but got an error "Cannot Load C:\Windows\system32\XInput1_4.dll error:0x7e" when I ran the game. Any idea what the issue could be?

Thanks!

Joined: Mar 2003
Location: Canada
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Location: Canada

Do you have the x360ce program, ini file and xinput1_3.dll file it creates in the EE shipping install folder?
In the Game Settings tab, on the My Game Settings tab, there are checkboxes to specify which xinput files to use.

https://github.com/x360ce/x360ce

I only tried x360ce briefly to get a Steelseries 3GC working, but it didn't recognize the sticks, and I didn't do much troubleshooting. I had it set up and fully working using motion In Joy, but it stopped recognizing the controller at all, until I went through the initial setup again. It also wasn't recognizing the sticks properly, but I couldn't remember how I set it up the first time (I didn't have to do anything special).
The problem was rendered moot by a sale on a better controller.

Joined: Jan 2016
J
stranger
Offline
stranger
J
Joined: Jan 2016
I'm having a similar problem on OSX/Steam with a DS4 controller. I can get the game to recognize it as a PS4 controller, and it works perfectly well in the initial game menu. However once I get into character creation or in-game, the X button suddenly becomes unresponsive, and I have to force quit the application.

Joined: Jan 2016
_
stranger
Offline
stranger
_
Joined: Jan 2016
I am using x360ce. It looks like it is pulling the files from "C:\Windows\system32" instead of the local directory (like we want). Once I change it to only install xinput1_3.dll there is no error but it does not recognize the joystick. frown

Any idea on how to get it to load the right version of the dll?

Joined: Jan 2016
_
stranger
Offline
stranger
_
Joined: Jan 2016
BTW: Renamed the dll in system32 and it got the same error for xinput1_3.dll. It is pulling in the wrong version of the dll.

What's up with Larian Studios only supporting 2 joysticks. It's not hard to support a generic joystick.

Joined: Mar 2016
stranger
Offline
stranger
Joined: Mar 2016
Hey,


I did all of the above that Nehm89 said without any problem. Now when I start the game, the prompts shown on loading screen tips(on the first loading) are displayed as controller buttons BUT I am still unable to play with them or even tick the controller option under game settings.

I am using 2 D-input controllers, one being DS2 and the other one a copy of that. Used those two for many games, worked with all xinput profiles and under both x32 and x64 games but no matter what I try, I can't make them work for D:OS EE
I am also on Windows 7 and I got my game from GOG

I'm really in a corner here and I would aprrecciate any kind of help. Thanks!

Last edited by geøstigma; 22/03/16 01:30 AM.
Joined: Mar 2003
Location: Canada
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Location: Canada

If you are getting the 'Press any key / A to start' screen on startup, the game is detecting a gamepad, at least.

Did you try with just one controller?

Did you try all the buttons and sticks on the controller, in case they were just mapped incorrectly?

In x360ce, under the Controller Settings tab, try different profiles in the 'Most Popular Settings for My Controller' tab.

Joined: Mar 2016
stranger
Offline
stranger
Joined: Mar 2016
The funny thing is that I am not even asked to "press any key" on start. Instead, after the initial loading screen, I hear a funny sound, twice. It's the exact sound that plays alongside with the "click" sound when you click on "Options" menu and the one that plays when you go back from "Join" menu. I don't know what it could be.

I played around the setting in the x360ce and I tried so many things. I usually do not resort to forums until I am defeated and have nowhere else to turn which seems to be the case now smirk

Edit:
Also, yeah, I have pressed every single button multiple times and I have also tried using only one controller but nothing seems to work. From what I see around the web, seems like awful lot of players are having this problem. Maybe we can expect a patch or something in the near future that should make it playable for us in co-op?

Last edited by geøstigma; 22/03/16 04:25 AM.
Page 1 of 2 1 2

Moderated by  gbnf, Kurnster, Monodon, Stephen_Larian 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5