Larian Banner
Previous Thread
Next Thread
Print Thread
#618852 22/09/17 09:04 AM
Joined: Apr 2011
OP Offline
Joined: Apr 2011
I'll use this topic to post bugs, exploits, quirks etc. throughout my playthrough of D:OS2, as I did with D:OS beta, D:OS, and D:OS2 beta.
Sadly due to a firstborn taking up most of my time I haven't played the beta of D:OS2 nearly as often as D:OS1 to give regular feedback on it. Due to that I'll probably wont be able to update this topic regularly, since I can't play much regurlarly. But I'll always return back here after sessions.
Considering I write as I play, the further down you scroll the more you'll get spoilers along the game. Due to the nature of the topic, be advised, there WILL be spoilers, and they wont be marked.
Hopefully this can all be of good use.
If these sound nitpicky at times it's because thawhat it is at times. All to make the game the least buggy it can be.

Bugs (
*Doesn't quite look good, the other fangs do match the color, this one's the head's bright red instead instead of collor darker red;
*Even if the rug was folded, what's with the yellow stripes suddenly stopping?:
*No VO for all steal-failing convo? Rather odd in an otherwise fully voiced game.
*You don't know any effects, even of water. But do of the cup of milk, apple-juice or orange juice. Mashed Patato was known too, but that might have been the recipes. Even if so, patoto is still unknown, so that seems rather arbitrary. Same for cheese bread and pumpkin soup. Rather odd random items to know stats off right away. And Intestines apparently. Yuck.
*The zoom in for conversations function fails upon trading, afterwards it'll be zoomed out again till convo re-initialisation.
*Lizard tails still clip through chairs while sitting:
*There are several lines on the floor flickering while rotating (from other games this is overlapping textures, not sure here, seems likely).
*Talking to the Beast the narrators "squeeek" is unvoiced/nor has any sound.
*The sitting dwarves soul collor pretty much goes through their neck and faces.
*Getting recipes on the ship the 3rd and 5th mashed patatoes are the exact same one (cold mashed patato + boiling pot)
*There seem to be a few issues with sitting and outstretched arm animation. On short lines it loops and gets cut short. On longer it hangs, the character goes completely animate-less and then jitters about rather oddly when the line ends.
*Fane likes holding his hands to his tights, clipping his book in his knee before dissapearing entirely. Not that the book is generally visible. It wasn't first meet, even if the text kept refering to it. He probably shouldn't use the knee thing at all, just keeping his book reading.
*Kitchen Pot don't stack, but Cooking Pot (same item) does. Although I also have an idividual cooking pot smirk.
*Magister and Sourceror Food Supplies item contents match. From the title it seems Magister's content are supposed to be different.
*The empty cups and bottle of wine in the cupboard of Magister Williams closet do not stack with all other empty cups/bottle of wine. I really wish this D:OS problem would not surface again frown
*Garlic does not stack. I realise since different model, but still annoying in the inventory.
*I also agree with a workshop mod that bedrolls should stack.
*Beast and Ifan's conversations can be repeated on knockdown, Lohse and Sebille cannot. Also Beast and Sebille are knocked through their chair, lying under them. It looks... funny.
*You can trade with Magister Siwan while she's knocked down and dying.
*On Magicks Faire and Foul doesn't change description from "Use to read" after reading. Could be due stolen property? Same for Soggy Diary. Not stolen this time.
*It appears it's possible to murder your teammates on the ship, raid their corpses and find them alive in Fort Joy, naked but alive. Atlhough they gain full gear upon joining (Lohse anyway, Ifan kinda died in his own battle as I rushed trying to see if I screwed myself over):
**I did loose Beast's hat and Ifan's letter upon arriving on shore. Oddly, kept Beasts's letter.
*Captain's Journal seems to indicate it has a last entry that's readable, but... nothing?
*Ships dont work like this:
*Fane's reading animation on the upper deck also has him randomly stop reading and put the book in his crotch before proceeding again.
*Talking to him THERE (as undead) the book just sits on there floating under him while he waves around his arms without it smirk
*My tail is flickering!
*The craftingbook you find just after the Voidwaken attack at Fort Joy. Yeah, useless now since it's automatically given information at gamestart smirk
*Submerged shell:
*Fane's starting book about Lucian probably should have a new line after the title beofore starting the * text, rather than * without space.
*Apparently "zoomed in conversations" on Atusa cuts off her head 0_o
*Trying to sell things to Unnis (21 gold) to 21 gold, and pressing the balance with gold button did nothing. Also doesn't show physically she has gold. Other vendors seemed to work fine.

*The Stool saga. Sitting on chairs that are (by default!) placed very wrongly. Seriously, nobody thought about sitting on every chair ingame to check their default settings are not weird like;

Last edited by Hassat Hunter; 22/09/17 01:49 PM. Reason: Apparently Alexander's collar is intended according to the questlog.
Joined: Apr 2011
OP Offline
Joined: Apr 2011
Got a couple more hours in, and seesm I broke Griff's questline... greeeat frown
Seems even with my experience from beta, this Fort Joy attempt goes worse. Not because I do worse, but because quests get into deadlock and things don't trigger properly.

*Seems my killing screwed up quests though. Both Ifan and Lohse's quests mention they are dead, despite being in my party smirk
*More instantly known effects: Yarrow flower, eggs, mashed potato, cheese bread, pumpkin soup, tea herbs, poisoned fish pie (seeing the poisoned beer is unknown), boiled patato (crafted), Dinner (crafted)
*Odd "character" till conversation with Gawin triggers (There's also one at the other side. Don't think triggers are supposed to be pointed out):
*Assassination Contract (Red Prince questline), Magilla's Journal, Adventures of the Hero, Sticky Letter, Houndmasters Logbook and Scrapbook, Son Against Father remain "use to read".
*Repair needed increases price? I got shivs (6 gold) and 1 with 19/20 durability and that sells for 10 gold, even though it's the same item. That makes no sense!
*Each party member can listen to Margo's story, each gaining a restoration scroll.
*Chirp-chirp of Septa is soundless (for the no-Pet guys)
*It appears the 600XP from sleeping with Stingtail is only given to the Red Prince, not the whole party. Considering no other XP bonus has been for a single member, I doubt this is intentional.
*If you offer the doctor booze, she takes the FULL STACK. 2 bottle of beer gone, reloaded, dropped it, 5 mugs of beer, gone. She also gives double-XP for some reason (once upon giving the beer, once after the convo is done). Oddly enough the Yarrow plant encounter nearby does work properly.
*The escape updates WAY too soon after giving the ring to Yarrow. It mentions she gives us a key, but nothing of the kind has happened at that point, it happens at the beach much later than you get the quest update.
*Yarrow mentions she'll point you to where you can use the key, and from beta I can recall she pointed out a secret door. Nothing of the kind here though, reward box, taking reward, nothing.
*When going over the max amount of money a vendor has, while some money is laid in, clicking the "fill with coin" button just swaps what the vendor has left with the amount in the box, rather than maxing it out.
*Saving Saheila Lohse's "let's go" is unvoiced.
*You can mention Amyro to Saheila far before you even know they're connected (just talking about far-seeing).
*After forcing Stingtail to use the Daedra to go to sleep there seems to be no way to make his name known to Griff, thus freeing the Elf. Only killing (by forced killing) is an option. And if I kill Stingtail, Griff will attack me regardless since the oranges are empty. And Butter still wants me dead then too despite our love smirk.
*Verdas "and I'm done for. But you, there's still hope" has a bunch of VO infront of it that isn't subtitled.
*I noticed Lohse seems no longer source-muted (no icon). Could be because Leadership, or her battle with Saheila. Only noticed it after these events though, so not quite sure.
*Emmie and Bruno's barks are very soft (especially after the voiced woof woof).
*Questlog tries to point me to Sebille after talking to the elf in the cave. Even though she's really REALLY dead (killed once more in the Fort).

Joined: Apr 2011
OP Offline
Joined: Apr 2011
Just mopping up Fort Joy mostly, which takes time. So small report for now:

*Interacting with an Iron Maiden the bleeding effect says it does piercing damage. Isn't that supposed to be physical damage? Death Wish spell also says piercing. What's special about it? Ignores armor?
*I have a feeling that corpse is supposed to be on the painbench:
*Why doesn't teleportation list the damage it does?
*Double bench-saw:
*More items that don't stack: Spoons, Targets.
*More "use to read": Craddleson's Silly Book of Blanks.
*At the top of the fort there can be 2 books found called simply "book", remaining use to read and 'book' even after reading.
*They can't open the door, so you can really cheese them from this location. Until they could suddenly cut me up there, while I could not melee down. Also their attacks of opportunity triggered but failed;
*Rope does not light up when using alt.
*Using the Bench Saw to cut a log, the crafting menu entry is broken:
*Shouldn't the spoon, cutting board and light golden teaspoon be in misc, not ingredients?
*Seems I've gotten 4 stackable bowls and 1 unstackable bowl. Don't recall where I got it, but probably the toppart of the fort.
*Source Hound Gracie's bark or gnarl has no sound, and she doesn't speak with my Pet Palled Red Prince (using just bark), only Ifan.
*Talking to Lord Withermoore nothing happened. Only talking to him *again* (without taking the spear) activated the journal entry.
*The used-to-be Blood Rose in the Beta in Joy's dungeon is now an ordinary rose. Not perse an issue, but it can be eaten for literally no effect for 10 turns. I doubt that's intentional.
*I'll make a giant post of weight-issues (just like in beta, just like with D:OS) soonish, since there are still a LOT of odd values floating about, and as I continue I'll probably find hundreds more frown but here are some examples:
** The Sparkler Card, a single playing card... weighs 0.2
** Quil; 0.05, Ink 0.2... Quil+Ink 0.6
*Here's a screenshot for my earlier reported Unnis vendor issue;
*Using the boat simply teleport the Black Cat to you from whatever location it was at, making that achievement very very easy.

Last edited by Hassat Hunter; 25/09/17 10:06 AM. Reason: Recalled cat-bug
Joined: Apr 2011
OP Offline
Joined: Apr 2011
Mopped up the remaining fort forces and escaped. Here's the new bugs so far;

*Talking to Tola, saying you wish to challenge your teammates, then back out "as you wish" VO-level is MUCH lower than every single other line.
*It appears you cannot continue the Arena questline since it doesn't allow you to fight any of your teammates in single-player???
*Stardust Herb has the "consume" option, it just doesn't do anything. Should be greyed out then.
*The guardians (souljar quest) are skeleton but sounds very human when hit or attacking.
*Why does teleport (and apparently also flurry, I suppose all offensive skills) outline dead opponents in thick red outlnies? (noticed at souljar location)
*Using the Face Ripper gives the Apprentice achievement (using a source spell) despite that not being a source spell and Fane still having his source collar.
*My party of 3 often has difficulty with ladders... I *think* it's the black cat blocking their path.
*The bucket next to the bath in the Fort is used for transporting fish? Yuck... other bucket is probably more suitable wink
*Enclopedia of Flora, Tales of the Seven Gods, Cautionary Pamphlet, On the Origins of Lucian also keep "use to read". I feel like that might be intended, but during the tutorial they all got replaced far I know upon reading smirk
*It seems while fire dissapates, poison, oil and smoke lasts forever? Could be the save-gamebloat I've seen some other users talk about.
**Looking at the outlines if using boulder, the fragments of broken barrels also never despawn.
*Richly-bound book is still called that after reading. Also description makes it seem it should be valuable, but it's 1 gold of value like most other books.
*Frolie & Modi's lines seem to randomly be unvoiced (might be related to being collar-less?)
*Finding Withermoore's dead corpse (broke the souljar in the chamber) and looting him doesn't finish his quest???
*Approaching Davya triggers combat? I recall from EA there was a whole cutscene with conversation and all, killing the silent monks. Also the 2 people at the harbor happilly keep chatting on.
*Found 2 plates (with a border), somewhere in the fort. They appear in the ingredients, same description as plate and old plate who appear in misc. Found one more on a dead magister ranger in the swamp.
*The ! over teammates for escaping lasts much short than the conversation with the cat...
*Mending and Soothing Cold seem to do more healing than they claim. When it was 8 they did 9. When it said 11, they did 13.
*Badly placed bed:
*That's not a relic. Was a bit too fast in stealing it, but it hang over that altar;

Joined: Apr 2011
OP Offline
Joined: Apr 2011
I forgot how annoying and riled up that stupid Gargoyle Maze got me. Got into it today again, still hate it. Still want to drop the game... Still going to totally circumvent it. Stupid %@##@# place. Drains all the joy out of the game.
Anyway, another day of D:OS2, almost finished with Fort Joy again, just that Maze's dungeon, killing Radeka, the final fort, and trying to finish all the 20 unfinished questlines in my journal. Most of which I have no idea how to proceed if possible at all. Fun smirk.

Bugs (
*Typo (pic). VO is okay though.
*Why is Simone (camp Amadia) also hurt? She's the healer (well, cook)!
*Matis "Gareth is looking for a way to defeat them now [...]" line is much louder than all his other lines.
*Issue with reward Healing Touch quest, Lohse cured all with Restoration (She only doesn't talk with Red Prince, my Main, the rest works fine :/):
*One of Exter's sheet of paper isn't properly bound to him and can be taken without being "stolen"
*Similarly, still half of Kerbans items are up for grabs. Used to make a little sense when they were all damaged, but now only the melee still uses said system and has 0 durability, the other items being perfectly fine.
*Is it intended the wounded try to sell you their rewards for healing them?
*VO: Even if he. ST: If he even
*You can see the sea suddenly breaking off if rotating through the shrine:
*Using the repair hammer doesn't actually fix weaponry anymore? How do you restore durability? Not? What purpose has a repair hammer now then?
*Mackarel under the ground:
*The Vault of Braccus Rex's magic entrance GFX doesn't appear if you load a savegame infront of it. You can still enter it though.
*Trompdoy cast a water balloon on the ground even though everyone was already wet from rain?
*Combat Log doesn't write down amount of magic armor enemies regenerate due to soothing cold (and probably armor equivalant)
*How does an illusionary chest burn?
*Or weigh 50, or... fit in your inventory, or has visibility glitches (no, I don't talk about it's see-through appearance):
*Phoenix Egg whaaaat?
*In the mysterious room the SMALLEST painting weighs the most smirk (all other bigger ones are 1 weight)
*Apparently the Amadia (back-access?) vines are not detected if far away and pathing will fail until reaching closer and the game realises the vine's existance.
*Enabled the Shrine and talked about Gareth now Gratiana doesn't allow me to talk about her Soul Jar or the Purging Wand I found till I save him???
*Beehive should get the "interaction" icon upon hovering, not the "unlooted"
*In the Radeka fight all her spawns go after all your units since they enter combat late, before going Round Robin on round #2 smirk
*Redaka's Blood Sucker spell heals you? (She can cast it on foes, but my first attempt she gave it to Lohse)
*Looting Redaka's cave is EXTREMELY annoying and difficult smirk
*While being Charmed Fane cast Restoration... he doesn't KNOW that spell, nor does any of his items give this spell.
EDIT: Do Charmed use scrolls? Should they use scrolls? I didn't check if his scroll got used up, mostly cause we all died.
*Radeka's "I'm coming for you" and "Argh" is unvoiced.
*Trying to talk to the Dragon the quest-entry reads 'We met Slane the Dragon'... how do you know the name if it can't talk to us yet?
*You can cripple crates
*Is an endgame hidden chest supposed to have a measly my first bow in it? (buried chest in camp before final fort)
*Appears Pixie Dust doesn't appear with alt? (found one hidden in one tent, really really hard to see)
*Pillow doesn't appear with alt.
*Peppers don't stack.
*An empty potion bottle found at the destroyed seeker camp before the fort doesn't stack with the other potion bottles (unless there's a stack limit of 15?)
*Found another non-stacking empty potion bottle at the corpses near the shrieker near Gareth.
*The squirrel there contains rabbit paw and rabbit meat loot!
*If you use the curse from the lever while wearing the Band of Braccus, the curse remains. You need to unequip the ring and re-equip it to get rid of the penalties.
*Found a Fish bone, couldn't reach, decide to teleport. Has some GFX issue when doing so:
*Wait, an enemy ranger used Richochet on a dead ally, then it still hit 3 of my people? Shouldn't it be 2 in that case? If using it on dead allies to trigger is even an intended thing.
*Thulnir: Barking isn't howling. Also very soft VO-clip again.
*The empty mug near the pigs doesn't stack with the 2 other empty mugs I got.
*Pigs squee squee is unvoiced (floating dialogue).
*Voidwoken Deep-Dweller taunted *only* Lohse instead of my Main; The Red Prince.
*"Hot enough down here to melt silver" is unvoiced.
*Still hate the Gargoyle Maze: Went right, used skeleton head there to open door to teammates at the other side of the portal, aaaand... stuck? No way to continue? I guess I'll just skip it per the beach as I did in EA. Screw that.

Seat adventures:

Last edited by Hassat Hunter; 30/09/17 09:38 PM.
Joined: Apr 2011
OP Offline
Joined: Apr 2011
Don't know when this weeks big patch hits, so here's todays findings:

*Tried traveling with the other entrance to the Seeker camp (near the bell); same 'can't reach'.
*Transforming from one species to another with the changer mask inproperly fails to apply the proper icon, changing it into the default Red Prince icon till changing back to normal and to another species again.
*Bahara's "As you wish" is almost inaudiable
*There is a rug at Exter's former location that has the pickup icon, has an inventory icon (if dragging over inventory) but just refuses to enter the inventory in ANY way.
*The 2 books near Exter's former location remain "book" after reading. One of them is a copy of violently shred book found in the Fort ('Claws of Deceit').
*So in my attempt to finish the Griff quest I found if I tried to put the Drudae inside the orange, the orange just dissapears. Dropping the orange, then opening it, then entering the Drudae does work as intended. Very odd;
**Sadly enough it didn't do much difference, even the Drudae-filled oranges Griff thinks there's nothing inside and attacks me smirk.
*How is 10% of 40 3?
*Similar issue to the lever with the light in Braccus Maze dungeon reward, it'll make the curse last on the Band of Braccus even if wearing it, forcing you to re-equip to fix.
*Lord Withermoore only appears at this light if you bless it? Otherwise not? Also didn't I release him by smashing his soul-jar? Also it doesn't lock the quest if I reject it? Also if I just open the door as intented his quest wont end? Blessing it doesn't actually help at all, only using source in convo? It makes very little sense to actually do any of this, and will loose you 2000XP if opening the door yourself smirk Very odd setup.
*Okay, what? Why can we reach THIS very far-away skeleton but are all the others locked up ontop (also in another room) are out of reach?
*Of the deck of cards you can pick at at the Necromancers 2 stack, 1 doesn't
*Battering Ram says "requires a Melee Weapon" but doesn't ACTUALLY reinforce this law, allowing my ranger with boots giving it to use it with his crossbow;

Joined: Apr 2011
OP Offline
Joined: Apr 2011
You know those days you really wanted to dig into the "new" content of D:OS2, but can't. Well, today is such a day. So here are some of the last few bugs I encountered on Joy Island:

*Seems the Fort's "bridge" has the same issue as the vines in that a loaded game wont recognise it being lowered until getting really near.
*Undead Medat's golden useless plate also appears under "ingredients"
*When changing a +1 Aeorothuge robe for a +2 Aerothuge robe my teleportation still got removed for "not reaching skill level". While it makes sense technically (remove old bonus, add new bonus) it would be nice if there were exceptions for this so I don't need to manually re-add it?
*The voice near the Decomposing Terramancer only triggered now, waaaay after I did battle there.
*Magister Ames doesn't drop his Letter to Kasper if he dies? He only sells it?
*Gareth conversation talks about the wand even if you use the helm conversation option:
*Typo (famlies):
*The bodies of dead Shriekers dissapear upon loading a savegame.
*When killing Alexander Ifan gets another bonus 1500XP nobody else gets ("my contract is forfilled") upon the 5050XP that everyone does get for the kill.
*Malady's "As you wish" when not boarding is unvoiced.
*Might be randomnised, but why does Alexander's Cloak have +2 strength?
*Even after giving the doll to one of your companions Fama says she "lost" her doll when talking to other teammates? Shouldn't she *know* she gave it away?
*Slightly odd placed bed:
*Flickering nearby:

Joined: Apr 2011
OP Offline
Joined: Apr 2011
Seems the patch is upon us. These are my last few reports on the old version, updating now.

*Dinner + Beer = Dwarven Stew. Dinner is +15% health, 1STR, 6 rounds. Dwarven Stew is +10% health, 1STR, 6 rounds... wait, what? WHY WOULD YOU DO THAT? The Elven Stew (Dinner+Tomate Sauce) also reduces healing, but atleast has FIN instead of STR to variate. Still probably could use that missing 5%.
*Eating wheet and milk seperately rather than the porridge it makes is much more beneficial.
*All "worth 0" items still fetch 1 gold at vendors. You could rip off everyone's face if you want to and sell them. Not that I would, but you can!
*Again ship issues. The bottles of beer on the Vengeance (beer room table) don't stack! The ones at the opposite side (Fane and Leya) do however work properly.
**Neither do the vials, but that may be a generic itemissue.
*Well, the 2 garlic from the Vengeance stack with the tutorial again (since the whole room is carbon copied, makes sense) leaving me with 4 different garlic items in my inventory at the moment.
*Having sex with Fane gives him 725XP. And *only* him.
**Similarly talking to Lohse about murdering her gives *only* her 600XP.
***Oddly enough neither make a difference as they match my player in XP, Ifan having more XP. Seems the XP boost is applied before they get boosted to match the player (who got a fair share of Solo XP for sleeping much much earlier in the game).
*(!!!) Using the mirror deletes your bonus from the blood rose potion. The buff icon still displays, but the +1's are ALL gone.
*Empty bottle (crafting ingredient) doesn't appear with alt.
*Zaikk's Talon and Silver Cups dont stack.
*So the version of "Son Against Father" on Fort Joy was 0.5. The one onboard the Vengeance is 0.1. They also look different. Why are there different variations of the same book?
*Putting a +10% physical armor rune on a 50 armor turns it to 54. Again with the faulty math smirk (same as 40 > 43 before)
*Empty glasses in the Vengeance's Dhallis room appear with alt, but they are useless sellables.
*In Dhallis office the paintings of the Knight and Lucian are 20 apiece. The MUCH larger Painting of a Battle is 1 however in weight.
*Erroneous extra space after this effect;

The stool saga (Vengeance edition):
*Both of them there;

Makes more sense to look at the food then the wall:

Way too close to the table:

Not like that!
Yes, like that!
No, you damn lizard!

Joined: Apr 2011
OP Offline
Joined: Apr 2011
Also the topic all were waiting for; weight watchers with Hassat Hunter!

Fortunately, it's not the mess of random values D:OS1 seemed to be. Though there are still oddities and I'll sure find more as I progress or actually do crafting (just for testing probably, I hate crafting).

*Bottle of Wine (got 8 of one stack and an unstackable apparently) are 0.7. However a bottle of water is 1. A (poisoned) bottle of beer is 0.33.
*A mug of beer is 0.33. A mug of water is 0.3. A mug of wine is 0.2. A poisoned mug of beer is 0.03
*Lemonde is 0.03. Milk, apple juice and orange juice holding the same "cup" weigh 0.3
*Anthropod legs and teeth have no weight. Neither do the packages on the upper deck of the Lady Vengeance.
*Books need a checking over, most including notes or other small items are 0.5, all crafting books are 0.05 though (and stack! (excluding the "True Brew" variations :/) Why don't other books? :0). Huwbert books are all 0.2.
*Potato is 0.05, boil it 0.05. Make (rivellon) fries 0.2, make mashed potato (warm or cold) 0.2

Also like to make a correction, seems ink (0.2) and quill (0.05) make ink and quill (0.3). 0.6 was since I apparently had 2 I overlooked. Whoops, my bad. Still feels a quill is a bit too heavy, with feathers being just 0.01.

Joined: Apr 2011
OP Offline
Joined: Apr 2011
Well, time for an update since my doc's getting fairly big and we got 2 new patches in, even if they wont really affect me any. I'll post a little snippet of impressions in the feedback topic, this post will be long enough as is. Without further ado, a ton of bugs;

*Well, since the patch boasted many Magic Mirror fixes, I tried it (left near it anyway)... still eats my Blood Rose Potion permanent boost.
*If you ask Malady questions and end the convo, re-talking her doesn't give the tutorial popup about no more party changes that instantly saying you'll sail out gives. Also in that case Jules and Simone where at the end, instead of the center of the ship during the combat segment.
*(!!!)You loose Blood Rose bonus *forever* after the ship battle (which caused me to become encumbered) frown
*Zorl-Stissa's "Go" is very soft.
*And then you get the "fancy bottle of beer" in Driftwood to further annoy non-stacking smirk
*While the voidlings on Fort Joy gave a lot of XP for little effort, the Driftwood beach voidlings give no XP *at all*.
**Neither do the chickens, but their fight is a lot easier.
*Little Grimlets "goodbye" bock sounds too soft. Same for Big Marge's Bacaw when drawing on your map.
*Spoon (useless) shows with alt.
*And more varations of the same item smirk The "cup" instead of "empty cup"
*Inside Meistr Siva's house there are 2 books that stay 'Book'. Amongst them YET another copy of "Father Against Son".
*Also inside Siva's house is another variant of the empty bottle smirk
*In the basement is "censer", a bowl weighing 20 0_o
*In the basement is a "book" that remains book, which is a clone of Huwbert vol 35 (Braccus Rex). Also an ode to Kirill which remains "book" as well.
*The soundbit when swapping teammates in Siva's basement is really annoying!
*"Is this the deepest recess of my soul? But it looks like the Hall of Echoes" (Red Prince) is unvoiced.
*But they don't *have* single-handed? Or does it just not show (it should if they got it);
*You can create Cooking Stations in fireplaces. Which are, well... aaaaawkward:
*This is very akwardly written. Why not "Ask what will happen to the other races"? This is like someone wrote an actual line, then realised the while * * thing D:OS2 had going for it and plunked a word behind it.
*Giving Dashing June the 250 doesn't actually substract money. Tried all options, none takes money away.
*Typo (Counfel - Trufted - Bleffed):
More on the tavern poster:
"capacity af the", "juft"
I guess it's intentional? Too many to be a mistake. But the narator speaks all of them properly. So, I don't know... smirk
*Bellsworth: "That's magister business. Keep your nose away."... quest-update: We learned the records are hold in the basement of the barracks. Me: Wait... WHAT?
*Casting Spirit Vision turns Magisters hostile? It's not a source-spell.
*This box;
*Why do the haystacks get marked as theft-items, triggering -attitude upon interaction?
*Minor graphical issue:
*Ball and Chain got item, hand-pickup icon, are "theft" locked, and don't go into the inventory in ANY way.
*Playing Cards don't stack. Deck of Cards do. Both weigh 0.2 btw.
*Hen behind tavern has interaction, but does nothing.
*(Old report:) Lemonde is 0.03. Milk, apple juice and orange juice holding the same "cup" weigh 0.3 (New info:) Cup of tea is 0.03 too.
*Julian: Text; West. VO; East.
*"The Wrecked Caravan" closed with an entry saying I told the Magisters Voidwoken attacked. I didn't; I told them I found dead Sourcerors, Magisters and Dwarves.


*I DIDN'T TELL THEM ABOUT NO LEG. Conspiracy! They killed Joe! They had to. Can't even hide behind *you told them* because this is like the single line of dialogue for the protagonist found in the game, and fully voiced too! That's some grim quest man. Grim!
*Rusty's *whine.* *mewl* is low volume. Asking him what ails without having Pet Pal the line repeats, but there's no VO at all even.
*(!!!)If you help Rusty without Pet Pal you get 7000XP (Pet Pal XP) and 5000XP (Not Pet Pal XP), with both accompanying journal entries. Whoops? (using Lohse/Fane's Mystic)
*Beggar logic error:
*If extorting the beggar for the dog's part (20 gold) I actually only get 5. 2 for the prince, and 1 for all other party members. Very odd.
*If extorting the beggar for all his profits (5 gold) I actually get 10 gold. 3 for the red prince and Ifan, 2 for the others. Still odd.
*Glenna Graeme is sleeping, so I robbed her house. No problem. Till I tried talking to her and she immediately accused me on theft on waking.
*Typo (Understsand):
*Actually, that's not true, I never persued any "reward" dialogue lines;
*Grebb says he wont deal with the mixes, but he actually gives one with the recipe. Doesn't quite mix with the conversation (Crimson Bream fish). Same for the Yellow Ridgeback and Umber Longfish.
*Logic error:
*"Psst, hey, hey you" (fish barrel) is unvoiced.
**Same for "Please leave me be, I don't want to draw any attention" once you escored him out.
*Lines when passing by with Higba are unvoiced (also doesn't seem Kannox acknowledges us carrying him with us in convo).
*Apparently only me (Red Prince) and Fane got the Hero tag, leaving Ifan and Lohse without. Why? Is it because they are listed "dead" since I whacked them in the tutorial?
*And then suddenly, west of Driftwood on the beach near Lagan there's a beehive that can be looted instead of being a craft interaction, unlike all others.
*Void-tainted Sailfish weighs 100! Really?
*Typo (somehwere):
*Her, her, he. What?
*Barstang Tungs will keep poeting even if you attack people in the tavern turning everyone hostile, till his poem ends (it wont loop though).

And of course, your favorite segment... the wall-staring anti-social lizard locations guide! More commonly known as incorrectly faced default placement benches.

The Chair Saga: (the one beside it aswell) (The stool there also faces that way, while as merchant, the other way around would make more sense. Of course that little place is abandoned, hence not reporting that chair, since a case could be made for being switched around. Not so much for "into wall bench") (which is weird seeing the one right NEXT to it works fine; )

Joined: Apr 2011
OP Offline
Joined: Apr 2011
Getting rather long so dumping it before contuining exploring around Driftwood.


*After killing Wylvia the "loose plank" still appears as theft-interaction (I looted it before killing her).
*Same bad counting for magic armor. Got a necklace with +10% magic armor going from 40 to 43 smirk
*Critical damage now shows "critical multiplier" and my crossbow does 160% (from old 150%). Stat say 159% though.
*Papa Trash "book" is another Huwbert clone.
*The upper line says (50) while it's rejecting payment. It shouldn't list it and money isn't substracted (correctly)
*The potent herbmix recipes don't recognise that you can't craft them anymore running out of ingredients (still listing [1]), something other recipes do.
*I don't think she's supposed to do *that* little damage:
*Broken stool, marked for theft and cannot be sit on, only "picked up"?
*Used Ifans dead body twice for Bloated Corpse. Is that intended?
*So I attacked the Champ outside of the arena being stuck on the quest, and she did a LOT of fighting in a single round, doesn't seem intentional. Backlash each round too, seems broken. Also note at the end how it does double the damage to Fane with a crit with the second compared to first weapon; could be 50% dual-wield penalty, but the stats as shown next simply do both weapons together * finesse penalty. So one of the 2 is wrong.
*(above screen) From Pyrokinetic or From Warfare should not appear if not having said stats, and the bonus is 0%. Seems Warfare is always present if dual-wielding (also noticed it on other characters), and pyro could be because of her dagger with fire damage (yet to detect any so far, but I rarely inspect).
*Lavrik still talks to an unconscious Safa... and gets stuck.
*Onions seem oddly weightless.
*I usually don't look close at stuff, but this time I did, and the cup and mug are upside down:
*Some more small graphical glitches:
*Near the Witches house are 2 recursive crossbows. One level 12... the other... level 1?
*Chew Toys (bones) don't stack.
*Typo (And egg);
*Garlic through the floor of tavern second floor:
*The altar (near Gheralt's location) only gives XP to the main character (Red Prince in my case). Others *cannot* use the altar ("It waits for... someone") to get the boon.
*Huwbers volume 3 there's no proper spacing between title and rest of the text upon reading.
*The 3 goldpieces lying around in the abandoned sawmill (near the Lone Wolf camp) do not stack with your other gold? They don't count to your total.
*Elf Cloudpiercer seems the only person so far I've seen that can trade, but has no trade-icon, just the conversation option.
*Firewaters staff just lies on the ground next to him for the taking? Not even theft-locked? That intended?
*No update to the Redemption main quest talking to Hardwin as Red Prince and asking for Brahmos?
*Djinn is cut short on Wealth and Power lines.
*It appears digging up a "secret" removes it from the map. No such thing if the treasure is dug up before being marked a secret.
*Enemies don't seem to really care if their Re-active Shot skill hurts their own people (and them alone, I easily walked out of one of these circles with no consequences).
*One of the hands infront of the Wrecker's Cave's entrance does not give a conversation upon eating. Inside, in the Voidwoken parts one disembodied hand gave a Skill without conversation, although another reload it did nothing at all anymore, and yet another reload it gave Elemental Totem (it gave a ranger one first try, so not the same), same with another disembodied hand found there (I accidentily ate all at the start of the cave without being elf, whoops there).
*(!!!)In this auto-save the Voidwoken doesn't drag Lohse down in the Wrecker's Cave. Had to resort to one before that to properly continue! Reloading the earlier it's fairly evident the cause is it auto-saves too early (before all 4 Voidwoken burrow).
*Appears all Lone Wolves bar Roost Anlon are hurt?
*Could be a wordplay due to the quest's content, but likely just a typo ("warmed us")
*Well, that looks... bad;
*More gold that's not actual gold in the Voidwoken lair (Ifan's drop, with all the paintings)
*Not sure if the last patchlogs taunt-fix was to remove physical armor blockage, but Wolf Howl (Ifan's source-summon) is still blocked by physical armor.
*Again no XP for killing voidlings in the Wrecker's Cave smirk. Atleast the Voidwoken do.
*Rat's "I'll do you harm" and followup lines are very low volume.
*The corpses of Voidlings dissapear upon loading a savegame?
*Are these meant to turn hostile if you over there... no way to reach each other than moving all around;
*Fane got stuck here trying to look the marked fish barrel. No way to move AT ALL. Had to teleport him out of there.
*Tried looking up Ifan's affection and saw THIS instead. That's not helpful!
*I though the erroneous space was bad, it's even worse on inspection. Also note the "reflections" and then a bunch of +damage skills smirk
*Reading "The Taming of the Holy Fire" gives a sizeable stack of XP, but why? There's no questupdate? A quest I didn't start yet?
*Mordus used Glitter Dust (Throw dust) on his own team. To heal? Still seems rather odd to blind all his wizards like that.
*"Thank you sourcerors for the Source I needed to becoming Mord'Akaim" is unvoiced. Also he leached source of his ally, rather than us? Are his teammates supposed to have source on them? In the second attempt he drained Source from a dead Fane. But Fane had no Source.
*If I murder Mordus without him shapeshifting, the quest entry *still* says we fought him as Voidwoken.
*Only 3 out of 4 sourcerors in the final battle turn into Spirits???
*The pouch with the glowing eye generates level 1 items (in a lvl 11-12 area). Also how could you not notice Chew toys not stacking with the half dozen strewn around there? Why are there even chew toy bones around a sacrificial altar?
*It really doesn't need "blocked by physical armor" twice;

*If I fits, I sits: (suppose you can theorise this is a campfire bench, not a table though) (3 out of 3 for a single table, think this is the recordholder so far)

Joined: Apr 2011
OP Offline
Joined: Apr 2011
I was planning to report these after tomorrow's long session, but considering a patch was released, and these were all noted on the old version, here's a dump now;

*The reward for the Mordus quest, a lvl 11 area quest... is lvl 9 gear since it's resolved in Driftwood? Eh?
*No exp for killing Badalore? (Lohar thug). Even Marla who wasn't even part of the fight gave 4000XP.
*Should "The Law and Order" close upon Lohar's death? After all I still need to report back to Julian.
*Drudanae pipe has entire wrong bonus display (gives drundanae bonus, says immunity to a bunch of stuff instead). They also don't stack.
*Talking to the utmost right Drundanae addict counts as theft? I just tried to talk!
*Drundanae user using drudanae just pushes it belows ground rather than destroying it. Also they give no XP upon death.
*Great. The drunadanae (I hope this is the last I need to write it) in the little garden are different variations that don't stack smirk
*Not quite sure if said yet, but things definitely not suitable for "ingredients" that are there; Toy wooden block, bed linnen, cutting board.
*Checking the cave at the destroyed Dwarven Camp after killing Mordus the inhabitants are gone. The descriptive lines telling you so are oddly not voiced by the narrator like all others.
*Spirit of a Crushed Elf (near Grog the Troll) is clearly male but the [Scholar] line says "Tell her that you find her research fascinating". Talking to 'her' again the narrator also says "She".
*If you take the ferry back (without reviving) the bodies move along but the spirits still linger on the old location (can still revive properly though, just a display thing).
*Talking to Brun the Honeybear asking for scented honey the dialogue is missing its voiceover. Same for talking again.
*Jahan intro; text says one cage (it is one cage). VO says two cages.
*Hannag situation; While the Magister Knight and Priest don't allow trade, the Ranger does oddly enough.
*Giving Garvin the Tainted Stew he runs to the outhouse, which then runs the line if you click on (instead of probably an intended unique line?)
*The questentry for "Aggressive Takeover" mentions a secret cache in the woods, but there is no marker on the map? Or is this probably the only case where it wont mark an already found loot?
*Appears if you insert a rune from a teammate the UI doesn't properly update immediately, requipping the item or closing/re-opening inventory fixes it, and fairly sure a rune from your own inventory shows fine right away too.
*we > us
*Logic error:
*Paying the troll the price of 3 gold, no gold is actually substracted at all.
*I'm not quite sure I'm supposed to see my god leveling up, right?
*trifiled > trifled
*There are some animation issues if you try to go down a ladder while standing on oil (slowed) and being encumbered:

Joined: Apr 2011
OP Offline
Joined: Apr 2011
Suddenly, hotfix. So here are some of the old version;

*Giving the ghost in Rykers house her hand doesn't actually remove her hand. The Masked Servant giving you a note doesn't actually give a note.
*I've also noticed I still had Lahar's head even if I gave it away to Julian in Driftwood.
*"This flesh is well past ripe. Whatever memories it once hold are now gone." is unvoiced.
*The lair with all petrified people has the same annoying SFX upon teammate swapping issue as Meistr's dungeon.
**Also is it intended the rusty amulet there is lvl 1?
*The "Hero's Rest" tombs are unvoiced (started convo at Garrick).
*Spirit of Master Awan (near Featherfall) lacks VO for *all* lines.
*Can't rob the Dwarven corpses there?
*Creeva's body part heals even non-elves?
*Killed one poisonout trunk; XP. Killed another; nothing. Killed 2 more foes, also nothing. What? Or could it be I literally only got XP the first kill since my Condor killed it? (Ghalann battle). I did get XP for 2 enemies of the several once Ghalann died. Rest were summons? No loot on any of them?
*Voidwokens dissolving mucus (poison) attacks physical armor?
*The Skull Sentinel in Ryker's basement does nothing?
*I've decided to explore a little before lowering the bridge and now Mari *and* her son are both completely missing??? I've found a similar topic saying they're in the barracks. And they are. But quest remains open, no reward, and how did she get over without me lowering the bridge? Other topic;
*Wait, why do grenades weigh 1 a piece?
*There are 2 blackpit locations; "The Blackpits" and "blackpits"... I assume one is supposed to be a questentry for Fane instead?
*Digging up Garick's loot the icon doesn't dissapear. Is the cat's loot the exception after all?
*Easel has a pickup icon, and an inventory icon, but cannot be picked up.
*Gregorious Swann: VO: knock down, ST: weaken.
*The little hidden picnic place near Gareth's Farm in Paradise Down has a lvl 1 ring and lvl 1 wand?
*Dot missing at the end of quest-entry;
*Tiny GFX issue, but since it's the way it's set up by itself, nothing I did;
*The Rhalic statues infront of the graveyard; You can interact with the one in the middle, but the left and right just give "can't reach" when trying to interact.
*Typo, and it says Swann approaches Natalie, but he didn't in my game. Additional attempts I could only kill her and then he did come, so cant't confirm if always or a fluke.
*Actually, she died during the post-combat surgery (0 enemies killed before it triggered). Couldn't actually get the cutscene to trigger to try again though, dunno how I got this. But when I got this I got 0XP, while killing everyone gives a ton, so not being able to trigger it again wasn't *that* bad.
*These gravestones have a rather curious issue;
*The rat got some issues with food on unreachable locations;
*Well, this wasn't the sollution after all, but some more rat oddities:
*Why yes, yes, more rat-quest stuff.
* Immune to Silence + Silence armor = Total spammage;

Joined: Apr 2011
OP Offline
Joined: Apr 2011
Getting reports out of my system;

*If you made Wilty say the phrase (everything's going to be alright) talking to her again said line has a very low volume.
*The burning house with the Inquisitor and the hatch has a Huwbert clone as "book" on the ground.
*Several issues with "No Way Out". To start I asked him to hand over his weapon, and the questlog updated incorrectly. Then upstairs Lohse talked and no option with the sword at all, so combat ensured. Killing the Inquisitor the quest updated with "All Magisters dead" and Owin rose to the surface.
*No XP for Oil/Fire Voidlings (The Blackpits) intended? (It's a looooong fight especially with a necro-fire filled battlefield (which is every D:OS2 battlefield)). The Primordial fire/oil voildings do give 7500XP.
*Gwydian Rince's "I'm coming for you" (during combat) is unvoiced.
*"On the Ropes" closes but I still need to return to Hannag for training?
*Huwbert volume 13: Lacking spaces between "Rock of Ages" title and content.
*The shackled Black Ring will still do attacks of opportunity upon the Magisters.
*Talking to the canary again the first line says (continue) but closes the conversation.
*The eternal plate, despite being an important crafting ingredient, doesn't highlight with ALT.
*Both the Aeteran's "tomb" as well as the players response to the conversation are unvoiced.
*"By the heaven, it's Eternal... It's one of our vaults!" by Fane is unvoiced.
*Behind Ryker, first bookcase on the right; All 3 "Book" are Huwbert clones. Further along the wall there's another one. Further along with 3 books near each other 2 are copies. Further along another. Near "For Jack" another (needs a space between The Birth of the Seven and content). Left to that; 3 more clones. I would like them official. Easier to keep track of which I read own, and they weigh less!
**On one of the torture benches is a clone of True Brew: Penny Bun. Presumably not giving it's recipe, and being 10x as heavy.
**Moving on to the hidden library, right most case; Tales of the Seven clone. Atleast 3 Huwbert clones (send last book to ship, oops).
**On the left we got a crafting book clone, 2 huwbert clones, 1 blood rose clone, and 2 unknowns (darn that shipstore interaction location).
**Behind the stairs back above is another Huwbert clone.
*There's some HEAVY texture clipping around one of the pillars here.
*Another item that should stack; Mortar and Pestle.
*The Parchment empty paper item in Ryker's office also doesn't stack.
*Does not appear with ALT; Stardust.
*The default interaction of the Face Ripper in Ryker's hidden library is using it rather than picking it up?
*Well, after killing Ryker I found the message on the Masked Servant, same as left behind if returning with the Artifact, they even stack. So I assume it triggering at the very first conversation was also an error, even if the message wasn't given.
*Ferry asks for 100 gold, actually using it only substracts 50.
*"The Elven Seer" rewards you with lvl 9 loot, even if battling a lvl 14 Sawmill for it smirk
*Mummie Dearest's head is simply marked "Severed head", unlike other important heads (Lohar's head for example).
*Mummie Dearests (a lvl 15 foe) drops lvl 11 loot.
*This item has placeholder description? (the | | used to denounce placeholder in beta);
*Shouldn't that be YOU have to believe?
*Never swaps back to shield+sword though;
*All voidlinks at the Blackpit fall under the surface upon death. Glad I did it after the new alt-corpse outlining.
*As you can see from the timestamp, finding the Shriekers and getting it's update immediately also adds another update that probably shouldn't happen since I've not approached the Magisters yet;
*Range issues with Source Vampirism;
*What hood?
*She should *probably* be aware that he's dead;

*Lizards can't sit, the story; (they also can't paint, apparently) (the chair also faces the wall, but I figured with a backside it's facing is much more obvious so that might actually be intended? I personally would suggest changing it, though.) (they also can't play piano, apparently) (a bit too intimate with Ifan, skull-crackingly so)

Joined: Apr 2011
OP Offline
Joined: Apr 2011
Another hotfix, lemme just dump my issues of today then, mopping up what remains of ACT II.


*No music for the post-Sadhe combat?
*Near Harbinger; Inquisitor gives no XP, knight & swordsman did? Last (of 3) Inquisitors gave XP though, fairly sure the first 2 weren't summons, didn't see them getting called anyway. Though I guess "forgiveness, teleporting X in the air" could be. Probably should be clearer.
*Harbinger of Dooms death hitbox is way too big, impossible to loot anything died besides him.
*"End times" farmer clearly voiced by a woman but the option is 'ask him what happened'. Also lvl 15 area with lvl 1 skullcap there.
**The leather boots on the washboard you need to teleport to there is also level 1.
*Spirit just says young folks, couple... then the journal suddenly goes on about a witch and traitor.
*Almira's Ring reward is level 1!!! (killed Harbinger and had tablet before conversation)
*Unlikely lover's quest-entry says I deepend my Source connection, even though I had 3 source already so that didn't happen.
*Driftwood arena void woken "pen" still has interaction but no VO after killing Voidwoken.

EDIT: Whoops, forgot the screens;
*Poison Wave description/effect disrepency;

*Minor graphical issue with floating cards;

*And finally, this Voidwoken is supposed to be dead, not looking at his own corpse (fought just the Voidwoken);

Last edited by Hassat Hunter; 03/11/17 06:21 PM. Reason: Screens
Joined: Apr 2011
OP Offline
Joined: Apr 2011
Looks like Reaper's Coats is done. This likely should be the last bugs I report from them for now, onwards to the Nameless Isle.


*Natalie Bromhead's spirit is unvoiced.
*Painting of a man (Ryker's estate) goes from calling guards to 5s to guards to 5s.
*Eyrhen of Havoc's first line (both first meet and subsequent) VO volume is very very soft.
*So on Bloodisland next to a corpse that requires teleporting to get to is a backpack. This backpack... is broken. It wont open as container.
*After talking to Corbin near the workstation, he walks off to the door to the level below, and once arriving suddenly spawns mid-way the current level. Looks very off. He does this EACH time you talk to him. Talk to him while he walks back to his workstation? He will start doing circles around the level being unable to talked to, until you load another area and return. One time he even went downstairs with me, wandering a little till he suddenly dissapeared.
*If I give Fletcher Corbin Day gold as Ifan to butter him up, the +attitude goes towards the Red Prince instead. Cause of no trade button but only conversation option?
*This locked door is pointless, you can simply loot the skeleton through the bars. Don't know if that's intended as fluff, or a failure to prevent looting till unlocked;
*Its > It's;
*Although certain cocoons hang too high to reach, all of these are reachable. Except for the marked one, that's just a bit too far;
*The Elven Pilgrim ("Druid" quest) has its body finely stuck deep within a wall. Considering these bodies are supposed to be the hint for ghost. Fortunately there was another Elven body nearby, still, it probably should be moved to its intended location;
*So from the Archivist in the Bloodmoon archive we learn all the hyms where lost from the island... but the book is *right* there in that room? Ehm?
*Black Ring Reaver is clearly female, narrator says "his mouth"
*Upon subsequent talks Brother Roberts repeats himself.
*Possessed Dwarves "just destroy the pillars" is low VO volume.
*Possessed Dwarf keeps looping it's conversation, VERY rarely going to the subsequents. Broken?
*Typo: commit a two souls;
*You can trade with the Possessed Child.
*Teleporting the Possessed girl to the Vengeance, she remains there. Talking to her again... well. Then she's gone though;
*This weird conversation;
*Black Ring besides tree; "Blood amon [conversation cut due to combat]" (picked the 'backfire - yes - speaking for Advocate option).
*14450XP is given for the death (or in this case, expiration time) of the Bone Smasher summons. First time I see summons giving XP.
*Meanwhile the Undead Black Ring Destroyer (easily the biggest threat) gave 0XP.
*"Black Ring Instructions" unlocks an entry for passing the Deathfog. "Myseterious letter" unlocks an entry about the Black Rings goals, but that's also content of the Black Ring Instructions, not the Letter at all!
*Malqg gets left behind when they move to the tree.
*Grog's severly overpriced passage of 5000 Gold also isn't substacted from my gold amount. Oh well, free XP?
*Business Rivals: "We told Marg Grog is dead. She rewarded us". She's a he.
*Marg's new extremely overpriced toll isn't reducted from your money either.
*After finishing Business Rivals Marg still uses the "I wonder what Grog is up to" random convo line.
*I suppose the holes in the witches' basement are supposed to spew rats? They don't. Also one rat doesn't want to blow itself up.
*The hunk of meat near Roost doesn't give a conversation upon an Elf eating it?
*Witch's Potion Notes doesn't appear under books, rather under Misc?
*The Rat at the Blackpits "docks" area lacks VO.
*"A letter from R." found at the docks implies it's found at the Driftwood prison. It isn't.
*You can find a letter there saying [This book is unreadable]. That's no book.
*The gold found there is also of the unusable kind, stacking with those found near the sawmill.
*"Powerful Awakening" says to summon Malady with the figurehead but going to the Vengeance she'll already be there.
*The book in the locked in room (beneath a painting with a knife in it that cannot be picked up) is another Huwbert clone. Also needs spacing between "Rock of Ages" and content. The book next to the chest is another clone, but can't quickly tell of what book (a crafting one).
*The dead rat in the tub is called tub? 0_o
*In the basement of the Fish Factory a there's a "book" that's a clone of the "Healing Advertisement" book.
*No XP for the Voidwoken beneath the Fish Factory frown
*Molly the Dog: "She crouches and growls low" - again; male VO.
*Re-adding Lohse from the ship her armor wouldn't regenerate till I removed and re-added one part, nor her health change till I removed a +con part and re-added it.
*One of the its should be it's here;
*Small graphical issue with Lich-killed Source Hounds:
*Letting Zol-Stissa talk for to the Eternal she says "Where. Is. It.", but it's a question so it should end with a ?

Joined: Apr 2011
OP Offline
Joined: Apr 2011
List is getting rather large, so it's time for a dump;

*I forgot to collect my reward for "Dark Dealings in the Blackpits" and the questentry says they are under attack by Voidwoken, but they are clearly undead shadowcloak, which I don't think are voidwoken at all?
*Entering Nameles Isle, most questentries where empty till I opened and closed the questlog some time. New entries, messages about saving, identifying items... all where suppressed. All appear during Black Ring fight (first fight I got). Afterwards all worked fine.
*Shouldn't the exit out of the cave be the Cave Exit? Rather than the Cave Entrance again?
*Casting Encouraged overwrites (and thereby removes) Delores permanent Encouraged modifier smirk
*Delores looses the HP from encourage and his Source Points upon loading a savegame smirk
*At the Shrine of Xantessa there's some scattered gold on the ground (one a (5)). Again; False gold like many placable gold smirk
*While it seems overall items are lvl 16 on the Isle, one Spear near the Shrine, next to a Purged Corpse is lvl 1. Also a Good Part of a Sword inside a Dead Elf is level 1.
*Near the Temple of Rhallic a lvl 1 Battle Axe. Another spear. And a minor healing potion (at that stage?).
*Hmm, the Magisters in the battle vs. The Black Ring do benefit from me casting Encouragement or having Leadership, but not Lohse's Favorable Wind aura?
*The Paladins Sword at Rhalic's Altar is inside the ground.
*Southwest of Rhalic's there's a corpse with a lvl 16 bow and lvl 1 shiv.
*Hatchet in the lava parts is lvl 1 too frown
*Relinquiries near Zorl-Stissa and Xantessa need to be interacted twice to loot. Once to close, then once to open again and get the loot.
*The Gold at Zorl-Stissa is, again, fake gold.
*Shadow prince; VO (correct): Wings clipped. Subtitle (faulty): Wing clipped.
*The Quest Entry upon talking to the Shadow Prince says I should not mate with Sadhe... but I already did?
*Got the same issues with the Black Ring traders as I did with the Fletcher. It appears no matter who gives the gold, the conversation initiliser gets the +attitude. Definitely didn't work that way in the past, not that I recalled anyway.
*Fly Agaric Mushroom's don't stack??? (found on Namless Isle)
*The Nameless Isle Diamonds don't stack with one I found before.
*Questentry for Imp when countdown starts says Core is disabled (it's not). Also the Deathfog it causes actually kills Fane, unlike the Emergency Flush Deathfog (as deathfog should be).
*To make matters even worse in the Imp Realm (is that possible) only your selected character runs. Everyone else just walks, making them EVEN SLOWER.
*While I haven't found many incorrect chairs, The Imp Realm is literally littered with them. It seems all chairs face the same way, and it's often not a good look.
*More VO confusal. The Confused Crocodile is clearly female, but the narrator uses him and his.
*In the Orc Shrine the Defiler spirit is apparently supposed to lie on his back (like the Blackpits spirit) but he keeps standing?
*Spirit of the Orc Priest/Spirit of the Knight of Vrognir have no icon.
*The Knight of Amadia keeps repeating her "I have to kill you?" convo. Got tired of it, said "I'm leaving" and she attacked. *sigh* Oh well, XP for me I suppose.
*The Drudanae in Amelia's secret doesn't stack, much like the ones from Lahar's plantage back in Driftwood.
*This stool is not properly stool-trained. Oh and the pickaxe there? Level 1. Sane for the pickaxe in the other nearby camp.
*Convincing Fane/Ifan that I must ascend gives them (and *only* them) XP? Lohse however does not?
*Entering the Academy side-ways updates "An unlikely Patron" full of lies how we met Alexander and all. Nothing of that happened... at all.
*It appears the Engraved Jewel is not used up when placed in Amadia's statue?
*It appears Delorus armor leveled with us. But while it's max values are higher now, his actual armor is still on the old level from when I recruited him, and fortified/magic armor just drops it back there again after its effects wear off. Okay, seems removing and re-adding added the missing armor. However loading a savegame once more it's gone again frown.
*I answered Woomera (bear)'s question and subsequently she says "Philosophymy not your strong point, eh?"... Seems I should get an other response.
*Listener Priest keeps looping his Red Prince conversation.
*Got issues with "The Seven Altars". Got them all, it's at 5/7. I did use Ifan for Rhalic and transformed into a dwarf for Duron, so I guess those are counted against it? That's just... weird.
*The Poisonous Trunk summon from the Dryads (Mother Tree) use Voidwoken taunts.
*Killing the Poisonous Trunk summon grants XP.
*If you interrupt "The Pawn" talent in any way, all remaining distance is wiped left for that 0AP is wiped, any movement requiring 1AP even if you barely moved at all smirk
*Alexander's Faith hover-over says +5 to skills, inventory says +4 to skills.
*Similarly the Plague of Sallow Man says -5 Constitution but gives -4.
*It doesn't make much sense for the Lizard Monk, follower of my religion (Red Prince) and convinced I'm the new Divine after I blessed him to turn hostile upon adding Deathfog to the Mother Tree. Somewhat similar for the otherwordly traders.
*Intended that a whole troupe goes into Turn-based at once? Forktongue took a long way around and when combat started he was at the start of the temple. By the time he arrived at the front everyone was dead, and the Paladins and Magisters had easy pickings, total massacre.
*The gold near Rhalic (apparenlty missed that before) is also "fake gold"
*After detonating the Deathfog the Shadow Prince will depart, leaving his red questnote for the Red Prince quest on the map.
*Killing the Wendigo wields no XP?
*Picking up Isbeil's Missive the Red Prince says "Dwarf Business. Might be of interest to Beast." Beast is looooooooooooong dead.
*The Sallow Man's gold stash is... once again... "fake gold". Although there's a pile of gold on the table that's actually the real deal aswell.
*The eye found on that table also doesn't stack with other eyes.
*The 2 books on the table are also clones. What a messy table.
*Talking to the Voidwoken Delegate with Fane I used the strength option and it extremely jarringly turned to the original conversation. Shouldn't there be a Fane line or something?
*Math issue? No, it doesn't display the Demon Talent;
*Shouldn't the ghost be near the rack then? And there actually be a body? Those usually indicate corpses, and if he died on the torture rack...
*Yup, they be floating. Also another container a little past them floats aswell;
*After killing the Sallow man killing Alexander updates the questlog telling you to bring his head to the Sallow man;

EDIT: Forgot the broken ACT II quests;
*Getting the stolen amulet from the Djinn keeps the quest open with no way to solve it ("Wishful Thinking").
*"Love has a Price" doesn't finish if using the Red Prince and seeing Sadhe.
*Had to abandon "They Shall Not Pass" as mentioned before smirk

Last edited by Hassat Hunter; 09/11/17 10:56 PM.
Joined: Apr 2011
OP Offline
Joined: Apr 2011
It's been a while, so obviously the buglist got big, very very big. Here it is. Won't be too long before the game's over.

*Last Rites; Magic effect is "Potion"... huh?
*Interesting area-name;
*The copycats seem to be intended to have the same armorvalues as you. But they don't take into account runes. So any bonus from there is not on the clones.
*Malady's *cough**hack*snort*hack* is unvoiced.
*The Nameless Isle - Arx cutscene lacks it's subtitles.
*After my little escapade it seems my teammates have lost their armor and max health, the issue with needing to re-equip armor to reset it and something with hp/con to reset health.
*"We left the Isle without fulfilling Sallow Man's Demands"... well, we kinda kinda murdered him. Maybe triggering combat by Lohse demon-conversation bugged it out?
*The Elven Pilgrim is clearly female, but has male VO.
*Arx Harbor: The Spirit of a Dead Woman is near the corpse of a Dead Man.
*Spirit of a Magister Swordsman text says he lies on the ground; he probably should.
*This sign has a little bit too many p's and l';
*There is a well underneath this well. Probably should be deleted (sadly, can't screenshot with ALT);
*Male Paladin Defender and Female Paladin Elementalist don't seem to realise the trial is over.
*Wendigo: The machine says to remember the Fort Joy blacksmith and copy HIS technique. But it was a female blacksmith.
*No body for Cryptographer Marwell?
*These VO's run at the same time looking at the pamflet;
*Beneath the Magister Barracks in the hidden treasure room Gold is once again fake frown
*Why don't Reimond's Orders, Encrypted Book, Intelligence Brief and Civilian Ledger stack? frown
*In Reimond's lair there's another clone "book"... oddly all others are fine.
*Spirit of Reimond is completely unvoiced.
*Not to mention I killed him before in the Blackpits. I've noticed this has been reported before though, it's just... rather weird all...
*Whirlwind says "enemies" but also hits neutrals (Paladins hit me, and they also got hostile on me when I used it). Also I got knocked down by their Battle Stomp.
*The work in progresses for Crawley Huwbert are all 0.5, 2.5x his books! Also "Inspired Words" has / rather than the proper linebreaks.
*This is a major contradiction;
*The wedding guests on the benches lack VO.
*Also the Royal Protector spirits got swapped around (the patrolling one standing still and the vigilant one patrolling).
*Dwarven Wedding Invitation appears under Ingredients? (Could be used for scrolls???). Shouldn't it be a 'book/key' not up for that? (You can't actually read the invitation though)
*Bella the Scoop's "Lucian Day's arrive" is voiceless. Cranlew Huwbert news is almost inaudiable (but the floating line saying the same works fine). Same for "Voidwoken attacks increase", "Magisters Routed", "Magisters colluded with Black Ring", "Queen Justinia confronts rebels", "Paladins Promise" and "Suspect in Alexander murder".
*The sign near Trader Keyren doesn't work.
*The inventory of Trader Glas is very curious;
*Toysellers Sanders: "For the first you need an amulet that's charged with source"... unvoiced addition to the line: "5 Souls' worth to be precise". The 5 thing is also missing from the line immediately following it (granting 'Toy Story' achievement). Asking about it's workings again "once it's charged (with five souls)".
*Replenish Source magic effect is once again "set potion".
*Seems it already starts out with one of the five charges. Intentional?
*On the second floor of the Toymaker's store, many toys are *under* the floor.
*This Paladin guard cowers when fighting breaks out, should assist instead, no? (she will do if teleported into the fight)
*Lohse snuffing out candles *only* gives her XP.
*The Severed Head on the painbench in the Doctor's House gives no conversation upon eating.
*Eating Alexander's Head (atleast in Arx) gives no conversation either.
*Inside the doctor's house there are a lot of non-stacking sheets of paper. One of them oddly enough is a "misc" item.
*Disembodied hand, Blooded arm, Severed Head (x2), Bloodied leg (x2) and a Disembodied Torso all found between the Doctor and his basement all lack dialogues when eaten.
*The drunk dwarf near the wedding DIED? Why?
*The citizens to monsters "The doctor is dead, you'll pay" lacks Voice Over.
*Trina says she'll mark the Thieves Guild on your map, but doesn't?
*Talking to Sister Schori updates the wrong entry for Hammerfall; It says we entered the Cathedral instead.
*After departing Sister Schori's mapmarker is still stuck on the map, persisting even after the quest is finished.
*The Pilgrims at the Voidwoken near the Lizard consulate lack Voice Overs.
*Trader Rennald's goods are not tied to him so you can just steal them all.
*The unique's of the traders in this area are crap and INSANELY priced. 100K for a bad item? What?
*Creg Ganim doesn't take money for second or more songs, and sometimes he doesn't recite the song at all (nice touch with the re-appearance of the song of ACT II).
**If you do go with the classic, like Act II he'll keep looping it by himself. Probably not intended here.
*Well, that's just sad with Butter. Though I recall murdering her in beta her journal dropped in Fort Joy telling about a great person they met (you), but here I get a journal with some Fort Joy story, nothing really to do with the character. Doubt that's intended, wrong journal?
*Maddelyn Kemm's VO and subtitles are extremely different (VO: "can't go upstairs. Text: "Cat brought to garden". VO: "Very tolerant of you". Text: "Not allowed to play with the cat").
*Paulina Kemm's "Green Tea" item is... odd (-2AP). Using it in combat it actually seems to LOWER AP-cost by 2 (to a minimum of 1) for skills (and basic attack). That's some massive boost there 0_o. Is that intended? It would be the most powerful potion out there.
*In the basement of Kemm's estate there are 2 "Painting of a fan - placeholder" paintings. Sucks to be those Kickstarter backers smirk
**Also in that basement various items are not floored properly going through tables or ramps.
*On the second level of Lord Kemm's mansion the wall-mounted weaponry has a rather odd consistency what's considered theft and what isn't. Also they're all level 1, but that might be intentional.
*Going by the Rose in the garden the Red Prince/Fane talks about a Blood Rose bush. Also it has blood all around. Shouldn't it be a blood rose rather than the garden variety Rose?
*The arm you pull out of Jimmy in conversation already lies next to him before the conversation starts?
*Using the Magic Mirror and changing your instrument, no examples are given.
*Using the Magic Mirror the "current level" pop-ups only take into account gear levels;
*Seems using the mirror limits skills to [base] + [gear] = 10 (5 for civilian). Rather than base being 10/5. Fooled me there, had to re-do it, leaving 1 civil point left for Fane to spend in Thieving after using the mirror since he had +1 from gear.
*I lost 1 Intelligence for Fane for some reason using the Magic Mirror, and his avatar changed despite no changes to appearance.
*The Failed Expiriments (Dorian Gall's laboratory) also fall through the floor upon death.
*You can steal the potions out of the locked display cases at Dorian's without needing to lockpick the display case.
*Some (all?) of the healing potions at Dorian's are different from all others ("unknown effect").
*I found a cup of tea (I think in Kemm's Gardens, don't recall) with no effects, and I can't consume it even if it's in consumables.
*The Kemms' tea have no weight. They also cost no AP to use in battle.
*Onion has a 3AP cost to use in battle.
*Another "Placeholder fan painting" in the Demon's basement. It's incorrectly placed on the eel aswell, making it much harder to see. Poor backers.
*Can the eternal plate and bowl stack please???
*The armor on Lord Ruanay's boots seems a little low for it's level.
*In Kemm's Vault there's a lvl 2 Paladin Shield and lvl 5 Weaponry. That's probably not intended.
*Cat's shrug has one too many g's;
*The Wealthly Pilgrim seems to have some issues with money. I figured he was a good fence, but too many issues, way too many issues.
**Money just gone;
**If going over 100K gold, only the excess above 99999 is in his inventory, the rest missing;

Lizards can't sit re-mastered. To be fair, it was quite some time since I last saw a chair with a wrong direction, and there aren't all that many in Arx, while there are a lot of chairs and benches. But got some; (staring at a rockwall instead of the garden)
*The most confusing table in Rivellon;

Joined: Apr 2011
OP Offline
Joined: Apr 2011
New patch. So to be clear these are still all made on the old version ( And... I finished the game. Still probably will be one more report afterwards if I try some crafting (hate it, so didn't do really any at all) and find issues there... and I plan to murder Arx and loot it and likely there's many cloned books, fake gold etc. lying around when doing that. We'll see.
I can't say it'll be likely I'll replay so that would then be the final report. And of course making a nice review in my feedback topic later aswell. It's not all that positive, game's rather "okay". Not bad, not great. Just... okay. And that's a shame.

*The voidwoken near consulate's blood clips with a hole in the ground, heavily flickering.
*Female pilgrim there also has no VO if spoken directly to her.
*Cursed Revenants use normal hit-sounds (as if from living beings).
*Isn't Sadhe's presence in the consulate (reading ledger) supposed to update the Red Prince's quest rather than the Consulate questline?
* *look for the Face of the Red Princess* spirit-talking loops.
*Painting of Zorl-Stissa has an interaction, but you can't reach it to use it? (or is it just doing nothing?)
*Asking Alexander for the exit in Horrorsleep the VO volume is too low.
*Can't use regular tea herbs (+5% VP) with the teacup (creating Kemm's potions)?
*While being Mad Fane used potions again (tea) that didn't replace the old stack but became a new stack?
*The empty Djinn lamp at Sadhe is worth 1, while the one found in Driftwood was 2000?
*You can trade with the Shadow Prince when he appears in the Consulate.
*Killing him The Shadow Prince's Signet is level 16 (for a lvl 20 fight).
*Portal of Dreams map-note stays even when the Portal is gone.
*Spirit of the Dwarven Thief (sewers) lacks VO.
*While Targh's regeneration stopped upon poison, Log's didn't on poison, nor Latif's upon air damage?
*Poisoned carrot is just called "carrot"
*The Drudanae pipe I stol... found... later on did have the proper stats and worth. Could be just that Driftwood Dwarves' that's broken? Or a patch fixed it just for items picked since then?
*So if you piss off the Thieves and the trolls attack you the door locks. But the key can nowhere be found, bit of a trap (forcing teleporting) if you have no thievery character? Probably should be a key somewhere.
*Talking to the Royal Protector the entire conversation starts over and over and over.
*Ifan's "I can't believe I let this happen" upon using the Deathfog machine is unvoiced.
*You can't loot Ifan and don't get his items, all will be lost.
*After using the Deathfog there's still a note pointing at Paladin Kemm, but no body there?
*Some weird graphical anomaly with the deathfog at the cheese-stand.
*Quest that become unfinishable (Blood Dowry for example) should probably close when unleashing deathfog.
*It's kinda odd how all the children vanished rather than died. There were childrencorpses in the game at several occassions, why not for this?
*(!!! gamebreaker!) Although it seems the Deathfog is placed so it doesn't stop progression, you can't actually enter the Cathedral's Blood Path to finish the game unless you're undead, stopping you dead in track
*Killing the Queen her flag is still on the map aswell.
*Why is the Broken Source collar at the Source-drained souls a "brownish amulet"?
*Inside Kemm's Vault (painting placed) several books do not appear with ALT, including skill books!
**Same for Arhu's Chambers.
***And the Domoh Domura weapon under the Pet Basket there. Though that may be intentional to hide it.
*And, as with all placed gold on the map, the random gold found on the floor is more "fake gold"
*The "missing prisoners" quest already locks when you find the book detailing what happened to them, even if the Paladin Warden got a questreward for telling her about it?
**Even if going "So many experiments" once very rapidly her next random conversation was again "Maybe they escaped?"
*I found the Shrine in Kemm's basement, tried to confront him, but "Hammerfall" updated with 'He says he doesn't. Maybe we were lied to?'... Hello? God King Shrine?
*I told Brannt what happened to the prisoners and he left without caring for Wainslow's fate?
*Trader Friel is dead. So is Citizen Breifne and a Devine Prelate. No idea why.
*Do the city guide to Arx 1,2 and 4 even exist? I literally ONLY found 3 and 5 *ever*
*Sister Avenny says "You have the trust of Lord Arhu. Show that you deserve it"... to who? There's no-one else in the room, and it's definitely not to me, I haven't even met Arhu yet.
*Although all the male scribes work, the females are completely stuck, not animated.
*Dog's Ball should have the Shiny Red Ball description instead of the generic ball one.
*Asking Brother Lyle who created the trial his lines are unvoiced.
*Praying Paladins "A new devine shall rise" VO volume is very very low. If you talk to her again it sounds fine though.
*A pilgrim can suddenly go into prayer while sitting on a bench. It looks very weird.
*Some weird stuff goin on with the Arhu battle. It's supposed to be Ifan-other-Fane, but with Kemm arriving Fane gets skipped and 3 back guys get a turn in row, skipping Fane that round entirely???
*Why is Lord Kemm considered UNDEAD???
*The Arhu battle is a lvl 19/20 fight but the quest rewards for it are level 18.
*The Bloodied arms and unidentified flesh found near the Arhu fight have no conversations attached to them.
*It says Cow Form (Death Room) disables interactions, but it works just like Taunt/Mad taking your control away and allowing the AI to do all the things it *says* it disables?
*Chapter 7 log entry - "While Lucian Dallas used"... ehhhm?
**The log entry says my persuasion succeeded. I failed however (not realising it used Lohse for the convo rather than my Red Prince).
*Worm Tremor isn't resisted by Magic Armor for undead since it deals poison damage, even if it immobalates.
*There seems to be an issue with the Dragon's fly abbility near Dallis/Kraken. Take in mind those "hangs" took about 100x the duration for me ingame;
*During the ending scene Fane talks, Ifan talks... but Lohse? Nothing from Lohse... and we slept together in the Hall of Echoes. Such a shame...
*End of Lucian Tomb cutscenes again lack subtitles (the actual endings do have them).
*Epilogue journal: Shouldn't it be "I chose this world" rather than "this word" (Divine ending)
*Somehow Fane's journal says he stands against me, even if everything leading up he was supportive of me.
*Did the Lohse plot but seemingly it implies she's still possessed. Intended (one never knows with all the questbugs around)?
*Instead of calling his Soul Wolf when walking away, he does at the end of his walk, and if talked to again (over, and over, and over).
*The ending epilogue goes to Arx again before Gareth, even if starting with it. Also no mention at all about Dragons for the Lizards, even though I forfilled the profecy.
**Similarly nuking the Mother Tree with Deathfog apparently makes no difference what-so-ever? (Need to check Deathfogging Arx later)
*Refusing Divinity, the God King took over and updated Chapter 7's entry, the new entry being about 50% clone of the previous one in the journal though.
*The Epilogue may be even more messed up, saying a Godwoken entwined with Adramelik (or whatever) took power. I distinctly remember killing him in Arx, not to mention that was literally not at all what happened.
*I was then shown literally the shortest epilogue possible literaly starting with "And what of you?" as if there was supposed to be more before that (which probably is the case, right?)
*(source devided ending:) Seems it talks of a Dorotheya with a kiss. Who? Also Lagan passes... didn't I kill him?
**Similarly like the divine Arx comes along twice (got abandoned - seekers for the blood path) but this time Driftwood got duplicated aswell (it prospered, it became haven for trade).
*It doesn't really make much sense if I was revived without Source I can use Source skills and such on the epilogue ship, wouldn't you say? (Also how can the spirits still exist and be interacted with?)
*For the "no source" ending Driftwood and Arx appeared twice again aswell. As well as Dorotya (still no clue) and Lagan (still dead me thinks).
**Actually reading a guide I'm reminded who Dorotya is. And I killed her. Killed her good. So that's a bug.
Some screens;
*Don't think this conversation is supposed to be rigged like this;
*This ghost doesn't seem to realise his victim is, well, dead;
*Lizards can't sit, Dwarven edition;
*This unique seems to be missing something, and as a result is very very crappy;
*UNKNOWN container;
*These passages are just so... awkward. I can't help but feel something's lacking;
*Okay, in text it doesn't look that jarring, but the intonation "See you around" is said definitely makes it so...
*These shouldn't be setup like this. Heck, it shouldn't even be possible to loop either;
*But... but... this is the ending where I removed all Source;

Joined: Oct 2018
Joined: Oct 2018
im having the powerful awakening issue and i cant find any fix

Last edited by Avesinistra; 29/10/18 01:45 PM.

Moderated by  gbnf, Monodon 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5