Larian Banner
Previous Thread
Next Thread
Print Thread
Joined: Sep 2017
Gomisan Offline OP
stranger
OP Offline
stranger
Joined: Sep 2017
Yes, I've sent this to support, but after three days without a response I figure I'll give it a wider airing, perhaps someone else has an idea or two.

I've been experiencing problems with DOS2 ever since he official release. As a KS backer I had access to the pre-release versions and did not have any issues at that time. I'm pretty upset that I've bought the Collectors Edition, but cant even play the game! I've provided as much detail below as possible.

The Problem
The problem I am having is the game locks up/freezes everytime I play it (after I arrive on the island), usually usually in under 5 mins, though I have played as long as about 10 mins. It usually doesn't lock up until I have left the boat and landed on the island, but once at that point of the game it is constantly crashing.

This lockup is extreme, the computer becomes completely non-responsive, to the point that I have to force a power off and reboot. I've noticed that the lockup happens in three distinct stages. (albeit these happen quickly one after the other, and no matter what i try it always progresses)

The Symptoms
1) The mouse doesn't respond to a click (could be anything, opening a character sheet, closing the inventory, movement, attack etc) - mouse can still move for a couple of seconds then....
2) The mouse cursor changes to a windows 'waiting' cursor, animated.... for a second or two, and then...
3) The mouse cursor locks up and its animation freezes.
Game music continues playing indefinately. I have left the computer overnight in this state and it didn't recover, but the music kept playing.

I cannot access ANY other computer command. Alt-Tab, Ctrl-alt-del dont work, Caps and Num lock keys dont turn on/off. Any monitoring (such as Windows resource monitor or BIOS CPU heat/Fan monitor) stop updating their display.

Troubleshooting
This has been going on since release, and I have tried a LOT of different things. None of the patches have made any difference.
• Updated motherboard BIOS Firmware
• Updated system drivers, tried both legacy and latest video card drivers
• Removed ALL USB peripherals other than mouse and keyboard
• Removed Virtual USB device (Synology) - uninstalled and removed from device manager
• No problem devices in Device Manager
• Deleted profile and all save games and started from scratch
• Turn off cloud syncing
• Turned off auto and quick saves
• Uninstalled and or quit other programs that may have been running in background such as Discord, A/V, printer management, Adobe cloud, Dropbox etc etc

I have run system monitoring utilities both Windows Resource Monitor and Gigabyte's mainboard utilities and monitored CPU , Memory etc. No spikes in activity, CPU usage normal, temperatures normal, fan speed normal, hard drive access normal.

Event Viewer shows NOTHING. The full lockup means no events are being written to log. Also no Crashdump files are being created.

System Specs

OS Name Microsoft Windows 10 Pro
Version 10.0.15063 Build 15063
System Manufacturer Gigabyte Technology Co., Ltd.
System Model Z87-HD3
Processor Intel(R) Core(TM) i5-4670K CPU @ 3.40GHz, 3401 Mhz, 4 Core(s), 4 Logical
BIOS Version/Date American Megatrends Inc. F6, 3/08/2013
SMBIOS Version 2.7
Embedded Controller Version 255.255
BIOS Mode Legacy
Locale Australia
Hardware Abstraction Layer Version = "10.0.15063.502"
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 16.0 GB
Available Physical Memory 9.22 GB
Total Virtual Memory 18.3 GB
Available Virtual Memory 11.8 GB
Page File Space 2.38 GB
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualisation Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Radeon Software Version - 17.7.2
Radeon Software Edition - Crimson ReLive
Graphics Chipset - AMD Radeon R9 200 Series
Memory Size - 3072 MB
Memory Type - GDDR5
Core Clock - 1100 MHz
Windows Version - Windows 10 (64 bit)
System Memory - 16 GB
CPU Type - Intel(R) Core(TM) i5-4670K CPU @ 3.40GHz

PSU: Thermaltake TP-850MPCGAU, Toughpower 850W 80 Plus Gold

Power requirements check doen on a third party site puts my power load at under 450W requirement, so PSU has PLENTY of headroom.




Joined: Jul 2014
C
stranger
Offline
stranger
C
Joined: Jul 2014
same here...i noticed most of having this randomly freezing problem are AMD card users.......and problem usually occurs during combat its just sudden freeze my computer system and require a hard reset......some time i can play 2-3 hour without any problem....the only temporary solution now is change full screen to fake full screen and cap FPS to 60 fps.......and lower my resolution from 144hz to 60 hz.......

Last edited by commander1122; 12/10/17 03:43 AM.
Joined: Sep 2017
Gomisan Offline OP
stranger
OP Offline
stranger
Joined: Sep 2017
I wish I had it as good as you!

I can play through the first party on the ship, but once I've landed on the island I'm guaranteed a crash every 5 to 10 mins. Makes it unplayable.

I've tried fake and windowed modes, but I might try dropping refresh rates and FPS. I mean at this point anything is worth trying!

Also, it's not combat for me that causes it. It can happen at anytime without warning.

Joined: Jul 2014
C
stranger
Offline
stranger
C
Joined: Jul 2014
anyway i also using an AMD r290x graphic card.....

Joined: Oct 2017
A
stranger
Offline
stranger
A
Joined: Oct 2017
same problem here, GTX 580.

Joined: Jun 2010
E
apprentice
Offline
apprentice
E
Joined: Jun 2010
Try running a monitoring program like Afterburner, specifically single out RAM and VRAM usage and alt+f4 your game as soon as it starts to lock up. Does anything look out of order at this point? Look at thermals as well, it could always be related to overheating although that usually causes a BSOD.

Also what game version are you on? It should tell you in the top right corner of the main menu. Don't tell me which patch GOG or Steam supposedly installed, but which version the game recognizes.

Last edited by Eolath; 12/10/17 02:32 PM.
Joined: Sep 2017
Gomisan Offline OP
stranger
OP Offline
stranger
Joined: Sep 2017
Hopefully I'll get time tonight and over the weekend to try a couple more ideas that people have put forth.

I have tried monitoring RAM and CPU, and watching the game's processes in particular, but at the moment the game starts to lock up the k/b becomes unresponsive. So alt-f4, alt-tab, crtl-alt-del ... nothing works.

Monitoring software running on a second monitor shows that the game is running well within the computers capabilities with temp, CPU use, RAM usage, RAM errors etc etc all staying stable, no obvious memory leaks or runaway process.

I'd screenshot it but... that's right, k/b non responsive. I guess I could take screen shots every few seconds while playing and then pick the one closest to the crash... but honestly it doesn't look like that is where the issue is.

I'll provide the game version when I get home.


Moderated by  gbnf, Monodon 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5