Larian Banner
Previous Thread
Next Thread
Print Thread
Update broke my mod #633783
26/10/17 06:59 PM
26/10/17 06:59 PM
Joined: Oct 2017
Posts: 17
T
T-Rection Offline OP
stranger
T-Rection  Offline OP
stranger
T

Joined: Oct 2017
Posts: 17
Just wondering what was changed with the new update to the editor, i have been working on a race mod for about a week now and i finally got it working, this morning i start up steam to find that there has been an update and upon starting the game have found that it has broken my mod, nothing in the mod file or editor files have been changed but my mod and a few others from steam no longer works.

Re: Update broke my mod [Re: T-Rection] #633797
26/10/17 07:49 PM
26/10/17 07:49 PM
Joined: Oct 2017
Posts: 17
T
T-Rection Offline OP
stranger
T-Rection  Offline OP
stranger
T

Joined: Oct 2017
Posts: 17
It would appear that the engine somehow had overwritten my mod along with a couple others. I managed to fix this by uninstalling and reinstalling the steam mods as well as deleting my race mod and remaking it as a new project. Everything seems to be working now *fingers crossed*

Re: Update broke my mod [Re: T-Rection] #633822
26/10/17 09:09 PM
26/10/17 09:09 PM
Joined: May 2017
Posts: 349
LaughingLeader Offline
enthusiast
LaughingLeader  Offline
enthusiast

Joined: May 2017
Posts: 349
Not sure if this is related to your mod, but I had to generate definitions + build my mods with story scripts to get them to load properly in-game. This is probably because they changed the MoveAllItemsTo call and added an additional parameter, which then causes an error in a few base scripts (if you don't generate definitions).

Re: Update broke my mod [Re: T-Rection] #633824
26/10/17 09:19 PM
26/10/17 09:19 PM
Joined: Sep 2017
Posts: 159
M
monzua Offline
member
monzua  Offline
member
M

Joined: Sep 2017
Posts: 159
JESUS - ONE HOUR WASTED - sorry to be upset but THIS is soo annoing. WHY???

Re: Update broke my mod [Re: T-Rection] #633825
26/10/17 09:21 PM
26/10/17 09:21 PM
Joined: Sep 2017
Posts: 159
M
monzua Offline
member
monzua  Offline
member
M

Joined: Sep 2017
Posts: 159
Please tell me in simple english how to fix it before i start raging again ^^

Re: Update broke my mod [Re: T-Rection] #633828
26/10/17 09:25 PM
26/10/17 09:25 PM
Joined: Jan 2010
Posts: 362
USA
F
fireundubh Offline
enthusiast
fireundubh  Offline
enthusiast
F

Joined: Jan 2010
Posts: 362
USA
You should be more specific about your issue. "Broken" and "no longer works" are not enough for third-party diagnosis.

Re: Update broke my mod [Re: LaughingLeader] #633830
26/10/17 09:27 PM
26/10/17 09:27 PM
Joined: Sep 2017
Posts: 159
M
monzua Offline
member
monzua  Offline
member
M

Joined: Sep 2017
Posts: 159
Originally Posted by LaughingLeader
Not sure if this is related to your mod, but I had to generate definitions + build my mods with story scripts to get them to load properly in-game. This is probably because they changed the MoveAllItemsTo call and added an additional parameter, which then causes an error in a few base scripts (if you don't generate definitions).


How can i fix this`?

Re: Update broke my mod [Re: monzua] #633833
26/10/17 09:29 PM
26/10/17 09:29 PM
Joined: Dec 2013
Posts: 872
Windemere Offline

old hand
Windemere  Offline

old hand

Joined: Dec 2013
Posts: 872
Originally Posted by monzua
Originally Posted by LaughingLeader
Not sure if this is related to your mod, but I had to generate definitions + build my mods with story scripts to get them to load properly in-game. This is probably because they changed the MoveAllItemsTo call and added an additional parameter, which then causes an error in a few base scripts (if you don't generate definitions).


How can i fix this`?


Open up the story editor and select File->Generate Definitions, Build, and Reload.

Last edited by Windemere; 26/10/17 09:30 PM.

DOS2 Mods: Happily Emmie After and The Noisy Crypt

Steam Workshop
Nexus Mods
Re: Update broke my mod [Re: Windemere] #633834
26/10/17 09:31 PM
26/10/17 09:31 PM
Joined: Sep 2017
Posts: 159
M
monzua Offline
member
monzua  Offline
member
M

Joined: Sep 2017
Posts: 159
Originally Posted by Windemere
Originally Posted by monzua
Originally Posted by LaughingLeader
Not sure if this is related to your mod, but I had to generate definitions + build my mods with story scripts to get them to load properly in-game. This is probably because they changed the MoveAllItemsTo call and added an additional parameter, which then causes an error in a few base scripts (if you don't generate definitions).


How can i fix this`?


Open up the story editor and select File->Generate Definitions, Build, and Re-load.


Doesnt fix it for me sadly.



Re: Update broke my mod [Re: T-Rection] #633835
26/10/17 09:33 PM
26/10/17 09:33 PM
Joined: Sep 2017
Posts: 159
M
monzua Offline
member
monzua  Offline
member
M

Joined: Sep 2017
Posts: 159
[Linked Image]

Re: Update broke my mod [Re: T-Rection] #633838
26/10/17 09:45 PM
26/10/17 09:45 PM
Joined: Sep 2017
Posts: 159
M
monzua Offline
member
monzua  Offline
member
M

Joined: Sep 2017
Posts: 159
I was able to fix it by creating a copy of _Global & _CRIME_Prison in my mod and then manually adding the new parameter to the calls .... lets hope for the best I used correct Parameter so I didnt break anything...

PS: You can only edit the script (you didnt creat) by right clicking and selecting "Copy to my mod.." What a shame i wasted another 15 minutes on this´...

Last edited by monzua; 26/10/17 09:48 PM.
Re: Update broke my mod [Re: monzua] #633844
26/10/17 10:00 PM
26/10/17 10:00 PM
Joined: May 2017
Posts: 349
LaughingLeader Offline
enthusiast
LaughingLeader  Offline
enthusiast

Joined: May 2017
Posts: 349
Originally Posted by monzua
I was able to fix it by creating a copy of _Global & _CRIME_Prison in my mod and then manually adding the new parameter to the calls .... lets hope for the best I used correct Parameter so I didnt break anything...

Did you originally overwrite those files?

Those files had "errors" for me as well until I clicked "File -> Generate Definitions & Build". The errors are from the MoveAllItemsTo call gaining a new parameter, and your definitions file not having that definition, hence why you need to rebuild the definitions. The base story files should have been updated from the last patch, if your files were updated correctly.

Re: Update broke my mod [Re: fireundubh] #633908
27/10/17 01:40 AM
27/10/17 01:40 AM
Joined: Oct 2017
Posts: 17
T
T-Rection Offline OP
stranger
T-Rection  Offline OP
stranger
T

Joined: Oct 2017
Posts: 17
It was as if my mod no longer existed, just to help with anyone else or to clarify, i didnt overwrite any of the games files, it was as if the game no longer recognized my mod. All the files were still their and nothing had been changed and yet it no longer worked in game. The only way i managed to fix this issue was to fully delete my mod from the game files and delete the project itself from the editor and then start it all over again as a new project. Everything seems to be working fine now so i honestly have no idea why that happened..

Last edited by T-Rection; 27/10/17 01:43 AM.
Re: Update broke my mod [Re: T-Rection] #634015
27/10/17 10:56 AM
27/10/17 10:56 AM
Joined: Jun 2013
Posts: 655
Cromcrom Offline
addict
Cromcrom  Offline
addict

Joined: Jun 2013
Posts: 655
Mod is broken, I have to generate definitions every times, and some flags don't work anymore. F*g crap s*t


Un chemin de 1000 lieues commence par un premier pas.

Project:
Steam workshop Frontiere
Re: Update broke my mod [Re: Cromcrom] #634086
27/10/17 03:10 PM
27/10/17 03:10 PM
Joined: Sep 2017
Posts: 159
M
monzua Offline
member
monzua  Offline
member
M

Joined: Sep 2017
Posts: 159
Originally Posted by Cromcrom
Mod is broken, I have to generate definitions every times, and some flags don't work anymore. F*g crap s*t


i feel your pain - i had to manually edit larians OWN default scripts to make them work again - god knows why they put so many obstancles into the editor...

Re: Update broke my mod [Re: T-Rection] #634387
28/10/17 07:25 PM
28/10/17 07:25 PM
Joined: Aug 2017
Posts: 168
D
D00med Offline
member
D00med  Offline
member
D

Joined: Aug 2017
Posts: 168
I don't know what the update has done, but mods seem broken. For example my own mod seems to work on my local machine, but the published version on steam is completely non-functional.

https://imgur.com/a/mXWR4 This shows the crate I added (with books) in editor. I load this very mod published on steam on my 2nd PC and there is nothing there (No crate or trace of any of my mod). At the same time I'm getting a warning on my 2nd pc telling me that I have invalid dependencies https://imgur.com/a/sHq8d People are reporting the same problem to me. I have manually deleted everything and re-installed on my 2nd PC, problems remain.

So I'm guessing the editor is broke or the publish button isn't publishing everything needed?

Re: Update broke my mod [Re: T-Rection] #634439
29/10/17 01:41 AM
29/10/17 01:41 AM
Joined: Sep 2017
Posts: 59
J
JRavens Offline
journeyman
JRavens  Offline
journeyman
J

Joined: Sep 2017
Posts: 59
@D00Med - have you tried clearing the local mods AND mods folder (both folders) on the 2nd PC and resubscribing to it?

1) Unsubscribe
2) Clean out MODS and LOCAL MODS in My Documents\Larian\Divinity 2\
3) Resubscribe

Test and see if that makes any difference.

Re: Update broke my mod [Re: T-Rection] #634444
29/10/17 02:59 AM
29/10/17 02:59 AM
Joined: Sep 2016
Posts: 81
G
Grondoth Offline
journeyman
Grondoth  Offline
journeyman
G

Joined: Sep 2016
Posts: 81
Anyone figure out how to do model replacement now? The old ways no longer work.


Moderated by  Larian_Koala, Larian_KVN 

Powered by UBB.threads™ PHP Forum Software 7.6.2