Larian Banner
Previous Thread
Next Thread
Print Thread
Joined: Jan 2018
Posts: 37
C
apprentice
OP Offline
apprentice
C
Joined: Jan 2018
Posts: 37
At late game (Act 4) seems all unique wands and all unique staff do not provide any critical chance. But many 2H Axe/hammer/sword/1H sword/dagger have critical chance. So to make critical build the mage had to equip an unique melee weapon (excluding staff). Or finding special staff or wands with crit from traders... Feels bad man.

Last edited by Core One; 03/10/18 06:26 PM.
Joined: Oct 2017
Posts: 556
addict
Offline
addict
Joined: Oct 2017
Posts: 556
Back in my classic playthrough, I got a strong impression that all wands with critical chance modifier seemed to almost disappear altogether. It was impossible to find two wands with +10% critical chance. All the ones that had +5% were only blue-tier. Legendary and divine-tier ones pretty much stopped being spawned with critical chance.

But then a big problem with Act 4 is that it is really hard to outfit your entire party with decent equipment. There are only a few traders that do sell equipment, but they don't sell equipment of all classes (STR, FIN, INT), and sometimes they don't even generate magical items. You're at level 19 and you realize your mage is still using level 17 pants, and want to get a new pair of mage pants with decent modifiers? Good luck with that.

I just hit level 20 earlier and realized my mage is still using level 17 and level 15 wands.


"We make our choices and take what comes and the rest is void."
Joined: Sep 2017
Posts: 81
S
journeyman
Offline
journeyman
S
Joined: Sep 2017
Posts: 81
iirc most of the Wands with crit (and other weapons too) were nerfed in DE. at least the wand with a socket and +10%crit from act1 were changed to 5%. and later vendors had only 7%crit wands.....

not that I complain. mages rarely use wands for damage. and if you have int+10%crit+socket(another 3wits with a rune)… you'll never need to replace it again


Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5