Larian Banner
Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
Joined: Jan 2014
Elverils/Larian Studios
OP Offline
Elverils/Larian Studios
Joined: Jan 2014
Anybody who want to try out dos2 without any Avx can ask Raze to join the public beta
Please remember that goal of the beta is to gather your input on the executable.

Beta will last fairly quickly and then we will integrate the fix. We don’t need Apple or any os updates.

The faster you report success or failure the faster we can close this smile

Joined: Mar 2003
Location: Canada
Support
Offline
Support
Joined: Mar 2003
Location: Canada

EDIT: since the beta has not been updated since the 2013 AVX2 fixes were moved to the main branch, it is outdated and I removed the passwords below.

With the Steam version, right click on the game in the library, select Properties, switch to the Betas tab and enter the password <redacted>. That should unlock a branch called 'public_macbeta', which you can select from the dropdown list.

With the GOG version, in Galaxy, select the game, click More and select Settings; near the top, to the right of the 'Configure Game' heading, click on 'Beta Channels' and select 'On', then click on 'default' for the Channel, select 'Add Private Channels', enter the password <redacted>, click Submit, then re-open the Channel dropdown list and select 'Public_MacBeta'.

Last edited by Raze; 12/06/19 06:11 AM.
Joined: Jan 2014
Elverils/Larian Studios
OP Offline
Elverils/Larian Studios
Joined: Jan 2014
Public beta is being updated with more AVX2 fixes.

Joined: Oct 2006
F
journeyman
Offline
journeyman
F
Joined: Oct 2006
Cool noted, going try.

EDIT: Problem fixed (AVX2 required) the game launch fine, Mac Pro late 2013, ADM FirePro D700 6Gb VRAM, Intel Xeon 6 cores 3.5Ghz, 16Gb RAM, macOS 10.13.6.

Reach welcome screen fast.

Thanks to Larian and the Russian dev team.

EDIT2: The performances seem for now better than for DOS. But I need reach a town to get a better point of view. There's a slider to tune the speed of camera scroll, there should be one for camera rotation and one for zoom in/out. Both are too fast and change the mouse (trackball kensignton) setup isn't a good/cool option in general, but I think I can have a setup just for the game.

Last edited by Fend; 05/02/19 08:25 PM.
Joined: Jan 2014
Elverils/Larian Studios
OP Offline
Elverils/Larian Studios
Joined: Jan 2014
Mojave should provide even better experience. Please note Avx fixes are not going to ship in next patch.

The problem is that old MacPro 2010 doesn’t support Avx at all. MacPro 2013 supports Avx but not avx2. Thus we will continue to remove code and we will see how it goes. For now we are not finished yet.

MacPro 2010 might in the end be considered unsupported frown but let’s see
MacPro 2013 will be definitely supported.

MacPro 2010 users should have game launching now and crash should be in lz4.


Joined: Oct 2006
F
journeyman
Offline
journeyman
F
Joined: Oct 2006
I only played the tutorial and the next area, a lot of stuff to do and no problem so far, but it's a tiny bit. I'll play more later or tomorrow, I wasn't ready to start play the game because of the avx2 problem.

Mojave is too recent for me, I'll prefer delay, if even I can upgrade to it.


Joined: Oct 2006
F
journeyman
Offline
journeyman
F
Joined: Oct 2006
Originally Posted by Stauff1138
Mojave should provide even better experience. Please note Avx fixes are not going to ship in next patch.

The problem is that old MacPro 2010 doesn’t support Avx at all. MacPro 2013 supports Avx but not avx2. Thus we will continue to remove code and we will see how it goes. For now we are not finished yet.

MacPro 2010 might in the end be considered unsupported frown but let’s see
MacPro 2013 will be definitely supported.

MacPro 2010 users should have game launching now and crash should be in lz4.


Isn't it risked to just remove it? I quoted in windows it's AVX that is used/required, not AVX2, remove for Mac everything AVX could slower pointlessly the Mac version.

I can understand you want support Mac Pro 2010, but why it worth it for a so old model? I always ignored those MacPro generations (switched from first MacPro to the one late 2013, so I don't know what was this series, but can they run the game even fairly well?

For sure, I don't have the right perspective, the best would have been a special version for non AVX. But ok it's perhaps not possible.

Last edited by Fend; 06/02/19 08:15 AM.
Joined: Feb 2019
stranger
Offline
stranger
Joined: Feb 2019
I have an early 2009 mac pro, but flashed so it thinks its a 2010.
My system specs are:

OSX 10.14.1
Early 2009 Mac Pro (flashed firmware to 2010) ... not sure what, or if this matters
2 x 3.46 GHz 6-Core Xeon (Dual X5690)
64 GB 1333 Mhz Ram
AMD R9 280x

So, from a hardware standpoint, there should be no issues here. In fact, I know I can run the game on the highest settings on this setup because I've tried it in windows. I no longer have access to the windows partition and would very much like this to work on my system. Currently, the beta is not working for me. I've sent my crash data to the team.

Thank you.

Joined: Feb 2019
stranger
Offline
stranger
Joined: Feb 2019
Initial results are good for me. Loaded and played a part of the beginning act. Joined a saved multiplayer game and walked around a bit. [s]Initial load time feels a bit slow compared to running under BootCamp though I did not time it.[/s] There are the obvious Nvidia issues as well. Hopefully life will be more manageable tomorrow and I will continue my game with my wife for a more proper test.

10.14.2 (18C54)
iMac (27-inch, Late 2012)
3.2 GHz Intel Core i5
16 GB 1600 MHz DDR3
NVIDIA GeForce GTX 675MX 1024 MB

Last edited by GoblinCleaver; 08/02/19 06:17 AM. Reason: Load time is fine
Joined: Feb 2019
journeyman
Offline
journeyman
Joined: Feb 2019
Works really well on a 2013 13" MacBook Pro with an eGPU. High Sierra. I currently have an NVidia 1050Ti card. I am getting some flickering when moving through dark areas, but it doesn't affect performance. I'll put together an AMD RX570 set-up this weekend to test the flickering issue since you don't support the NVidia cards.

Joe

Joined: Feb 2019
stranger
Offline
stranger
Joined: Feb 2019
The recent update was not rolled into the beta so I cannot test playing with my wife as version numbers are different. Do you plan another beta release or do you have enough data from this one?

Last edited by GoblinCleaver; 08/02/19 08:24 AM. Reason: I can't spell!
Joined: Mar 2003
Location: Canada
Support
Offline
Support
Joined: Mar 2003
Location: Canada

GoblinCleaver
There will be more beta updates to continue testing AVX2 fixes, including one later today or early next week. You may need to wait for the AVX2 fixes to be moved to the main release to get matching version numbers, though.


jfutral
The flickering issue may be better, or possibly eliminated, at lower game resolutions.

Last edited by Raze; 08/02/19 08:29 AM.
Joined: Mar 2003
Location: Canada
Support
Offline
Support
Joined: Mar 2003
Location: Canada

GoblinCleaver
The beta has been updated to include the recent updates to the main branch, so if your wife switches to the beta, you'll stay in sync until the AVX2 fixes are moved to the main branch.

Joined: Feb 2019
stranger
Offline
stranger
Joined: Feb 2019
My 2010 machine finally saw a launch menu today, but it still crashed. Hopefully work continues! Thank you all so much.

Edit: I apparently saw the config panel, and can consistently pull that up while holding cmd when launching. Still no game launch.

Last edited by kartoonstew; 08/02/19 06:40 PM.
Joined: Feb 2019
journeyman
Offline
journeyman
Joined: Feb 2019
Dropping down to 1280x720 got rid of the flickering. A bit disappointing since I was able to run DOS1 at 1920x1080 no prob. But only a little. Hopefully the AMD setup will alleviate this?

Anyway, still a great game and glad I can play on my old, barely hanging in there, machine!

Joe

Joined: Mar 2003
Location: Canada
Support
Offline
Support
Joined: Mar 2003
Location: Canada

kartoonstew
There will continue to be beta updates with additional AVX2 fixes.


jfutral
Yes, the AMD GPU should have similar performance, but without the flicker issue.

Joined: Feb 2019
stranger
Offline
stranger
Joined: Feb 2019
Originally Posted by Raze

GoblinCleaver
The beta has been updated to include the recent updates to the main branch, so if your wife switches to the beta, you'll stay in sync until the AVX2 fixes are moved to the main branch.


Thank you. She actually plays on Windows so we should be in sync now. When we get out of sync, I will just reboot into Windows. I just prefer to play on the MacOS side when I can.

Joined: Nov 2018
stranger
Offline
stranger
Joined: Nov 2018
Hey, I just installed the beta on late 2012 15" Macbook Pro and the game itself seems to work well. Should I be able to connect via LAN to my wife's windows install? These are both GOG installs, one regular Windows install, one beta Mac. The GOG window shows 3.6.36.1643 on Windows and 3.6.36.1643_beta on Mac.

Whenever I go on LAN connection, I cannot connect. It says that the Mac version doesn't match and lists it as 3.6.35.8270. I hosted via the Mac version, and it is the Windows version that cannot connect. I'm going to try the reverse now, but any tips to get LAN going would be great! Thanks.

Joined: Feb 2019
stranger
Offline
stranger
Joined: Feb 2019
I am playing on he LAN with my wife. I am using the Steam Mac Beta version and she is using the Steam Windows version. Everything seems to be working correctly aside from the known issues with Nvidia cards.

My wife hosts on the Windows box.

No idea why the GoG version does not work as I do not have access to it.

Last edited by GoblinCleaver; 10/02/19 03:42 AM.
Joined: Feb 2019
journeyman
Offline
journeyman
Joined: Feb 2019
Great that the AMD set-up fixed my graphics issue. Funny that the NVidia Gameworks splash screen pops up.

Joe

Page 1 of 2 1 2

Moderated by  gbnf, Monodon, Nicou 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5