Larian Banner
Previous Thread
Next Thread
Print Thread
Page 5 of 7 1 2 3 4 5 6 7
Joined: Sep 2017
G
stranger
Offline
stranger
G
Joined: Sep 2017
I ran into the issues above none of the fixes worked, however i did find an interesting work around, navigate to where ever your game is installed IE X:\SteamLibrary\steamapps\common\Baldurs Gate 3\bin change the compatibility as above to admin for all users on both EXE files "BG3" and "bg3_dx11" then run steam and the launcher

instead of using the play on the launcher tab over to the windows browser where the EXE files named above are hold Shift and Select both exe's simultaneously right click and hit open, this will try and launch them both at the same time, and prompt the ( allow run on this system (admin ) both games should flash and try to run, at this point usually but not always the DX 11 version will eventually crash, but the Vulcan version will now run normally.

Sometimes the other way around (Vulcan will crash dx 11 will succeed). If you tab between them you will see which one launched successfully then you can force end the one that has crashed or will eventually crash from the task manager and play away, this is the only reliable way to open the game that has worked for my windows 7 machine. best of luck!

Loptr #680337 08/10/20 05:17 AM
Joined: Oct 2020
stranger
Offline
stranger
Joined: Oct 2020
I bought this game within the first few hours on it being released and I cant get it to start up. I have tried uninstalling it multiple times before and after restarting steam and my tower and i have tried verifying the integrity of the files downloaded. Every time I get the same thing MISSING GAME FILES- this is exactly what it says when I hover over the words. please someone help me with this I truly want to play and game test this game!

C:\Program Files (x86)Steam\steamapps\downloading\1086940\Launcher\CefSharp.BrowserSubprocess.exe

Loptr #680421 08/10/20 06:30 AM
Joined: Oct 2020
stranger
Offline
stranger
Joined: Oct 2020
I was able to load yesterday (once)after multiple attempts by using DX11. Was able to create a character and start the game. Tried loading today probably about 50 times and nothing that I tried worked - updated drivers etc and switched from DX11 to Vulcan . My Profile and savegame are in the system files so the game did work at some point. I'm on steam and there was a hotfix today - perhaps it "unfixed" my game. BTW I did report each crash to Larian

Loptr #680423 08/10/20 06:32 AM
Joined: Oct 2020
stranger
Offline
stranger
Joined: Oct 2020
I was able to load yesterday (once)after multiple attempts by using DX11. Was able to create a character and start the game. Tried loading today probably about 50 times and nothing that I tried worked - updated drivers etc and switched from DX11 to Vulcan . My Profile and savegame are in the system files so the game did work at some point. I'm on steam and there was a hotfix today - perhaps it "unfixed" my game. BTW I did report each crash to Larian

Loptr #680469 08/10/20 07:11 AM
Joined: Oct 2020
stranger
Offline
stranger
Joined: Oct 2020
Deleting my profile in the Documents folder allowed me to start the game again with no problems.

Joined: Oct 2020
stranger
Offline
stranger
Joined: Oct 2020
I tried your solution, it worked! Did a dozen times just to be sure, with both 'bg3.exe' and 'bg3_dx11.exe'.

But in my case there was a peculiar thing: in my tests, when I clicked 'Run as Administrator', I had to quickly close the Explorer window, otherwise the game would crash as before.

Well, so far so good.

Thank you and gather your party before venturing forth.

EDIT:

Originally Posted by Liliana M
Win 7, GOG Galaxy. Black screen at launch.

What works for me:
1. Hold SHIFT (or any other key) + click Play button from Larian Launcher and keep holding SHIFT until the game loads. (no need to launch from exe, or messing with administrator rights)
2. Click Play button from Larian Launcher and keep fast clicking anywhere within the Larian Launcher window until the game loads in the background.
3. Click Play and keep spamming Alt+Tab until the game loads.

It seems that the game crashes if the game window is focused when launching.
But it works when you keep the game window (out of focus) in the background while it is loading - else by spam clicking, or holding keyboard keys.


Tried this, and worked too. It's hilarious this rascaldom of solutions that is actually the only way to play tha game.



Last edited by Barkhamn; 08/10/20 08:35 AM.
Jaws #680499 08/10/20 07:34 AM
Joined: Oct 2020
stranger
Offline
stranger
Joined: Oct 2020
this is stupid... this forum post is stupid.... game still not running from the hotfix yesterday larian... plz help guys

Joined: Oct 2020
stranger
Offline
stranger
Joined: Oct 2020
Originally Posted by TheBlackMarvel
Deleting my profile in the Documents folder allowed me to start the game again with no problems.


Deleting the PlayerProfile Folder is what fixed it for me after trying everything else everyone has posted, started the game in vulkan as well and now i'm playing again!

Loptr #681666 08/10/20 05:54 PM
Joined: Jul 2020
member
Offline
member
Joined: Jul 2020
Still no reaction from Larian on this issue?

The SHIFT+run as admin doesn't work every time here, it's about 50%, sometimes I even have to do it 3-4 times in a row

EDIT: scratch that, the success rate is much, much lower than 50%

Last edited by Redglyph; 09/10/20 07:58 AM.
Loptr #681737 08/10/20 06:32 PM
Joined: Oct 2020
stranger
Offline
stranger
Joined: Oct 2020
I have a Win 10 CyberPower PC, purchased the game from Steam, and all Windows updates have been installed. I have disabled the AMD Radeon overlay, however the game still will not launch. I receive an error message asking me to check if Windows updates have been installed, if the drivers have been installed, and to disable SLI/CrossfireX.

I can not find where SLI/CrossfireX is. AMD Radeon is also up to date.

Suggestions?

Loptr #682067 08/10/20 08:58 PM
Joined: Oct 2020
stranger
Offline
stranger
Joined: Oct 2020
Add me to the din of people where holding down shift and right click to run as administrator FINALLY worked for me. Just in time for my Steam refund to come through, OH WELL. Got to create a character at least.

Loptr #682089 08/10/20 09:13 PM
Joined: Oct 2020
stranger
Offline
stranger
Joined: Oct 2020
A friend gave me the game a few hours ago, I was able to play 1 hour, then I did chores around the house and when I returned the game no longer opens.

Loptr #682102 08/10/20 09:24 PM
Joined: Oct 2020
stranger
Offline
stranger
Joined: Oct 2020
For me it only works when launching directly via the bg3_dx11.exe file and I have to verify integrity of game files on steam before every launch.

Last edited by Obsidian Gold; 08/10/20 09:26 PM.

When the time has come... oh wait, I can make it come!
Loptr #682188 08/10/20 10:09 PM
Joined: Oct 2020
stranger
Offline
stranger
Joined: Oct 2020
@MTGPackFoils crossfire/SLI is only if you have dual graphics cards working at the same time. If you only have 1 card its not on for you.

aylictal #682295 08/10/20 11:12 PM
Joined: Oct 2020
stranger
Offline
stranger
Joined: Oct 2020
Originally Posted by aylictal
@MTGPackFoils crossfire/SLI is only if you have dual graphics cards working at the same time. If you only have 1 card its not on for you.


I still can not log in. It doesn't matter if I choose the default option, or the DirectX 11 option. If I choose the latter both of my monitors turn black, and my computer reboots. If I choose the default I receive the following message:

"The game has encountered an unrecoverable Vulkan error and will shut down.
This error may be triggered by reasons that are not related to Baldur's Gate 3.

Please try the following before restarting:
-Disable any screen recording software you may be running
-Make sure all your Windows updates have been installed
-Make sure you have the latest graphics drivers installed
-Disable SLI/CrossFireX

You could also try contacting developer support with your gold.log and your vulakninfo.txt.
If you make significant changes to your system (like installing updates or drivers), please send us before and after versions of those files. We are sorry for the inconvenience."

So...now what do I do if I have done all of this?

Last edited by MTGPackFoils; 08/10/20 11:12 PM. Reason: forgot something
Loptr #682374 09/10/20 12:03 AM
Joined: Oct 2020
K
stranger
Offline
stranger
K
Joined: Oct 2020
For ASUS motherboard users, this may sound silly but it worked for me.

Download ASUS Armoury Crate from their website, and use it to update your drivers. I had updated my drivers through device manager as an earlier attempt, but the game would still not launch without crashing.

After using the Armory Crate software to update, I was able to launch in Vulkan and DX11 without issues. I realize this is not for everyone, but hopefully it will help someone.


Last edited by kast; 09/10/20 12:04 AM.
Joined: Oct 2020
X
stranger
Offline
stranger
X
Joined: Oct 2020
bump...

This seemed to work for me after black screen issue at launch via Vulkan and DX11

Machine specs = Win7, Intel 4790k, GTX108

Many tanks captainfish!

good luck lads

Loptr #682507 09/10/20 01:15 AM
Joined: Oct 2020
stranger
Offline
stranger
Joined: Oct 2020
I have uninstalled, and reinstalled from Steam.

Same problems. What do I do now? I have a CyberPowerPC on Win 10 with dual monitors.

Loptr #682829 09/10/20 04:55 AM
Joined: Jan 2009
veteran
Offline
veteran
Joined: Jan 2009
For me and many others, Double-clicking bg3_dx11.exe and immediately holding down left Shift works.

I did not need to do shift+run as administrator (although I will note that I am running from an admin account already), or select both executables. Good luck figuring this out, QA department.

Joined: Oct 2020
S
stranger
Offline
stranger
S
Joined: Oct 2020
Originally Posted by lDanielHolm
When I start the game with Vulkan, it directly crashes; I don't even get an opening screen. When I start it using DirectX 11, it goes to a black screen, at which point nothing happens and I have to force it to shut down via the task manager.

I've had this problem also with it only managing to launch properly once in more than a dozen tries at this point.

Originally Posted by Bitterman
Gentlemen/ladies, I have mine through steam. What worked for me was finding the exe in the programfiles (x86)/Steam/steamapps/common/baldursgate3/bin folder....or where ever similar you may have manually installed it.

Once there, clicking on bg3.exe to select/highlight first, I then held SHIFT and right clicked on it again to bring up the menu to choose "Run as Administrator". The game launched properly from there.

Give it a go, hope that works.

Run as admin worked once, the first time I tried it and then not again.

Last edited by Sinthel; 09/10/20 06:18 AM.
Page 5 of 7 1 2 3 4 5 6 7

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5