Larian Banner
Previous Thread
Next Thread
Print Thread
#720724 28/10/20 07:46 PM
Joined: Oct 2020
M
Meteox Offline OP
stranger
OP Offline
stranger
M
Joined: Oct 2020
For more than several hours me and a friend try so setup multiplayer session, but we cant connect to each other.

I have the Steam Version, he has the GOG Version. Both are von 3.6.69.4648.

We always get the error "Connection failed: No free Slots".

When a third friend who has the game (Steam Version) sets up a lobby can both join it and start the game.

Anybody has an idea how to get this working?

Joined: Mar 2003
Location: Canada
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Location: Canada

Have you tried joining in an existing save, as long as there are at least 2 characters in the party?

Are you shutting down all non-essential programs before starting the game, especially anti-virus and anything network related (utility or monitoring programs, etc)?

Have you tried hosting/joining an Arena match?

If you are using any mods, try testing in a new profile without any mods enabled.

Can either of you try switching between a wired and wifi connection, if available, to see if that makes a difference?
If possible, testing with a mobile phone's wifi hotspot feature, VPN or other available network, could help confirm if it is a network or system issue.


Try verifying local files: in the Steam library, right click on the game and select Properties, switch to the Local Files tab and then click on the 'Verify Integrity of Game Files...' button.
With the GOG version, in the (optional) Galaxy client, select the game, then the settings icon at the top right (beside the Play button) and under Manage Installation select 'Verify / Repair'.

Note that after verifying files, if any mods you use require Norbyte's Script Extender, the dll will need to be replaced again.


Have you tried different ways to join? Other than Direct Connection (with a Server ID, which the host can get in the Connectivity Menu after starting a new game or loading a save, or IP address), LAN may be an option, but since you are not on the same local network, it would require VPN software, such as Hamachi or Tunngle.
If you use Discord, it has an invite function that you can try, as well.

Try resetting your network adapters:
- click Start (or Search in Win 10), type cmd into the search box, right click Command Prompt and select run as administrator.
- type the following command and hit Enter
netsh winsock reset
- when that is done, there should be a message 'Winsock reset completed successfully'
- type exit and hit Enter, then reboot your computer.
For more details, see:
https://iihelp.iinet.net.au/Resetting_Network_Adapter_(Winsock_Reset)


If you can not join other people, either, try starting the game, switch to windowed mode and lower the game resolution (and maybe check the option to mute the sound volume when the game doesn't have focus), start a multiplayer game, hit Esc, open the Connectivity Menu, optionally disable online multiplayer (if it is enabled) and make sure LAN Connections is enabled (or that can be done in the options before starting a new game).
Next, start the game again from the 'EoCApp.exe' program file (doesn't matter if the first instance is started through Steam/Galaxy or the executable), select Join Online Game in the Campaign section, switch to the LAN tab, rather than Online, and try joining.

If you and your first friend can join in existing saves, but not a new game, this could also let the host set up both characters, and have the other person join once in-game.


Moderated by  gbnf, Monodon 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5