Larian Banner
Previous Thread
Next Thread
Print Thread
Joined: Nov 2009
S
steun Offline OP
stranger
OP Offline
stranger
S
Joined: Nov 2009
Hi, I have a problem with Divinity 2

First my specs:
Core2Duo 2.66ghz
2gb ram
Geforce 8800gts 320mb
Windows7 64bit

The problem:
The menu:

The mouse cursor doesnt move smooth at all. It looks like it skips frames

The game:

I got good solid 60fps most of the time, but I have a small but annoying stutter every 2 seconds. I tried the latest nvidia drivers, and those before that. Currently I'm using the 190.38.

It doesnt matter if I put every graphic setting on low.

I tried defragmenting the disk without result.

Thanks for your time!!

edit: Weird behaviour. After writing this post I alt-tabbed back to div2 and the game stopped stuttering, en the mouse was smooth in the menu. I've put the setting on medium and i'm going to restart the game.

edit2: It appears the stuttering has something to do with the water. Alt-tabbing doesnt fix this like I said in the first edit. I got a dual boot with winxp, so I'm gonna test it there

Last edited by steun; 11/11/09 08:37 PM.
Joined: Nov 2009
M
apprentice
Offline
apprentice
M
Joined: Nov 2009
Originally Posted by steun
Hi, I have a problem with Divinity 2

First my specs:
Core2Duo 2.66ghz
2gb ram
Geforce 8800gts 320mb
Windows7 64bit

The problem:
The menu:

The mouse cursor doesnt move smooth at all. It looks like it skips frames

The game:

I got good solid 60fps most of the time, but I have a small but annoying stutter every 2 seconds. I tried the latest nvidia drivers, and those before that. Currently I'm using the 190.38.

It doesnt matter if I put every graphic setting on low.

I tried defragmenting the disk without result.

Thanks for your time!!

edit: Weird behaviour. After writing this post I alt-tabbed back to div2 and the game stopped stuttering, en the mouse was smooth in the menu. I've put the setting on medium and i'm going to restart the game.

edit2: It appears the stuttering has something to do with the water. Alt-tabbing doesnt fix this like I said in the first edit. I got a dual boot with winxp, so I'm gonna test it there




Uninstall all of your Nvidia Drivers. Reboot your computer.
Install the following Nvidia Driver.

http://downloads.guru3d.com/Forceware-182.50-XP-32-bit-WHQL-download-2235.html (MicrosoftXP)
http://www.nvidia.com/object/winvista_x86_182.50_whql.html (Vista)

Reboot again


That fixed the stuttering for me.

Last edited by make7ac; 11/11/09 09:25 PM.
Joined: Nov 2009
S
steun Offline OP
stranger
OP Offline
stranger
S
Joined: Nov 2009
Thanks for your reply, but the stutters are still there.

It's much worse when I come near water. With dynamic lightning the stutters are worse. HDR on or off makes no difference.

The game won't boot on winxp, I won't bother investing any more time in that OS because I fully switched to windows7 now.

What are your system specs and what settings do you use?

Last edited by steun; 11/11/09 10:07 PM.
Joined: Aug 2009
Location: Soviet Empire
veteran
Offline
veteran
Joined: Aug 2009
Location: Soviet Empire
Enable following options in "Graphics" tab:

* Timeslice animation update
* Shadows animation update

If these are enabled - try to play with them, like disable 1st but left enabled 2nd or vice versa or disable all.

Joined: Nov 2009
S
steun Offline OP
stranger
OP Offline
stranger
S
Joined: Nov 2009
The stuttering is not completely gone, but I have to live with that.

it's a lot more playable then it was in the beginning. With the 182.5 drivers and the animation updates enabled.

I also ordered 2gb ram, because I think 2gb isnt enough for smooth gameplay. I have to live with the fact my PC isn't high end anymore frown

Thanks for replying, I'm going to enjoy the game now. (Finally !!! laugh )

Last edited by steun; 11/11/09 11:30 PM.
Joined: Jan 2010
H
stranger
Offline
stranger
H
Joined: Jan 2010
I have found a tweak to the ntfs file system that happened to fix my stuttering issue.. was so bad I could barely play (core 2 duo e7200 OC'd 4.03 8GB of ram 8800 GT 512MB)

This fixed it for me Type in the following command to increase the cache setting:

fsutil behavior set memoryusage 2

To check the current value, type in this command:

fsutil behavior query memoryusage

To change the setting back to the default, use this command:

fsutil behavior set memoryusage 1
Top

command prompt is in the all programs/accessories menu ( sorry for the long delay for me to get back to you...) mine was set at 0 as well and after changing to 2, stuttering problem is gone I can play on extreme settings @ 1680x1050... after checking default, if it is set at 0, then go back and change to 2.. and I am 90% sure your problem goes away.. what is being altered is the file system cache buffer. make sure to right click it and choose run as administrator otherwise you cannot change system settings I hope this helps.. let me know if it works for you

Joined: Apr 2010
R
stranger
Offline
stranger
R
Joined: Apr 2010
Installing the latest Directx solved my stutterings.
Hope this helps.

http://www.microsoft.com/downloads/...4A-4F56-B157-5AB8109CB4F5&displaylang=en

Joined: Apr 2010
Z
stranger
Offline
stranger
Z
Joined: Apr 2010
I'm also getting this problem. I'm on Windows 7 64 bit. Anyone got any recommendations on Nvidia drivers i should be using? Got an 8800GT.

Joined: Jan 2010
K
stranger
Offline
stranger
K
Joined: Jan 2010
I used FPS Limiter and locked the game at 30 fps. This eliminated the mouse lag. If you aren't happy with 30fps you can also try 45 or 59 or something.

For in game stuttering try setting your Frames to Render Ahead to 1. The default is usually 3.

Joined: Apr 2010
Z
stranger
Offline
stranger
Z
Joined: Apr 2010
I've got FPS Limiter, that seemed to help a bit. Do you know where do you change the settings for the frames to render ahead? smile

Joined: Jan 2010
K
stranger
Offline
stranger
K
Joined: Jan 2010
There should be a FPS_Limiter_GUI.jar file in the package. Double click that and you can input your max fps then create a bat file that you will use to launch the Divinity2.exe.

.jar files are Java platform files so you will need java installed on your machine.

Joined: Apr 2010
Z
stranger
Offline
stranger
Z
Joined: Apr 2010
I know how to do that mate, just wondering how do you change what you mentioned below.

Originally Posted by Kirii

For in game stuttering try setting your Frames to Render Ahead to 1. The default is usually 3.


Joined: Jan 2010
K
stranger
Offline
stranger
K
Joined: Jan 2010
OH, woops sorry, read your post a little too fast and miss understood.

I see you have a 8800GT so you need to go into your Nvidia Control Panel->Manage 3d settings->Program Settings tab and select the Divinity 2 entry and there is a drop down selection for Maximum pre-rendered frames. Set that to 1.

If there is no Divinity 2 entry in the drop down list you will have to Add it. I had to add mine.


Moderated by  Bvs, ForkTong, Larian_QA, Lar_q, Lynn, Macbeth, Raze 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5