Larian Banner
Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
Joined: Sep 2009
RanShak Offline OP
stranger
OP Offline
stranger
Joined: Sep 2009
I have something of a solution. It seems to be that the game renders too many frames and has a need to catch up with itself in the form of the stuttering, where the game is finally sending you the most recent frame. I found that, if I set all settings as high as possible, my framerate was hurt, but the stuttering was gone. Contrarily, if I set all settings to the bare minimum, my framerate skyrockets, but stutters uncontrollably. The solution, then, is FPSLimit, which you can download here.

You need Java installed to run it. Just extract the contents to a new folder and run FPS_Limiter_GUI.jar. From there, select Divinity2.exe as the application and set the max framerate to somewhere between 25-35 whichever yields best for you (I'm using 32). Select OSD if you want an onscreen FPS display. Click "create bat" and run the game from the .bat file. In-game, F10 toggles the FPS display, F11 decreases the max framerate, and F12 increases it. Hope this helps someone.

Last edited by RanShak; 28/11/09 10:17 PM.
Joined: Nov 2009
stranger
Offline
stranger
Joined: Nov 2009
mmm when i do what you said a black box comes up saying its starting divinity.exe then just say pusha ny button to quit but the game doesnt start up ? just starts the disk up in the drive and thats about it ?

Joined: Nov 2009
stranger
Offline
stranger
Joined: Nov 2009
i dont think that fpslimit works with window 7?

Joined: Sep 2009
RanShak Offline OP
stranger
OP Offline
stranger
Joined: Sep 2009
Hm. You should only get that "any key to quit" message after you've already exited the game. Are all of the contents of the RAR in the same directory?

I'm running windows 7, so that shouldn't be the problem. However, I'm running the game in XP SP3 compatibility mode. If you need help setting that up, let me know. If not, please don't think I'm patronizing you.

Last edited by RanShak; 28/11/09 11:12 PM.
Joined: Nov 2009
stranger
Offline
stranger
Joined: Nov 2009
mmm when i run the game in xp sp3 mode it just doesnt even start up the dos box comes up then disaperes :S kinda weird and yes everything is in the same folder it just comes up saying starting etc etc then it hangs t hen says push any button to quit frown

Joined: Nov 2009
stranger
Offline
stranger
Joined: Nov 2009
maybe my game is trying to run in dx10 it says it can in vista so why not window 7? but how the hell do you find out if its usein dx10 or 9 mmm

Joined: Sep 2009
RanShak Offline OP
stranger
OP Offline
stranger
Joined: Sep 2009
You can choose the rendering hook when you make the bat file, but DX10 isn't an option. I set mine to DX9.

Joined: Nov 2009
stranger
Offline
stranger
Joined: Nov 2009
how much better does it make your game run i mean no stuttering at all or just a bit better? i did everything what your ment to do with that fpslimit just comes up saying push button to quit :S

Joined: Sep 2009
RanShak Offline OP
stranger
OP Offline
stranger
Joined: Sep 2009
I get no stuttering, but the caveat is that you're locked at 30fps, which is relatively low. Also, I'm using a NoCD to run the game, which might have an effect on that.

Joined: Nov 2009
stranger
Offline
stranger
Joined: Nov 2009
yes useing the nocd crack does make the fpslimit work but it still feels kinda stuttery etc :s or maybe its just all in my mind now lol

Joined: May 2008
Location: AZ
journeyman
Offline
journeyman
Joined: May 2008
Location: AZ
Originally Posted by GothicCorpse
maybe my game is trying to run in dx10 it says it can in vista so why not window 7? but how the hell do you find out if its usein dx10 or 9 mmm


It's DX9.
Installed on a fresh Win7 (which has only DX11 files) and I got a DX9 error when trying to start the game. Found out I needed DX9 installed to run it.

Here is a stuttering fix I posted elsewhere today:

If you have Vista or Win7, then there is a tweak you can do to make the game more playable. You still get the stuttering, but it is hardly noticeable.

-Run Windows Task Manager
-Start the game and leave it at main screen
-In Task Manager(under the processes tab), right click the Divinity2.exe, and set priority to high.
-Alt+Tab back to the game and play.

Also turn on Timeslice Shadow updates.

The game may hang when you exit out, so you may have to kill the process manually.


One more thing...... Disable SLI if you have it.

HTH

Last edited by Conan 1; 29/11/09 12:33 AM. Reason: One more thing

ASUS M3N72-D
AMD Athlon 64 X2 5600+ Brisbane @ 3GHz
4 Gigs DDR2 PC6400 Dual Ch. Corsair
ASUS GeForce 9800GT 512MB x2 SLI
Win7 64bit or XP Pro x64
Joined: Sep 2009
RanShak Offline OP
stranger
OP Offline
stranger
Joined: Sep 2009
I suspect the ideal FPS setting will differ between computers, so if 30-ish isn't working for you, try higher. If that doesn't, try lower. However, anything below 25 will be pretty unplayable.

Joined: Dec 2009
L
stranger
Offline
stranger
L
Joined: Dec 2009
I tried this fix it didnt work for me i hope it does for others tho, i also tried lowering my hardware sound to basic to see if that helped it didnt im going to scan the fallout and oblivion forum see if any fixes there will help maybe maybe not if they do i will let u know.

Last edited by lex1ca; 02/12/09 06:36 PM.
Joined: Sep 2009
Location: Portugal
enthusiast
Offline
enthusiast
Joined: Sep 2009
Location: Portugal
http://www.rpgwatch.com/forums/showthread.php?t=9286



- (Win7/Vista only): Right-click shortcut and configure it to run in "XP SP3" compatibility mode. Also put a checkmark at "Disable Desktop Composition".

- Make sure the in-game graphics setting for "Dynamic Geometry Distance" is set at "High" or lower - and not "Very High". According to a developer at Larian, if the setting is "Very High" then the engine effectively disables the lowest LOD for trees.

- Disable the "Render GUI at desktop resolution" graphics option. I have not actually measured if this option has any performance implication - but it sounds like special code would be needed to render GUI at (potentially) another resolution than the game itself. And in my case I was actually running the game at desktop resolution anyway…

- Enable the "Timeslice shadow update" graphics option.

- Limit the number of frames the game is allowed to render ahead in DirectX. If you have an nVidia card you can control this setting on a per-application base through their control panel. Default is 3, I lowered this setting to 1.


Finally, I did try a suggestion from the Larian forums about tabbing out of the game to set the thread priority to "High" for the game. It seemed to improve stuttering a little, but it's annoying to have to do this each time the game is started so I don't know if I can be bothered once I start playing it for real…




For people with ATI cards, you can download ATI Tool and check for the :

Limit the number of frames the game is allowed to render ahead in DirectX. Default is 3, I lowered this setting to 1.

Last edited by KnightPT; 03/12/09 11:06 AM.
Joined: Jan 2010
B
stranger
Offline
stranger
B
Joined: Jan 2010
Don't suppose anyone's managed to get FPS_limiter working with the Steam version of the game?

Joined: May 2008
Location: AZ
journeyman
Offline
journeyman
Joined: May 2008
Location: AZ
OMG, this actually works!!! smile

For weeks I've been trying to get my game to play without that darn CPU hiccup that sticks your CPU @ 100% for 3 seconds at a time and freezes the game temporarily. Had this occur in The Black Boar Tavern downstairs and also when you go upstairs to talk with Brave Sir Robin or David. Game also locks up on your way to the Bandit Camp when you leave Goblin Hamlet.
These lockups were only temporary, but the game still stuttered and it was unplayable.

Used FPS Limiter (read about it in the Divinity 2 thread over at GameSpot and here) just as directed, set the max frames to 30 and off I went. No more game freezes whatsoever.

I've also tried the following fixes/tweaks to no avail:
Installed AMD DCO (Dual Core Optimizer) works for XP based OS (win7 balances the cores equally by default)
Updated DirectX, Sound drivers, Nvidia Drivers, Windows XP, all C++ runtimes, etc. etc. etc.
Defragged Hard Drive
Tried setting CPU affinity level in task manager for divinity2.exe
Tried set priority level to high (which helped somewhat)
Tried Nvidia Control Panel settings like render frames ahead from 3 to 2 to 1
Also tried Nvidia control panel setting for thread optimization to always on

So it works now. If you do this fix, don't run the game from the auto-run on the DVD when you insert it. Close the screen and click the Divinity2.exe.limited.bat file you created. Give it some time and all is ok.

There is still some jerkyness and stuttering, but no more CPU usage topping out at 100%.
I imagine I can increase the framerate to see what is best for my system and suggest you try the same.

HTH

***EDIT*** - I found what works for my system and have FPS limiter set to 53 FPS max.

Last edited by Conan 1; 25/01/10 10:36 AM.

ASUS M3N72-D
AMD Athlon 64 X2 5600+ Brisbane @ 3GHz
4 Gigs DDR2 PC6400 Dual Ch. Corsair
ASUS GeForce 9800GT 512MB x2 SLI
Win7 64bit or XP Pro x64
Joined: Jan 2010
U
apprentice
Offline
apprentice
U
Joined: Jan 2010
But how to do it with ATi and W7 x64? Win7 x64 doesn't like ATi Tray tools becouse it's driver is not signed. And I doubt it will as app is rather old...

Joined: Jan 2010
stranger
Offline
stranger
Joined: Jan 2010
Your advice seems to have fixed the in-game stuttering I was experiencing. Just wanted to say thanks.


If mountains could move who are we to assume they'd bother to step over us?
Joined: Jan 2010
stranger
Offline
stranger
Joined: Jan 2010
With the help of this thread I was finally able to make my copy of Divinity II playable! So first of all I wanted to thank the OP for the advice. I also wanted to share what I did.

My system specs are as follows:
DFI INFINITY NF4 939
AMD Athlon 64 X2 4200+ @ 2.6GHz
4GB OCZ Platnium DDR400
eVGA 8800GT
Running Win XP x64

Not the latest or greatest system by far, but it does the job for most games. The problem with Divinity II was the micro stuttering I was experiencing. I screwed around with the in game setting and I was able to boost the FPS, but I could never get rid of the micro stuttering no matter what I did. I was to the point where I couldn't keep playing because it was just too jerky for my taste. Very distracting.

Upon finding this thread I tried the FPS limiter and while it did limit the FPS, the jerkiness remained. I tired various FPS caps along with various in game settings but nothing seemed to help the micro stuttering. Following advice about the "Frames to render ahead" setting, I tried setting that to "0" in the Nvidia control panel and it did the trick finally! (along with the FPS limiter) I also tested running the game with the Russian NoCD exe and that seemed to help give it a little extra "push". The NoCD exe also speeds up load times dramatically. SecuROM FTL.

To recap, here's what I did:

"Frames to render ahead" set to "0" in the Nvidia control panel.
FPS limiter set to 45 FPS
Russian NoCD exe

If anyone is interested in my in game settings i'll gladly post them here when I get home tonight.


Joined: Jan 2010
U
apprentice
Offline
apprentice
U
Joined: Jan 2010
Quote
SecuROM FTL.

SPAM

Last edited by lynn; 29/06/10 10:05 AM.
Page 1 of 2 1 2

Moderated by  Bvs, ForkTong, Larian_QA, Lar_q, Lynn, Macbeth, Raze 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5