Larian Banner
Previous Thread
Next Thread
Print Thread
#410737 10/04/10 03:02 PM
Joined: Apr 2010
U
stranger
OP Offline
stranger
U
Joined: Apr 2010
Hi,

I recently bought Divinty 2 and haven't been able to start a game yet.
I have updated my video drivers, uninstalled/re-installed the game seberal times, installed the 1.03 patch yet everytime I click New Game the game crashes to my desktop after the menu bar.

I have tried different graphical settings and have searched through the forum for similar problems but have found no solution.

Joined: Mar 2003
Location: Canada
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Location: Canada

In the topic Never ending loading screen. 100% of the time., Donice posted a save after the initial cutscene. There is an illusionist in the first village that can change the geneder / voice / appearance / name of the character.
Perhaps you could download that save, at least to see if it can be loaded. Mehale also posted a link to a save just after the intro. Presumably the game has maintained backward compatibility (not sure about mixing saves between game versions) even if there were changes to the save game format, so perhaps this save could help narrow down the problem.


In XP the saves go in the folder

C:\Documents and Settings\ %username% \Local Settings\Application Data\Divinity 2\Savegames


or in Vista / Win 7

C:\Users\ %username% \AppData\Local\Divinity 2\Savegames


You may need to set Windows Explorer to show hidden files and folders.



First Aid Kit for Divinity II

First Aid : when Div2 does not start or crashes

Joined: Apr 2010
U
stranger
OP Offline
stranger
U
Joined: Apr 2010
The save game worked fine but I still can't start from scratch. I even installed VC++ as recommended on another forum. I have no idea what is supposed to come up after the timer on new game ?

Joined: Mar 2003
veteran
Offline
veteran
Joined: Mar 2003
Originally Posted by Usquequaque
The save game worked fine but I still can't start from scratch. I even installed VC++ as recommended on another forum. I have no idea what is supposed to come up after the timer on new game ?


I had a similar issue when I was playing one of the Lord of the Rings games a while back. The game wouldn't play because it was built for a single core processor while my machine had a dual core. I had to go in and tell the task manager to only use the first core to run the specific process...worked fine after that.

I don't know if this is an issue with DII since I haven't played it, but the symptoms sound familiar.

Joined: Mar 2003
Location: Canada
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Location: Canada

D2:ED was designed for a dual core processor, though there is a single core optimization option.

At least with the Xbox version, hitting New Game produces a loading screen, and then an intro video plays (showing Damian on a flying fortress, and then a slayer stalking a dragon knight), after which the character customization screen comes up. Once you finalize your appearance / voice, another video plays (flyby of Farglow following a ladybug, then showing the airship arriving).

If you go through the game folder, can you view the videos in Windows Media Player?

Joined: Mar 2003
veteran
Offline
veteran
Joined: Mar 2003
Raze, could a quad core system have similar issues with dual core games?

Joined: Mar 2003
Location: Canada
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Location: Canada

You'd think in theory a quad core system should be able to handle a dual core program fine, since both are designed with multiple cores in mind. In practice I'd think it should be much less likely than a single threaded program having problems on a multi core system, but we are talking about computers here, so I wouldn't be terribly shocked if a dual core program did have issues on a quad core CPU.
It couldn't hurt to try setting the affinity to specific cores.

Joined: Apr 2010
U
stranger
OP Offline
stranger
U
Joined: Apr 2010
Ah after much frustration and experimentation I discovered that once I uninstalled an old codec package I had, it all worked perfectly.

Thanks for all the support guys.

Joined: Mar 2003
Location: Canada
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Location: Canada

Thanks for the update, and a belated welcome to the forum. wave

Joined: Mar 2003
veteran
Offline
veteran
Joined: Mar 2003
Wooo!

Someone actually came back to tell us we helped. Well...Raze helped, I did more hypothetical theorizing on this one...

Last edited by NeroJB; 20/04/10 03:50 PM.

Moderated by  Bvs, ForkTong, Larian_QA, Lar_q, Lynn, Macbeth, Raze 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5