Larian Banner
Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
Joined: Mar 2003
Posts: 6,141
Viper Offline OP
veteran
OP Offline
veteran
Joined: Mar 2003
Posts: 6,141
I started D2 yesterday and the menu is completely screwed.
Rebooted the PC, installed tonns of updates (windows :()
started it again today and the same problem.

see screenshot for what I mean.
I changed nothing, it worked fine last week.

help !!
[Linked Image]

some help would be nice smile

Last edited by Viper; 24/08/10 07:54 PM.

Viper
Joined: Mar 2003
Posts: 27,974
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Posts: 27,974

Do you have any programs set to automatically update?

Are you shutting down all non-essential programs (especially anti-virus) before starting the game?

Did you try dropping the resolution, etc?

Did you try uninstalling the game, rebooting, making sure there wasn't anything left in the game folder, and reinstalling it?

Do you have any other DirectX games installed? If so, do they still work fine?

Joined: Mar 2003
Posts: 6,141
Viper Offline OP
veteran
OP Offline
veteran
Joined: Mar 2003
Posts: 6,141
i'll try reinstalling it tonight. it's just weird that it happens all of a sudden. no automatic updates as far as I know besides the windows updates.

just wanted to let larian know about this


Viper
Joined: Mar 2003
Posts: 6,141
Viper Offline OP
veteran
OP Offline
veteran
Joined: Mar 2003
Posts: 6,141
reinstalled the game, reinstalled DirectX... problem stays frown

now i DO need help.
i'll try updating my video drivers now...

to be continued


Viper
Joined: Mar 2003
Posts: 27,974
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Posts: 27,974

Have you tried other DirectX games?

Try emailing support@larian.com, and maybe include a link to this topic.

Joined: Mar 2003
Posts: 6,141
Viper Offline OP
veteran
OP Offline
veteran
Joined: Mar 2003
Posts: 6,141
got no other DX games at the moment frown

i'll send an email now, thx raze

Last edited by Viper; 25/08/10 08:06 PM.

Viper
Joined: Mar 2003
Posts: 27,974
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Posts: 27,974

If you don't have any games handy you can install, you could download a DirectX9 benchmark, like 3DMark06, or a game demo. That would help determine if there is a hardware or system problem effecting 3D graphics, or if the issue is just with D2:ED.

Joined: Mar 2003
Posts: 6,141
Viper Offline OP
veteran
OP Offline
veteran
Joined: Mar 2003
Posts: 6,141
i'll try that tonight, didn't think of downloading a demo :s


Viper
Joined: Feb 2003
Posts: 3,095
veteran
Offline
veteran
Joined: Feb 2003
Posts: 3,095
Originally Posted by Raze

If you don't have any games handy you can install, you could download a DirectX9 benchmark, like 3DMark06, or a game demo. That would help determine if there is a hardware or system problem effecting 3D graphics, or if the issue is just with D2:ED.


Exactly, because this error can't pop up just like that. You were playing the game before without any problems, so I have doubts that the cause is with Ego Draconis.
Also as I said (via email) we haven't been reported by such an error as of yet.

Please let us know the results it might help other gamers in the future.

Thank you,
Lynn

Joined: Mar 2003
Posts: 6,141
Viper Offline OP
veteran
OP Offline
veteran
Joined: Mar 2003
Posts: 6,141
Haven't read my email yet Lynn, can't access it during the day, but it seems to me also highly unlikely that is't D2's fault.

i'm just puzzled that it happes so suddenly.

anyways, reinstalling my PC is sth that was bound to happen one of these months, it's just such a long task frown

isn't there any sort of debug/error report that the game creates that I might be able to send you guys ?

if I can fix the problem without reinstalling the PC i'll let you know, otherwise it's a ghost that I'll have to chase away smile


Viper
Joined: Mar 2003
Posts: 27,974
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Posts: 27,974

I'd try a different game/demo/benchmark first, just to check if it is a hardware issue. If you have a spare hard drive to install Windows on, that would let you check if that is the problem (if so you could keep going and restore all your settings and programs, etc, if not you could just boot back to the original drive).

Joined: Mar 2003
Posts: 6,141
Viper Offline OP
veteran
OP Offline
veteran
Joined: Mar 2003
Posts: 6,141
i'll try a demo when I get the chance (hopefully tonight), otherwise i'm gonna start backing up my PC and do a reinstall... it's been almost a year nog without reinstall so it was bound to happen one day.


Viper
Joined: Mar 2003
Posts: 6,141
Viper Offline OP
veteran
OP Offline
veteran
Joined: Mar 2003
Posts: 6,141
ok, strangely enough the textures seem to have come back, but now I get really weird polygons across my screen.

I get black stripes, stripes with textures on them,...

Haven't tried a demo yet in the meantime (shame on me) but I'll do that tonight for sure !!


Viper
Joined: Feb 2003
Posts: 3,095
veteran
Offline
veteran
Joined: Feb 2003
Posts: 3,095
Hi Viper, please let us know the result of this, maybe it can help other gamers too.

Thanks,
Lynn

Joined: Mar 2003
Posts: 6,141
Viper Offline OP
veteran
OP Offline
veteran
Joined: Mar 2003
Posts: 6,141
will do, will do.

for the textures problem: i have no idea why they're back now, haven't changed a thing :s, I've only rebooted twice or so.


Viper
Joined: Mar 2003
Posts: 6,141
Viper Offline OP
veteran
OP Offline
veteran
Joined: Mar 2003
Posts: 6,141
So I tried the 3D mark 06 demo last night and it worked perfectly.

started up D2 after it, same problem frown

I'll try reinstalling my PC one of these days... first I need to backup everything


Viper
Joined: Feb 2003
Posts: 3,095
veteran
Offline
veteran
Joined: Feb 2003
Posts: 3,095
Very strange... it's just so weird that you didn't run into these problems before.
I am out of ideas at the moment. Not sure if the problem will be solved after a re-install.

Joined: Mar 2003
Posts: 6,141
Viper Offline OP
veteran
OP Offline
veteran
Joined: Mar 2003
Posts: 6,141
well, I guess my GFX card has gone to hell. tried another game and same problems with polygons.
i'm gonna buy a new gfx card one of the days and hope I fix the problem this way.


Viper
Joined: Mar 2003
Posts: 6,141
Viper Offline OP
veteran
OP Offline
veteran
Joined: Mar 2003
Posts: 6,141
well, I tried the game some more and this is how it looks like now:
[Linked Image]

the strange thing is that t doesn NOT look like that indoors (caves or houses), there it looks perfectly fine.


Viper
Joined: Mar 2003
Posts: 27,974
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Posts: 27,974

A couple people have had a similar problem with grass / vegetation.

nasty graphical artifacts on screen

Page 1 of 2 1 2

Moderated by  Bvs, ForkTong, Larian_QA, Lar_q, Lynn, Macbeth, Raze 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5