Larian Banner
Previous Thread
Next Thread
Print Thread
Joined: Nov 2007
addict
OP Offline
addict
Joined: Nov 2007
Audio corruption issues in Mysterious Cave

Lately, I've been getting a bit of strange audio distortion issues: crackling and pops but they eventually go away.

In Mysterious Cave though, it really gets in the way of the music and dialogue.

I've restarted the game, continued from another save, restarted the pc and the problems still remain. I don't get such problems with other games.

Alas, my laptop uses some so-so Realtek sound.

How do I work my way around this?

Joined: Mar 2003
Location: Canada
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Location: Canada

You can try changing the sound quality in the options.

One person had a problem with echoes and static using headphones (speakers were fine), which disappeared if they disabled V-sync in the video options.


If the problem is the echo effect in caves, a few people have had similar issues, with a couple possible workarounds reported:

Try lowering the main system volume and in-game max all the sound sliders. That has removed the echo for some people.

Someone in the topic My sound is echo-y said it helped if they changed the setting for the audio channels in Windows to 8, started the game, Alt-Tabbed out and changed the audio channels to 2 and switched back to the game.

Joined: Nov 2007
addict
OP Offline
addict
Joined: Nov 2007
K good... I'll go try your fixes as soon as I... finish dling this game. Blasted, I uninstalled the wrong game.

Hmm, hopefully the other "PC freezing" issue I got while playing D2 is solved for now. I think I covered up the vents on the laptop by mistake. :P

Joined: Mar 2003
Location: Canada
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Location: Canada

Oops. Before going to bed I checked the forum for new posts from the 'Active Topics', and answered your post as if it were D:OS.

Joined: Nov 2007
addict
OP Offline
addict
Joined: Nov 2007
Hmm I've disabled vsync. I also tried setting Win7 comptability mode, uninstalled any codecs on the pc.

Looks like I'll have to uninstall my Audio drivers and get the ones from Realtek. I hope they'll install 'cos Asus relabelled the ver nos. T___T

Edit: Reinstalled the drivers.

K I switched to the laptop speakers and the problems are still there. Looks like I'll have to give Bellegar a skip even though he's so awesome.

It's okay, Raze, we all make mistakes.

Last edited by DrunkenTofu; 16/09/15 07:59 AM.
Joined: Nov 2007
addict
OP Offline
addict
Joined: Nov 2007
In the end, I managed to reduce the audio problems: still some crackles but at least, it's playable. smile I adjusted the graphics quality to "Low".

Joined: Mar 2003
Location: Canada
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Location: Canada

If you continue to have issues after the cave, check the advanced graphics options, near the bottom, and try disabling multicore support or enabling Lockstep mode.


Moderated by  Bvs, ForkTong, Larian_QA, Lar_q, Lynn, Macbeth, Raze 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5