Larian Banner
Previous Thread
Next Thread
Print Thread
#598566 17/01/17 06:08 PM
Joined: Oct 2016
journeyman
OP Offline
journeyman
Joined: Oct 2016
Hello people, I hate to be bothering Larian's technical support, but I have been experiencing this small problem since last week:

Whenever I try to start the game the message "Connection to the Larian support server failed. The Larian support tool will be disabled. An exception occurred during a WebClient request. - Error creating the Web Proxy specified in the 'system.net/defaultProxy' configuration section.". The game itself launches just fine, but I can't get in the arena and can't play the SP campaign either, it just remains stuck on loading forever.

I have already tried uninstalling reinstalling the game, but it did little to nothing. Editing the firewall settings seemed to have had no impact whatsoever, either.

I can't tell if it is an issue with my pc or the latest update, since my old pc kinda died 4 months ago and I've managed to get a new one running only now.

What could the issue be, and more importantly, how can I fix it?

Joined: Mar 2003
Location: Canada
Larian Studios
Offline
Larian Studios
Joined: Mar 2003
Location: Canada

There was a known issue in D:OS EE where the game could hang on the loading screen trying to start a new game, and give an error about network initialization clicking on Join from the main menu, possibly caused by a too strict firewall, network drivers or other problems with a network card.

In that case, it would help to reset your network adapter. One person has had a similar problem in D:OS 2, which this helped with, though they were not getting the connection errors.
- click Start (or Search in Win 10), type cmd into the search box, right click Command Prompt and select run as administrator.
- type the following command and hit Enter
netsh winsock reset
- when that is done, there should be a message 'Winsock reset completed successfully'
- type exit and hit Enter, then reboot your computer.
For more details, see:
https://iihelp.iinet.net.au/Resetting_Network_Adapter_(Winsock_Reset)


If that doesn't help, try exiting out of the Steam client, and starting the game directly from the '..\SteamApps\common\Divinity Original Sin 2\bin\EoCApp.exe' program file, by right clicking and running as administrator.
If you start the game from the executable with the Steam client running, it should be able to connect to make Steamworks functions available (the multiplayer lobby, friend invites).

Try creating a new profile, and see if that will let you start a new game.

Joined: Oct 2016
journeyman
OP Offline
journeyman
Joined: Oct 2016
It worked! Resetting the network adapter actually did the trick. Now the game is running as slick as oil. thanks Raze, much appreciated! laugh



Moderated by  Elwyn, gbnf, Larian_Koala, Monodon 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5