Larian Banner
Previous Thread
Next Thread
Print Thread
WorldMap rendering issue #675395
20/09/20 11:56 PM
20/09/20 11:56 PM
Joined: Oct 2014
Posts: 11
F
FreddyK83 Offline OP
stranger
FreddyK83  Offline OP
stranger
F

Joined: Oct 2014
Posts: 11
Hey all,

Does anyone know why these black square outlines are appearing when I try and generate World Maps?

https://drive.google.com/file/d/1JoPx6NKHX2ti3YJeM1EjKFKuXt9GsMj-/view?usp=sharing

Re: WorldMap rendering issue [Re: FreddyK83] #675482
22/09/20 05:05 AM
22/09/20 05:05 AM
Joined: Oct 2014
Posts: 11
F
FreddyK83 Offline OP
stranger
FreddyK83  Offline OP
stranger
F

Joined: Oct 2014
Posts: 11
If I change the atmosphere, the boxes change size and shape.

https://drive.google.com/file/d/1P_WuIXLRBmQbM3fNa5tCzyqfs28nKCd8/view?usp=sharing

could it be the outline of a camera? a sun setting? a shadow setting?

it's a mystery to me!

Last edited by FreddyK83; 22/09/20 05:06 AM.
Re: WorldMap rendering issue [Re: FreddyK83] #675495
22/09/20 06:26 AM
22/09/20 06:26 AM
Joined: Sep 2017
Posts: 874
The Composer Offline

Moderator
The Composer  Offline

Moderator

Joined: Sep 2017
Posts: 874
In the WorldMap renderer window, what is the bounding box size of your level? Do you have an atmosphere trigger + distant light probe in place within its bounds?

[Linked Image]

Re: WorldMap rendering issue [Re: FreddyK83] #675500
22/09/20 07:25 AM
22/09/20 07:25 AM
Joined: Oct 2014
Posts: 11
F
FreddyK83 Offline OP
stranger
FreddyK83  Offline OP
stranger
F

Joined: Oct 2014
Posts: 11
So the map has the following:

- 1x Region trigger covering the span of the terrain and the height of the building (which i'm using as the selected trigger for the minimap)
- 1x Atmosphere trigger set the same Atmosphere as Level Data (ATM_Default)
- 1x Distant Light probe placed roughly in the centre of the terrain

I have recalculated level bounds and light probe data.

Here's a screen grab of the editor. You can see if you compare the editor window to the minimap preview, the shadow of the building is being displaced by the artifact squares.

https://drive.google.com/file/d/1s9sKpUrfjV8nN4JLRvM8TurVF8qtU1Yt/view?usp=sharing

-------------------------------------------------------------------------------------------------------------------------



I should add as well, since my post from earlier I found some Atmospheres that don't produce the squares:

- Work
- Sunny_01
- ATM_PBR_Default_SmallScale_Minimap (This one is a good one as it has shadows unlike the previous two)

Others in the list may work too...those are just the ones I tried that worked fine.


So it may just be i'll have to choose a 'compatible' atmosphere for map generation if there's no solution.

The boxes seem to be connected to contrast and shadow....the deeper and darker the contrast and shadows, the more prominent the boxes...

lol..i mean, take a look when i generate a map using the atmosphere "Dusk_01".

https://drive.google.com/file/d/1hcPzG4gjoIhbuiG8n_BkCX8MCVvGaG10/view?usp=sharing



Last edited by FreddyK83; 22/09/20 07:51 AM.
Re: WorldMap rendering issue [Re: FreddyK83] #675502
22/09/20 07:57 AM
22/09/20 07:57 AM
Joined: Sep 2017
Posts: 874
The Composer Offline

Moderator
The Composer  Offline

Moderator

Joined: Sep 2017
Posts: 874
So your atmosphere trigger should look something like this (click spoiler to expand images):

[Linked Image]


Lightprobe placed inside of the atmosphere trigger bounds, and a bit above ground. Make sure it's Probe Type is 'Distant'. Each Atmosphere trigger needs one distant probe in it, but one maximum.

[Linked Image]



Hit Level > Render all lightprobes in the menu bar up top.

Then make sure your atmosphere is actually the one showing when viewing the world in the render window:

[Linked Image]


Try to render the worldmap then, and see if it works. Otherwise I can do a write-up for you to make a custom minimap atmosphere to get roughly this result:

[Linked Image]






Re: WorldMap rendering issue [Re: FreddyK83] #675504
22/09/20 08:22 AM
22/09/20 08:22 AM
Joined: Oct 2014
Posts: 11
F
FreddyK83 Offline OP
stranger
FreddyK83  Offline OP
stranger
F

Joined: Oct 2014
Posts: 11
Which atmosphere did you set for the trigger?

I followed your steps to the letter, with an atmosphere trigger set to ATM_Default, and I get this:

https://drive.google.com/file/d/1uyqJdSuADxk4rW3U9aJmRnBnkTHEnk5G/view?usp=sharing

I'll try again typing the numbers in for the atmosphere box (position, extents etc) from your screenshot so im identical


Last edited by FreddyK83; 22/09/20 08:23 AM.
Re: WorldMap rendering issue [Re: FreddyK83] #675505
22/09/20 08:31 AM
22/09/20 08:31 AM
Joined: Sep 2017
Posts: 874
The Composer Offline

Moderator
The Composer  Offline

Moderator

Joined: Sep 2017
Posts: 874
I made my own.

So, open the resource browser, select your package (or hit the rubiks cube + symbol to make a new package for your project), then hit new resource > atmosphere, and call it something like 'ATM_Baseline' or something so you can 'create new from' from that later as a baseline for new atmospheres. (Pro tip for lazy people)

[Linked Image]


Double click the new atmosphere to open the customization panel. Copy these settings.

[Linked Image]

[Linked Image]


Anything not shown in either of those two pictures, leave as-is. Hit OK, then go to your atmosphere trigger and change to the new atmosphere. Hit 'Off' then back to atmosphere so it'll update properly in the work atmosphere panel.

[Linked Image]


Hit level > render all lightprobes, then try rendering your world map again.









Re: WorldMap rendering issue [Re: FreddyK83] #675506
22/09/20 08:33 AM
22/09/20 08:33 AM
Joined: Sep 2017
Posts: 874
The Composer Offline

Moderator
The Composer  Offline

Moderator

Joined: Sep 2017
Posts: 874
Then later you can make new atmospheres for different settings and mood, you can get more advanced with color grading and lumination and sun pitch/yaw to simulate early morning, sunsets, or lower sun significantly and use color grading to make night-like atmospheres, etc.

Re: WorldMap rendering issue [Re: FreddyK83] #675507
22/09/20 08:37 AM
22/09/20 08:37 AM
Joined: Oct 2014
Posts: 11
F
FreddyK83 Offline OP
stranger
FreddyK83  Offline OP
stranger
F

Joined: Oct 2014
Posts: 11
Thanks. I will give that a try.

So, with the custom atmosphere, what is it about the settings that are being set for the baseline specifically that create a working minimap atmosphere?

Re: WorldMap rendering issue [Re: FreddyK83] #675508
22/09/20 08:39 AM
22/09/20 08:39 AM
Joined: Sep 2017
Posts: 874
The Composer Offline

Moderator
The Composer  Offline

Moderator

Joined: Sep 2017
Posts: 874
I suspect it's rather something about inherited atmospheres not working properly with atmosphere triggers at the moment. I had the same issues when trying to replicate your problem on my end. Just it being a new atmosphere in your own mod's package seem to resolve it, rather than any individual setting. Those I've shown are just a nice baseline to start from to make your own personal touches and flavour on how you want it to look smile

Re: WorldMap rendering issue [Re: FreddyK83] #675509
22/09/20 08:46 AM
22/09/20 08:46 AM
Joined: Oct 2014
Posts: 11
F
FreddyK83 Offline OP
stranger
FreddyK83  Offline OP
stranger
F

Joined: Oct 2014
Posts: 11
Interesting.

Well,I can confirm creating a new one from scratch using your screenshots and setting that as the atmosphere in the trigger works!

Re: WorldMap rendering issue [Re: FreddyK83] #675510
22/09/20 08:50 AM
22/09/20 08:50 AM
Joined: Sep 2017
Posts: 874
The Composer Offline

Moderator
The Composer  Offline

Moderator

Joined: Sep 2017
Posts: 874
Great!

Re: WorldMap rendering issue [Re: FreddyK83] #675511
22/09/20 09:29 AM
22/09/20 09:29 AM
Joined: Oct 2014
Posts: 11
F
FreddyK83 Offline OP
stranger
FreddyK83  Offline OP
stranger
F

Joined: Oct 2014
Posts: 11
So i've just spent the past hour or however long it's been, copying atmospheres that dont work over to my mod, and changing sliders and rendering light probe and map until i could find which settings are causing the boxes.

I believe I have isolated it down to Shadows settings in the Sun tab, and specifically the Cascade settings: Distribution slider and Fade Amount seem to make them appear/disappear depending how you set them.


Moderated by  Larian_Koala, Larian_KVN 

Powered by UBB.threads™ PHP Forum Software 7.6.2