Larian Banner
Previous Thread
Next Thread
Print Thread
#670996 24/07/20 06:56 AM
Joined: Jul 2020
bebo Offline OP
stranger
OP Offline
stranger
Joined: Jul 2020
So i created a GM game and when my players come in to play they have unlited stats and they cant pick thier powers properly in the character creation menu. All the mods i have are simply map mods and thats it so i am very confused. I want them to make classes like normal, any ideas?

bebo #671031 25/07/20 05:54 AM
Joined: Mar 2003
Larian Studios
Offline
Larian Studios
Joined: Mar 2003

If you create a new profile and host one of the existing campaigns, without mods, does that work properly if people join (also from a new profile)?
If so, try a new basic campaign without mods (with just the minimum done that someone can test joining), and then with the same mods.

If you have problems with one of the existing campaigns, tried switching who is hosting, and see if that makes a difference, or helps narrow the problem down to specific system(s).

If you start a second instance of the game, do you have any problems when joining by LAN?
Start the game, switch to windowed mode and lower the game resolution (and maybe check the option to mute the sound volume when the game doesn't have focus), start the GM campaign, hit Esc, open the Connectivity Menu, optionally disable online multiplayer (if it is enabled) and make sure LAN Connections is enabled (or that can be done in the options before starting a new game).
Next, start the game again from the '..\SteamApps\common\Divinity Original Sin 2\DefEd\bin\EoCApp.exe' program file (doesn't matter if the first instance is started through Steam/Galaxy or the executable), select Play Campaign in the Game Master section, switch to the LAN tab, rather than Online, and join. That should work, since both instances of the game are using the same data, and only the local networking is involved.

Try having everyone verify local files: in the Steam library, right click on the game and select Properties, switch to the Local Files tab and then click on the 'Verify Integrity of Game Files...' button.
With the GOG version, in the (optional) Galaxy client, select the game, then the settings icon at the top right (beside the Play button) and under Manage Installation select 'Verify / Repair'.

bebo #671087 27/07/20 04:10 AM
Joined: Jul 2020
bebo Offline OP
stranger
OP Offline
stranger
Joined: Jul 2020
I have changed hwo is hosting as well as deleting basicly all mods and none of it seems to help. I have done the verify already and that does not seem to help at all. i did lan connection with myself and the issue is gone. How do i fix that?

Last edited by bebo; 27/07/20 04:14 AM.
bebo #671089 27/07/20 04:19 AM
Joined: Mar 2003
Larian Studios
Offline
Larian Studios
Joined: Mar 2003

Did you try a different profile, and one of the included campaigns with no mods, etc?

bebo #671093 27/07/20 07:15 AM
Joined: Jul 2020
bebo Offline OP
stranger
OP Offline
stranger
Joined: Jul 2020
Yes i tried that, did not seem to help...i will try again just to be safe.

bebo #671094 27/07/20 08:56 AM
Joined: Mar 2003
Larian Studios
Offline
Larian Studios
Joined: Mar 2003

Did you test in pairs, to see if it happened in a default campaign only when particular system(s) are involved?

Has anyone used mods that require Norbyte's script extender dll, or otherwise have files or folder copied into the install folder?

Has anyone used the editor, even if they didn't save any levels / projects or create any mods?

bebo #671133 27/07/20 05:33 PM
Joined: Jul 2020
bebo Offline OP
stranger
OP Offline
stranger
Joined: Jul 2020
Iv used mods with the exstender but iv uninstalled them and got rid of the exstendeer, also i have used the editor to mod a level, but i never touched the character creation stuff. Also the normal campeign seems to be uneffected

Last edited by bebo; 27/07/20 06:07 PM.
bebo #671148 28/07/20 03:45 AM
Joined: Mar 2003
Larian Studios
Offline
Larian Studios
Joined: Mar 2003

Try everyone exiting out of Steam/Galaxy, create a new Windows user account, switch to that account, start the game from the executable, create a new profile when prompted and try testing with an included campaign, joining by Direct Connection. If that helps, the problem is likely in the mods or profiles on one or more systems, which testing in pairs (or other people) could help identify.

If the same thing happens in new Windows user accounts, the issue is likely in the install folder of one or more systems.
To check for mismatched data, if you each use a program like DVDSig or ExactFile to scan the install folder, then swap files to verify, it would identify any differences. There would be legitimate differences just from having the editor installed on at least one system, but if you move/delete any mods or projects you are not using first, hopefully it will identify what is causing the problem.
DVDSig is tiny (alternate download), portable and doesn't require an install, while ExactFile has more features.

bebo #675903 25/09/20 10:34 AM
Joined: Aug 2020
Banned
Offline
Banned
Joined: Aug 2020
That's crazy and weird.


Moderated by  Elwyn, gbnf, Larian_Koala, Monodon 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5