Larian Banner
Previous Thread
Next Thread
Print Thread
Joined: Jan 2016
Jhelzei Offline OP
journeyman
OP Offline
journeyman
Joined: Jan 2016
Under Patch 3 I didn't have too much trouble getting the game to run under Linux (Fedora 33, Proton 5.13), I mostly just had to bypass the launcher. But with Patch 4, I can only get a split second of audio from the Larian logo screen, and the game freezes. The only clue in the debugging info is a failure to load ChromaSDK, though that might be unrelated. Was Razer Chroma added in Patch 4? Is there anyway to bypass it? Or is that just a red herring?

Joined: Jan 2016
Jhelzei Offline OP
journeyman
OP Offline
journeyman
Joined: Jan 2016
Seem to have found a workable fix. Needed Proton-6.1-GE-2 and this on the launch options:

__NV_PRIME_RENDER_OFFLOAD=1 %command%

Gotta love Nvidia Optimus. Games runs beautifully so far.

Joined: Mar 2021
stranger
Offline
stranger
Joined: Mar 2021
Thanks for posting this! I am about to try it out.

Joined: Mar 2021
stranger
Offline
stranger
Joined: Mar 2021
Still crashing on my end. I tried with Proton 5.10, 5.13, 5.21-GE-1, and 6.1-GE-2.

Operating System: Kubuntu 20.04
KDE Plasma Version: 5.18.5
KDE Frameworks Version: 5.68.0
Qt Version: 5.12.8
Kernel Version: 5.4.0-66-generic
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-2600 CPU @ 3.40GHz
Memory: 15.6 GiB of RAM

Any other recommendations? smirk

Joined: Jan 2016
Jhelzei Offline OP
journeyman
OP Offline
journeyman
Joined: Jan 2016
AMD or Nvidia? Desktop or laptop?

Last edited by Jhelzei; 04/03/21 12:02 PM.
Joined: Mar 2021
stranger
Offline
stranger
Joined: Mar 2021
desktop and NVIDIA (4.60)

Joined: Mar 2021
stranger
Offline
stranger
Joined: Mar 2021
Update: still not working with today's hotfix smirk

I tried with and without your recommended launch option, and with Proton 5.10, 5.21-GE-1, and 6.1-GE-2.

Joined: Jan 2016
Jhelzei Offline OP
journeyman
OP Offline
journeyman
Joined: Jan 2016
If I had to guess (and I am, lol) I'd say it's probably due to your old kernel version. You're running 5.4 which is pretty long in the tooth. With Fedora I get 5.10.19 out of the box.

There are ways to get a recent kernel in Ubuntu, but it's been a long time since I tried it. And there are some drawbacks but again, it's been such a long time I don't remember the details.

EDIT: And my launch options are only really suitable for an Optimus laptop (i.e., one with hybrid Intel and Nvidia GPUs.)

Last edited by Jhelzei; 05/03/21 05:11 AM.
Joined: Mar 2021
stranger
Offline
stranger
Joined: Mar 2021
So, no dice. I updated my kernal version, and it broke my pc. I had to do a fresh kubuntu install (thankfully I have most important stuff on secondary and external hardrives).

Thanks for the attempt, but I am open to any more advice you, @Jhelzei or anyone else might be able to offer.

Joined: Mar 2021
stranger
Offline
stranger
Joined: Mar 2021
So! My problem was solved by a suggested I received on the Steam discussion boards by @Space Munks.

Originally Posted by Space Munks
https://github.com/ValveSoftware/Proton/issues/4243#issuecomment-787060767
seems to be Chroma causing an issue. set env WINEDLLOVERRIDES="cchromaeditorlibrary64=" %command% as the launch option


Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5