Larian Banner
Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
Joined: Oct 2020
Eddiar Offline OP
enthusiast
OP Offline
enthusiast
Joined: Oct 2020
Something I have noticed. My frame rates have dropped by a solid 20 fps. I just don't know why.

Joined: Mar 2020
Location: Belfast
veteran
Offline
veteran
Joined: Mar 2020
Location: Belfast
I only finished the introduction, but I felt the game run much better then the previous patch (without DLSS and certainly with). We will see how the more graphically intensive will fare, but so far it plays far smoother then ever before.

Joined: Oct 2020
addict
Offline
addict
Joined: Oct 2020
Originally Posted by Eddiar
Something I have noticed. My frame rates have dropped by a solid 20 fps. I just don't know why.

Probably due to the new volumetric lighting and fog.



Feel free to steal my profile pic if you feel the same way. Let's show some solidarity.
Joined: Oct 2020
Location: Liberec
veteran
Offline
veteran
Joined: Oct 2020
Location: Liberec
Originally Posted by Eddiar
Something I have noticed. My frame rates have dropped by a solid 20 fps. I just don't know why.
There was also new drivers released on nvidia few days back ... that are optimizing BG-3 a little ...
Maybe check that out?


Vive et vivant. wink
Joined: Oct 2020
Eddiar Offline OP
enthusiast
OP Offline
enthusiast
Joined: Oct 2020
I have also noticed my character's face is always dirty... like she got dirt on her face.
Is this a new future?

Joined: Oct 2020
Location: Liberec
veteran
Offline
veteran
Joined: Oct 2020
Location: Liberec
It is new feature ...
We will be sweating, we will get dirty, and our meele characters will get bloody in fight ...

The dirt is being a little extreme if you ask me, but except that it works well for immersion. smile
Bath is now natural part of every long rest. laugh


Vive et vivant. wink
Joined: Mar 2020
Location: Belfast
veteran
Offline
veteran
Joined: Mar 2020
Location: Belfast
After playing a bit more, it does seem like BG3 has some extreme swings in performance. In gameplay I seem to run somewhere between 80-130 (maxed out, DLSS quality, 2k) but in conversations in certain shots it dips as low as 20-30. Some optimisation to be done, no doubt.

Joined: Sep 2020
addict
Offline
addict
Joined: Sep 2020
When loading into the game it now takes ages for everything to show up. After having it running for a few hours I notice some lag that I can't remember being there before.

Joined: Jun 2012
member
Offline
member
Joined: Jun 2012
Used to run at a solid 60 in the previous patch (Ryzen 7, 8 Gb VRAM, 16 Gb RAM), but now I cannot comfortably play without FSR turned on, so yes, the overhaul does seem to be quite taxing. Even with FSR on some conversations just have my FPS drop below 20 (in the druid grove, for example).

It will probably get ironed out by the release at the latest, given how D:OS2 EA was barely optimized at all compared to the full version which ran smoothly and crisply.

Joined: Jun 2020
veteran
Offline
veteran
Joined: Jun 2020
I'm finding that there are a lot more stilted transitions now, especially around cutscenes.

By this I mean, you'll move someone, and the screen will fade out, then it will briefly show you your characters standing in new positions or similar positions on the top-down adventure view, THEN play the cutscene, then another view flicker of between load view before it returns to the game. Camping is a big offender for this - you select the bed, say yes, and you see a brief stutter of all of your characters moved to their bed, then it shows you the pan cutscenes, then the camp fire, which stutters back a few frames every time during its pan, then another shot for a half a second of the characters all lying down on their beds, but in the normal adventure view, and then it fades out and in to return your characters to where you left them.... it's gotten really clippy and unpolished...

Joined: Jul 2021
journeyman
Offline
journeyman
Joined: Jul 2021
Yeah, I've noticed some really intense frame drops, most noticeable in the tiefling cave where Zorru stands, and in the Blighted Village in the necromancer's cellar when you pick up the book. I think it has something to do with the new lighting system, when the camera is in front of the character and a complicated light source is behind them, I'm getting majorrrr lag, like 15 FPS, when pre-patch 6 I could run the same scenes at 60FPS.

I'm also noticing during location transitions, like the end of the nautiloid cinematic, after the loading screen it will briefly show my character on the beach before loading the cutscene where Ragzlin and Minthara are watching the nautiloid crash. I think maybe they're fully loading the world and then playing the cutscenes so that they play smoother, and I have noticed less stuttering in the cutscenes, so I guess it's a double edged sword. Hopefully they iron out all these bugs in a hotfix soon.

Joined: Oct 2021
stranger
Offline
stranger
Joined: Oct 2021
im on a ryzen 3600x and a 2070 super on 32gb ram. i used to play with a smooth 60-70 fps maxed out on ultrawide 2k.

now it gets bad at times. sometimes it nosedives to 15-20 fps , where i have to alt-tab to recover it, there are some cut scenes/dialogues where the lighting goes off the rail and everyone is uber lit fps also drops at these times.

Its weird how a single patch/update can fix things for half the community and destroy things for the other half.

Joined: Oct 2020
T
enthusiast
Offline
enthusiast
T
Joined: Oct 2020
So things seem to be smoother for me once I updated my Nvidia drivers.

What's interesting is instead of getting framerate drops now in "busy areas" (or if I move from place to place too fast), I get occasionally buffer pauses (not frequent).

Joined: Dec 2020
D
stranger
Offline
stranger
D
Joined: Dec 2020
Originally Posted by Wormerine
After playing a bit more, it does seem like BG3 has some extreme swings in performance. In gameplay I seem to run somewhere between 80-130 (maxed out, DLSS quality, 2k) but in conversations in certain shots it dips as low as 20-30. Some optimisation to be done, no doubt.
same here, about 150 max, but goes WAY down during dialog and cut-scenes. i've got a 3070ti with the newest Nvidia drivers (496.13) running at 1080p with video on ultra high. If i turn vsync on, it maxes out at 60fps in general but still goes down to 20ish in the same spots.

Joined: Sep 2015
N
old hand
Offline
old hand
N
Joined: Sep 2015
Graphics have been upped and performance went down as a result. They will probably polish it in next patches

Joined: Oct 2020
C
journeyman
Offline
journeyman
C
Joined: Oct 2020
Originally Posted by Zarna
When loading into the game it now takes ages for everything to show up. After having it running for a few hours I notice some lag that I can't remember being there before.

This is a classic sign of weak hardware, you should turn down the graphic settings then, unless you want to reboot your computer very now and then to free up RAM.

I run on a high end computer and have nos uch problems with loading or anything.

Joined: Oct 2020
Eddiar Offline OP
enthusiast
OP Offline
enthusiast
Joined: Oct 2020
Teleporting into blight village just caused my FPS drop by like 95% lol

Joined: Feb 2021
Location: Alaska
member
Offline
member
Joined: Feb 2021
Location: Alaska
Originally Posted by Anthraxid
im on a ryzen 3600x and a 2070 super on 32gb ram. i used to play with a smooth 60-70 fps maxed out on ultrawide 2k.

now it gets bad at times. sometimes it nosedives to 15-20 fps , where i have to alt-tab to recover it, there are some cut scenes/dialogues where the lighting goes off the rail and everyone is uber lit fps also drops at these times.

Its weird how a single patch/update can fix things for half the community and destroy things for the other half.


Yeah, I am running this on a graphic workstation with a 16 core Threadripper, Radeon VII card, 128gig of ram, on a 38" monitor and the graphics look more detailed in some ways, but the face on my drow characters looks, as there is another texture on the face that is mottled, and makes him look sick and diseased. I am also getting a lot more crashes in cut scenes.

I am guessing there is some problem with AMD cards running Vulcan (what I run).

Last edited by Aazo; 21/10/21 03:24 AM.
Joined: Feb 2021
veteran
Online Content
veteran
Joined: Feb 2021
I am noticing a lot of cutscenes no longer being triggered or not working properly.

For example, I entered the chamber with the drow so I could talk more privately with Nettie, and instead of cutscenes, she just talked to me with the dialogue bubbles over our heads. She still had the same lines and all, but it was not in a cutscene.

At another point, a cutscene was triggered with Lae'zel, but there was no dialogue at all. It just showed her standing there, and there was a "Continue Cinematic" option. I clicked the option, and her dialogue showed up in words only, and it only gave me a portion of what she was saying and what options I had to respond with. It was very broken.

I am using DirectX, not Vulcan. Maybe I'll try to switch to Vulcan. I don't know. It's just a lot of little weird things going on.

On the plus side, I'm able to run the game smoothly now with High graphics, whereas before I couldn't. I had to use a Custom Medium/Low setting in order to make it work even remotely well. So, something's improving there.

Joined: Jun 2021
Location: Netherlands
K
journeyman
Offline
journeyman
K
Joined: Jun 2021
Location: Netherlands
Originally Posted by GM4Him
I am noticing a lot of cutscenes no longer being triggered or not working properly.

For example, I entered the chamber with the drow so I could talk more privately with Nettie, and instead of cutscenes, she just talked to me with the dialogue bubbles over our heads. She still had the same lines and all, but it was not in a cutscene.

At another point, a cutscene was triggered with Lae'zel, but there was no dialogue at all. It just showed her standing there, and there was a "Continue Cinematic" option. I clicked the option, and her dialogue showed up in words only, and it only gave me a portion of what she was saying and what options I had to respond with. It was very broken.

I am using DirectX, not Vulcan. Maybe I'll try to switch to Vulcan. I don't know. It's just a lot of little weird things going on.

On the plus side, I'm able to run the game smoothly now with High graphics, whereas before I couldn't. I had to use a Custom Medium/Low setting in order to make it work even remotely well. So, something's improving there.
I think when you see dialogues in that manner, they are either reworking the animation part of it, or it might be a bug. Also noticed a few NPC's have different looks now. Mol now has a more unique look and such. She is no longer Generic Tiefling Girl Child #34501.

But yes performance is a bit variable in areas, although I noticed only around Waukeen's Rest for some reason. I expect patch six will get a good number of hotfixes laugh

Page 1 of 2 1 2

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5