Hi there,

I bought DoS:EE on gog and want to play it using my controller (gamesir t4 pro, which should be recognized as an xbox one controller). However, I experience the same problems as described in this thread:


- Map not showing when clicking the Select button
- Clicking the left and right stick doesn't work

I tried the proposed solution to update the GamePadDefinitions.plist file with the version provided by Raze, but that didn't work unfortunately.

As a next possible workaround, I tried to launch the game through Steam, hoping I could use a custom controller mapping to fix some of the issues. However, when I launch the game through steam (and also when launching the game directly from the OS, not going through the GOG client) I can't see my already existing profile, nor can I create a new profile. This very much sounds like a permission issue to me, but I'm not sure how to solve it.

The game data is stored in ~/Document/Larian Studios/Divinity Original Sin Enhanced Edition/

I checked permissions on those folders, and they seem fine. My user has (at least) read and write permissions on all directories inside ~/Documents/Larian Studios/, including this top level folder. I also game full disk access to Steam and DoS:EE.

So now onto the question(s):
- Is there a proper solution for the xbox one controller issue that I missed?
- If not, how can I play the game through the steam client?
- Are there any other workarounds for this issue?

I'm on macOS Catalina version 10.15.7 and my DoS:EE version is .

Thanks in advance,