It should be DX 10 compatible. It's probably quite a ways off and almost every new game being released now is DX 10 compatible. Just because it is capable of that does not mean it won't run on DX9 hardware. Hellgate: London, Lord of the Rings Online, Crysis and numerous others run on both systems. Don't worry that it's going to exclude you if you are still on XP.