I'm running Windows 7 64bit

Not Having AA still bothers me, but my temporary fix has been to move my screen farther away from me :hihi:

Studdering is getting worse, even now that I have found settings that keep the game between 50 and 60 frames at all times.

The timesplice shadow update fixed a lot of issues the game had with moving shadows (obviously because they are nolonger moving.)