yes, i have the patch 1.03 installed for divinity 2: ego draconis. i don't think the DKS support page applies to me since i have the originial divinity 2: ego draconic game or does it?

anyway, i sent an email to larian support.

Last edited by droidZ; 18/02/11 01:31 AM.